クエリ エディターで R を使用するUsing R in Query Editor

Power BI Desktop クエリ エディターでは、統計学者、データ科学者、データ分析官によって広く使用されているプログラミング言語、R を使用できます。You can use R, a programming language widely used by statisticians, data scientists, and data analysts, in the Power BI Desktop Query Editor. R とクエリ エディターを統合することで、R によるデータ クレンジングを実行したり、データセットで高度なデータ シェイプ/データ分析 (失ったデータを埋める、予測、クラスター化など) を実行したりできます。This integration of R into Query Editor lets you perform data cleansing using R, and perform advanced data shaping and analytics in datasets, including completion of missing data, predictions, and clustering, just to name a few. R は高度な言語であり、クエリ エディターで使用し、データ モデルを用意したり、レポートを作成したりできます。R is a powerful language, and can be used in Query Editor to prepare your data model and create reports.

R をインストールするInstalling R

Power BI Desktop のクエリ エディターR を実行するには、ローカル コンピューターに R をインストールする必要があります。To use R in Power BI Desktop's Query Editor, you need to install R on your local machine. R はさまざまな場所から無料でダウンロードし、インストールできます。たとえば、Revolution Open ダウンロード ページCRAN Repository があります。You can download and install R for free from many locations, including the Revolution Open download page, and the CRAN Repository.

クエリ エディターで R を使用するUsing R in Query Editor

クエリ エディターR を使用する方法を示すために、ある株式市場のデータセットを例として使用します。これは .CSV ファイル形式であり、ここからダウンロードし、ご利用いただけます。To show how to use R in Query Editor, take this example from a stock market dataset, based on a .CSV file that you can download from here and follow along. この例の手順は次のようになります。The steps for this example are the following:

  1. 最初に、Power BI Desktop にデータを読み込みます。First, load your data into Power BI Desktop. この例では、EuStockMarkets_NA.csv ファイルを読み込み、Power BI Desktop[ホーム] リボンから [データの取得] > [CSV] を選択します。In this example, load the EuStockMarkets_NA.csv file and select Get Data > CSV from the Home ribbon in Power BI Desktop.

  2. ファイルを選択し、[開く] を選択します。CSV が [CSV ファイル] ダイアログに表示されます。Select the file and select Open, and the CSV is displayed in the CSV file dialog.

  3. 読み込まれたデータは、Power BI Desktop の [フィールド] ウィンドウに表示されます。Once the data is loaded, you'll see it in the Fields pane in Power BI Desktop.

  4. Power BI Desktop[ホーム] タブで [クエリを編集] を選択し、クエリ エディターを開きます。Open Query Editor by selecting Edit Queries from the Home tab in Power BI Desktop.

  5. [変換] タブで、[R スクリプトを実行する] を選択します。[R スクリプトを実行する] エディターが表示されます (次の手順の画像を参照してください)。In the Transform tab, select Run R Script and the Run R Script editor appears (shown in the next step). 行 15 と行 20 にデータが欠けています。画像では確認できませんが、他にもデータが欠けている行があります。Notice that rows 15 and 20 suffer from missing data, as do other rows you can't see in the following image. このような行のデータを R で自動的に補完する方法を以下に示します。The steps below show how R can (and will) complete those rows for you.

  6. この例では、次のスクリプト コードを入力します。For this example, enter the following script code:

       library(mice)
       tempData <- mice(dataset,m=1,maxit=50,meth='pmm',seed=100)
       completedData <- complete(tempData,1)
       output <- dataset
       output$completedValues <- completedData$"SMI missing values"
    

    注意

    前のスクリプト コードを正しく動作させるためには、R 環境に mice ライブラリをインストールする必要があります。You'll need to have the mice library installed in your R environment for the previous script code to work properly. mice をインストールするには、R のインストールで | > install.packages('mice') コマンドを実行します。To install mice, run the following command in your R installation: | > install.packages('mice')

    [R スクリプトを実行する] ダイアログに入力するコードは次のようになります。When put into the Run R Script dialog, the code looks like the following:

  7. [OK] を選択すると、クエリ エディターにデータ プライバシーに関する警告が表示されます。After selecting OK, Query Editor displays a warning about data privacy.

  8. Power BI サービスで R スクリプトを正しく動作させるためには、すべてのデータ ソースを [パブリック] に設定する必要があります。For the R scripts to work properly in the Power BI service, all data sources need to be set to public. プライバシー設定とその意味に関する詳細については、「プライバシー レベル」を参照してください。For more information about privacy settings and their implications, see Privacy Levels.

    [フィールド] ウィンドウに completedValues という新しい列が表示されます。Notice a new column in the Fields pane called completedValues. 行 15 や行 18 行など、いくつかの行でデータ要素が不足しています。Notice there are a few missing data elements, such as on row 15 and 18. 次のセクションでは、R がデータ要素の不足を処理するしくみを確認します。Take a look at how R handles that in the next section.

わずか 5 行の R スクリプトで、クエリ エディターは予測モデルで不足値を埋めました。With just five lines of R script, Query Editor filled in the missing values with a predictive model.

R スクリプト データからビジュアルを作成するCreating visuals from R script data

これで、R スクリプト コードと mice ライブラリで不足値を補うしくみを示すビジュアルを作成できます。次の画像のようになります。Now we can create a visual to see how the R script code using the mice library completed the missing values, as shown in the following image:

そのビジュアルが完成したら (Power BI Desktop 他のビジュアルを作成すると、さらに効果的な場合もあります)、Power BI Desktop ファイルを保存し (.pbix ファイルとして保存)、Power BI サービスでデータ モデル (R スクリプトが含まれる) を使用できます。Once that visual is complete, and any other visuals you might want to create using Power BI Desktop, you can save the Power BI Desktop file (which saves as a .pbix file) and then use the data model, including the R scripts that are part of it, in the Power BI service.

注意

以上の手順を完了した .pbix ファイルをご覧になる場合は、Want to see a completed .pbix file with these steps completed? 上記の例で使用されている Power BI Desktop ファイルの完成したものをここからダウンロードできます。You're in luck - you can download the completed Power BI Desktop file used in these examples right here.

.pbix ファイルを Power BI サービスにアップロードしたら、さらにいくつかの手順を実行し、(サービスで) データ更新を有効にし、サービスでビジュアルの更新を有効にする必要があります (ビジュアルを更新するには、データが R にアクセスする必要があります)。Once you've uploaded the .pbix file to the Power BI service, a couple more steps are necessary to enable data refresh (in the service) and to enable visuals to be updated in the service (the data needs access to R for visuals to be updated). 追加の手順は次のとおりです。The additional steps are the following:

  • データセットの定期更新を有効にする - データセットを含むブックを R スクリプトで定期的に更新する方法については、「スケジュールされた更新の構成」を参照してください。Personal Gateway に関する情報もあります。Enable scheduled refresh for the dataset - to enable scheduled refresh for the workbook that contains your dataset with R scripts, see Configuring scheduled refresh, which also includes information about Personal Gateway.
  • Personal Gateway をインストールする - ファイルが置かれ、R がインストールされているコンピューターに Personal Gateway をインストールする必要があります。Power BI サービスは、そのブックにアクセスし、更新されたビジュアルがあれば、それを再レンダリングできなければなりません。Install the Personal Gateway - you need a Personal Gateway installed on the machine where the file is located, and where R is installed; the Power BI service must access that workbook and re-render any updated visuals. Personal Gateway のインストール方法と構成方法については、他にも情報を参照できます。You can get more information on how to install and configure Personal Gateway.

制限事項Limitations

クエリ エディターで作成された R スクリプトを含むクエリにはいくつかの制限事項があります。There are some limitations to queries that include R scripts created in Query Editor:

  • R データ ソース設定はすべて、[パブリック] に設定する必要があります。クエリ エディターで作成されたクエリの他の手順もすべてパブリックにする必要があります。All R data source settings must be set to Public, and all other steps in a query created in Query Editor must also be public. データ ソース設定にアクセスするには、Power BI Desktop で、[ファイル]、[オプションと設定]、[データ ソース設定] の順に選択します。To get to data source settings, in Power BI Desktop select File > Options and settings > Data source settings.

    [データ ソース設定] ダイアログで、データ ソースを選択し、[アクセス許可の編集] を選択し、[プライバシー レベル][パブリック] に設定されていることを確認します。From the Data Source Settings dialog, select the data source(s) and then select Edit Permissions... and ensure that the Privacy Level is set to Public.

  • R のビジュアルやデータセットの定期更新を有効にするには、スケジュール更新を有効にし、ブックが置かれ、R をインストールしているコンピューターに Personal Gateway をインストールする必要があります。To enable scheduled refresh of your R visuals or dataset, you need to enable Scheduled refresh and have a Personal Gateway installed on the computer that houses the workbook and the R installation. それぞれの詳細な情報については、この記事の前のセクションにリンクがあります。For more information on both, see the previous section in this article, which provides links to learn more about each.

R とカスタム クエリを利用すれば、さまざまなデータ表示が可能です。いろいろ試してください。There are all sorts of things you can do with R and custom queries, so explore and shape your data just the way you want it to appear.