チュートリアル: Excel と OData フィードの売上データを結合するTutorial: Combine sales data from Excel and an OData feed

製品情報を入れるデータベースと売上情報を入れるデータベースが異なるなど、データが複数のデータ ソースにまたがることは珍しくありません。It's common to have data spread across multiple data sources, such as product information in one database and sales information in another. Power BI Desktop では、異なるソースからのデータを組み合わせて、興味深く説得力のあるデータ分析と視覚エフェクトを作成できます。With Power BI Desktop, you can combine data from different sources to create interesting, compelling data analyses and visualizations.

このチュートリアルでは、2 つのデータ ソースからのデータを結合する方法を学習します。製品情報を含む Excel ブックと、注文データを含む OData フィードです。In this tutorial, you learn how to combine data from two data sources: an Excel workbook that includes product information, and an OData feed that contains orders data. 各データセットをインポートし、変換と集計の手順を実行した後、両方のソースからのデータを使って、対話型の視覚エフェクトを含む売上分析レポートを生成します。After you import each dataset and perform transformation and aggregation steps, you use data from both sources to produce a sales analysis report with interactive visualizations. これらの手法は、SQL Server クエリ、CSV ファイル、および Power BI Desktop の他の任意のデータ ソースにも適用できます。These techniques can also be applied to SQL Server queries, CSV files, and any other data sources in Power BI Desktop.

注意

Power BI Desktop では多くの場合、タスクを複数の方法で実行できます。In Power BI Desktop, there are often a few ways to accomplish a task. たとえば、リボンのオプションの多くは、右クリックや、列またはセルの [その他のオプション] メニューを使って、使用することもできます。For example, many ribbon selections are also available by using a right-click or More options menu on a column or cell. 以下の手順では、複数の代替方法を説明します。Several alternate methods are described in the steps below.

Excel から製品データをインポートするImport the product data from Excel

最初に、Excel の Products.xlsx ブックから Power BI Desktop に製品データをインポートします。First, import the product data from the Excel Products.xlsx workbook into Power BI Desktop.

  1. Products.xlsx Excel ブックをダウンロードし、Products.xlsx として保存します。Download the Products.xlsx Excel workbook, and save it as Products.xlsx.

  2. Power BI Desktop リボンの [ホーム] タブの [データを取得] の横にあるドロップダウン矢印を選んで、[よく使われる] ドロップダウンから [Excel] を選びます。Select the dropdown arrow next to Get Data in the Home tab of the Power BI Desktop ribbon, and then select Excel from the Most Common dropdown.

    データの取得

    注意

    [データを取得] 項目自体を選ぶか、Power BI の [作業の開始] ダイアログから [データを取得] を選び、[データを取得] ダイアログで [Excel] または [ファイル] > [Excel] を選んで、[接続] を選ぶこともできます。You can also select the Get Data item itself, or select Get Data from the Power BI Get started dialog, then select Excel or File > Excel in the Get Data dialog box, and then select Connect.

  3. [開く] ダイアログ ボックスで、Products.xlsx ファイルを探して選び、[開く] を選びます。In the Open dialog box, navigate to and select the Products.xlsx file, and then select Open.

  4. [ナビゲーター] ウィンドウで [製品] テーブルを選択してから、 [編集] を選択します。In the Navigator pane, select the Products table and then select Edit.

    Excel の [ナビゲーター] ウィンドウ

テーブルのプレビューが Power Query エディターで開きます。ここで、変換を適用してデータをクリーンアップできます。A preview of the table opens in the Power Query Editor, where you can apply transformations to clean up the data.

Power Query エディター

注意

また、Power BI Desktop の [ホーム] リボンから [クエリの編集] > [クエリの編集] を選ぶことで、またはレポート ビューで右クリックするかクエリの横にある [その他のオプション] を選んでから [クエリの編集] を選ぶことで、Power Query エディターを開くこともできます。You can also open the Power Query Editor by selecting Edit Queries > Edit Queries from the Home ribbon in Power BI Desktop, or by right-clicking or choosing More options next to any query in Report View, and selecting Edit Query.

製品の列をクリーンアップするClean up the products columns

結合されたレポートでは、Excel ブックの ProductIDProductNameQuantityPerUnitUnitsInStock 列だけを使うので、他の列は削除できます。Your combined report will only use the ProductID, ProductName, QuantityPerUnit, and UnitsInStock columns from the Excel workbook, so you can remove the other columns.

  1. Power Query エディターで、ProductIDProductNameQuantityPerUnit、および UnitsInStock 列 を選びます (1 つ以上の列を選ぶには Ctrl キーを押しながらクリックし、隣り合う複数の列を選ぶには Shift キーを押しながらクリックします)。In Power Query Editor, select the ProductID, ProductName, QuantityPerUnit, and UnitsInStock columns (use Ctrl+Click to select more than one column, or Shift+Click to select columns that are next to each other).

  2. 選んだいずれかの列のヘッダーを右クリックし、ドロップダウンから [他の列の削除] を選んで、選んだ列を除くすべての列をテーブルから削除します。Right-click any of the selected headers and select Remove Other Columns from the dropdown, to remove all except the selected columns from the table. [ホーム] リボン タブの [列の管理] グループから [列の削除] > [他の列の削除] を選んでもかまいません。You can also select Remove Columns > Remove Other Columns from the Manage Columns group in the Home ribbon tab.

    他の列の削除

OData フィードから注文データをインポートするImport the order data from an OData feed

次に、サンプルの Northwind 販売システムの OData フィードから注文データをインポートします。Next, import the order data from the sample Northwind sales system OData feed.

  1. Power Query エディターで、[新しいソース] を選び、[よく使われる] ドロップダウンから [OData フィード] を選びます。In Power Query Editor, select New Source and then select OData feed from the Most Common dropdown.

    OData を取得する

  2. [OData フィード] ダイアログ ボックスで、Northwind OData フィードの URL http://services.odata.org/V3/Northwind/Northwind.svc/ を貼り付けて、[OK] を選びます。In the OData Feed dialog box, paste the URL for the Northwind OData feed, http://services.odata.org/V3/Northwind/Northwind.svc/, and select OK.

    [OData フィード] ダイアログ

  3. [ナビゲーター] ウィンドウで、Orders テーブルを選び、[OK] を選んで、Power Query エディターにデータを読み込みます。In the Navigator pane, select the Orders table, and then select OK to load the data into Power Query Editor.

    OData の [ナビゲーター] ウィンドウ

    注意

    [ナビゲーター] では、チェック ボックスを選択せずにテーブル名を選んで、プレビューを表示できます。In Navigator, you can select any table name, without selecting the checkbox, to see a preview.

注文データを展開するExpand the order data

リレーショナル データベースや Northwind OData フィードのように複数のテーブルが含まれるデータ ソースに接続するときは、テーブル間の参照を使ってクエリを作成できます。When you connect to data sources that have multiple tables, such as relational databases or the Northwind OData feed, you can use references between tables to build up your queries. Orders テーブルには、複数の関連テーブルへの参照が含まれています。The Orders table contains references to several related tables. 展開操作を使うことによって、関連する Order_Details テーブルの ProductIDUnitPrice、および Quantity 列を、サブジェクト (Orders) テーブルに追加できます。You can add the ProductID, UnitPrice, and Quantity columns from the related Order_Details table into the subject (Orders) table by using the Expand operation.

  1. Order_Details 列が表示されるまで、Orders テーブルを右にスクロールします。Scroll to the right in the Orders table until you can see the Order_Details column. この列にはデータではなく別のテーブルへの参照が含まれていることに注意してください。Note that instead of data, it contains references to another table.

    Order_Details 列

  2. Order_Details 列のヘッダーで、[展開] アイコン [展開] アイコン を選びます。Select the Expand icon (Expand icon) in the Order_Details column header.

  3. [展開] ドロップダウンで以下の操作を行います。In the Expand drop-down:

    1. すべての列をオフにするため、 (すべての列を選択) を選択します。Select (Select All Columns) to clear all columns.

    2. ProductIDUnitPriceQuantity を選んで、[OK] を選びます。Select ProductID, UnitPrice, and Quantity, and then select OK.

      [展開] ダイアログ

Order_Details テーブルを展開すると、Order_Details 列が入れ子になったテーブルからの 3 つの新しい列に置き換えられ、各注文から追加されたデータの新しい行がテーブルに存在するようになります。After you expand the Order_Details table, the Order_Details column is replaced by the three new columns from the nested table, and there are new rows in the table for the added data from each order.

展開された列

カスタム計算列を作成するCreate a custom calculated column

Power Query エディターでは、データを充実させるために計算フィールドとカスタム フィールドを作成できます。Power Query Editor lets you create calculations and custom fields to enrich your data. 単価と項目の数量を乗算することによって注文の各明細項目の合計価格を計算するカスタム列を作成します。You will create a custom column that calculates the total price for each line item in an order by multiplying the unit price by item quantity.

  1. Power Query エディターの [列の追加] リボン タブで、[カスタム列] を選びます。In the Add Column ribbon tab of Power Query Editor, select Custom Column.

  2. [カスタム列] ダイアログ ボックスで、[新しい列名] フィールドに「LineTotal」と入力します。In the Custom Column dialog box, type LineTotal in the New column name field.

  3. [カスタム列の式] フィールドの = の後に、「[Order_Details.UnitPrice] * [Order_Details.Quantity]」と入力します。In the Custom column formula field after the = , enter [Order_Details.UnitPrice] * [Order_Details.Quantity]. (入力する代わりに、[使用できる列] スクロール ボックスからフィールド名を選び、[<< 挿入] を選んでもかまいません。)(You can also select the field names from the Available columns scroll box and select << Insert, instead of typing them.)

  4. [OK] を選択します。Select OK.

    [カスタム列] ダイアログ

Orders テーブルの最後の列として、新しい LineTotal フィールドが表示されます。The new LineTotal field appears as the last column in the Orders table.

新しいフィールドのデータ型を設定するSet the data type for the new field

Power Query エディターは、データに接続するとき、各フィールドの最適なデータ型を決定し、それに応じてデータを表示します。When Power Query Editor connects to data, it determines the best data type for each field and displays the data accordingly. フィールドに割り当てられているデータ型は、ヘッダーのアイコンで、または [ホーム] リボン タブの [変換] グループの [データ型] で、確認できます。You can see the data types assigned to fields by the icons in the headers, or under Data Type in the Transform group of the Home ribbon tab.

新しい LineTotal 列のデータ型は [すべて] になっていますが、その値は通貨です。Your new LineTotal column has a data type of Any, but its values are currency. データ型を割り当てるには、LineTotal 列のヘッダーを右クリックし、ドロップダウンから [データ型の変更] を選んで、[固定小数点数] を選びます。To assign a data type, right-click the LineTotal column header, select Change Data Type from the dropdown, and then select Fixed decimal number.

データ型を変更する

注意

または、LineTotal 列を選び、[ホーム] リボン タブの [変換] 領域の [データ型] の横にあるドロップダウン矢印を選んで、[固定小数点数] を選んでもかまいません。You can also select the LineTotal column, then select the dropdown arrow next to Data Type in the Transform area of the Home ribbon tab, and then select Fixed decimal number.

注文列をクリーンアップするClean up the orders columns

レポートでモデルの作業をしやすくするため、列の削除、名前変更、順序変更を行うことができます。To make your model easier to work with in reports, you can delete, rename, and reorder some of the columns.

このレポートでは、OrderDateShipCityShipCountryOrder_Details.ProductIDOrder_Details.UnitPriceOrder_Details.Quantity 列だけを使います。Your report will only use the OrderDate, ShipCity, ShipCountry, Order_Details.ProductID, Order_Details.UnitPrice, and Order_Details.Quantity columns. Excel データで行ったようにこれらの列を選んで [他の列の削除] を使うか、上記の列以外のすべての列を選び、選んだ列のいずれかを右クリックして [列の削除] を選んで、すべての列を削除することもできます。You can select these columns and use Remove Other Columns as you did with the Excel data, or you can select all the columns except those listed, right-click on one of the selected columns, and select Remove Columns to remove them all.

列名から Order_Details. プレフィックスを削除することにより、Order_Details.ProductIDOrder_Details.UnitPriceOrder_Details.Quantity 列をYou can make the Order_Details.ProductID, Order_Details.UnitPrice and Order_Details.Quantity columns easier to identify by removing the Order_Details. 識別しやすくすることができます。prefixes from the column names. 列の名前を ProductIDUnitPriceQuantity に変更するには、次のようにします。To rename the columns to ProductID, UnitPrice and Quantity, respectively:

  1. 各列のヘッダーをダブルクリックまたは長押しします。または、列ヘッダーを右クリックして、ドロップダウンから [名前の変更] を選びます。Double-click or tap and hold each column header, or right-click the column header and select Rename from the dropdown.
  2. Order_Details.Delete the Order_Details. プレフィックスを各名前から削除して、Enter キーを押します。prefix from each name, and then press Enter.

最後に、LineTotal 列にアクセスしやすくするため、この列を左にドラッグして ShipCountry 列のすぐ右にドロップします。Finally, to make the LineTotal column easier to access, drag and drop it to the left, just to the right of the ShipCountry column.

クリーンアップされたテーブル

クエリのステップを確認するReview the query steps

Power Query エディターでデータを整形して変換すると、Power Query エディターの右側にある [クエリの設定] ウィンドウの [適用したステップ] 領域に、各ステップが記録されています。As you shaped and transformed data in the Power Query Editor, each step was recorded in the Applied Steps area of the Query Settings pane on the right side of Power Query Editor. [適用したステップ] をさかのぼり、行った変更を正確に確認し、必要に応じて編集、削除、または再配置を行うことができます (ただし、前のステップを変更すると後のステップが動作しなくなる可能性があるため、危険な可能性があります)。You can step back through the Applied Steps to review the changes you made, and edit, delete, or rearrange them if necessary (although this can be risky, because changing preceding steps can break later steps).

Power Query エディターの左側にある [クエリ] の一覧で各クエリを選び、[クエリの設定][適用したステップ] を確認します。Select each of your queries in the Queries list on the left side of Power Query Editor, and review the Applied Steps in Query Settings. これまでのデータ変換を適用すると、2 つのクエリの [適用したステップ] は次のようになります。After applying the previous data transformations, the Applied Steps for your two queries should look like the following:

製品クエリの適用したステップ    注文クエリの適用したステップ

ヒント

[適用したステップ] の基礎は、M 言語とも呼ばれる Power Query 言語で記述された数式です。Underlying the Applied Steps are formulas written in the Power Query Language, also known as the M language. 数式を表示および編集するには、リボンの [ホーム] タブの [クエリ] グループで [詳細エディター] を選択します。To see and edit the formulas, select Advanced Editor in the Query group of the Home tab of the ribbon.

変換されたクエリをインポートするImport the transformed queries

変換したデータに問題がなければ、[ホーム] リボン タブの [閉じる] グループで [閉じて適用] > [閉じて適用] の順に選び、Power BI Desktop のレポート ビューにデータをインポートします。When you are satisfied with your transformed data, select Close & Apply > Close & Apply in the Close group of the Home ribbon tab, to import the data into Power BI Desktop Report View.

閉じて適用

データが読み込まれると、Power BI Desktop のレポート ビューの [フィールド] 一覧にクエリが表示されます。Once the data is loaded, the queries appear in the Fields list in the Power BI Desktop Report View .

[フィールド] 一覧のクエリ

データセット間のリレーションシップを管理するManage the relationship between the datasets

Power BI Desktop では、レポート作成のためにクエリを結合する必要はありません。Power BI Desktop does not require you to combine queries to report on them. ただし、共通に存在するフィールドに基づくデータセット間のリレーションシップを使うと、レポートを拡張して充実させることができます。However, you can use the relationships between datasets, based on fields they have in common, to extend and enrich your reports. Power BI Desktop でリレーションシップを自動的に検出できます。または、Power BI Desktop の [リレーションシップの管理] ダイアログで作成することもできます。Power BI Desktop may detect relationships automatically, or you can create them in the Power BI Desktop Manage Relationships dialog. Power BI Desktop でのリレーションシップについて詳しくは、「Power BI Desktop でのリレーションシップの作成と管理」をご覧ください。For more details about relationships in Power BI Desktop, see Create and manage relationships.

このチュートリアルの Orders データセットと Products データセットには共通の ProductID フィールドがあるので、これらの間にはその列に基づくリレーションシップがあります。The Orders and Products datasets in this tutorial share a common ProductID field, so there is a relationship between them based on that column.

  1. Power BI Desktop のレポート ビューで、[ホーム] リボン タブの [リレーションシップ] 領域の [リレーションシップの管理] を選びます。In Power BI Desktop Report View, select Manage Relationships in the Relationships area of the Home ribbon tab.

    [リレーションシップの管理] リボン

  2. [リレーションシップの管理] ダイアログでは、Power BI Desktop によって Products テーブルと Orders テーブルの間のアクティブなリレーションシップが既に検出されて一覧に表示されていることに注意してください。In the Manage Relationships dialog, note that Power BI Desktop has already detected and listed an active relationship between the Products and Orders tables. リレーションシップを表示するには、[編集] を選びます。To view the relationship, select Edit.

    [リレーションシップの管理] ダイアログ

    [リレーションシップの編集] ダイアログが開き、リレーションシップに関する詳細が示されます。The Edit Relationship dialog opens, showing details about the relationship.

    [リレーションシップの編集] ダイアログ

  3. Power BI Desktop はリレーションシップを正しく自動検出しているので、[キャンセル][閉じる] の順に選んでリレーションシップ ダイアログを終了できます。Power BI Desktop has autodetected the relationship correctly, so you can select Cancel and then Close to exit the relationship dialogs.

Power BI Desktop ウィンドウの左側で [リレーションシップ] ビューを選んで、クエリ間のリレーションシップを表示および管理することもできます。You can also view and manage the relationships between your queries by selecting the Relationship view at the left side of the Power BI Desktop window. 2 つのクエリを接続する線の矢印をダブルクリックして [リレーションシップの編集] ダイアログを開き、リレーションシップを表示または変更します。Double-click the arrow on the line connecting the two queries to open the Edit Relationship dialog and view or change the relationship.

リレーションシップ ビュー

リレーションシップ ビューからレポート ビューに戻るには、[レポートの表示] アイコンを選びます。To get back to Report View from Relationships View, select the Report View icon.

レポート ビュー

データを使って視覚エフェクトを作成するCreate visualizations using your data

Power BI Desktop のレポート ビューでは、データから分析情報を得るためにさまざまな視覚エフェクトを作成できます。In Power BI Desktop Report View, you can create a variety of visualizations to gain insights from your data. 複数のページで構成されるレポートを作成し、各ページに複数のビジュアルを含めることができます。You can build reports with multiple pages, and each page can have multiple visuals. そうした視覚エフェクトと対話して、データの分析や把握に役立てることができます。You and others can interact with your visualizations to help analyze and understand your data. Power BI サービス (お使いのサイト) でのレポートの表示と編集について詳しくは、レポートの編集に関する記事をご覧ください。For more information about viewing and editing reports in Power BI Service (your site), see Edit a Report.

両方のデータセットおよびそれらの間のリレーションシップを使うと、売上データの視覚化と分析に役立ちます。You can use both of your data sets, and the relationship between them, to help visualize and analyze your sales data.

最初に、両方のクエリからのフィールドを使う積み上げ縦棒グラフを作成し、各製品の注文数量を示します。First, create a stacked column chart that uses fields from both queries to show the quantity of each product ordered.

  1. 右側の [フィールド] ウィンドウで OrdersQuantity フィールドを選ぶか、フィールドをキャンバスの空白の領域にドラッグします。Select the Quantity field from Orders in the Fields pane at the right, or drag it onto a blank space on the canvas. これにより、製品の合計注文数量を示す積み上げ縦棒グラフが作成されます。This creates a stacked column chart showing the total quantity of all products ordered.

  2. [フィールド] ウィンドウで ProductsProductName を選ぶか、フィールドをグラフにドラッグして、各製品の注文数量を表示します。Select ProductName from Products in the Fields pane, or drag it onto the chart, to show the quantity of each product ordered.

  3. 注文の多い順に製品を並べ替えるには、視覚エフェクトの右上にある [その他のオプション] の省略記号 [...] を選び、[Quantity で並べ替え] を選びます。To sort the products by most to least ordered, select the More options ellipsis (...) at the upper right of the visualization, and then select Sort By Quantity.

  4. グラフの隅にあるハンドルを使ってグラフを拡大し、より多くの製品名が表示されるようにします。Use the handles at the corners of the chart to enlarge it so more product names are visible.

    ProductName 別数量の横棒グラフ

次に、時間の経過 (OrderDate) に伴う注文の金額 (LineTotal) を示すグラフを作成します。Next, create a chart showing order dollar amounts (LineTotal) over time (OrderDate).

  1. キャンバスで何も選択されていない状態で、[フィールド] ウィンドウの Orders から LineTotal を選ぶか、キャンバスの空白領域にドラッグします。With nothing selected on the canvas, select LineTotal from Orders in the Fields pane, or drag it to a blank space on the canvas. 積み上げ縦棒グラフに、すべての注文の合計金額が表示されます。The stacked column chart shows the total dollar amount of all orders.

  2. グラフを選び、Orders から OrderDate を選ぶか、グラフにドラッグします。With the chart selected, select OrderDate from Orders, or drag it onto the chart. グラフに各注文日の明細合計が表示されるようになります。The chart now shows line totals for each order date.

  3. 視覚エフェクトの隅をドラッグしてサイズを変更し、表示されるデータを増やします。Resize the visualization by dragging the corners to be able to see more data.

    OrderDate 別 LineTotals の折れ線グラフ

    ヒント

    グラフに Years のみが表示される場合は (3 つのデータ ポイントだけ)、[視覚化] ウィンドウの [軸] フィールドで OrderDate の横にある矢印をドロップダウンし、[日付の階層] の代わりに OrderDate を選びます。If you only see Years on the chart (only three data points), drop down the arrow next to OrderDate in the Axis field of the Visualizations pane, and select OrderDate instead of Date Hierarchy.

最後に、各国の注文金額を示すマップ視覚エフェクトを作成します。Finally, create a map visualization showing order amounts from each country.

  1. キャンバスで何も選択されていない状態で、[フィールド] ウィンドウの Orders から ShipCountry を選ぶか、キャンバスの空白領域にドラッグします。With nothing selected on the canvas, select ShipCountry from Orders in the Fields pane, or drag it to a blank space on the canvas. Power BI Desktop によってデータが国名であることが検出され、注文があった各国のデータ ポイントを含むマップ視覚エフェクトが自動的に作成されます。Power BI Desktop detects that the data is country names, and automatically creates a map visualization, with a data point for each country that had orders.

  2. 各国の注文金額をデータ ポイントのサイズに反映させるには、LineTotal フィールドをマップにドラッグします (または、[視覚化] ウィンドウの下半分にある [サイズ][ここにデータ フィールドをドラッグしてください] にドラッグします)。To make the sizes of the data points reflect the order amounts for each country, drag the LineTotal field onto the map (or drag it to Drag data fields here under Size, in the bottom half of the Visualizations pane). マップ上の円のサイズが、各国からの注文の金額を反映するようになります。The sizes of the circles on the map now reflect the dollar amounts of the orders from each country.

    ShipCountry 別 LineTotals のマップ視覚エフェクト

レポートのビジュアルと対話してさらに分析するInteract with your report visuals to analyze further

Power BI Desktop を使うと、相互に強調表示したり、フィルター処理したりすることによってビジュアルと対話して、さらに傾向を明らかにすることができます。Power BI Desktop lets you uncover further trends by interacting with visuals that cross-highlight and filter each other. 詳しくは、レポートにおけるフィルター処理と強調表示に関する記事をご覧ください。For more information, see Filtering and Highlighting in Reports.

クエリ間のリレーションシップのため、ある視覚エフェクトと対話すると、そのページ上の他のすべての視覚エフェクトに反映されます。Because of the relationship between your queries, interactions with one visualization will affect all the other visualizations on the page.

マップ視覚エフェクトで、カナダの中央にある円を選びます。On the map visualization, select the circle centered in Canada. 他の 2 つの視覚エフェクトがフィルター処理されて、カナダの明細金額と注文数量だけが強調表示されることに注意してください。Note that the other two visualizations filter to highlight the line totals and order quantities just for Canada.

カナダについてフィルター処理された売上データ

Quantity by ProductName グラフで製品の 1 つを選ぶと、マップと日付グラフがその製品のデータを反映するようにフィルター処理され、LineTotal by OrderDate グラフで日付の 1 つを選ぶと、マップと製品グラフがその日付のデータを表示するようにフィルター処理されます。If you select one of the products in the Quantity by ProductName chart, the map and the date chart filter to reflect the data for that product, and if you select one of the dates in the LineTotal by OrderDate chart, the map and the product chart filter to show the data for that date.

ヒント

選択を解除するには、再びクリックするか、他の視覚エフェクトのいずれかをクリックします。To deselect a selection, select it again, or select one of the other visualizations.

完成した売上分析レポートComplete the sales analysis report

完成したレポートでは、Products.xlsx Excel ファイルと Northwind OData フィードからのデータが、異なる国、期間、および製品の注文情報を分析するのに役立つビジュアルに結合されています。Your completed report combines data from the Products.xlsx Excel file and the Northwind OData feed in visuals that help analyze order information for different countries, timeframes, and products. レポートの準備ができたら、それを Power BI サービスにアップロードして、他の Power BI ユーザーと共有できます。When your report is ready, you can upload it to Power BI service to share it with other Power BI users.

次の手順Next steps