Power BI Embedded 移行ツールPower BI Embedded migration tool

この移行ツールを使用して、Power BI Embedded Azure サービス (PaaS) のレポートを Power BI サービス (SaaS) にコピーできます。This migration tool can be used to copy your reports from the Power BI Embedded Azure service (PaaS) to the Power BI service (SaaS).

ワークスペース コレクションから Power BI サービスへのコンテンツの移行は、現在のソリューションと並行して行うことができ、ダウンタイムを必要としません。Migrating your content from your workspace collections to the Power BI service can be done in parallel to your current solution and doesn’t require any downtime.

制限事項Limitations

  • プッシュされたデータセットはダウンロードできません。Power BI サービス用の Power BI REST API を使用して作成し直す必要があります。Pushed datasets cannot be downloaded and will need to be recreated using the Power BI REST APIs for the Power BI service.
  • 2016 年 11 月 26 日より前にインポートされた PBIX ファイルはダウンロードできなくなります。PBIX files imported before November 26, 2016 will not be downloadable.

ダウンロードDownload

移行ツールのサンプルは GitHub からダウンロードできます。You can download the migration tool sample from GitHub. リポジトリの zip をダウンロードするか、ローカルに複製を作成することができます。You can either download a zip of the repository, or you can clone it locally. ダウンロードしたら、Visual Studio 内で powerbi-migration-sample.sln を開いてビルドし、移行ツールを実行できます。Once downloaded, you can open powerbi-migration-sample.sln within Visual Studio to build and run the migration tool.

移行プランMigration Plans

移行プランは、Power BI Embedded 内のコンテンツと、Power BI サービスに発行する方法を列挙した単なるメタデータです。Your migration plan is just metadata that catalogs the content within Power BI Embedded and how you want to publish them to the Power BI service.

新しい移行プランを開始するStart with a new migration plan

移行プランは、Power BI Embedded で使用し、Power BI サービスに移行できる項目のメタデータです。A migration plan is the metadata of the items available in Power BI Embedded that you then want to move over to the Power BI service. 移行プランは XML ファイルとして保存されます。The migration plan is stored as an XML file.

新しい移行プランを作成して開始します。You will want to start by creating a new migration plan. 新しい移行プランを作成するには、次の手順を実行します。To create a new migration plan, do the following.

  1. [ファイル] > [New Migration Plan](新しい移行プラン) を選択します。Select File > New Migration Plan.

  2. Select Power BI Embedded Resource Group (Power BI Embedded リソース グループの選択) ダイアログで 環境 ドロップダウンを選択し、製品を選択します。In the Select Power BI Embedded Resource Group dialog, you will want to select the Environment dropdown and select prod.
  3. サインインするように求められます。You will be prompted to sign in. Azure サブスクリプションのログイン アカウントを使用します。You will use your Azure subscription login.

    重要

    これは Power BI へのサインインに使用する Office 365 の組織アカウントではありませんThis is not your Office 365 organization account that you sign into Power BI with.

  4. Power BI Embedded ワークスペース コレクションを保存する Azure サブスクリプションを選択します。Select the Azure subscription which stores your Power BI Embedded workspace collections.

  5. サブスクリプション リストの下にあるワークスペース コレクションを含む [リソース グループ] を選択し、[選択] を選択します。Below the subscription list, select the Resource Group that contains your workspace collections and select Select.

  6. [分析] を選択します。Select Analyze. Azure サブスクリプション内の項目のインベントリが表示され、プランを開始することができます。This will get an inventory of the items within your Azure subscription for you to begin your plan.

    注意

    ワークスペース コレクション数と、ワークスペース コレクション内に存在するコンテンツ数によりますが、分析プロセスには数分かかります。The analyze process could take several minutes depending on the number of Workspace collections and how much content exists in the workspace collection.

  7. 分析が完了すると、移行プランを保存するように求められます。When Analyze is complete, it will prompt you to save your migration plan.

この時点で、移行プランは Azure サブスクリプションに接続されています。At this point, you have connected your migration plan to your Azure subscription. 移行プランの操作方法の流れについては、後述の説明を参照してください。Read below to understand the flow of how to work with your migration plan. 移行プランには、移行の分析と計画、ダウンロード、グループの作成、アップロードが含まれています。This includes Analyze & Plan Migration, Download, Create Groups and Upload.

移行プランを保存するSave your migration plan

移行プランを保存して、後で使用することができます。You can save your migration plan for use later. 保存すると、移行プランのすべての情報を含む XML ファイルが作成されます。This will create an XML file that contained all the information in your migration plan.

移行プランを保存するには、次の手順を実行します。To save your migration plan, do the following.

  1. [ファイル] > [Save Migration Plan]/(移行プランの保存/) を選択します。Select File > Save Migration Plan.

  2. ファイルに名前を付けるか、自動生成されたファイル名を使用して、[保存] を選択します。Give your file a name or use the generated file name and select Save.

既存の移行プランを開くOpen an existing migration plan

保存した移行プランを開き、移行の作業を続けます。You can open a saved migration plan to continue working on your migration.

既存の移行プランを開くには、次の手順を実行します。To open your existing migration plan, do the following.

  1. [ファイル] > [Open Existing Migration Plan]/(既存の移行プランを開く/) を選択します。Select File > Open Existing Migration Plan.

  2. 移行ファイルを選択し、[開く] を選択します。Select your migration file and select Open.

手順 1: 移行の分析と計画Step 1: Analyze & Plan Migration

[Analyze & Plan Migration]/(移行の分析と計画/) タブには、Azure サブスクリプションのリソース グループの現在の内容が表示されます。The Analyze & Plan Migration tab gives you a view of what is currently in your Azure subscription’s resource group.

[移行の分析と計画] タブ

例として SampleResourceGroup を見てみましょう。We will look at the SampleResourceGroup as an example.

PaaS トポロジPaaS Topology

これは [リソース グループ] > [Workspace collections]/(ワークスペース コレクション/) > [ワークスペース] の一覧です。This is a listing of your Resource Group > Workspace collections > Workspaces. リソース グループとワークスペース コレクションにはフレンドリ名が表示されます。The resource group and workspace collections will show a friendly name. ワークスペースには GUID が表示されます。The workspaces will show a GUID.

一覧の項目には、色と (#/#) 形式の数値も表示されます。The items in the list will also display a color and a number in the format of (#/#). これは、ダウンロードできるレポート数を示します。This indicates the number of reports that can be downloaded. 黒色は、すべてのレポートをダウンロードできることを示します。A black color means that all reports can be downloaded.

赤色は、一部のレポートをダウンロードできないことを示します。A red color means that some reports cannot be downloaded. 左側の数値は、ダウンロードできるレポートの合計数を示します。The left number will indicate the total number of reports that can be downloaded. 右側の数値は、グループ内のレポートの合計数を示します。The number on the right indicates the total number of reports within the grouping.

PaaS トポロジ内の項目を選択して、レポート セクションにレポートを表示することができます。You can select an item within the PaaS topology to display the reports in the reports section.

レポートReports

レポート セクションには、使用できるレポートが一覧表示され、ダウンロードできるかどうかが示されます。The reports section will list out the reports available and indicates whether it can be downloaded or not.

ターゲット構造Target structure

ターゲット構造は、ダウンロード先とアップロード方法をツールに指示するための場所です。The Target structure is where you tell the tool where things will be downloaded to and how to upload them.

[Download Plan]/(ダウンロード プラン/)Download Plan

パスは自動的に作成されます。A path will automatically be created for you. このパスは必要に応じて変更できます。You can change this path if you wish. パスを変更する場合は、[Update paths](パスの更新) を選択する必要があります。If you do change the path, you will need to select Update paths.

注意

この項目を設定しても、実際にダウンロードは実行されません。This does not actually perform the download. レポートのダウンロード先の構造を指定するだけです。This is only specifying the structure of where the reports will be downloaded to.

[Upload Plan]/(アップロード プラン/)Upload Plan

Power BI サービス内で作成されるアプリ ワークスペースに使用するプレフィックスを指定できます。Here you can specify a prefix to be used for the App Workspaces that will be created within the Power BI service. プレフィックスの後は、Azure に存在するワークスペースの GUID になります。After the prefix will be the GUID for the workspace that existed in Azure.

注意

この項目を設定しても、実際に Power BI サービス内にグループは作成されません。This does not actually create the groups within the Power BI service. グループの名前付けの構造を定義するだけです。This only defines the naming structure for the groups.

プレフィックスを変更する場合、[Generate Upload Plan]/(アップロード プランの生成/) を選択する必要があります。If you change the prefix, you will need to select Generate Upload Plan.

必要に応じて、グループを右クリックし、[Upload Plan]/(アップロード プラン/) 内のグループ名を変更することもできます。You can right click on a group and choose to rename the group within the Upload plan directly, if desired.

注意

グループの名前にスペースや無効な文字を含めることはできません。The name of the group must not contain spaces or invalid characters.

手順 2: ダウンロードするStep 2: Download

[ダウンロード] タブには、レポートとそれに関連するメタデータの一覧が表示されます。On the Download tab, you will see the list of reports and associated metadata. エクスポート状態が前のエクスポート状態と共に表示されます。You can see what the export status is along with the previous export status.

2 つのオプションがあります。You have two options.

  • 特定のレポートを選択し、[Download Selected]/(選択項目のダウンロード/) を選択しますSelect specific reports and select Download Selected
  • [Download All]/(すべてダウンロード/) を選択します。Select Download All.

正常にダウンロードされると、[完了] という状態が表示され、PBIX ファイルが存在することが反映されます。For a successful download, you will see a status of Done and it will reflect that the PBIX file exists.

ダウンロードが完了したら、[Create Groups]/(グループの作成/) タブを選択します。After the download is completed, select the Create Groups tab.

手順 3: グループを作成するStep 3: Create Groups

使用できるレポートをダウンロードしたら、[Create Groups]/(グループの作成/) タブを選択します。このタブでは、作成した移行プランに基づいて、Power BI サービス内にアプリ ワークスペースが作成されます。After you have downloaded the reports that are available, you can go to the Create Groups tab. This tab will create the app workspaces within the Power BI service based on the migration plan that you created. [Analyze & Plan Migration]/(移行の分析と計画/) 内の [アップロード] タブで指定した名前のアプリ ワークスペースが作成されます。It will create the app workspace with the name you provided on the Upload tab within Analyze & Plan Migration.

アプリ ワークスペースを作成するには、[Create Selected Groups]/(選択されているグループの作成/) または [Create All Missing Groups]/(見つからないすべてのグループの作成/) を選択します。To create the app workspaces, you can select either Create Selected Groups or Create All Missing Groups.

いずれかのオプションを選択すると、サインインするように求められます。When you select either of these options, you will be prompted to sign in. "アプリ ワークスペースを作成する Power BI サービスの資格情報を使用します。"You will want to use your credentials for the Power BI service that you want to create the app workspaces on.

これで、Power BI サービス内にアプリ ワークスペースが作成されます。This will create the app workspace within the Power BI service. この操作では、アプリ ワークスペースにレポートがアップロードされません。This does not upload the reports to the app workspace.

Power BI にサインインしてワークスペースが存在することを確認することで、アプリ ワークスペースが作成されたことを確認できます。You can verify that the app workspace was created by signing into Power BI and validating that the workspace exists. ワークスペースには何も表示されません。You will notice that nothing is in the workspace.

ワークスペースの作成後は、[アップロード] タブに移動できます。After the workspace is created, you can move onto the Upload tab.

手順 4: アップロードStep 4: Upload

[アップロード] タブで、レポートを Power BI サービスにアップロードします。On the Upload tab, this will upload the reports to the Power BI service. [ダウンロード] タブでダウンロードしたレポートの一覧と、移行プランに基づいたターゲット グループ名が表示されます。You will see a list of the reports that we downloaded on the Download tab along with the target group name based on your migration plan.

選択したレポートをアップロードするか、すべてのレポートをアップロードすることができます。You can upload selected reports, or you could upload all the reports. また、アップロードの状態をリセットして項目を再アップロードすることもできます。You can also reset the upload status to re-upload items.

また、同じ名前のレポートが存在する場合の処理方法を選択することもできます。You also have the option of selecting what to do if a report with the same name exists. [中止][無視][上書き] から選択できます。You can choose between Abort, Ignore and Overwrite.

重複するレポート名Duplicate report names

同じ名前のレポートがあり、内容が異なるレポートとわかっている場合は、レポートの TargetName を変更する必要があります。If you have a report that has the same name, but you know it is a different report, you will need to change the TargetName of the report. 名前を変更するには、移行プランの XML を手動で編集します。You can change the name by manually editing the migration plan XML.

移行ツールを閉じてから変更し、ツールと移行プランを開き直す必要があります。You will need to close the migration tool to make the change and then re-open the tool and the migration plan.

上の例では、重複するレポートの 1 つが同じ名前のレポートが存在するために失敗していることが表示されています。In the above example, one of the cloned reports failed indicating a report with the same name existed. 移行プランの XML を開くと、次のような内容が表示されます。If we go look at the migration plan XML, we will see the following.

<ReportMigrationData>
    <PaaSWorkspaceCollectionName>SampleWorkspaceCollection</PaaSWorkspaceCollectionName>
    <PaaSWorkspaceId>4c04147b-d8fc-478b-8dcb-bcf687149823</PaaSWorkspaceId>
    <PaaSReportId>525a8328-b8cc-4f0d-b2cb-c3a9b4ba2efe</PaaSReportId>
    <PaaSReportLastImportTime>1/3/2017 2:10:19 PM</PaaSReportLastImportTime>
    <PaaSReportName>cloned</PaaSReportName>
    <IsPushDataset>false</IsPushDataset>
    <IsBoundToOldDataset>false</IsBoundToOldDataset>
    <PbixPath>C:\MigrationData\SampleResourceGroup\SampleWorkspaceCollection\4c04147b-d8fc-478b-8dcb-bcf687149823\cloned-525a8328-b8cc-4f0d-b2cb-c3a9b4ba2efe.pbix</PbixPath>
    <ExportState>Done</ExportState>
    <LastExportStatus>OK</LastExportStatus>
    <SaaSTargetGroupName>SampleMigrate</SaaSTargetGroupName>
    <SaaSTargetGroupId>6da6f072-0135-4e6c-bc92-0886d8aeb79d</SaaSTargetGroupId>
    <SaaSTargetReportName>cloned</SaaSTargetReportName>
    <SaaSImportState>Failed</SaaSImportState>
    <SaaSImportError>Report with the same name already exists</SaaSImportError>
</ReportMigrationData>

失敗した項目については、SaaSTargetReportName の名前を変更できます。For the failed item, we can change the name of the SaaSTargetReportName.

<SaaSTargetReportName>cloned2</SaaSTargetReportName>

プランを開き直し、失敗したレポートを移行ツールでアップロードします。We can then re-open the plan, in the migration tool, and upload the failed report.

Power BI に戻ると、レポートとデータセットがアプリ ワークスペースにアップロードされたことを確認できます。Going back to Power BI, we can see that the reports and datasets have been uploaded in the app workspace.

ローカル PBIX ファイルをアップロードするUpload a local PBIX file

ローカル バージョンの Power BI Desktop ファイルをアップロードできます。You can upload a local version of a Power BI Desktop file. ツールを閉じ、XML を編集し、PbixPath プロパティにローカル PBIX の完全なパスを指定します。You will have to close the tool, edit the XML and put the full path to your local PBIX in the PbixPath property.

<PbixPath>[Full Path to PBIX file]</PbixPath>

XML を編集した後は、移行ツール内でプランを再び開き、レポートをアップロードします。After you have edited the xml, re-open the plan within the migration tool and upload the report.

DirectQuery レポートDirectQuery reports

DirectQuery レポートの接続文字列をアップロードするには、更新する必要があります。You will need to update to update the connection string for DirectQuery reports. この操作は powerbi.com 内で実行するか、Power BI Embedded (PaaS) から接続文字列をプログラムでクエリを実行することができます。This can be done within powerbi.com, or you can programmatically query the connection string from Power BI Embedded (Paas). 例については、「PaaS レポートから DirectQuery 接続文字列を抽出する」を参照してください。For an example, see Extract DirectQuery connection string from PaaS report.

Power BI サービス (SaaS) 内のデータセットの接続文字列を更新し、データ ソースの資格情報を設定することができます。You can then update the connection string for the dataset within the Power BI service (Saas) and set the credentials for the data source. その方法については、次の例を参照してください。You can look at the following examples to see how to do this.

埋め込みEmbedding

Power BI Embedded Azure サービスから Power BI サービスにレポートが移行されたので、アプリケーションを更新し、このアプリ ワークスペースにレポートを埋め込むことができるようになりました。Now that your reports have been migrated from the Power BI Embedded Azure service to the Power BI service, you can now update your application and begin embedding the reports in this app workspace.

詳細については、「Power BI に Power BI Embedded ワークスペース コレクション コンテンツを移行する方法」を参照してください。For more information, see How to migrate Power BI Embedded workspace collection content to Power BI.

次の手順Next steps

Power BI で埋め込みEmbedding with Power BI
Power BI に Power BI Embedded ワークスペース コレクション コンテンツを移行する方法How to migrate Power BI Embedded workspace collection content to Power BI
Power BI Premium とはPower BI Premium - what is it?
JavaScript API Git リポジトリJavaScript API Git repo
Power BI C# Git リポジトリPower BI C# Git repo
JavaScript 埋め込みサンプルJavaScript embed sample
Power BI Premium ホワイト ペーパーPower BI Premium whitepaper

他にわからないことがある場合は、More questions? Power BI コミュニティで質問してみてくださいTry asking the Power BI Community