レポート ビルダーでページ分割されたレポートにデータを直接入力する - Power BIEnter data directly in a paginated report in Report Builder - Power BI

この記事では、新しいバージョンの Microsoft Power BI レポート ビルダーに搭載された、埋め込みデータセットとして RDL レポートにデータを直接入力できる機能を紹介します。In this article, you learn about a feature in the new version of Microsoft Power BI Report Builder that lets you enter data directly into an RDL report as an embedded dataset. この機能は Power BI Desktop によく似ています。This feature is similar to Power BI Desktop. レポートのデータセットにデータを直接入力したり、Microsoft Excel など、別のプログラムから貼り付けたりできます。You can type the data directly in a dataset in your report, or paste it from another program like Microsoft Excel. データを入力してデータセットを作成したら、作成した他の埋め込みデータセットの場合と同じようにそれを利用できます。After you've created a dataset by entering data, you can use it just like you would any other embedded dataset you've created. また、複数のテーブルを追加したり、他のテーブルのフィルターとしてテーブルを利用したりできます。Plus you can add more than one table and use one as a filter for the other. この機能は特に、レポート パラメーターなど、レポートで場合によっては使用する必要がある、少量の固定データセットに便利です。This feature is especially useful for small, static datasets you might need to use in your report, like report parameters.

前提条件Prerequisites

データ ソースとデータセットを作成するCreate a data source and dataset

レポート ビルダーをダウンロードし、インストールしたら、埋め込みのデータ ソースやデータセットをレポートに追加するときと同じワークフローを実行します。After you’ve downloaded and installed Report Builder, you follow the same workflow you use to add an embedded data source and dataset to your report. 次の手順で、 [データ ソース] の下に次の新しいオプションが表示されます: [データの入力]In the following procedure, under Data Sources you see a new option: Enter Data. このデータ ソースはレポートで 1 回だけ設定します。You only need to set up this data source once in a report. その後、その 1 つのデータ ソースを使用し、入力したデータから複数のテーブルを個々のデータセットとして作成できます。After that, you can create multiple tables of entered data as separate datasets, all using that single data source.

  1. [レポート データ] ペインで、 [新規作成] > [データセット] を選択します。In the Report Data pane, select New > Dataset.

    レポート ビルダーの新しいデータセットのスクリーンショット。

  2. [データセットのプロパティ] ダイアログ ボックスで [レポートに埋め込まれたデータセットを使用する] を選択します。In the Dataset Properties dialog box, select Use a dataset embedded in my report.

  3. [データ ソース] の隣にある [新規作成] を選択します。Next to Data source, select New.

    新しい埋め込みデータ ソースのスクリーンショット。

  4. [データ ソースのプロパティ] ダイアログ ボックスで [レポートに埋め込まれた接続を使用する] を選択します。In the Data Source Properties dialog box, select Use a connection embedded in my report.

  5. [接続の種類の選択] ボックスで [データの入力] > [OK] の順に選択します。In the Select connection type box, select ENTER DATA > OK.

    データ ソースの [データの入力] のスクリーンショット。

  6. [データセットのプロパティ] ダイアログ ボックスに戻り、 [クエリ デザイナー] を選択します。Back in the Dataset Properties dialog box, select Query Designer.

  7. [クエリ デザイナー] ウィンドウで右クリックし、テーブルにデータを貼り付けます。In the Query Designer pane, right-click and paste your data in the table.

    クエリ デザイナーの [データの入力] のスクリーンショット。

  8. 列名を設定するには、各 NewColumn をダブルクリックし、列名を入力します。To set the column names, double-click each NewColumn and type the column name.

    列名の設定のスクリーンショット。

  9. 元のデータからの列見出しが最初の行に含まれる場合、右クリックして削除します。If the first row contains column headings from the original data, right-click and delete it.

  10. 既定では、各列のデータ型は文字列です。By default, the data type for each column is String. データ型を変更するには、列ヘッダーを右クリックして [型の変更] を選択し、日付や浮動小数点など、別のデータ型に設定します。To change the data type, right-click the column header > Change Type, and set it to another data type, such as Date or Float.

    データ型の変更のスクリーンショット。

  11. テーブルの作成が完了したら、 [OK] を選択します。When you’ve finished creating the table, select OK.

    生成されたクエリは、XML データ ソースの場合と同じになります。The query that’s generated is the same as you’d see with an XML data source. 実際には、データ プロバイダーとして XML を使用しています。Under the covers, we’re using XML as the data provider. このシナリオも有効にするために転用しています。We’ve repurposed it to enable this scenario as well.

    XML データ構造のスクリーンショット。

  12. [データセットのプロパティ] ダイアログ ボックスで、 [OK] を選択します。In the Dataset Properties dialog box, select OK.

  13. [レポート データ] ウィンドウにデータ ソースやデータセットが表示されます。You see your data source and dataset in the Report Data pane.

    [レポート データ] ペインのデータセットのスクリーンショット。

レポートのデータ視覚化の基礎として自分のデータセットを使用できます。You can use your dataset as the basis for data visualizations in your report. 別のデータセットを追加し、それに対して同じデータ ソースを使用することもできます。You can also add another dataset and use the same data source for it.

レポートのデザインDesign the report

データ ソースとデータセットを用意できたら、レポートを作成する準備は完了です。Now that you have a data source and dataset, you're ready to create your report. 次の手順では、前のセクションのデータに基づいて簡単なレポートを作成します。The following procedure creates a simple report based on the data in the previous section.

  1. [挿入] メニューで [テーブル] > [テーブル ウィザード] の順に選択します。On the Insert menu, select Table > Table Wizard.

    [テーブル ウィザード] オプションが選択されたスクリーンショット。

  2. 作成したデータセット、 [次へ] の順に選択します。Select the dataset you just created > Next.

    [データセットの選択] ダイアログのスクリーンショット。

  3. [フィールドの配置] ページで、グループ化するフィールドを [使用できるフィールド] ボックスから [行グループ] ボックスにドラッグします。In the Arrange fields page, drag fields you want to group by from the Available fields box to the Row groups box. この例は次のとおりです。In this example:

    • CountryRegionCountryRegion
    • SalesYearSalesYear
  4. 集計するフィールドを [使用できるフィールド] ボックスから [値] ボックスにドラッグします。Drag the fields you want to aggregate from the Available fields box to the Values box. この例は次のとおりです。In this example:

    • SalesAmountSalesAmount

    レポート ビルダーの既定では、 [値] ボックスのフィールドの合計が計算されますが、別の集計を選択することもできます。By default, Report Builder sums the fields in the Values box, but you can choose another aggregation.

    選択できるさまざまな集計のスクリーンショット。

  5. [次へ] を選択します。Select Next.

  6. [レイアウトの選択] ページでは、すべての設定を既定のままにしますが、 [グループの展開/折りたたみ] はオフにします。In the Choose the layout page, keep all the default settings, but clear Expand/collapse groups. 一般にグループの展開と折りたたみは優れた機能ですが、今回はすべてのデータを表示します。In general, expanding and collapsing groups is great, but this time we want to see all the data.

  7. [次へ] > [完了] の順に選択します。Select Next > Finish. テーブルがデザイン サーフェイスに表示されます。The table is displayed on the design surface.

    デザイン ビューのレポートのスクリーンショット。

レポートを実行するRun the report

実際の値を確認してレポートをプレビューするには、それを実行します。To see the actual values and preview the report, you run it.

  1. [ホーム] リボンの [実行] を選択します。Select Run in the Home ribbon.

    [ホーム] リボンの [実行] が選択されたスクリーンショット。

    これで、値が表示されるようになります。Now you see the values. マトリックスには、デザイン ビューで表示されていたものよりも多くの行があります。The matrix has more rows than you saw in Design view! ローカル コンピューターに保存したり、サービスに発行したりする前に、ページの書式を設定するか、既定の設定を使用することを決定できます。You can either format the page or decide to use the default settings before saving to your local computer or publishing to the service.

  2. レポートを印刷したときの外観を確認するには、 [印刷レイアウト] を選択します。To see how your report will look when you print it, select Print Layout.

    [印刷レイアウト] が選択されたスクリーンショット。

    これで印刷ページの見た目を確認できます。Now you see it as it will look on a printed page.

    印刷レイアウト ビューのレポートのスクリーンショット。

ページ分割されたレポートを Power BI サービスにアップロードするUpload the paginated report to the Power BI service

これで Power BI サービスでページ分割されたレポートがサポートされたので、自分のページ分割されたレポートを Premium 容量にアップロードできます。Now that paginated reports are supported in the Power BI service, you can upload your paginated report to a Premium capacity. 詳細については、「ページ分割されたレポートをアップロードする」を参照してください。See Upload a paginated report for details.

ページ分割されたレポートをレポート サーバーにアップロードするUpload the paginated report to a report server

ページ分割されたレポートは、Power BI Report Server や SQL Server Reporting Services 2016 または 2017 のレポート サーバーにアップロードすることもできます。You can also upload your paginated report to a Power BI Report Server or SQL Server Reporting Services 2016 or 2017 report server. アップロードする前に、追加のデータ拡張機能として RsReportServer.config に次の項目を追加する必要があります。Before you do, you need to add the following item to your RsReportServer.config as an additional data extension. 問題が発生した場合に備え、変更前に RsReportServer.config ファイルのバックアップを作成してください。Back up your RsReportServer.config file before you make the change, in case you run into any issues.

<Extension Name="ENTERDATA" Type="Microsoft.ReportingServices.DataExtensions.XmlDPConnection,Microsoft.ReportingServices.DataExtensions">
    <Configuration>
        <ConfigName>ENTERDATA</ConfigName>
    </Configuration>
</Extension>

編集後、構成ファイルのデータ プロバイダー一覧は次のようになります。After you've edited it, here's what the list of data providers in the config file should look like:

RsReportServer 構成ファイルのスクリーンショット。

作業はここまでです。これで、この新機能を使用するレポートをレポート サーバーに公開できます。That’s it – you can now publish reports that use this new functionality to your report server.

次の手順Next steps