SQL Server Analysis Services のデータの分析

 

適用先: SharePoint Server 2010

トピックの最終更新日: 2016-11-30

Microsoft Excel 2010 および Microsoft SQL Server 2008 R2 PowerPivot for Microsoft Excel 2010 を使用して、ピボットテーブル レポートおよびピボットグラフ レポートを作成し、Microsoft SQL Server 2008 Analysis Services (SSAS) からインポートされたデータを分析できます。PowerPivot for Excel 2010 は Excel 2013 へのアドインで、Microsoft ダウンロード センター (http://go.microsoft.com/fwlink/?LinkId=224183&clcid=0x411) からダウンロードできます。

Excel 2013 を使用するか PowerPivot for Excel 2010 を使用するかは、主に分析するデータの量によって決まります。PowerPivot for Excel 2010 では、より多くのデータ行がサポートされ、ユーザーは複数のソースからデータをインポートできます。また、Excel 2013 のすべてのネイティブ機能が使用されますが、計算はメモリ内のビジネス インテリジェンス エンジンによってより高速に処理されます。

ネットワーク管理者または IT 部門は、大規模組織および中規模組織でさまざまなサーバーを展開し維持しますが、インフォメーション ワーカー (IW) は、これらのサーバーに格納されているデータに頻繁にアクセスする必要があります。IW は、Excel 2013 および PowerPivot for Excel 2010 を使用して、ビジネス インテリジェンス用のセルフサービス タスクを実行できます。分析を実行するには、最初に SQL Server 2008 Analysis Services からビジネス インテリジェンス データをインポートする必要があります。通常、IT 部門は組織のバックエンド データを管理し、次のような重要な質問に答えることができます。

  • 必要なデータは何ですか。

  • このデータはどこに存在しますか。

  • このデータにアクセスする権限はありますか。

  • このデータにアクセスするために使用できるデータ接続ファイルはありますか。

Excel 2013 または PowerPivot for Excel 2010 でデータがインポートされると、そのデータをフィルター処理、整理、または並べ替えて、さらに分析することができます。

ピボットテーブル レポートは、大量のデータを集計し、集計データを分析、操作、および表示するための対話的な方法を提供します。ピボットグラフ レポートは、ピボットテーブルでブック データを視覚的に表現できるようにし、データのパターンや傾向を比較したり見つけたりするのを支援します。Excel でデータを作成し保持すると、ブックまたはワークシートの値を継続的に編集でき、ユーザーは、Excel 2013 または PowerPivot でこのデータを使用して分析を行います

外部データからピボットテーブル レポートを作成するときは、通常、Office データ接続 (ODC) ファイルを使用して外部データ ソースへの接続を作成します。接続情報は、Excel ブック内への埋め込み、ローカルまたはネットワーク ドライブからの参照、SharePoint Server の信頼できる場所 (データ接続ライブラリなど) からの参照もできます。ODC では、次のデータ プロバイダーをサポートします。

  • SQL Server、SQL Server Analysis Services、および PowerPivot

  • Oracle

  • IBM DB2

注意

SharePoint Server 管理者は、他のデータ プロバイダーをインストールおよび登録できます。

この記事の内容

  • Excel 2013 でのデータの分析 でのデータの分析

  • PowerPivot for Excel 2010 でのデータ分析 でのデータの分析

  • ピボットテーブルまたはピボットグラフの SharePoint Server 2010 への保存

Excel 2013 でのデータの分析

Excel クライアントを使用して外部ソースのデータを分析する場合は、以下の手順のいくつかまたはすべてを実行します。

  • 外部データ ソースを使用するピボットテーブル レポートまたはピボットグラフ レポートを作成するには

  • ピボットテーブル レポートを構成するには

  • ピボットテーブルでのスライサーの使用

このセクションでは、まず、SQL Server 2008 Analysis Services への接続を格納する ODC ファイルを作成する方法について説明します。次に、格納された接続を使用して外部ソースからデータをインポートする方法、最後に、ピボットテーブル レポートまたはピボットグラフ レポートを使用して Excel 2013 でデータを分析する方法について説明します。

以下の手順では、SQL Server 2008 Analysis Services への接続を格納する ODC ファイルを作成して、外部データをインポートし、次にピボットテーブル レポートおよびピボットグラフ レポートを構成する方法を説明します。

外部データ ソースを使用するピボットテーブル レポートまたはピボットグラフ レポートを作成するには

  1. Excel で [挿入] タブをクリックし、[テーブル] グループで [ピボットテーブル] の下にある矢印をクリックし、[ピボットテーブル] をクリックします。ピボットテーブル レポートに基づいて、同時にピボットグラフを作成することもできます。その場合は、[ピボットグラフ] をクリックします。

  2. [ピボットテーブルの作成] ウィンドウの [分析するデータを選択してください。] セクションで、[外部データ ソースを使用] をクリックし、外部データ ソース (SQL Server 2008 Analysis Services など) に接続します。次に、既存の Office データ接続 (ODC) ファイルを使用できる [接続の選択] をクリックします。または [参照] をクリックし、[データ ソースの選択] ウィンドウで [新しいソース] をクリックしてデータ接続ウィザードを開きます。

    データ接続ウィザードでは、以下の情報が必要です。

    • サーバーまたはインスタンスの名前

    • ログオン資格情報 (統合 Windows 認証または固定の資格情報)

    • データベース (リレーショナルまたは OLAP)

    • リレーショナル データベース用のテーブルまたはビュー、あるいは OLAP 用のキューブまたはパースペクティブ

    • データ接続ファイルの名前と保存場所 (ローカル ドライブ、ネットワーク ドライブなど)、または SharePoint Server の信頼できる場所 (データ接続ライブラリ)

    • 説明 (任意)

    • 検索キーワード

    • フレンドリ名 (ブックに表示されるデータ接続ファイルの名前)

    • Excel Services が接続ファイルで使用される場合は、以下の認証設定の 1 つを設定する必要があります。

      • Windows 認証   現在のユーザーの資格情報を使用する既定の認証方法

      • SSS   資格情報は Secure Store Service (SSS) アプリケーションに保存されます (SSS またはアプリケーションの ID が必要)

      • なし   認証情報は接続文字列に埋め込まれ、無人サービス アカウントが必要になります

  3. データ接続ウィザード ウィンドウで、表示されているリストから接続先のデータ ソースを選択し、[次へ] をクリックします。

  4. [データベース サーバーに接続] セクションの最初のボックスにサーバー名を入力し、接続に使用するログオン資格情報を選択します。この例では、ログオン資格情報として [Windows 認証を使用する] を選択し、[次へ] をクリックします。

  5. [データベースとテーブルの選択] セクションの [使用するデータが含まれているデータベースを選択] セクションの矢印をクリックし、リストからデータベースを選択します。次に、接続先の特定のデータがわかっている場合は、[指定したキューブまたはテーブルに接続] をクリックし、このウィンドウ下部にあるリストからキューブまたはリストを選択して、[次へ] をクリックします。

  6. [データ接続ファイルを保存して終了] ウィンドウで、この新しいデータ接続 (ODC) ファイルの名前と説明を入力し、[完了] をクリックして保存します。このウィンドウ下部で検索キーワードを入力し、必要に応じて [常にこのファイルを使用してデータを更新する] オプションをオンにすることもできます。Excel Services を使用してブックにアクセスするときに、このデータ接続で使用する認証の種類を指定する場合は、[認証の設定] をクリックし、[OK] をクリックします。データ接続ウィザードで [完了] をクリックします。

  7. この外部データ ソース接続に使用する新しい ODC 接続が作成されたので、[ピボットテーブルの作成] ウィンドウに戻ります。[ピボットテーブル レポートを配置する場所を選択してください] セクションで、以下の場所の 1 つを選択します。

    • ピボットテーブル レポートを新しいワークシートに 1 番目のセル A1 を先頭として配置するには、[新規ワークシート] オプションをクリックします。

    • 既存のワークシートにピボットテーブル レポートを配置するには、[既存のワークシート] オプションをクリックし、[場所] ボックスで、ピボットテーブル レポートを配置するセル範囲の先頭セルを指定します。既定の場所は、最初のワークシートの先頭セルで Sheet1!$A$1 になります。

  8. 完了したら [OK] をクリックします。

注意

ピボットテーブル レポートを作成しているときにピボットグラフ レポートを作成すると、Excel では関連するピボットテーブル レポートにグラフが表示されます。ピボットグラフ レポートと関連するピボットテーブル レポートは、必ず同じ Excel ブックに存在している必要があります。

Excel では、指定した場所に空のピボットテーブル レポートを追加し、ピボットテーブル フィールドの一覧を表示するため、分析するデータに応じて、フィールドの追加、レイアウトの作成、レポートのカスタマイズを行うことができます。このシナリオでは、空のピボットテーブル レポートを新しい Excel ワークシートに追加しました。次に、以下の手順を使用してフィールドをレポートに追加します。

ピボットテーブル レポートを構成するには

  1. Excel ワークシートの空のピボットテーブル レポートにフィールドを追加するには、以下の方法を使用します。

    注意

    ピボットグラフ レポートをピボットテーブル レポートと同時に作成すると、Excel ではピボットテーブル レポートにグラフが表示されます。ピボットテーブル レポートは、ピボットグラフ レポート用のソース データを提供します。つまり、一方のレポートでデータまたはレイアウトが変更されると、必ずもう一方のレポートも変更されます。

    • フィールド セクションの各フィールド名の横にあるチェック ボックスをオンにします。フィールドは、レイアウト セクションの既定のエリアに配置されます。ただし、必要に応じてフィールドを再編成できます。

      注意

      非数値フィールドは行ラベル エリアに、数値フィールドは値エリアに、オンライン分析処理 (OLAP) データと時間階層は列ラベル エリアにそれぞれ追加されます。

    • フィールド名を右クリックし、使用する適切なコマンドを選択します。以下のコマンドを利用できます。

      • レポート フィルターに追加

      • 列ラベルに追加

      • 行ラベルに追加

      • 値に追加

  2. フィールドをレイアウト セクション エリアにドラッグすることもできます。[レポートに追加するフィールドを選択してください] ボックスでフィールドをクリックしたまま、フィールド セクションから目的のレイアウト セクションにドラッグします。

ピボットテーブルのフィールドの一覧では、データのフィールド レイアウトを調整することによってピボットテーブル データとピボットグラフ データを管理できます。これによって、データをカスタマイズして分析をより簡単にできます。詳細については、Office.com の「ピボットテーブル レポートまたはピボットグラフ レポートのピボット データ 」 (http://go.microsoft.com/fwlink/?LinkId=224955&clcid=0x411) を参照してください。

ピボットテーブルでのスライサーの使用

Excel 2013 では、スライサーを使用して、ピボットテーブル レポートのデータをフィルター処理します。スライサーは、フィルター処理を可能にする一連のボタンを提供するフィルター コンポーネントです。各スライサーは特定のピボットテーブル フィールドでフィルター処理を行うため、通常、各ピボットテーブル レポートで複数のスライサーを使用します。共有スライサーは複数のピボットテーブルで使用され、ローカル スライサーは 1 つのピボットテーブルで使用されます。OLAP キューブ関数から参照されるスタンドアロンのスライサーを作成し、後から任意のピボットテーブルで使用することもできます。

既存のピボットテーブルでスライサーを作成するには

  1. Excel 2013 でピボットテーブル レポートを開き、レポート内の任意の場所をクリックします。これによって、[オプション] と [デザイン] を含むピボットテーブル ツール (グループ) が有効になります。

  2. [オプション] をクリックし、次に [並べ替えとフィルター] セクションで [スライサー​​の挿入] をクリックします。

  3. [スライサー​​の挿入] ウィンドウで、スライサーを作成するピボットテーブル フィールドのチェック ボックスをオンにします。複数のアイテムを選択するには、Ctrl キーを押しながら、フィルター処理する他のアイテムをクリックします。

  4. [OK] をクリックします。選択したすべてのフィールドを含むスライサーが表示されます。

スタンドアロンのスライサーを作成するには

  1. Excel 2013 でピボットテーブル レポートを開き、リボンの [挿入] タブをクリックし、[フィルター] グループの [スライサー] をクリックします。

  2. [既存の接続] ダイアログ ボックスの [表示] ボックスで、以下の接続タイプの 1 つを選択します。

    • すべての接続   利用可能なすべての接続を表示します。

    • このブック内の接続   このブック用に作成された接続 (たとえばデータ接続ウィザードを使用して作成された接続) のリストのみを表示します。

    • ネットワーク上の接続ファイル   ネットワークで利用できる接続のみを表示します。これらの接続は、通常、SharePoint Server 2010 のデータ接続ライブラリに存在します。

    • このコンピューター上の接続ファイル   このコンピューターで利用できる接続のみを表示します。

      新しいデータ接続ファイルを作成する必要がある場合は、[参照]、[新しいソース] の順にクリックします。これにより、データ接続ウィザードが開き、リモート データ ソースに対する新しい接続を作成できます。

  3. [接続の選択] ウィンドウで、使用する接続をクリックし、[開く] をクリックします。

  4. [スライサーの挿入] ダイアログ ボックスでスライサーを作成するフィールドのチェック ボックスをオンにし、[OK] をクリックします。

スライサーを別のピボットテーブルと共有するには

  1. 共有するスライサーを含むピボットテーブルを開き、スライサーをクリックします。リボンに [スライサー ツール] タブが表示されます。

  2. リボンの [オプション] タブをクリックし、[スライサー] グループの [ピボットテーブルの接続] をクリックします。

  3. [ピボットテーブルの接続] ダイアログ ボックスで、共有するピボットテーブルのチェック ボックスをオンにし、[OK] をクリックします。

別のピボットテーブルから共有スライサーを使用するには

  1. Excel 2013 ブックのリボンで [データ] タブをクリックし、[外部データの取り込み] セクションで [既存の接続] をクリックします。

  2. [既存の接続] ダイアログ ボックスの [表示] ボックスで、[すべての接続] が選択されていることを確認します。使用する接続を選択し、[開く] をクリックします。

  3. [データのインポート] ウィンドウで、[ピボットテーブル レポート] のオプション ボタンをクリックし、[OK] をクリックします。

  4. ピボットテーブル レポートが表示されたら、レポートの任意の場所をクリックし、[ピボットテーブル ツール] をリボンに表示します。[オプション] タブをクリックし、[並べ替えとフィルター] セクションで [スライサーの挿入] をクリックし、次に [スライサーの接続] をクリックします。

  5. [スライサーの接続] ウィンドウで、使用するスライサーのチェック ボックスをオンにし、[OK] をクリックします。

  6. 各スライサーで、フィルター処理するアイテムをクリックします。スライサーを共有するすべてのピボットテーブルに同じフィルターが表示されます。

PowerPivot for Excel 2010 でのデータ分析

PowerPivot for Excel 2010 では、データをインポートし、そのデータを自由に分析できます。データを PowerPivot for Excel ウィンドウにインポートしたら、以下のタスクのいずれかを実行して分析の準備を行うことができます。

  • データのレビュー

  • 状況に応じた情報のフィルター処理

  • テーブル列の追加または削除によるデータの操作

  • リレーションシップによる複数テーブルの接続

  • データの目的を示すための新しい計算の作成

PowerPivot for Excel 2010 には柔軟性があります。つまり、データ分析の準備をするときに必ずこれらのプロセスを実行する必要はありませんが、多くの場合、これらのプロセスは互いに独立して実行でき、ユーザーが同じ結果を得るのに役立ちます。詳細については、「Prepare Data for Analysis in PowerPivot」を参照してください。

このセクションでは、PowerPivot for Excel ウィンドウに追加したデータを操作する方法について、以下の分野を説明します。

  • SQL Server Analysis Services キューブからのデータのインポート

  • ピボットテーブル レポートまたはピボットグラフ レポートの作成

  • ピボットテーブルまたはピボットグラフでのメジャーの作成

  • スライサーを使用した PowerPivot のデータのフィルター処理

  • ピボットテーブルまたはピボットグラフの SharePoint Server 2010 への保存

SQL Server Analysis Services キューブからのデータのインポート

このセクションでは、PowerPivot for Excel 2010 で SQL Server Analysis Services キューブからデータをインポートする方法について説明します。PowerPivot for Excel でキューブからデータをインポートする場合は、クエリを使用して、データを指定および取得する必要があります。また、キューブからインポートするデータはフラット化されます。つまり、複数のディメンションとともにメジャーを取得するクエリを定義すると、各ディメンションがそれぞれ別の列になるデータがインポートされます。

キューブからデータをインポートするには

  1. Excel で [PowerPivot] タブをクリックし、[起動] セクションで [PowerPivot ウィンドウ] をクリックします。

  2. PowerPivot ウィンドウの [外部データの取り込み] セクションで、[データベースから] をクリックし、次に [Analysis Services または PowerPivot から] を選択します。

  3. [テーブルのインポート ウィザード] ウィンドウの [Microsoft SQL Server Analysis Services に接続します。] ページで、[接続の表示名] ボックスにこのデータ接続用のわかりやすい名前を入力します。

  4. [サーバー名またはファイル名] ボックスに、SQL Server Analysis Services インスタンスをホストするサーバーの名前と SQL Server Analysis Services インスタンス名を入力します。ここでは、Contoso\SSAS を使用します。

  5. [データベース名] で、ボックスの横の下矢印をクリックし、リストから Analysis Services データベースを選択します。

  6. [次へ] をクリックして続行します。

  7. [MDX クエリの指定] ページで、使用する既存の MDX クエリ ステートメントをボックスに貼り付けるか、[デザイン] をクリックし MDX クエリ ビルダーを開きます。

    独自の MDX クエリをボックスに貼り付ける場合は、[検証] をクリックし、クエリが動作することを確認します。

  8. 以下の手順では、例としてサンプルの Contoso キューブを使用し、MDX クエリ ビルダーでクエリを作成します。

    1. [キューブの選択] をクリックし、利用可能なキューブの一覧を展開します。このボタンは、クエリ ビルダーの左側と [メタデータ] ウィンドウの上部にあります。使用する [Slaes] キューブをこのリストから選択します。

    2. [メタデータ] ウィンドウで、[メジャー]、[Slaes] の順に展開します。

    3. [Sales Amount] を [データ ペイン] にドラッグします。

    4. [メタデータ] ウィンドウで、[製品] ディメンションを展開し、[Product Category Name] を [データ ペイン] の [Sales Amount] の左にドラッグします。

    5. [メタデータ] ウィンドウで、[日付] ディメンションを展開し、[Calendar Year] を [データ ペイン] の [Product Category Name] の左にドラッグします。

    6. [メタデータ] ウィンドウで、日付を [フィルター] ウィンドウの [ディメンション] 列にドラッグします。[階層] で [Calendar Year] を選択します。[演算子] で、[範囲 (排他)] を選択します。[フィルター式] で下矢印をクリックし、左側で [Year 2005] を選択し、右側で [Year 2009] を選択します。

      これによってキューブにフィルターが作成され、2005 と 2009 の値が除外されます。

    7. [OK] をクリックすると、MDX クエリが MDX ステートメント ボックスに表示されます。

    8. [クエリの表示名] ボックスにこのデータ セットの名前を入力し、[終了] をクリックします。

    9. [インポートしています] ページで、データの読み込みが完了したら [閉じる] をクリックします。

MDX クエリを作成する方法については、「Analysis Services MDX Query Designer (PowerPivot)」を参照してください。

ピボットテーブル レポートまたはピボットグラフ レポートの作成

PowerPivot for Excel で Excel ブックを使用すると、2 か所でピボットテーブルとピボットグラフを作成できます。これらは、PowerPivot ウィンドウの [ホーム] タブ、または Excel ウィンドウの [PowerPivot] タブで作成できます。PowerPivot ウィンドウのデータを使用してピボットテーブルまたはピボットグラフを作成するときは、これらのオプションの 1 つを使用する必要があります。[Excel] ウィンドウの [挿入] タブの [ピボットテーブル] ボタンでは、Excel ブックに格納されたデータを使用し、PowerPivot データは使用しません。

ピボットテーブル レポートまたはピボットグラフ レポートを作成するには

  1. PowerPivot ウィンドウの [ホーム] タブの [レポート] グループで、[ピボットテーブル] ボタンの下にある下矢印をクリックします。

  2. 表示されているリストから必要なオプションを選択します。

    • ピボットテーブル

    • ピボットグラフ

    • グラフとテーブル (横)

    • グラフとテーブル (縦)

    • 2 つのグラフ (横)

    • 2 つのグラフ (縦)

    • 4 つのグラフ

    • フラット化したピボットテーブル

  3. 新しいピボットテーブルまたはピボットグラフを作成する場所を指定するには、[新しいワークシート] または [既存のワークシート] をクリックします。

  4. [OK] をクリックします。Excel には、選択された場所にレポートが追加され、フィールドの追加とレポートのカスタマイズに使用できる [PowerPivot フィールドの一覧] が表示されます。

詳細については、「ピボットテーブル レポートまたはピボットグラフ レポートの作成」および「PowerPivot フィールドの一覧」を参照してください。

ピボットテーブルまたはピボットグラフでのメジャーの作成

ピボットテーブル レポートまたはピボットグラフ レポートを作成したら、レポートを分析するためのメジャーを作成できます。メジャーは、ピボットテーブルまたはピボットグラフ専用に作成される数式で、PowerPivot データを使用します。[メジャーの設定] ダイアログ ボックスを使用して、標準の集計 (合計、平均など) や、PowerPivot ウィンドウの列およびテーブルを使用する別の計算を含むメジャーを作成します。フィールドを [値] フィールド エリアにドラッグし、標準集計メソッド (COUNT、SIM、AVERAGE、MIN<、MAX など) の 1 つを選択することにより、Excel と全く同じように標準集計を作成します。メジャーは、保存時に、基本テーブルとともに保存されますが、ピボットテーブル レポートまたはピボットグラフ レポートのどこででも使用できます。

[メジャーの設定] ダイアログ ボックスを使用して、カスタム集計またはユーザー定義集計を作成します。PowerPivot メジャーの数式は、Excel の数式と似ていますが、テーブルを操作し、フィルター集計を計算し、さらにタイム インテリジェンスとともに使用する、さまざまな機能が追加されています。

メジャーを作成するには

  1. Excel ウィンドウで、PowerPivot ウィンドウのテーブルに関連付けられた既存のピボットテーブルの内部をクリックします。

  2. [PowerPivot] タブをクリックし、[メジャー] セクションで [新しいメジャー] をクリックします。

  3. [メジャーの設定] ダイアログ ボックスで、[テーブル名] の横にある矢印をクリックし、ドロップダウン リストからテーブルを選択します。

  4. [メジャー名 (すべてのピボットテーブル)] で、このメジャーの識別子として使用する名前を入力します。識別子名は一意でなければなりません。この名前は、ブックに存在している列、テーブル、メジャーと同じ名前にすることはできません。

  5. [カスタム名 (このピボットテーブル)] で、ピボットテーブルでこのメジャーの表示名として使用する名前を入力します。

  6. [] ボックスで、使用する数式を入力するか、[Fx] をクリックしてリストから関数を選択して数式を作成します。

    数式の作成方法については、「計算式を作成する」を参照してください。

  7. [数式の確認] をクリックして数式を確認し、[OK] をクリックします。

メジャーを編集するには

  1. [Excel] ウィンドウで、既存のピボットテーブルまたはピボットグラフ エリアの内部をクリックし、[PowerPivot フィールドの一覧] を表示します。

  2. PowerPivot のフィールドの一覧で、編集するメジャーを含むテーブルの名前を検索し、メジャーを右クリックして [式の編集] をクリックします。メジャーが表示され、名前の横に小さな計算アイコンが表示されます。

  3. [メジャーの設定] ダイアログ ボックスで、数式を編集します。終了したら、[数式の確認] をクリックし、[OK] をクリックします。

スライサーを使用した PowerPivot のデータのフィルター処理

PowerPivot のスライサーは Excel のスライサーと同じです。スライサーは、ピボットテーブルおよびピボットグラフのデータを絞り込むワンクリックのフィルター処理コントロールです。スライサーを使用すると、条件を選択したときの変化を協調的に表示することができます。スライサーでは、行はテーブルに追加されず、データの対話的なビューのみが表示されます。以下の手順では、PowerPivot でスライサーを使用する方法について説明します。

Excel 2013 のリボンを使用するか、フィールド アイテムを [PowerPivot フィールドの一覧] の [垂直スライサー] エリアまたは [水平スライサー] エリアにドラッグして、スライサーを追加できます。

PowerPivot フィールドの一覧を使用してスライサーを追加するには

  1. Excel 2013 ウィンドウで、ピボットテーブルの任意の場所をクリックし [PowerPivot フィールドの一覧] を表示します。

  2. [PowerPivot フィールドの一覧] で、以下のタスクの 1 つを実行します。

    • フィルター処理に使用するフィールドを右クリックし、[水平スライサーに追加] または [垂直スライサーに追加] をクリックします。

    • フィルター処理に使用するフィールドを [垂直スライサー] エリアまたは [水平スライサー] エリアにドラッグします。

    スライサーがブックに表示され、スライサー アイテムが表示されます。既定では、すべてのスライサー アイテムが選択されています。

  3. ピボットテーブルのデータにフィルターを適用するために使用するスライサー アイテムをクリックします。複数のアイテムを追加するには、Ctrl キーを押しながら各スライサー アイテムをクリックします。

ブック内でスライサーを並べ替えるには

  • [PowerPivot フィールドの一覧] で [垂直スライサー] エリアまたは [水平スライサー] エリアでフィールド名を右クリックし、[上へ移動]、[下へ移動]、[先頭に移動]、または [末尾に移動] の 1 つを選択して順序を変更します。

スライサーのサイズと位置を変更するには

  1. Excel 2013 ウィンドウで、ピボットテーブルの任意の場所をクリックし [PowerPivot フィールドの一覧] を表示します。PowerPivot を使用して既に追加されているスライサーは、灰色の境界線の内部に表示されます。

  2. スライサー ゾーンの灰色の境界線をクリック アンド ドラッグし、スライサーのサイズと位置を変更します。

  3. 複数のスライサーを並べて配置する場合は、目的の順序でスライサーを並べてドラッグします。スライサーは灰色の境界線内に収まります。

ピボットテーブルまたはピボットグラフの SharePoint Server 2010 への保存

ピボットテーブル レポートまたはピボットグラフ レポートを作成したら、他のユーザーがこのデータを Web ブラウザーで分析できるように、それらを SharePoint Server 2010 サイトに保存します。このとき、Excel をコンピューターにインストールする必要はありません。ブックを SharePoint Server 2010 サイトに保存するときは、完了したブックが保存されますが、発行する個々のワークシート アイテムまたはブック アイテムを選択することもできます。

ピボットテーブル レポートまたはピボットグラフ レポートを SharePoint Server 2010 に保存するには

  1. Excel 2013 のリボンで [ファイル] タブをクリックし、[保存と送信] をクリックし、[SharePoint に保存] をクリックします。

  2. 発行する特定のワークシート アイテムまたはブック アイテムを選択するには、[発行オプション] をクリックします。

  3. [発行オプション] の [表示] タブで、リスト内の既定の [ブック全体] の横にある矢印をクリックし、次に [ブック内のアイテム] をクリックします。これにより、名前付き範囲、グラフ、テーブル、ピボットテーブルなど、ブラウザーに表示する特定のアイテムをブックに応じて選択できるようになります。

  4. 次のボックスで、保存するアイテム ([すべてのグラフ]、[すべてのピボットテーブル] など) をリストから選択します。

  5. [パラメーター] タブで、使用する定義済みの名前を入力し、ユーザーがブラウザーで Excel を使用してブックを表示するときに編集できるセルを指定します。次に [OK] をクリックし、[発行オプション] ダイアログ ボックスを閉じます。

  6. ブックを保存する SharePoint Server 2010 サイトを [現在の場所]、[最近使用した場所]、または [場所] リストから選択します。保存されるサイトが一覧表示されない場合は、[場所の参照] をクリックし [名前を付けて保存] ダイアログ ボックスを開きます。

  7. [名前を付けて保存] ダイアログ ボックスで、SharePoint Server 2010 サイトの Web アドレスを入力し、ブックを保存するサイトを参照します。

  8. [ファイル名] ボックスで、ファイル名をそのまま使用するか、ファイル名を変更します。

  9. 保存した後にブラウザー ウィンドウにブックの内容を表示する場合は、[ブラウザー上の Excel で開く] チェック ボックスをオンにします。

  10. [保存] をクリックします。

See Also

Other Resources

Create a Reporting Services Report with PowerPivot Data