チュートリアル : カスタム動作の作成

更新 : 2007 年 11 月

次のチュートリアルでは、インストール終了時にユーザーを Web ページへ導く DLL カスタム動作の作成方法について、手順を説明します。

d9k65z2d.alert_note(ja-jp,VS.90).gifメモ :

使用している設定またはエディションによっては、ヘルプの記載と異なるダイアログ ボックスやメニュー コマンドが表示される場合があります。設定を変更するには、[ツール] メニューの [設定のインポートとエクスポート] をクリックします。詳細については、「Visual Studio の設定」を参照してください。

d9k65z2d.alert_note(ja-jp,VS.90).gifメモ :

以下の手順は、Visual Basic プロジェクトを例として使用して、配置を作成する方法を示しています。この一般原則は、Windows ベースのアプリケーションの配置をサポートするすべての言語の Visual Studio プロジェクトに適用されます。

カスタム動作を作成するには

  1. [ファイル] メニューの [新規作成] をポイントし、[プロジェクト] をクリックします。

  2. [新しいプロジェクト] ダイアログ ボックスで、[プロジェクトの種類] ペインの [Visual Basic プロジェクト] をクリックし、[テンプレート] ペインの [クラス ライブラリ] をクリックします。[プロジェクト名] ボックスに「OpenWeb」と入力します。

    新規プロジェクトがソリューション エクスプローラに追加されます。

  3. [プロジェクト] メニューの [クラスの追加] をクリックし、[新しい項目の追加] ダイアログ ボックスの [インストーラ クラス] をクリックします。Installer1.vb という既定の名前をそのまま使用します。[追加] をクリックします。

  4. デザイン サーフェイスの [ここをクリックするとコード ビューに切り替わります] をクリック (またはデザイン サーフェイスを右クリックして [コードの表示] をクリック) して、コード ビューに切り替えます。

  5. コード エディタで、Installer1.vb のコンストラクタの下に、次のコード (Web ブラウザを開くコード) を追加します。

    <Security.Permissions.SecurityPermission(Security.Permissions.SecurityAction.Demand)> _
    Public Overrides Sub Commit(ByVal savedState As _
      System.Collections.IDictionary)
    
      MyBase.Commit(savedState)
      System.Diagnostics.Process.Start("http://www.microsoft.com")
    End Sub
    
    d9k65z2d.alert_note(ja-jp,VS.90).gifメモ :

    「Public Overrides」と入力し、次に空白を入力すると、IntelliSense によってメソッドとプロパティのリストが表示されます。リストから [Commit] を選択して完全な宣言を取得します。

  6. ソリューション エクスプローラで、[Class1.vb] を右クリックし、これが不要であるため [削除] をクリックします。

配置プロジェクトを追加するには

  1. [ファイル] メニューの [追加] をポイントし、[新しいプロジェクト] をクリックします。

  2. [新しいプロジェクトの追加] ダイアログ ボックスの [プロジェクトの種類] ペインで、[その他のプロジェクトの種類] ノードを開き、[セットアップ/配置プロジェクト] をクリックします。[テンプレート] ペインの [セットアップ プロジェクト] をクリックします。[プロジェクト名] ボックスに「Custom Action Installer」と入力します。

    プロジェクトがソリューション エクスプローラに追加され、ファイル システム エディタが表示されます。

  3. ファイル システム エディタの左ペインで [アプリケーション フォルダ] を選択します。[操作] メニューの [追加] をポイントし、[プロジェクト出力] をクリックします。

  4. [プロジェクト出力グループの追加] ダイアログ ボックスの [プロジェクト] ボックスの一覧に OpenWeb が表示されます。[プライマリ出力] を選択します。

    アプリケーション フォルダに [OpenWeb (アクティブ) のプライマリ出力] が表示されます。

カスタム動作を追加するには

  1. ソリューション エクスプローラで、Custom Action Installer プロジェクトを選択します。[表示] メニューの [エディタ] をポイントし、[カスタム動作] をクリックします。

    カスタム動作エディタが表示されます。

  2. カスタム動作エディタで、[確定] ノードを選択します。[操作] メニューの [カスタム動作の追加] をクリックします。

  3. [プロジェクトから項目を選択] ダイアログ ボックスで、[アプリケーション フォルダ] をダブルクリックします。[OpenWeb のプライマリ出力] を選択します。

    カスタム動作エディタ内で、[確定] ノードの下に [OpenWeb の プライマリ出力] が表示されます。

  4. [プロパティ] ウィンドウで、InstallerClass プロパティに True (既定値) が設定されていることを確認します。

  5. [確定] ノードのときと同じように、カスタム動作エディタで [インストール] ノードを選択し、このノードに [OpenWeb のプライマリ出力] を追加します。

  6. [ビルド] メニューの [Custom Action Installer のビルド] をクリックします。

開発用コンピュータにインストールするには

  • ソリューション エクスプローラで、Custom Action Installer プロジェクトを選択します。[プロジェクト] メニューの [インストール] をクリックします。

    インストーラが実行され、開発用コンピュータに Custom Action Installer がインストールされます。インストールの最後に Internet Explorer が開始され、Microsoft.com Web サイトが表示されます。

    d9k65z2d.alert_note(ja-jp,VS.90).gifメモ :

    インストーラを実行するには、コンピュータ上でインストールを実行する権限が必要です。

ほかのコンピュータに配置するには

  1. Windows のエクスプローラで、プロジェクト ディレクトリに移動し、ビルドされたインストーラを探します。既定のパスは \Documents and Settings\yourloginname\My Documents\Visual Studio\Projects\Custom Action Installer\Custom Action Installer\project configuration\Custom Action Installer.msi です。既定の project configuration は Debug です。

  2. Custom Action Installer.msi、Setup.exe、およびディレクトリ内の他のファイルとサブディレクトリをすべて別のコンピュータにコピーします。

    d9k65z2d.alert_note(ja-jp,VS.90).gifメモ :

    ネットワークに接続していないコンピュータにインストールするには、ファイルを CD-ROM などの従来のメディアにコピーしてください。

  3. ターゲット コンピュータで、Setup.exe をダブルクリックしてインストーラを実行します。

    インストールの最後に Internet Explorer が開始され、Microsoft.com Web サイトが表示されます。

    d9k65z2d.alert_note(ja-jp,VS.90).gifメモ :

    インストーラを実行するには、コンピュータ上でインストールを実行する権限が必要です。

    d9k65z2d.alert_note(ja-jp,VS.90).gifメモ :

    ターゲット コンピュータに .NET Framework がインストールされていない場合はこの配置によってインストールされますが、このインストールには数分間かかる場合があります。

アプリケーションをアンインストールするには

  1. [コントロール パネル] で [プログラムの追加と削除] をダブルクリックします。

  2. [プログラムの追加と削除] ダイアログ ボックスの [Custom Action Installer] をクリックし、[削除] をクリックします。

    d9k65z2d.alert_note(ja-jp,VS.90).gifヒント :

    開発用コンピュータからアンインストールするには、ソリューション エクスプローラで Custom Action Installer プロジェクトを開いて選択し、[プロジェクト] メニューの [アンインストール] をクリックします。

参照

概念

カスタム動作

その他の技術情報

配置でのカスタム動作の管理