方法 : プロジェクト プロパティおよび構成設定を変更する

プロジェクトに関連するプロパティは、[プロパティ] ウィンドウまたは [<プロジェクト名> プロパティ ページ] ダイアログ ボックスで表示したり変更したりできます。Visual Studio でどこにプロパティが表示されるかは、プロジェクトの種類によって決まります。

[!メモ]

使用している設定またはエディションによっては、ダイアログ ボックスで使用可能なオプションや、メニュー コマンドの名前や位置がヘルプに記載されている内容と異なる場合があります。このヘルプ ページは、全般的な開発設定を考慮して記述されています。設定を表示または変更するには、[ツール] メニューの [設定のインポートとエクスポート] をクリックします。詳細については、「Visual Studio での開発設定のカスタマイズ」を参照してください。

プロジェクト プロパティを表示するには

  1. ソリューション エクスプローラーでプロジェクトを選択します。

  2. [表示] メニューの [プロパティ ウィンドウ] をクリックします。

  3. [プロパティ] ウィンドウで、変更するプロパティを変更します。

プロジェクト構成に固有のプロパティを変更するには、プロジェクト デザイナーを開く必要があります。プロパティ ページには、通常、プロジェクト全体に適用されるプロパティと、選択した構成に固有のプロパティが表示されます。

プロジェクト デザイナーを開くには

  1. ソリューション エクスプローラーでプロジェクトを選択します。

  2. [プロジェクト] メニューの [プロパティ] をクリックします。

    プロジェクト デザイナーが開きます。

ソリューションの共通プロパティの編集

[ソリューション '<ソリューション名>' プロパティ ページ] ダイアログ ボックスの [共通プロパティ] を設定すると、プロジェクトまたはソリューションの複数のビルドに組み込む要素を整理するのに役立ちます。これらのプロパティを使用する一般的な方法がいくつかあります。

[ソリューション '<ソリューション名>' プロパティ ページ] の [共通プロパティ] を編集するには

  1. ソリューション エクスプローラーで、ソリューションを選択します。

  2. [表示] メニューの [プロパティ ページ] をクリックします。

  3. [ソリューション プロパティ ページ] ダイアログ ボックスで、左ペインの一連の共通プロパティを選択します。

  4. 右に表示されるプロパティの値を入力します。

デバッガーの起動時における複数のプロジェクトの実行方法を決定するには

  1. [ソリューション '<ソリューション名>' プロパティ ページ] ダイアログ ボックスを開きます。

  2. [共通プロパティ][スタートアップ プロジェクト] のセットを選択します。

  3. 右のペインで、[マルチ スタートアップ プロジェクト] を選択します。

  4. 各プロジェクトの [アクション] フィールドで、起動オプションを選択します。

    [開始] デバッガーの起動時にプロジェクトを実行します。

    [デバッグなしで開始] デバッガーの起動時にプロジェクトを実行しますが、プロジェクトのデバッグは行いません。

    [なし] デバッガーの起動時にプロジェクトを実行しません。

デバッガーの起動時の複数のプロジェクトの実行順序を設定するには

  1. [ソリューション '<ソリューション名>' プロパティ ページ] ダイアログ ボックスを開きます。

  2. [共通プロパティ][スタートアップ プロジェクト] のセットを選択します。

  3. 右のペインで、[マルチ スタートアップ プロジェクト] を選択します。

  4. デバッガーの起動時に、選択したプロジェクトを先に実行する場合は、[上へ] をクリックします。後から実行する場合は、[下へ] をクリックします。

あるプロジェクトを別のプロジェクトに依存させるには

  1. [ソリューション '<ソリューション名>' プロパティ ページ] ダイアログ ボックスを開きます。

  2. [共通プロパティ][プロジェクト依存関係] のセットを選択します。

  3. [プロジェクト] メニューで、現在のソリューションのプロジェクトを選択します。

  4. 下にある [依存先] フィールドで、選択したプロジェクトよりも先にビルドする必要のあるプロジェクトのチェック ボックスをオンにします。

[プロジェクト依存関係] を使用してプロジェクトのビルド順序を設定するには

  1. [ソリューション '<ソリューション名>' プロパティ ページ] ダイアログ ボックスを開きます。

  2. [共通プロパティ][プロジェクト依存関係] のセットを選択します。

  3. [プロジェクト] メニューで、最後にビルドするプロジェクトを選択します。

  4. [依存先] ウィンドウで、上で選択したプロジェクトよりも先にビルドするすべてのプロジェクトのチェック ボックスをオンにします。

  5. [プロジェクト] メニューで、最後にビルドするプロジェクトの 1 つ前にビルドするプロジェクトを選択します。

  6. [依存先] ウィンドウで、上で選択したプロジェクトよりも先にビルドするすべてのプロジェクトを選択します。

  7. このプロセスをビルドするプロジェクトの最後のほうから開始して先頭のプロジェクトまで繰り返し、先にビルドするプロジェクトの一覧が [依存先] に表示されなくなるまで続けます。

参照

処理手順

方法 : 構成を作成および編集する

Visual Studio でのプロジェクトとソリューションのビルドおよびクリーン

関連項目

[プロパティ] ウィンドウ

概念

ソリューションおよびプロジェクト

ビルド構成について

その他の技術情報

Visual Studio でのアプリケーションのビルド