PowerPivot からのインポート (SSAS テーブル)Import from PowerPivot (SSAS Tabular)

このトピックでは、SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT) の PowerPivot からのインポート プロジェクト テンプレートを使用して PowerPivot ブックからメタデータおよびデータをインポートし、新しい表形式モデル プロジェクトを作成する方法を説明します。This topic describes how to create a new tabular model project by importing the metadata and data from a PowerPivot workbook by using the Import from PowerPivot project template in SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT).

Excel ファイルの PowerPivot から表形式の新しいモデルを作成します。Create a new Tabular Model from a PowerPivot for Excel file

PowerPivot ブックからのインポートにより新しいテーブル モデル プロジェクトを作成すると、ブックの構造を定義するメタデータが使用され、SQL Server Data ToolsSQL Server Data Tools にテーブル モデルの構造が作成および定義されます。When creating a new tabular model project by importing from a PowerPivot workbook, the metadata that defines the structure of the workbook is used to create and define the structure of the tabular model project in SQL Server Data ToolsSQL Server Data Tools. テーブル、列、メジャー、リレーションシップなどのオブジェクトは、PowerPivot ブックにあるとおりにテーブル モデル プロジェクトで保持および表示されます。Objects such as tables, columns, measures, and relationships are retained and will appear in the tabular model project as they are in the PowerPivot workbook. .xlsx ブック ファイルに対する変更は行われません。No changes are made to the .xlsx workbook file.

注意

リンク テーブルは、テーブル モデルではサポートされません。Tabular models do not support linked tables. リンク テーブルを含む PowerPivot ブックからインポートするとき、リンク テーブル データはコピー/貼り付けデータとして取り扱われ、Model.bim ファイルに保存されます。When importing from a PowerPivot workbook that contains a linked table, linked table data is treated as copy\pasted data and stored in the Model.bim file. コピー/貼り付けテーブルのプロパティを表示するとき、 ソース データ プロパティは無効であり、 [テーブル] メニューの [テーブルのプロパティ] ダイアログは無効です。When viewing properties for a copy\pasted table, the Source Data property is disabled and the Table Properties dialog on the Table menu is disabled.

モデルに埋め込まれているデータに追加できる行数は 10,000 行に制限されています。There is a limit of 10,000 rows that can be added to the data embedded in the model. PowerPivot からモデルをインポートしたときに、"データが切り捨てられました。If you import a model from PowerPivot and see the error, “Data was truncated. 貼り付けられたテーブルに含めることができるのは 10000 行までです。" というエラーが表示された場合は、SQL Server のテーブルなど、別のデータ ソースに埋め込みデータを移動することによって、PowerPivot モデルを変更する必要があります。Pasted tables cannot contain more than 10000 rows” you should revise the PowerPivot model by moving the embedded data into another data source, such as a table in SQL Server, and then re-import.

ワークスペース データベースが、 SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT) と同じコンピューター (ローカル) の Analysis Services インスタンスにあるか、リモートの Analysis Services インスタンスにあるかにより、特に注意する点が変わります。There are special considerations depending on whether or not the workspace database is on an Analysis Services instance on the same computer (local) as SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT) or is on a remote Analysis Services instance..

ワークスペース データベースが、Analysis Services のローカル インスタンスにある場合は、メタデータとデータの両方を PowerPivot ブックからインポートできます。If the workspace database is on a local instance of Analysis Services, you can import both the metadata and data from the PowerPivot workbook. メタデータはブックからコピーされて、テーブル モデル プロジェクトを作成するために使用されます。The metadata is copied from the workbook and used to create the tabular model project. データはブックからコピーされて、プロジェクトのワークスペース データベースに保存されます (Model.bim ファイルに保存されるコピー/貼り付けデータ以外)。The data is then copied from the workbook and stored in the project’s workspace database (except for copy/pasted data, which is stored in the Model.bim file).

ワークスペース データベースが、Analysis Services のリモート インスタンスにある場合は、PowerPivot for Excel ブックからデータをインポートできません。If the workspace database is on a remote Analysis Services instance, you cannot import data from a PowerPivot for Excel workbook. ブックのメタデータはインポートできますが、インポートすると、スクリプトがリモートの Analysis Services インスタンスで実行されます。You can still import the workbook metadata; however, this will cause a script to be run on the remote Analysis Services instance. 信頼できる PowerPivot ブックからのみメタデータをインポートする必要があります。You should only import metadata from a trusted PowerPivot workbook. データは、データ ソース接続に定義されたソースからインポートする必要があります。Data must be imported from sources defined in the data source connections. PowerPivot ブックのコピー/貼り付けデータとリンク テーブル データは、テーブル モデル プロジェクトにコピーして貼り付ける必要があります。Copy/pasted and linked table data in the PowerPivot workbook must be copied and pasted into the tabular model project.

PowerPivot for Excel ファイルから新しいテーブル モデル プロジェクトを作成するにはTo create a new tabular model project from a PowerPivot for Excel file

  1. SQL Server Data ToolsSQL Server Data Tools[ファイル] メニューの [新規作成] をクリックし、 [プロジェクト] をクリックします。In SQL Server Data ToolsSQL Server Data Tools, on the File menu, click New, and then click Project.

  2. 新しいプロジェクトダイアログ ボックスで、インストールされたテンプレート、 をクリックしてBusiness Intelligence、 をクリックし、 PowerPivotからインポート.In the New Project dialog box, under Installed Templates, click Business Intelligence, and then click Import from PowerPivot.

  3. [名前] にプロジェクトの名前を入力し、場所とソリューション名を指定してから、 [OK] をクリックします。In Name, type a name for the project, then specify a location and solution name, and then click OK.

  4. [ファイルを開く] ダイアログ ボックスで、インポートするモデル メタデータおよびデータを含む PowerPivot for ExcelPowerPivot for Excel ファイルを選択し、 [開く] をクリックします。In the Open dialog box, select the PowerPivot for ExcelPowerPivot for Excel file that contains the model metadata and data you want to import, and then click Open.

参照See Also

ワークスペース データベース(SSAS 表形式) Workspace Database (SSAS Tabular)
データ コピーして貼り付け(SSAS 表形式)Copy and Paste Data (SSAS Tabular)