Visual Studio Code を使用して作成し、Linux での TRANSACT-SQL スクリプトを実行するにはUse Visual Studio Code to create and run Transact-SQL scripts on Linux

適用対象: はいSQL サーバー (Linux のみ)ありませんAzure SQL DatabaseありませんAzure SQL Data Warehouseありません並列データ ウェアハウス APPLIES TO: yesSQL Server (Linux only) noAzure SQL Database noAzure SQL Data Warehouse noParallel Data Warehouse

この記事では、使用する方法を示します、 mssql for Linux での SQL Server データベースの開発に Visual Studio Code 拡張機能。This article shows how to use the mssql extension for Visual Studio Code to develop SQL Server databases in Linux.

インストールして Visual Studio Code を起動Install and start Visual Studio Code

Visual Studio Code は、Linux、macOS、および Windows 用のグラフィカルなコード エディターで、拡張機能をサポートします。Visual Studio Code is a graphical code editor for Linux, macOS, and Windows that supports extensions.

  1. ダウンロードして Visual Studio Code のインストールコンピューターにします。Download and install Visual Studio Code on your machine.

  2. Visual Studio Code を起動します。Start Visual Studio Code.

    注意

    Xrdp のリモート デスクトップ セッションを介して接続しているときに Visual Studio Code が起動しない場合は、VS Code の XRDP の使い方を接続すると、Ubuntu 上で動作していないを参照してください。If Visual Studio Code does not start when you are connected through an xrdp remote desktop session, see VS Code not working on Ubuntu when connected using XRDP.

Mssql 拡張機能をインストールします。Install the mssql extension

Visual Studio Code 用 mssql 拡張機能を SQL Server に接続することができますが transact-sql (T-SQL) クエリを実行し、結果を表示します。The mssql extension for Visual Studio Code lets you connect to a SQL Server, query with Transact-SQL (T-SQL), and view the results.

  1. Visual Studio code では、次のように選択しますビュー > コマンド パレット、またはキーを押しますCtrl+Shift 。+P、またはキーを押しますF1を開く、コマンド パレットします。In Visual Studio Code, select View > Command Palette, or press Ctrl+Shift+P, or press F1 to open the Command Palette.

  2. コマンド パレット拡張機能。拡張機能をインストールドロップダウン リストから。In the Command Palette, select Extensions: Install Extensions from the dropdown.

  3. 拡張 ウィンドウで「 mssqlします。In the Extensions pane, type mssql.

  4. 選択、 SQL Server (mssql) 拡張機能、および選択インストールします。Select the SQL Server (mssql) extension, and then select Install.

    Mssql 拡張機能をインストールします。

  5. インストールが完了すると、選択再読み込み拡張機能を有効にします。After the installation completes, select Reload to enable the extension.

作成したり、SQL ファイルを開くCreate or open a SQL file

Mssql 拡張機能により、mssql コマンドと T-SQL IntelliSense、コード エディターで言語モードが 設定されているSQLします。The mssql extension enables mssql commands and T-SQL IntelliSense in the code editor when the language mode is set to SQL.

  1. 選択ファイル > 新しいファイルまたはキーを押しますCtrl+Nします。Select File > New File or press Ctrl+N. Visual Studio Code では、既定で新しいテキスト ファイルを開きます。Visual Studio Code opens a new Plain Text file by default.

  2. 選択プレーン テキスト下部のステータス バー上でキーを押してCtrl+K > Mを選択します 。SQL言語ドロップダウン リストから。Select Plain Text on the lower status bar, or press Ctrl+K > M, and select SQL from the languages dropdown.

    SQL 言語モード

持つ既存のファイルを開いた場合、 .sqlファイルの拡張機能、言語モードは SQL には設定されて自動的にします。If you open an existing file that has a .sql file extension, the language mode is automatically set to SQL.

SQL Server への接続Connect to SQL Server

接続プロファイルを作成し、SQL Server に接続するこれらの手順に従います。Follow these steps to create a connection profile and connect to a SQL Server.

ヒント

作成し、ユーザー設定ファイルで接続プロファイルを編集できます (settings.json)。You can also create and edit connection profiles in the User Settings file (settings.json). 設定ファイルを開くには、次のように選択します。ファイル > 設定 > 設定します。To open the settings file, select File > Preferences > Settings. 詳細については、接続プロファイルの管理を参照してください。For more information, see Manage connection profiles.

  1. キーを押してCtrl+Shift+PまたはF1を開く、コマンド パレット.Press Ctrl+Shift+P or F1 to open the Command Palette.

  2. sql mssql を表示するコマンド、または型sqlcon、し、 MS SQL:接続ドロップダウン リストから。Type sql to display the mssql commands, or type sqlcon, and then select MS SQL: Connect from the dropdown.

    mssql コマンド

    注意

    SQL ファイルに作成した空の SQL ファイルなどが必要、コード エディターにフォーカスを mssql コマンドを実行する前にです。A SQL file, such as the empty SQL file you created, must have focus in the code editor before you can execute the mssql commands.

  3. 選択接続プロファイルの作成SQL Server の新しい接続プロファイルを作成します。Select Create Connection Profile to create a new connection profile for your SQL Server.

  4. 指示に従って、新しい接続プロファイルのプロパティを指定します。Follow the prompts to specify the properties for the new connection profile. それぞれの値を指定するには、後にキーを押して 」と入力を続行します。After specifying each value, press Enter to continue.

    1. サーバー名または ADO 接続文字列:SQL Server のインスタンス名を指定します。Server name or ADO connection string: Specify the SQL Server instance name. 使用localhostローカル コンピューターに SQL Server インスタンスに接続します。Use localhost to connect to a SQL Server instance on your local machine. リモート SQL Server に接続するには、SQL Server では、ターゲットの名前または IP アドレスを入力します。To connect to a remote SQL Server, enter the name of the target SQL Server, or its IP address. ポートを指定する必要がある場合は、コンマを使用して、名前から分離することです。If you need to specify a port, use a comma to separate it from the name. たとえば、ポート 1401 で実行されているローカル サーバーは、次のように入力します。 localhost、1401します。For example, for a local server running on port 1401, enter localhost,1401.

      注意

      データベースここでは、キーを押してを ADO 接続文字列を入力することもできます。 」と入力、必要に応じて名前、接続プロファイルとキーを押して 」と入力もう一度に接続し、プロファイルを作成します。You can also enter the ADO connection string for your database here, press Enter, optionally name the connection profile, and press Enter again to connect and create the profile.

    2. データベース名(省略可能)。使用するデータベースです。Database name (optional): The database that you want to use. 新しいデータベースを作成するには、データベースを指定しない名、およびキーを押して 」と入力を続行します。To create a new database, don't specify a database name, and press Enter to continue.

    3. 認証の種類:キーを押してEnterを選択するSQL ログインします。Authentication Type: Press Enter to select SQL Login.

    4. ユーザー名:サーバー上のデータベースにアクセス権を持つユーザーの名前を入力します。User name: Enter the name of a user with access to a database on the server.

    5. パスワード:指定したユーザーのパスワードを入力します。Password: Enter the password for the specified user.

    6. パスワードの保存:キーを押して 」と入力を選択する [はい] し、パスワードを保存します。Save Password: Press Enter to select Yes and save the password. 選択いいえ接続プロファイルを使用するたびにパスワードを求められます。Select No to be prompted for the password each time the connection profile is used.

    7. プロファイル名(省略可能)。接続プロファイルの名前を入力します。 localhost プロファイルします。Profile Name (optional): Type a name for the connection profile, such as localhost profile.

    選択した後Enter、Visual Studio Code が接続プロファイルが作成され、SQL Server に接続します。After you select Enter, Visual Studio Code creates the connection profile and connects to the SQL Server.

    ヒント

    内のエラー メッセージから問題を診断しよう、接続に失敗した場合、出力Visual Studio Code でパネル。If the connection fails, try to diagnose the problem from the error message in the Output panel in Visual Studio Code. 開くには、出力パネルで、ビュー > 出力します。To open the Output panel, select View > Output. 確認することも、接続のトラブルシューティングに関する推奨事項します。Also review the connection troubleshooting recommendations.

  5. 下部のステータス バーで、接続を確認します。Verify your connection in the lower status bar.

[接続状態]

SQL database を作成します。Create a SQL database

  1. 前に開始する新しい SQL ファイルに次のように入力します。 sql編集可能なコード スニペットの一覧を表示します。In the new SQL file that you started earlier, type sql to display a list of editable code snippets.

SQL スニペット

  1. 選択sqlCreateDatabaseします。Select sqlCreateDatabase.

  2. スニペットでは、置き換えるDatabaseNameTutorialDB:In the snippet, replace DatabaseName with TutorialDB:

    -- Create a new database called 'TutorialDB'
    -- Connect to the 'master' database to run this snippet
    USE master
    GO
    IF NOT EXISTS (
       SELECT name
       FROM sys.databases
       WHERE name = N'TutorialDB'
    )
    CREATE DATABASE [TutorialDB]
    GO
    
  3. キーを押してCtrl+Shift+E TRANSACT-SQL コマンドを実行します。Press Ctrl+Shift+E to execute the Transact-SQL commands. クエリ ウィンドウで、結果を表示します。View the results in the query window.

データベースのメッセージを作成します。

ヒント

Mssql コマンドのショートカット キーをカスタマイズすることができます。You can customize the shortcut keys for the mssql commands. 参照してくださいショートカットをカスタマイズするします。See Customize shortcuts.

テーブルの作成Create a table

  1. コード エディター ウィンドウの内容を削除します。Delete the contents of the code editor window.

  2. キーを押してCtrl+Shift+PまたはF1を開く、コマンド パレット.Press Ctrl+Shift+P or F1 to open the Command Palette.

  3. sql mssql を表示するコマンド、または型sqluseを選び、 MS SQL:Use データベースコマンド。Type sql to display the mssql commands, or type sqluse, and then select the MS SQL:Use Database command.

  4. 新しいTutorialDBデータベース。Select the new TutorialDB database.

    データベースの使用

  5. コード エディターで次のように入力します。 sql 、スニペットを表示するには、次のように選択します。 sqlCreateTable、およびキーを押します 」と入力します。In the code editor, type sql to display the snippets, select sqlCreateTable, and then press Enter.

  6. スニペットでは、次のように入力します。従業員テーブル名とdboスキーマ名。In the snippet, type Employees for the table name and dbo for the schema name.

  7. 次のコードに示すように、列を作成します。Create the columns as shown in the following code:

    -- Create a new table called 'Employees' in schema 'dbo'
    -- Drop the table if it already exists
    IF OBJECT_ID('dbo.Employees', 'U') IS NOT NULL
    DROP TABLE dbo.Employees
    GO
    -- Create the table in the specified schema
    CREATE TABLE dbo.Employees
    (
       EmployeesId        INT    NOT NULL   PRIMARY KEY, -- primary key column
       Name      [NVARCHAR](50)  NOT NULL,
       Location   [NVARCHAR](50)  NOT NULL
    );
    GO
    
  8. キーを押してCtrl+Shift+Eテーブルを作成します。Press Ctrl+Shift+E to create the table.

挿入とクエリInsert and query

  1. 次の 4 つの行を挿入するには、次のステートメントを追加、従業員テーブル。Add the following statements to insert four rows into the Employees table.

    -- Insert rows into table 'Employees'
    INSERT INTO Employees
       ([EmployeesId],[Name],[Location])
    VALUES
       ( 1, N'Jared', N'Australia'),
       ( 2, N'Nikita', N'India'),
       ( 3, N'Tom', N'Germany'),
       ( 4, N'Jake', N'United States')   
    GO   
    -- Query the total count of employees
    SELECT COUNT(*) as EmployeeCount FROM dbo.Employees;
    -- Query all employee information
    SELECT e.EmployeesId, e.Name, e.Location 
    FROM dbo.Employees as e
    GO
    

    ヒント

    入力するときに、ステートメントを完了させるために T-SQL IntelliSense を使用します。While you type, use T-SQL IntelliSense to help complete the statements. T-SQL での IntelliSenseT-SQL IntelliSense

  2. キーを押してCtrl+Shift+Eコマンドを実行します。Press Ctrl+Shift+E to execute the commands. 2 つの結果の表示を設定、結果ウィンドウ。The two result sets display in the Results window.

    [結果]

表示し、結果の保存View and save the result

  1. 選択ビュー > エディター レイアウト > レイアウトの反転垂直または水平方向の分割のレイアウトに切り替える。Select View > Editor Layout > Flip Layout to switch to a vertical or horizontal split layout.

  2. 選択、結果メッセージパネル、パネルを展開および折りたたむヘッダー。Select the Results and Messages panel headers to collapse and expand the panels.

    ヘッダーの切り替え

    ヒント

    Mssql 拡張機能の既定の動作をカスタマイズできます。You can customize the default behavior of the mssql extension. 参照してください拡張機能のオプションのカスタマイズします。See Customize extension options.

  3. これらの結果を拡大する 2 つ目の結果グリッドで最大化 [グリッド] アイコンを選択します。Select the maximize grid icon on the second result grid to zoom in to those results.

    グリッドを最大化します。

    注意

    T-SQL スクリプトが 2 つまたは複数の結果のグリッドを生成するとき、最大化アイコンを表示します。The maximize icon displays when your T-SQL script produces two or more result grids.

  4. グリッドを右クリックして、グリッドのコンテキスト メニューを開きます。Open the grid context menu by right-clicking on the grid.

    コンテキスト メニュー

  5. 選択すべて選択します。Select Select All.

  6. グリッド コンテキスト メニューを開き、もう一度選択JSON として保存、結果を保存する、 .jsonファイル。Open the grid context menu again and select Save as JSON to save the result to a .json file.

  7. JSON ファイルのファイル名を指定します。Specify a file name for the JSON file.

  8. JSON ファイルを保存し、Visual Studio Code で開きますを確認します。Verify that the JSON file saves and opens in Visual Studio Code.

    JSON として保存します。

保存し、管理や、大規模な開発プロジェクトのため、後で SQL スクリプトを実行する必要がある場合を使用してスクリプトを保存、 .sql拡張機能。If you need to save and run SQL scripts later, for administration or a larger development project, save the scripts with a .sql extension.

次の手順Next steps

T-SQL に慣れていない場合は、次を参照してください。チュートリアル:TRANSACT-SQL ステートメントを記述します。TRANSACT-SQL リファレンス (データベース エンジン)します。If you're new to T-SQL, see Tutorial: Write Transact-SQL statements and the Transact-SQL Reference (Database Engine).

またはを使用して、mssql 拡張機能に影響する詳細については、、 mssql 拡張機能プロジェクトの wikiを参照してください。For more information on using or contributing to the mssql extension, see the mssql extension project wiki.

Visual Studio Code の使用に関する詳細については、、 Visual Studio Code のドキュメントを参照してください。For more information on using Visual Studio Code, see the Visual Studio Code documentation.