XML 形式での実行プランの保存Save an Execution Plan in XML Format

適用対象: ○SQL Server ○Azure SQL Database XAzure SQL Data Warehouse XParallel Data WarehouseAPPLIES TO: yesSQL Server yesAzure SQL Database noAzure SQL Data Warehouse noParallel Data Warehouse

SQL Server Management StudioSQL Server Management Studio を使用すると、実行プランを XML ファイルとして保存し、開いて参照することができます。Use SQL Server Management StudioSQL Server Management Studio to save execution plans as an XML file, and to open them for viewing.

Management StudioManagement Studioの実行プラン機能または XML プラン表示 SET オプションを使用するには、実行プランを生成する Transact-SQLTransact-SQL クエリを実行するための適切な権限と、クエリが参照するすべてのデータベースに対する SHOWPLAN 権限が必要です。To use the execution plan feature in Management StudioManagement Studio, or to use the XML Showplan SET options, users must have the appropriate permissions to execute the Transact-SQLTransact-SQL query for which an execution plan is being generated, and they must be granted the SHOWPLAN permission for all databases referenced by the query.

XML 表示プラン SET オプションを使用してクエリ プランを表示するにはTo save a query plan by using the XML Showplan SET options

  1. SQL Server Management StudioSQL Server Management Studio でクエリ エディターを開き、 データベース エンジンDatabase Engineに接続します。In SQL Server Management StudioSQL Server Management Studio open a query editor and connect to データベース エンジンDatabase Engine.

  2. 次のステートメントを使用して、SHOWPLAN_XML を有効にします。Turn SHOWPLAN_XML on with the following statement:

    SET SHOWPLAN_XML ON;  
    GO  
    

    次のステートメントを使用して、STATISTICS XML を有効にします。To turn STATISTICS XML on, use the following statement:

    SET STATISTICS XML ON;  
    GO  
    

    注意

    SHOWPLAN_XML は、クエリのコンパイル時クエリ実行プラン情報を生成しますが、クエリの実行は行いません。SHOWPLAN_XML generates compile-time query execution plan information for a query, but does not execute the query. これは推定実行プランとも呼ばれます。This is also known as the estimated execution plan. STATISTICS XML は、クエリの実行時クエリ実行プラン情報を生成し、クエリを実行します。STATISTICS XML generates runtime query execution plan information for a query, and executes the query. これは実際の実行プランとも呼ばれます。This is also known as the actual execution plan.

  3. クエリを実行します。Execute a query. 例:Example:

    USE AdventureWorks2012;  
    GO  
    SET SHOWPLAN_XML ON;  
    GO  
    -- Execute a query.  
    SELECT BusinessEntityID   
    FROM HumanResources.Employee  
    WHERE NationalIDNumber = '509647174';  
    GO  
    SET SHOWPLAN_XML OFF;  
    
  4. [結果] ペインで、クエリ プランを含む [Microsoft SQL Server XML Showplan] を右クリックし、 [結果に名前を付けて保存] をクリックします。In the Results pane, right-click the Microsoft SQL Server XML Showplan that contains the query plan, and then click Save Results As.

  5. [ <グリッドまたはテキスト> の結果を保存] ダイアログ ボックスで、 [保存の種類] ボックスの [すべてのファイル (*.*)] をクリックします。In the Save <Grid or Text> Results dialog box, in the Save as type box, click All files (*.*).

  6. [ファイル名] ボックスに <name >.sqlplan の形式で名前を入力し、 [保存] をクリックします。In the File name box provide a name, in the format <name >.sqlplan, and then click Save.

フィードバックをお待ちしております。 この記事の手順やコード例の中で、古い情報や間違っている情報を見つけた場合は、ぜひお知らせください。We are listening: If you find something outdated or incorrect in this article, such as a step or a code example, please tell us. このページの下部にある [フィードバック] セクション内で [このページ] ボタンをクリックしてください。You can click the This page button in the Feedback section at the bottom of this page. SQL に関するフィードバックのすべての項目に目を通しています (通常は翌日)。We read every item of feedback about SQL, typically the next day. よろしくお願いいたします。Thanks.

SQL Server Management Studio のオプションを使用して実行プランを保存するにはTo save an execution plan by using SQL Server Management Studio options

  1. Management StudioManagement Studioで、推定実行プランまたは実際の実行プランを生成します。Generate either an estimated execution plan or an actual execution plan by using Management StudioManagement Studio. 詳細については、「推定実行プランの表示 」と「実際の実行プランの表示」を参照してください。For more information, see Display the Estimated Execution Plan and Display an Actual Execution Plan.

  2. 結果ペインの [実行プラン] タブで、グラフィカルな実行プランを右クリックし、 [実行プランに名前を付けて保存] をクリックします。In the Execution plan tab of the results pane, right-click the graphical execution plan, and choose Save Execution Plan As.

    代わりに、 [ファイル] メニューの [実行プランに名前を付けて保存] をクリックしてもかまいません。As an alternative, you can also choose Save Execution Plan As on the File menu.

  3. [名前を付けて保存] ダイアログ ボックスで、 [ファイルの種類][実行プラン ファイル (*.sqlplan)] に設定されていることを確認します。In the Save As dialog box, make sure that the Save as type is set to Execution Plan Files (*.sqlplan).

  4. [ファイル名] ボックスに <name >.sqlplan の形式で名前を入力し、 [保存] をクリックします。In the File name box provide a name, in the format <name >.sqlplan, and then click Save.

保存した XML クエリ プランを SQL Server Management Studio で開くにはTo open a saved XML query plan in SQL Server Management Studio

  1. SQL Server Management StudioSQL Server Management Studio[ファイル] メニューの [開く] をポイントし、 [ファイル] をクリックします。In SQL Server Management StudioSQL Server Management Studio, on the File menu, choose Open, and then click File.

  2. [ファイルを開く] ダイアログ ボックスで [ファイルの種類][実行プラン ファイル (*.sqlplan)] に設定し、保存済みの XML クエリ プラン ファイルだけを表示します。In the Open File dialog box, set Files of type to Execution Plan Files (*.sqlplan) to produce a filtered list of saved XML query plan files.

  3. 表示する XML クエリ プラン ファイルを選択し、 [開く] をクリックします。Select the XML query plan file that you want to view, and click Open.

    代わりに、Windows エクスプローラーで、拡張子が .sqlplanのファイルをダブルクリックしてもかまいません。As an alternative, in Windows Explorer, double-click a file with extension .sqlplan. プランが、 Management StudioManagement Studioで開かれます。The plan opens in Management StudioManagement Studio.

参照See Also

SET SHOWPLAN_XML (Transact-SQL) SET SHOWPLAN_XML (Transact-SQL)
SET STATISTICS XML (Transact-SQL)SET STATISTICS XML (Transact-SQL)