SQL Server データ ツールの Reporting Services (SSDT)Reporting Services in SQL Server Data Tools (SSDT)

SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT) は、ビジネス インテリジェンス ソリューションを作成するための MicrosoftMicrosoft Visual StudioVisual Studio 環境です。 is a MicrosoftMicrosoft Visual StudioVisual Studio environment for creating business intelligence solutions. SSDT は、レポート デザイナー作成環境を標準装備しています。この環境では、 Reporting ServicesReporting Services のページ分割されたレポート定義、共有データ ソース、共有データセット、およびレポート パーツを開けるほか、変更、プレビュー、保存、配置ができます。SSDT features the Report Designer authoring environment, where you can open, modify, preview, save, and deploy Reporting ServicesReporting Services paginated report definitions, shared data sources, shared datasets, and report parts. SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT) は、SQL Server には含まれていません。 is not included with SQL Server. SQL Server Data Toolsをダウンロードします。Download SQL Server Data Tools.

このトピックでは、 SQL Server Data ToolsSQL Server Data Tools に使用される Reporting ServicesReporting Servicesのソリューション、プロジェクト、プロジェクト テンプレート、および構成と、レポート デザイナーで使用できるビュー、メニュー、ツール バー、およびショートカットについて説明します。This topic describes SQL Server Data ToolsSQL Server Data Tools solutions, projects, project templates, and configurations used for Reporting ServicesReporting Services, and the views, menus, toolbars, and shortcuts that you can use in Report Designer.

レポートのデザインを開始するには、「レポート デザイナーを使用してレポートをデザインする (SSRS)」を参照してください。To get started designing reports, see Design Reports with Report Designer (SSRS).

ソリューションとプロジェクトSolutions and Projects

レポート プロジェクトは、レポート定義およびリソースのコンテナーの役割を果たします。A report project acts as a container for report definitions and resources. レポート プロジェクト内の各ファイルは、プロジェクトが配置されるときに、レポート サーバーにパブリッシュされます。Every file in the report project is published to the report server when the project is deployed. プロジェクトを初めて作成する場合は、プロジェクトのコンテナーとしてソリューションも作成されます。When you create a project for the first time, a solution is also created as a container for the project. 複数のプロジェクトを 1 つのソリューションに追加することができます。You can add multiple projects to a single solution.

構成Configurations

企業のテスト用レポート サーバーや実稼働レポート サーバーなど、さまざまな種類の配置に対して複数のプロジェクト プロパティのセットを作成するには、構成マネージャーを使用します。To create multiple sets of project properties for deployment variations such as enterprise test and production report servers, use the Configuration Manager. 詳細については、「 SQL Server データ ツールの配置およびバージョン サポート (SSRS)には含まれていません。For more information, see Deployment and Version Support in SQL Server Data Tools (SSRS).

レポート サーバープロジェクトReport Server Projects

Reporting ServicesReporting Servicesをインストールすると、 SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT)で次のプロジェクト テンプレートを使用できるようになります。When you install Reporting ServicesReporting Services, the following project templates are made available in SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT):

  • レポート サーバー プロジェクト。Report Server Project. レポート サーバー プロジェクトを選択すると、レポート デザイナーが開きます。When you select a Report Server Project, Report Designer opens. レポート サーバー プロジェクトは、 Visual StudioVisual Studio によってインストールされ、 [新しいプロジェクト] ダイアログ ボックスで使用できる、ビジネス インテリジェンス プロジェクト用のテンプレートです。A Report Server Project is a Business Intelligence Projects template installed by Visual StudioVisual Studio that is available from the New Project dialog box. 詳細については、「新規または既存のレポートをレポート プロジェクトに追加する (SSRS)」を参照してください。レポート サーバー プロジェクトのプロパティは、 SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT) プロジェクト内のすべてのレポートとすべての共有データ ソースに適用されます。For more information, see Add a New or Existing Report to a Report Project (SSRS).Report Server project properties apply to all reports and all shared data sources in a SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT) project. これらのプロパティには、レポート サーバーの URL、およびレポートと共有データ ソースのフォルダー名が含まれます。These properties include the URL for the report server and the folder names for reports and shared data sources. 現在のプロパティ値を確認するには、 [プロジェクト プロパティ ページ] ダイアログ ボックスを使用します。Use the Project Property Pages dialog box to view the current property values. このダイアログ ボックスを開くには、 [プロジェクト] メニューの [プロパティ]をクリックします。To open this dialog box, on the Project menu, click Properties.

  • レポート サーバー プロジェクト ウィザード。Report Server Project Wizard. レポート サーバー プロジェクト ウィザードを選択すると、レポート サーバー プロジェクトが自動的に作成され、レポート ウィザードが開きます。When you select a Report Server Wizard Project, a report server project is automatically created, and the Report Wizard opens. このウィザードでは、各ページの手順に従ってレポートを作成し、データ ソースへの接続文字列の作成、データ ソースの資格情報の設定、クエリのデザイン、テーブルまたはマトリックス データ領域の追加、レポート データやグループの指定、フォントや色のスタイルの選択、レポート サーバーへのレポートのパブリッシュ、およびローカルでのレポートのプレビューを行うことができます。In the wizard, you can create a report by following instructions on each page to create a connection string to a data source, set data source credentials, design a query, add a table or matrix data region, specify report data and groups, pick a font and color style, publish the report to a report server, and preview the report locally. ウィザードを使用してレポートを作成した後で、レポート サーバー プロジェクトでレポート デザイナーを使用して、レポート データおよびレポート デザイナーを変更できます。After you create a report with the wizard, you can change the report data and the report designer by using Report Designer in the Report Server project.

    SSDT の新しいプロジェクト テンプレートNew Project templates in SSDT

レポート デザイナーのウィンドウとペインReport Designer Windows and Panes

レポート デザイナーでは、レポート データとレポート レイアウトを定義するための [デザイン] ビューと、描画されたレポートのビューを表示するための [プレビュー] ビューがサポートされています。Report Designer supports two views: Design to define the report data and report layout, and Preview to display a rendered view of the the report. それぞれのビューでは、表示レポートをデザインまたは表示できるように複数のウィンドウを表示できます。In each view, you can display multiple windows to help you design or view a rendered report.

レポート データ ペインReport Data Pane

[レポート データ] ペインには、組み込みフィールド、データ ソース、データセット、フィールド コレクション、レポート パラメーター、および画像が表示されます。The Report Data pane displays built-in fields, data sources, datasets, field collections, report parameters, and images.

以下を表示するには、[レポート データ] ペインを使用します。Use the Report Data pane to view:

  • 組み込みフィールド レポート名やレポートの処理時刻など、事前に定義されたレポート情報です。Built-in Fields Predefined report information such as the report name or the time the report was processed.

  • データ ソース データ ソースは、基になるデータの名前とそのデータへの接続を表します。Data sources A data source represents a name and connection to a source of data.

  • データセット 各データセットには、データ ソースから取得するデータを指定するクエリが含まれています。Datasets Each dataset includes a query that specifies which data to retrieve from the data source. データセット クエリで指定されたフィールドのコレクションを表示するには、データセットを展開します。Expand the dataset to view the collection of fields specified by the dataset query.

    多次元データセット用のクエリ デザイナーの中には、[フィルター] ペインでフィルターを指定して、レポート パラメーターを作成するかどうかを指定できるものがあります。In some query designers for multidimensional datasets, you can specify filters in the Filters pane and indicate whether to create report parameters. レポート パラメーター オプションを指定した場合は、そのパラメーターの有効な値の一覧を設定する特別なデータセットが自動的に作成されます。If you specify the report parameter option, a special dataset is automatically created to populate the parameter’s valid values list. 既定では、データセットは [レポート データ] ペインに表示されません。By default, the dataset does not appear in the Report Data Pane. 詳細については、「多次元データのパラメーター値の非表示データセットの表示 (レポート ビルダーおよび SSRS)」を参照してください。For more information, see Show Hidden Datasets for Parameter Values for Multidimensional Data (Report Builder and SSRS).

  • レポート パラメーター レポート パラメーターの一覧です。Report parameters The list of report parameters. データセット クエリにクエリ パラメーターが含まれている場合は、パラメーターを手動または自動で作成できます。Parameters can be created manually or automatically when a dataset query includes query parameters.

  • 画像 レポートに画像レポート アイテムとして含めることができる画像の一覧です。Images The list of images that are available to include as an Image report item in a report.

    [レポート データ] ペインのデータ ソースおよびデータセットは、レポート定義内の要素を表します。Data sources and datasets in the Report Data pane represent the elements in the report definition. [レポート データ] ペインは、複数のレポート作成環境でサポートされている機能です。The Report Data pane is a feature supported by multiple report authoring environments. レポート ビルダーでは、データ ソースとデータセットの管理に使用できる唯一のペインです。In Report Builder, it is the only pane available for managing data sources and datasets. レポート デザイナーでは、[レポート データ] ペインはソリューション エクスプローラーと連携して動作します。ソリューション エクスプローラーでは、共有データ ソースと共有データセットがファイルとして表示されます。In Report Designer, the Report Data pane works with Solution Explorer, which lists shared data sources and shared datasets as files. [レポート データ] ペインの共有データ ソースと共有データセットは、ソリューション エクスプローラーの対応する共有データ ソースと共有データセットを参照する必要があります。Shared data sources and shared datasets in the Report Data pane must point to their corresponding Shared Data Sources and Shared Datasets in Solution Explorer. そのため、[レポート データ] ペインの要素には、ソリューション エクスプローラーのデータ ファイルへの参照が含まれます。The Report Data pane elements then contain a reference to the data files in Solution Explorer. プロジェクト プロパティによって、共有データ ソースと共有データセットがレポート サーバーに配置されるか、SharePoint サイトに配置されるかが決まります。The project properties determine whether the shared data sources and shared datasets are deployed to the report server or SharePoint site. 詳細については、「データ ソースの変換 (レポート ビルダーおよび SSRS)」を参照してください。For more information, see Convert Data Sources (Report Builder and SSRS).

注意

[レポート データ] ペインが表示されていない場合は、デザイン領域内をクリックし、 [表示] メニューの [レポート データ]をクリックします。If you do not see the Report Data pane, click in the Design area and then on the View menu, click Report Data. [レポート データ] ペインが固定されていない場合は、固定することができます。If the Report Data pane is floating, you can anchor it. 詳細については、「レポート デザイナーのレポート データ ペインをドッキングする (SSRS)」を参照してください。For more information, see Dock the Report Data Pane in Report Designer (SSRS).

グループ化ペインGrouping Pane

Tablix データ領域のグループを定義するには、[グループ化] ペインを使用します。Use the Grouping pane to define groups for a tablix data region. テーブルの行グループと詳細グループ、およびマトリックスの行グループと列グループを定義できます。You can define row groups and detail groups for tables and row and column groups for matrices. [グループ化] ペインを使用して、グラフまたは他のデータ領域のグループを定義することはできません。You cannot use the Grouping pane to define groups for Charts or other data regions. 詳細については、「グループについて (レポート ビルダーおよび SSRS)」を参照してください。For more information, see Understanding Groups (Report Builder and SSRS).

グループ化ペインには、次の 2 つのモードがあります。The Grouping pane has two modes:

  • 既定値です。Default. 親グループ、子グループ、隣接するグループ、および詳細グループのリレーションシップを示す階層形式ですべての行グループと列グループを表示するには、 既定 モードを使用します。Use the Default mode to display all row and column groups in a hierarchical format that shows the relationship of parent groups, child groups, adjacent groups, and detail groups. 子グループは、その親グループと比較して直下の次のインデント レベルに表示されます。A child group appears under and at the next indent level compared to its parent group. 隣接するグループは、そのピアまたは兄弟グループと同じインデント レベルに表示されます。An adjacent group appears at the same indent level as its peer or sibling groups.

    グループを追加、編集、または削除するには、既定のモードを使用します。Use default mode to add, edit, or delete groups. 1 つのデータセット フィールドに基づいたグループでは、[行グループ] ペインまたは [列グループ] ペインにフィールドをドラッグします。For groups based a single dataset field, drag the field to the Row Groups or Column Groups pane. グループは、既存のグループの上または下に挿入できます。You can insert the group above or below an existing group. 隣接するグループを追加するには、兄弟グループを右クリックして、コンテキスト メニューを使用します。To add an adjacent group, right-click the sibling group, and use the shortcut menu. グループに属している Tablix セルを表示するには、[グループ化] ペインでグループを選択します。To display which tablix cells belong to a group, select the group in the Grouping pane.

  • [詳細設定]。Advanced. 選択した Tablix データ領域の行グループと列グループの静的メンバーと動的メンバーを表示するには、 詳細設定 モードを使用します。Use the Advanced mode to display static and dynamic row and column group members of the selected tablix data region. グループまたはグループ メンバーに関連付けられている行と列の表示を制御するプロパティ、またはグループを 1 ページにまとめておくためにレンダラーで使用するルールを設定するには、グループ メンバーを使用する必要があります。You must use group members to set properties that control the visibility of the rows and columns associated with a group or group member, or the rules that renderers use to try to keep groups together on a page. グループ メンバーは、行グループ領域および列グループ領域のセルとして、デザイン画面に表示されます。Group members appear on the design surface as cells in the row group and column group areas.

注意

既定 モードと 詳細設定 モードを切り替えるには、 [列グループ] アイコンの右側にある下矢印を右クリックします。To toggle between Default and Advanced modes, right-click the down arrow to the right of the Column Groups icon.

詳細については、「 グループ化ペイン」を参照してください。For more information, see Grouping Pane.

[ツールボックス]Toolbox

ツールボックスには、デザイン画面にドラッグできるレポート アイテムが含まれています。The Toolbox contains report items that you can drag to the design surface. データ領域は、レポート上のデータを整理する際に使用するレポート アイテムです。Data regions are report items that you use to organize data on the report. テーブル、マトリックス、一覧、グラフ、ゲージ、データ バー、スパークライン、およびインジケーターはデータ領域です。Table, Matrix, List, Chart, Gauge, Data Bar, Sparkline, and Indicator are data regions. その他のレポート アイテムには、マップ、テキスト ボックス、四角形、線、画像、およびサブレポートがあります。Other report items include Map, Text Box, Rectangle, Line, Image, and Subreport. カスタム レポート アイテムがシステム管理者によってインストールおよび登録されている場合、それらのアイテムがこの一覧に表示されることがあります。Custom report items might also appear on this list if they have been installed and registered by your system administrator.

[プロパティ] ペインProperties Pane

[プロパティ] ペインは、 Visual StudioVisual Studio の標準的なウィンドウであり、デザイン画面で現在選択されているレポート アイテムのプロパティの名前と値が表示されます。The Properties pane is a standard Visual StudioVisual Studio window that shows property names and values for the currently selected report item on the design surface. ほとんどの場合、プロパティ名は、レポート定義言語 (RDL) ファイル内の要素と属性に対応します。In most cases, property names correspond to elements and attributes in the Report Definition Language (RDL) file. 最も一般的に使用されるプロパティは、選択したアイテムの [プロパティ] ダイアログ ボックスを使用して設定できます。The most commonly used properties can be set by using the Properties dialog box for the selected item. 対応するダイアログ ボックスを開くには、[プロパティ] ペイン ツール バーの [プロパティ ページ] ボタンをクリックします。To open the corresponding dialog box, click the Property Pages button on the Properties pane toolbar. 上級ユーザーは、[プロパティ] ペインでプロパティ値を直接設定できます。Advanced users can set property values directly in the Properties pane.

次の場合、[プロパティ] ペインを使用します。Use the Properties pane to:

  • デザイン画面で現在選択されている項目のプロパティを設定します。Set properties for the currently selected item on the design surface. プロパティによっては、値のドロップダウン リストが表示されます。Some properties provide a drop-down list of values. セルに値を直接入力することもできます。You can also type the value directly in the cell. 一部のプロパティには値のコレクションが含まれており、 [(コレクション)]という値で示されます。Some properties contain a collection of values, indicated by the value (Collection). ほとんどのプロパティでは式を使用できます。複雑な式は <式> という値で示されます。Most properties can accept an expression; complex expressions are indicated by the value <Expression>. [式] ダイアログ ボックスを開くには、 <式> をクリックします。Click <Expression> to open the Expression dialog box. 詳細については、「 [式] ダイアログ ボックス」を参照してください。For more information, see Expression Dialog Box.

  • グリッドをカテゴリ別の表示からアルファベット順の表示に変更するには、[プロパティ] ペインのツール バー ボタンを使用します。Use the Properties pane toolbar buttons to change the grid from category view to alphabetical view. カテゴリ別の表示では、カテゴリのすべてのプロパティを表示するには、そのカテゴリを展開する必要があります。In category view, you may need to expand a category to see all the properties under it. アイテムの [プロパティ] ダイアログ ボックスを開くには、ツール バーの [プロパティ ページ] ボタンをクリックするか、アイテムを右クリックして [プロパティ]をクリックします。To open an item's Properties dialog box, click the Property Pages button on the toolbar or by right-click the item and click Properties.

  • [グループ化] ペインで現在選択されているグループ メンバーのプロパティを設定します。Set properties for the currently selected group member in the Grouping pane. グループ メンバーのプロパティを使用すると、グループ インスタンスごとに静的なグループ ヘッダー行とフッター行を繰り返す方法を制御できます。Group member properties help control how static group header and footer rows repeat for each group instance. 詳細については、「グループ単位でのヘッダーとフッターの表示 (レポート ビルダーおよび SSRS)」を参照してください。For more information, see Display Headers and Footers with a Group (Report Builder and SSRS).

    [プロパティ] ペインを表示するには、 [表示] メニューの [プロパティ ウィンドウ]をクリックします。To display the Properties pane, from the View menu, click Properties Window. このペインのドッキングを解除して SQL Server Data ToolsSQL Server Data Toolsウィンドウの別の領域に移動したり、デザイン画面上にタブ付きビューとして表示したりできます。You can undock this pane and move it to another area of the SQL Server Data ToolsSQL Server Data Toolswindow, or display it as a tabbed view on the design surface.

ソリューション エクスプローラーSolution Explorer

ソリューション エクスプローラーは、標準的な Visual StudioVisual Studio コンポーネントであり、プロジェクト内のすべてのアイテムが表示されます。Solution Explorer is a standard Visual StudioVisual Studio component that displays all the items in your project. レポート サーバー プロジェクトの場合、これには共有データ ソース、共有データセット、レポート、およびリソースを整理するためのフォルダーが含まれます。For a Report Server project, this includes folders to organize shared data sources, shared datasets, reports and resources. ソリューション ファイルを開くと、フォルダーのアイテムが自動的にアルファベット順に並べ替えられます。Folder items are automatically alphabetized when you open the solution file. [プロパティ] ペインにアイテムのプロパティを表示するには、アイテムを選択します。To view item properties in the Properties pane, select the item.

出力Output

[出力] ウィンドウには、レポートをプレビューした場合の処理エラーと、レポートまたは共有データ ソースを配置した場合の発行エラーが表示されます。The Output window displays processing errors when you preview a report, and publishing errors when you deploy a report or a shared data source.

[出力] ウィンドウと [ドキュメント アウトライン] ウィンドウを使用すると、式のエラーをデバッグできます。Use the Output and the Document Outline windows to help debug errors in expressions.

[ドキュメント アウトライン]Document Outline

[ドキュメント アウトライン] ウィンドウには、レポート定義内のすべてのレポート アイテムの階層リストが表示されます。The Document Outline window displays a hierarchical list of all report items in the report definition. ドキュメント アウトライン ペインを開くには、 [表示] メニューの [その他のウィンドウ] をポイントし、 [ドキュメント ウィンドウ]をクリックします。To open the Document Outline pane, from the View menu, point to Other Windows and click Document Window.

ドキュメント アウトライン ペインを使用すると、テキスト ボックスとその他のレポート アイテムを名前で識別できます。Use the Document Outline pane to help identify text boxes and other report items by name. ドキュメント アウトラインでアイテムを選択すると、そのアイテムはデザイン画面でも選択されます。When you select an item in the Document Outline, the item is also selected on the Design Surface.

タスク一覧Task List

[タスク一覧] ウィンドウには、 MicrosoftMicrosoft Access などの別のアプリケーションからレポートをインポートした場合に、サポートされていない機能のビルド エラーが表示されます。The Task List window displays build errors for unsupported features when you import a report from another application, such as MicrosoftMicrosoft Access.

レポート デザイナーの [デザイン] ビューReport Designer Design View

既定では、レポート サーバー プロジェクトを作成する際に、レポート デザイナーが [デザイン] ビューで開き、デザイン画面が表示されます。By default, when you create a Report Server project, Report Designer opens in Design view and displays the design surface. 既定では、デザイン画面には、レポート本文とレポートの背景が表示されます。By default, the design surface displays the report body and the report background.

背景のコンテキスト メニューには、ページ ヘッダーとページ フッターを追加するオプションがあります。また、[表示] メニューを使用すると、ルーラーと [グループ化] ペインを表示することができます。The shortcut menu on the background provides options to add a page header and page footer, and from the View menu, display a ruler and the Grouping pane.

レポートの倍率を上げたり下げたりするには、ズーム コントロールを使用します。Use the zoom control to increase or decrease the magnification of the report.

レポートをデザインするには、レポート アイテムをツールボックスからデザイン画面にドラッグした後、そのプロパティを構成したり、レポート上での配置を変更したりします。To design a report, drag report items from the Toolbox to the design surface, and then configure their properties and alter their arrangement on the report.

レポート デザイナー プレビューReport Designer Preview

レポートを実行して、レポート ビューアーに表示レポートを表示するには、[プレビュー] を使用します。Use Preview to run the report and view the rendered report in the report viewer. プレビュー時には、レポート データがローカルでキャッシュされます。Preview caches report data locally. また、ブラウザーを使用してデバッグ ビューでレポートを実行するように構成プロパティを設定することもできます。You can also set configuration properties to run the report in debug view, using a browser.

レポートをプレビューすると、レポート デザイナーは、レポート データ ソースに接続し、データセット クエリを実行して、データをローカル コンピューターにキャッシュします。その後、レポートを処理してデータとレイアウトを組み合わせて、レポートを表示します。When you preview a report, Report Designer connects to the report data sources, runs dataset queries, caches the data on the local computer, processes the report to combine data and layout, and renders the report. レポートは、[プレビュー] タブに表示することも、デバッグ モードで表示するようにプロジェクトのプロパティを設定して直接ブラウザーに表示することもできます。You can view the report in on the Preview tab or you can set up project properties to view the report in debug mode and view it directly in a browser.

  • パラメーター化されたレポートのプレビュー:Previewing Parameterized Reports. レポートをプレビューする際に、すべてのレポート パラメーターに有効な既定値がある場合は、レポートが自動的に処理されます。When you preview a report, the report is processed automatically if all report parameters have valid default values. 1 つ以上のレポート パラメーターに有効な既定値がない場合は、未割り当ての各パラメーターの値を選択してから、レポート ツール バーの [レポートの表示]をクリックする必要があります。If one or more report parameters do not have a valid default value, you must choose a value for each unassigned parameter, and then, on the report toolbar, click View Report.

  • ローカル データ キャッシュについて : レポートをプレビューすると、レポート プロセッサでは、現在のパラメーターの既定値を使用してレポート内のデータセットに対するすべてのクエリを実行し、その結果をローカル データ キャッシュ (.rdl.data) ファイルとして保存します。Understanding the Local Data Cache When you preview a report, the report processor runs all the queries for datasets in the report using the current parameter defaults, and saves the results as a local data cache (.rdl.data) file. レポート データセット クエリまたはレポート パラメーターを変更しない場合は、このデータを再度取得するオーバーヘッドを発生させることなく、引き続きレポートをデザインできます。You can continue to design your report without incurring the overhead of retrieving this data again if you make no changes to either the report dataset queries or the report parameters.

  • 構成マネージャーとデバッグを使用したレポートのプレビュー:Previewing the Report using Configuration Manager and Debug. SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT)では、プロジェクトのプロパティによって、レポートを配置およびデバッグする方法を定義します。In SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT), project properties define how you want to deploy and debug your reports. これらのプロパティは、プロジェクトのすべてのレポートおよび共有データ ソースに適用されます。These properties apply to all reports and shared data sources in the project. プロジェクトのプロパティを設定するには、 [プロジェクト] メニューの [プロパティ]をクリックします。To set the project properties, from the Project menu, click Properties. レポートをテストしてレポート サーバーにパブリッシュするには、これらの設定を使用します。Use these settings to test your reports and publish them to the report server.

  • [出力] ペインでのエラー メッセージの監視:Monitoring the Output Pane for Error Messages. レポートのプレビュー時にレポート プロセッサで問題が検出されると、[出力] ペインにエラー メッセージが表示されます。When you preview a report and the report processor detects a problem, it writes error messages to the Output pane.

レポート デザイナーのメニューReport Designer Menus

SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT)でレポート デザイナー プロジェクトがアクティブになっている場合、次のツール バーがメイン ツール バーに追加されます。When a Report Designer project is active in SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT), the following toolbars are added to the main toolbar. レポート デザイナーのメニューは、[デザイン] ビューのみに表示されます。The Report Designer menus are visible only when in Design view.

[書式] メニューFormat Menu

デザイン画面でアイテムを選択した場合、 [書式] メニューには次のオプションがあります。When you select an item on the design surface, the Format menu contains the following options:

  • [前景色] テキストの色を選択します。Foreground Color Select a text color. 既定のテキストの色は黒です。Black is the default text color.

  • [背景色] テキスト ボックスとデータ領域の背景色を選択します。Background Color Select a background color for your text boxes and data regions.

  • [フォント] テキストを太字、斜体、または下線付きにするかどうかを指定します。Font Specify whether the text is bold, italic, or underlined.

  • [両端揃え] テキストを右揃え、中央揃え、または左揃えにするかどうかを指定します。Justify Specify whether the text is right-aligned, centered, or left-aligned.

  • [整列] レポート内で、選択したオブジェクトを互いの位置を基準にして整列する方法を指定します。Align Specify how the selected objects are aligned in relation to one another within the report.

  • [同じサイズに揃える] レポート内で選択したオブジェクトのサイズを調整します。Make Same Size Adjust the size of the selected objects within the report.

  • [左右の間隔] レポート内で選択したオブジェクト間の左右の間隔を調整します。Horizontal Spacing Adjust the horizontal spacing between the selected objects within the report.

  • [上下の間隔] レポート内で選択したオブジェクト間の上下の間隔を調整します。Vertical Spacing Adjust the vertical spacing between the selected objects within the report.

  • [フォームの中央に配置] 選択したオブジェクトを、レポート デザイナー ウィンドウに対して上下左右の中央に配置します。Center in Form Center the selected object vertically and horizontally in relation to the Report Designer window.

  • [順序] 選択したオブジェクトを背景または前景に移動します。Order Move selected objects into the background or foreground.

[レポート] メニューReport Menu

レポート デザイン画面がアクティブになっている場合、 [レポート] メニューには次のオプションがあります。When the report design surface has focus, the Report menu contains the following options:

  • [レポートのプロパティ] [レポートのプロパティ] ダイアログ ボックスを開きます。Report Properties Select to open the Report Properties dialog box. このダイアログ ボックスでは、一般的なレポートのプロパティ (作成者の名前やグリッドの間隔など) を割り当てたり、レポート レイアウトのプロパティ (列数やページ サイズなど) を指定したりできます。In this dialog box, you can assign general report properties, such as author name and grid spacing, and specify properties for the report layout, such as the number of columns and page size. また、カスタム コード、アセンブリやクラスへの参照、データ出力要素の名前、データ変換の名前、およびデータ スキーマの名前も含めることができます。You can also include custom code, references to assemblies and classes, and the names of data output elements, data transforms, and data schemas.

  • [表示] レポート デザイナーの [デザイン] タブと [プレビュー] タブを切り替えます。View Switch between the two Report Designer tabs: Design and Preview.

  • [ページ ヘッダー] レポートのページ ヘッダーを追加または削除します。Page Header Add or delete a page header to the report. ページ ヘッダーを削除すると、ページ ヘッダー内のすべてのアイテムが削除されます。When you delete a page header, all items in the page header are deleted.

  • [ページ フッター] レポートのページ フッターを追加または削除します。Page Footer Add or delete a page footer to the report. ページ フッターを削除すると、ページ フッター内のすべてのアイテムが削除されます。When you delete a page footer, all items in the page footer are deleted.

  • [グループ化ペイン] [グループ化] ペインの表示と非表示を切り替えます。Grouping Pane Show or hide the Grouping pane.

[表示] メニューView Menu

[表示] メニューを使用すると、レポート デザイナーのウィンドウとツール バーが表示されます。Use the View menu to display Report Designer windows and toolbars

  • [エラー一覧] このオプションを使用すると、レポートをパブリッシュまたはプレビューしたときに検出されたエラーが表示されます。Error List Use this option to display errors detected when publishing or previewing a report.

  • [出力] このオプションを使用すると、レポートをパブリッシュまたは処理するときに検出されたエラーや、レポートで "#Error" というテキストが表示された場合の式のエラーの詳細が表示されます。Output Use this option to display errors detected when publishing or processing a report, or for more information about expression errors when a report displays the text "#Error".

  • [プロパティ ウィンドウ] このオプションを使用すると、デザイン画面で現在選択されているレポート アイテムのプロパティ値が表示されます。Properties Window Use this option to display the property values for the currently selected report item on the design surface. 入れ子になったレポート アイテムのプロパティを表示するには、レポート アイテムを複数回クリックして、レポート アイテムとその入れ子になったメンバーの階層を切り替える必要があります。To see properties for nested report items, you must click a report item multiple times to cycle through the hierarchy for a report item and its nested members. [プロパティ] ペインの先頭に表示されているアイテムの名前を確認すると、どのレポート アイテムのプロパティが表示されているかがわかります。Check the name of the item that appears at the top of the Properties pane to see which report item's properties are displayed.

  • [ツールボックス] このオプションを使用すると、ツールボックスが表示されます。Toolbox Use this option to display the Toolbox.

  • [その他のウィンドウ] このオプションを使用すると、次のペインが表示されます。Other Windows Use this option to display the following pane:

    • [ドキュメント アウトライン] このオプションを使用すると、レポート内のレポート アイテムとそのテキスト ボックスのコレクションの階層ビューが表示されます。Document Outline Use this option to display a hierarchical view of report items and their collections of text boxes in a report.
  • [ツール バー] このオプションを使用すると、 [レポートの罫線][レポートの書式]など、レポート デザイナーの機能をサポートするツール バーが表示されます。Toolbars Use this option to display toolbars that support Report Designer features, including Report Borders and Report Formatting. 詳細については、「 レポート デザイナーのツール バー」を参照してください。For more information, see Report Designer Toolbars.

  • [レポート データ] このオプションを使用すると、[レポート データ] ペインが表示されます。このペインでは、レポート パラメーター、データ ソース、データセット、および画像を追加できます。Report Data Use this option to display the Report Data pane, where you can add report parameters, data sources, datasets, images.

[プロジェクト] メニューProject Menu

プロジェクト内の共有データ ソースおよびレポートを管理するには、 [プロジェクト] メニューを使用します。Use the Project menu to manage shared data sources and reports in a project. プロジェクトのアイテムを追加または削除すると、ソリューション エクスプローラーにおけるプロジェクト アイテムの階層表示が自動的に更新されます。When you add or remove items from the project, the hierarchical display of project items in Solution Explorer is automatically updated.

  • [新しい項目の追加] 新しい共有データ ソースまたは新しいレポートをプロジェクトに追加します。Add New Item Add a new shared data source or new report to the project.

  • [既存項目の追加] 既存の共有データ ソースまたは既存のレポートをプロジェクトに追加します。Add Existing Item Add an existing shared data source or an existing report to the project.

  • [レポートのインポート] Microsoft Access などの別のアプリケーションからレポートをインポートします。Import Reports Import reports from another application, for example, Microsoft Access.

  • [プロジェクトから除外] プロジェクトからアイテムを除外します。Exclude from Project Exclude items from the project. このオプションを使用しても、ファイル システムからアイテムは削除されません。This option does not delete the item from your file system.

  • [すべてのファイルを表示] プロジェクト内のすべてのファイルを表示します。Show All Files Show all files in a project.

  • [プロジェクト ツールボックス アイテムを最新の情報に更新] 新しいカスタム レポート アイテムをプロジェクトにインストールするときにツールボックスのキャッシュを更新します。Refresh Project Toolbox Items Refresh the toolbox cache when you install new custom report items in your project.

  • [プロパティ] このプロジェクトの [プロパティ ページ] ダイアログ ボックスを開きます。Properties Open the Property Pages dialog box for this project. 詳細については、「 [プロパティ ページ] ダイアログ ボックス」を参照してください。For more information, see Project Property Pages Dialog Box.

レポート デザイナーのツール バーReport Designer Toolbars

レポート デザイナーには、レポートのデザイン時に使用する、次の特殊なツール バーがあります。Report Designer provides the following specialized toolbars to use when designing reports:

  • [レポート] ページ ヘッダーやページ フッターの追加、レポート プロパティの設定、ルーラーや [グループ化] ペインの表示の切り替え、またはズームを使用したレポートの表示変更を実行します。Report Add a page header or page footer, set report properties, toggle the ruler or Grouping pane, or use zoom to change your view of the report.

  • [レポートの罫線] 選択したすべての線と、選択したすべてのレポート アイテムの罫線の色、スタイル、および幅を設定します。Report Borders Set the color, style, and width for all selected lines and the borders of all selected report items.

  • [レポートの書式] 選択したレポート アイテムの書式を設定します。Report Formatting Set the format of selected report items. テキスト ボックスの場合、ツール バーを使用して、フォントのプロパティとテキストの色、背景色、およびテキストの配置といった書式を変更できます。For text boxes, the following types of formatting can be changed using the toolbar: font properties and text color, background color, and text justification.

  • [レイアウト] データ領域内のレポート アイテムの描画順序やセルの結合を設定します。Layout Set the drawing order of report items and merging cells within a data region.

  • [標準] プロジェクトを開いたり保存したり、ウィンドウを表示したり、デバッグ構成を選択したりします。Standard Open or save projects, display windows, and select the Debug configuration.

    これらのツール バーを表示するかどうかを制御するには、 [表示] メニューを使用します。Use the View menu to control whether to display these toolbars. Visual StudioVisual Studio の他のツール バーは、その機能がレポート デザイナーの機能に当てはまらない場合、無効になっていることがあります。Other Visual StudioVisual Studio toolbars may be disabled if their functionality does not apply to Report Designer features.

ソース管理Source Control

SQL Server Data ToolsSQL Server Data Tools はソース プラグインと統合できます。[オプション] ダイアログ ボックスの [プロジェクトおよびソリューション] ページを使用して、プラグインを指定し、プロパティを構成します。 can integrate with source plug-ins. Use the Projects and Solutions pages in the Options dialog box to specify the plug-in and configure properties.

カスタム レポート テンプレートCustom Report Templates

新しいレポートのテンプレートとしてカスタム レポートを使用するには、 SQL Server Data ToolsSQL Server Data Tools がインストールされているコンピューターの ReportProject フォルダーにそれらのレポートをコピーするだけです。To use custom reports as templates for new reports, you simply copy them to the ReportProject folder on the computer on which SQL Server Data ToolsSQL Server Data Tools is installed. 既定では、このフォルダーは次の場所にあります: <drive>:\Program Files\Microsoft Visual Studio 14.0\Common7\IDE\Private Assemblies\ProjectItems\ReportProjectBy default, this folder is in the following location: <drive>:\Program Files\Microsoft Visual Studio 14.0\Common7\IDE\Private Assemblies\ProjectItems\ReportProject. レポート プロジェクトに新しいアイテムを追加すると、カスタム レポートが [テンプレート] ペインに表示されます。When you add a new item to the report project, your custom report appears in the Templates pane.

また、カスタム スタイルをレポート ウィザードに追加することもできます。You can also add custom styles to the report wizard.

SQL Server データ ツールのコマンド ライン サポートCommand Line Support for SQL Server Data Tools

SQL Server Data ToolsSQL Server Data Tools は、 MicrosoftMicrosoft Visual StudioVisual Studio および基になる devenv.exe アプリケーションに基づいています。 is based on MicrosoftMicrosoft Visual StudioVisual Studio and the underlying devenv.exe application. これらのオプションを使用するには、次の 2 つの項目に対して有効な値を設定しておく必要があります。Before you can use these options, you must set valid values for following two items:

  • OverwriteDataSources、TargetDataSourceFolder、TargetReportFolder、および TargetServerURL のプロジェクト プロパティ。Project properties for OverwriteDataSources, TargetDataSourceFolder, TargetReportFolder, and TargetServerURL.

  • 少なくとも 1 セットの構成プロパティ (デバッグやリリースなど)。At least one set of configuration properties, for example, Debug or Release.

    詳細については、「 データ ソースとレポートのパブリッシュ」を参照してください。For more information, see Publishing Data Sources and Reports.

    レポート サーバー プロジェクトの場合は、コマンド ラインから次のオプションを指定できます。For a report server project, you can specify the following options from the command line:

  • /deploy 構成ファイルで指定されたプロジェクト プロパティを使用してレポートを配置します。/deploy Deploy reports by using the project properties specified in a configuration file. たとえば、次のコマンドでは、プロジェクト プロパティで指定されたリリースの構成の設定を使用して、ソリューション ファイル Reports.sln で指定されたレポートを配置します。For example, the following command deploys the reports specified by the solution file Reports.sln by using the Release configuration settings that are specified in the project properties:

    devenv.exe "C:\Users\MyUser\Documents\Visual Studio 2015\Projects\Reports\Reports.sln" /deploy "Release"  
    
  • /build ソリューション ファイルをビルドしますが、配置しません。/build Build the solution file, but do not deploy it. たとえば、次のコマンドでは、プロジェクト プロパティで指定されたデバッグ構成の設定を使用して、ソリューション ファイル Reports.sln で指定されたレポートをビルドします。For example, the following command builds the reports specified by the solution file Reports.sln by using the Debug configuration settings that are specified in the project properties:

    devenv.exe "C:\Users\MyUser\Documents\Visual Studio 2015\Projects\Reports\Reports.sln" /build "Debug"  
    
  • /out ソリューションをビルドして生成した出力を、指定したファイルにリダイレクトします。/out Redirect the output generated by building a solution to the specified file. たとえば、次のコマンドでは、前の例のビルドの出力を mybuildlog.txt というファイルにリダイレクトします。For example, the following command redirects the output from the build in the previous example to a file named mybuildlog.txt.

    devenv.exe "C:\Users\MyUser\Documents\Visual Studio 2015\Projects\Reports\Reports.sln" /build "Debug" /out mybuildlog.txt  
    

Reporting Services のキーボード ショートカット キーKeyboard Shortcuts in Reporting Services

次の場合、キーボード ショートカットを使用します。Use keyboard shortcuts to:

  • SQL Server Data ToolsSQL Server Data Toolsでのウィンドウおよびモードの制御:Control windows and modes in SQL Server Data ToolsSQL Server Data Tools:

    DescriptionDescription キーの組み合わせKey Combination
    選択したプロジェクトをビルドするBuild the selected project Ctrl + Shift + BCTRL+SHIFT+B
    [プロパティ] ウィンドウを表示するDisplay Properties window F4F4
    データ ウィンドウを表示するDisplay Data window Ctrl + Alt + DCTRL+Alt+D
    デバッグを開始するStart debugging F5F5
    開いているウィンドウから次のウィンドウに移動するMove from one open window to the next F6F6
  • レポート デザイン画面でのアイテムの制御:Control items on the report design surface:

    DescriptionDescription キーの組み合わせKey Combination
    あるレポート アイテムから次のレポート アイテムにフォーカスを移動するMove focus from one report item to the next report item TabTAB
    選択したレポート アイテムを移動するMove selected report item 方向キーArrow keys
    選択したレポート アイテムを微調整するNudge selected report item Ctrl + 方向キーCTRL+Arrow keys
    選択したレポート アイテムのサイズを増減するIncrease or decrease the size of the selected report item Ctrl</localizedText> + <localizedText>Shift</localizedText> + 方向キーCTRL+SHIFT+Arrow keys
    テキスト ボックスで、表示されているテキストの先頭にカーソルを移動するIn a text box, move cursor to the beginning of the display text that is visible Ctrl</localizedText> + <localizedText>HomeCTRL+HOME
    テキスト ボックスで、表示されているテキストの末尾にカーソルを移動するIn a text box, move cursor to the end of the display text that is visible Ctrl</localizedText> + <localizedText>EndCTRL+END
    テキストボックスで、現在のカーソル位置から表示されているテキストの先頭までのテキストを選択するIn a text box, select text from the current cursor position to the beginning of the display text that is visible Shift + HomeSHIFT+HOME
    テキストボックスで、現在のカーソル位置から表示されているテキストの末尾までのテキストを選択するIn a text box, select text from the current cursor position to the end of the display text that is visible Shift + EndSHIFT+END
    テキスト ボックスで、現在のカーソル位置から表現の先頭までのテキストを選択するIn a text box, select text from the current cursor position to the beginning of the expression Ctrl + Shift + HomeCTRL+SHIFT+HOME
    テキスト ボックスで、現在のカーソル位置から表現の末尾までのテキストを選択するIn a text box, select text from the current cursor position to the end of the expression Ctrl + Shift + EndCTRL+SHIFT+END
    選択したレポート アイテムのコンテキスト メニューを開くOpen the shortcut menu for the selected report item Shift + F10 + 新しいキーボードのプロパティ キーSHIFT+F10+Property Key on newer keyboards

次の手順Next steps

SQL Server Data Tools のダウンロード ソリューション エクスプローラー Download SQL Server Data Tools Solution Explorer
Reporting Services レポート Reporting Services Reports
レポート定義言語 Report Definition Language
SQL Server Data Tools の配置およびバージョン サポートDeployment and Version Support in SQL Server Data Tools

その他の質問More questions? Reporting Services のフォーラムに質問してみてくださいTry asking the Reporting Services forum