SQL Server データ ツールの Reporting Services (SSDT)

SQL Server Data Tools (SSDT) は、ビジネス Microsoft Visual Studioソリューションを作成するための新しい環境です。 SSDT には レポート デザイナー オーサリング環境が用意されています。この環境では、Reporting Services のページ分割されたレポート定義、共有データ ソース、共有データセット、レポート パーツを開き、変更、プレビュー、保存、配置できます。 SQL Server Data Tools (SSDT) は、このSQL Server。 SQL Server Data Toolsをダウンロードします。

このトピックでは、SQL Server Data Tools に使用される SQL Server Data Tools ソリューション、プロジェクト、プロジェクト テンプレート、構成、および Reporting Services レポート デザイナー で使用できるビュー、メニュー、ツール バー、ショートカットについて説明します。

レポートのデザインを開始するには、「レポートを使用してレポートをデザイン する (SSRS)」レポート デザイナーを参照してください

ソリューションとプロジェクト

レポート プロジェクトは、レポート定義およびリソースのコンテナーの役割を果たします。 レポート プロジェクト内の各ファイルは、プロジェクトが配置されるときに、レポート サーバーにパブリッシュされます。 プロジェクトを初めて作成する場合は、プロジェクトのコンテナーとしてソリューションも作成されます。 複数のプロジェクトを 1 つのソリューションに追加することができます。

構成

企業のテスト用レポート サーバーや実稼働レポート サーバーなど、さまざまな種類の配置に対して複数のプロジェクト プロパティのセットを作成するには、構成マネージャーを使用します。 詳細については、「展開とバージョンのサポート 」を参照SQL Server Data Tools (SSRS) を参照してください

レポート サーバープロジェクト

アプリケーションをインストールReporting Services、次のプロジェクト テンプレートが SSDT (SQL Server Data Toolsで使用できます。

  • レポート サーバー プロジェクト。 レポート サーバー プロジェクトを選択すると、レポート デザイナーが開きます。 レポート サーバー Project は、 [新しいプロジェクト] ダイアログ ボックスから使用できる Visual Studio によってインストールされるビジネス インテリジェンス プロジェクト Projectです。 詳細については、「レポート レポートへの新規または既存のレポートの追加 (SSRS)」をProject参照してください。レポート サーバー プロジェクトのプロパティは、すべてのレポートと、1 つのレポート (SSDT) プロジェクト内SQL Server Data Tools共有データ ソースに適用されます。 これらのプロパティには、レポート サーバーの URL、およびレポートと共有データ ソースのフォルダー名が含まれます。 現在のプロパティ値を確認するには、 [プロジェクト プロパティ ページ] ダイアログ ボックスを使用します。 このダイアログ ボックスを開くには、 [プロジェクト] メニューの [プロパティ] をクリックします。

  • レポート サーバー プロジェクト ウィザード。 レポート サーバー プロジェクト ウィザードを選択すると、レポート サーバー プロジェクトが自動的に作成され、レポート ウィザードが開きます。 このウィザードでは、各ページの手順に従ってレポートを作成し、データ ソースへの接続文字列の作成、データ ソースの資格情報の設定、クエリのデザイン、テーブルまたはマトリックス データ領域の追加、レポート データやグループの指定、フォントや色のスタイルの選択、レポート サーバーへのレポートのパブリッシュ、およびローカルでのレポートのプレビューを行うことができます。 ウィザードを使用してレポートを作成した後で、レポート サーバー プロジェクトでレポート デザイナーを使用して、レポート データおよびレポート デザイナーを変更できます。

New Project templates in SSDT

レポート デザイナーのウィンドウとペイン

レポート デザイナーでは、レポート データとレポート レイアウトを定義するための [デザイン] ビューと、描画されたレポートのビューを表示するための [プレビュー] ビューがサポートされています。 それぞれのビューでは、表示レポートをデザインまたは表示できるように複数のウィンドウを表示できます。

レポート データ ペイン

[レポート データ] ペインには、組み込みフィールド、データ ソース、データセット、フィールド コレクション、レポート パラメーター、および画像が表示されます。

以下を表示するには、[レポート データ] ペインを使用します。

  • 組み込みフィールド レポート名やレポートの処理時刻など、事前に定義されたレポート情報です。

  • データ ソース データ ソースは、基になるデータの名前とそのデータへの接続を表します。

  • データセット 各データセットには、データ ソースから取得するデータを指定するクエリが含まれています。 データセット クエリで指定されたフィールドのコレクションを表示するには、データセットを展開します。

    多次元データセット用のクエリ デザイナーの中には、[フィルター] ペインでフィルターを指定して、レポート パラメーターを作成するかどうかを指定できるものがあります。 レポート パラメーター オプションを指定した場合は、そのパラメーターの有効な値の一覧を設定する特別なデータセットが自動的に作成されます。 既定では、データセットは [レポート データ] ペインに表示されません。 詳細については、「多次元データのパラメーター値の非表示データセットの表示 (Report Builder および SSRS)」を参照してください

  • レポート パラメーター レポート パラメーターの一覧です。 データセット クエリにクエリ パラメーターが含まれている場合は、パラメーターを手動または自動で作成できます。

  • 画像 レポートに画像レポート アイテムとして含めることができる画像の一覧です。

[レポート データ] ペインのデータ ソースおよびデータセットは、レポート定義内の要素を表します。 [レポート データ] ペインは、複数のレポート作成環境でサポートされている機能です。 レポート ビルダーでは、データ ソースとデータセットの管理に使用できる唯一のペインです。 レポート デザイナーでは、[レポート データ] ペインはソリューション エクスプローラーと連携して動作します。ソリューション エクスプローラーでは、共有データ ソースと共有データセットがファイルとして表示されます。 [レポート データ] ペインの共有データ ソースと共有データセットは、ソリューション エクスプローラーの対応する共有データ ソースと共有データセットを参照する必要があります。 そのため、[レポート データ] ペインの要素には、ソリューション エクスプローラーのデータ ファイルへの参照が含まれます。 プロジェクト プロパティによって、共有データ ソースと共有データセットがレポート サーバーに配置されるか、SharePoint サイトに配置されるかが決まります。 詳細については、「データ ソースの変換 (Report Builder SSRS)」を参照してください

Note

[レポート データ] ペインが表示されていない場合は、デザイン領域内をクリックし、 [表示] メニューの [レポート データ] をクリックします。 [レポート データ] ペインが固定されていない場合は、固定することができます。 詳細については、「レポート データ ペイン をレポート にドッキングする (SSRS)」レポート デザイナーを参照してください

グループ化ペイン

Tablix データ領域のグループを定義するには、[グループ化] ペインを使用します。 テーブルの行グループと詳細グループ、およびマトリックスの行グループと列グループを定義できます。 [グループ化] ペインを使用して、グラフまたは他のデータ領域のグループを定義することはできません。 詳細については、「グループについて (Report Builder および SSRS)」を参照してください

グループ化ペインには、次の 2 つのモードがあります。

  • 既定値。 親グループ、子グループ、隣接するグループ、および詳細グループのリレーションシップを示す階層形式ですべての行グループと列グループを表示するには、 既定 モードを使用します。 子グループは、その親グループと比較して直下の次のインデント レベルに表示されます。 隣接するグループは、そのピアまたは兄弟グループと同じインデント レベルに表示されます。

    グループを追加、編集、または削除するには、既定のモードを使用します。 1 つのデータセット フィールドに基づいたグループでは、[行グループ] ペインまたは [列グループ] ペインにフィールドをドラッグします。 グループは、既存のグループの上または下に挿入できます。 隣接するグループを追加するには、兄弟グループを右クリックして、コンテキスト メニューを使用します。 グループに属している Tablix セルを表示するには、[グループ化] ペインでグループを選択します。

  • [詳細設定]。 選択した Tablix データ領域の行グループと列グループの静的メンバーと動的メンバーを表示するには、 詳細設定 モードを使用します。 グループまたはグループ メンバーに関連付けられている行と列の表示を制御するプロパティ、またはグループを 1 ページにまとめておくためにレンダラーで使用するルールを設定するには、グループ メンバーを使用する必要があります。 グループ メンバーは、行グループ領域および列グループ領域のセルとして、デザイン画面に表示されます。

Note

既定 モードと 詳細設定 モードを切り替えるには、 [列グループ] アイコンの右側にある下矢印を右クリックします。

詳細については、「 グループ化ペイン」を参照してください。

ツールボックス

ツールボックスには、デザイン画面にドラッグできるレポート アイテムが含まれています。 データ領域は、レポート上のデータを整理する際に使用するレポート アイテムです。 テーブル、マトリックス、一覧、グラフ、ゲージ、データ バー、スパークライン、およびインジケーターはデータ領域です。 その他のレポート アイテムには、マップ、テキスト ボックス、四角形、線、画像、およびサブレポートがあります。 カスタム レポート アイテムがシステム管理者によってインストールおよび登録されている場合、それらのアイテムがこの一覧に表示されることがあります。

[プロパティ] ペイン

[プロパティ] ウィンドウは、デザインVisual Studio現在選択されているレポート アイテムのプロパティ名と値を表示する標準のレポート ウィンドウです。 ほとんどの場合、プロパティ名は、レポート定義言語 (RDL) ファイル内の要素と属性に対応します。 最も一般的に使用されるプロパティは、選択したアイテムの [プロパティ] ダイアログ ボックスを使用して設定できます。 対応するダイアログ ボックスを開くには、[プロパティ] ペイン ツール バーの [プロパティ ページ] ボタンをクリックします。 上級ユーザーは、[プロパティ] ペインでプロパティ値を直接設定できます。

次の場合、[プロパティ] ペインを使用します。

  • デザイン画面で現在選択されている項目のプロパティを設定します。 プロパティによっては、値のドロップダウン リストが表示されます。 セルに値を直接入力することもできます。 一部のプロパティには値のコレクションが含まれており、 [(コレクション)] という値で示されます。 ほとんどのプロパティは式を受け入れることができます。複合式は、値 Expression で示 されます>。 [] を>クリックして[式>を開きます。 詳細については、「 [式] ダイアログ ボックス」を参照してください。

  • グリッドをカテゴリ別の表示からアルファベット順の表示に変更するには、[プロパティ] ペインのツール バー ボタンを使用します。 カテゴリ別の表示では、カテゴリのすべてのプロパティを表示するには、そのカテゴリを展開する必要があります。 アイテムの [プロパティ] ダイアログ ボックスを開くには、ツール バーの [プロパティ ページ] ボタンをクリックするか、アイテムを右クリックして [プロパティ] をクリックします。

  • [グループ化] ペインで現在選択されているグループ メンバーのプロパティを設定します。 グループ メンバーのプロパティを使用すると、グループ インスタンスごとに静的なグループ ヘッダー行とフッター行を繰り返す方法を制御できます。 詳細については、「グループを使用したヘッダーとフッターの表示 (Report Builder と SSRS)」を参照してください。

[プロパティ] ペインを表示するには、 [表示] メニューの [プロパティ ウィンドウ] をクリックします。 このペインのドッキングを解除して [SQL Server データツール] ウィンドウの別の領域に移動したり、デザインサーフェイスにタブ付きビューとして表示したりできます。

ソリューション エクスプローラー

ソリューションエクスプローラーは、プロジェクト内のすべての項目を表示する標準の Visual Studio コンポーネントです。 レポート サーバー プロジェクトの場合、これには共有データ ソース、共有データセット、レポート、およびリソースを整理するためのフォルダーが含まれます。 ソリューション ファイルを開くと、フォルダーのアイテムが自動的にアルファベット順に並べ替えられます。 [プロパティ] ペインにアイテムのプロパティを表示するには、アイテムを選択します。

出力

[出力] ウィンドウには、レポートをプレビューした場合の処理エラーと、レポートまたは共有データ ソースを配置した場合の発行エラーが表示されます。

[出力] ウィンドウと [ドキュメント アウトライン] ウィンドウを使用すると、式のエラーをデバッグできます。

[ドキュメント アウトライン]

[ドキュメント アウトライン] ウィンドウには、レポート定義内のすべてのレポート アイテムの階層リストが表示されます。 ドキュメント アウトライン ペインを開くには、 [表示] メニューの [その他のウィンドウ] をポイントし、 [ドキュメント ウィンドウ] をクリックします。

ドキュメント アウトライン ペインを使用すると、テキスト ボックスとその他のレポート アイテムを名前で識別できます。 ドキュメント アウトラインでアイテムを選択すると、そのアイテムはデザイン画面でも選択されます。

タスク一覧

[タスク一覧] ウィンドウには、Microsoft Access などの別のアプリケーションからレポートをインポートするときに、サポートされていない機能のビルドエラーが表示されます。

レポート デザイナーの [デザイン] ビュー

既定では、レポート サーバー プロジェクトを作成する際に、レポート デザイナーが [デザイン] ビューで開き、デザイン画面が表示されます。 既定では、デザイン画面には、レポート本文とレポートの背景が表示されます。

背景のコンテキスト メニューには、ページ ヘッダーとページ フッターを追加するオプションがあります。また、[表示] メニューを使用すると、ルーラーと [グループ化] ペインを表示することができます。

レポートの倍率を上げたり下げたりするには、ズーム コントロールを使用します。

レポートをデザインするには、レポート アイテムをツールボックスからデザイン画面にドラッグした後、そのプロパティを構成したり、レポート上での配置を変更したりします。

レポート デザイナー プレビュー

レポートを実行して、レポート ビューアーに表示レポートを表示するには、[プレビュー] を使用します。 プレビュー時には、レポート データがローカルでキャッシュされます。 また、ブラウザーを使用してデバッグ ビューでレポートを実行するように構成プロパティを設定することもできます。

レポートをプレビューすると、レポート デザイナーは、レポート データ ソースに接続し、データセット クエリを実行して、データをローカル コンピューターにキャッシュします。その後、レポートを処理してデータとレイアウトを組み合わせて、レポートを表示します。 レポートは、[プレビュー] タブに表示することも、デバッグ モードで表示するようにプロジェクトのプロパティを設定して直接ブラウザーに表示することもできます。

  • パラメーター化されたレポートのプレビュー: レポートをプレビューする際に、すべてのレポート パラメーターに有効な既定値がある場合は、レポートが自動的に処理されます。 1 つ以上のレポート パラメーターに有効な既定値がない場合は、未割り当ての各パラメーターの値を選択してから、レポート ツール バーの [レポートの表示]をクリックする必要があります。

  • ローカル データ キャッシュについて : レポートをプレビューすると、レポート プロセッサでは、現在のパラメーターの既定値を使用してレポート内のデータセットに対するすべてのクエリを実行し、その結果をローカル データ キャッシュ (.rdl.data) ファイルとして保存します。 レポート データセット クエリまたはレポート パラメーターを変更しない場合は、このデータを再度取得するオーバーヘッドを発生させることなく、引き続きレポートをデザインできます。

  • 構成マネージャーとデバッグを使用したレポートのプレビュー: SQL Server Data Tools (SSDT) では、プロジェクトのプロパティによって、レポートを配置およびデバッグする方法が定義されます。 これらのプロパティは、プロジェクトのすべてのレポートおよび共有データ ソースに適用されます。 プロジェクトのプロパティを設定するには、 [プロジェクト] メニューの [プロパティ] をクリックします。 レポートをテストしてレポート サーバーにパブリッシュするには、これらの設定を使用します。

  • [出力] ペインでのエラー メッセージの監視: レポートのプレビュー時にレポート プロセッサで問題が検出されると、[出力] ペインにエラー メッセージが表示されます。

レポート デザイナーのメニュー

SQL Server Data Tools (SSDT) でレポートデザイナープロジェクトがアクティブになると、次のツールバーがメインツールバーに追加されます。 レポート デザイナーのメニューは、[デザイン] ビューのみに表示されます。

[書式] メニュー

デザイン画面でアイテムを選択した場合、 [書式] メニューには次のオプションがあります。

  • [前景色] テキストの色を選択します。 既定のテキストの色は黒です。

  • [背景色] テキスト ボックスとデータ領域の背景色を選択します。

  • [フォント] テキストを太字、斜体、または下線付きにするかどうかを指定します。

  • [両端揃え] テキストを右揃え、中央揃え、または左揃えにするかどうかを指定します。

  • [整列] レポート内で、選択したオブジェクトを互いの位置を基準にして整列する方法を指定します。

  • [同じサイズに揃える] レポート内で選択したオブジェクトのサイズを調整します。

  • [左右の間隔] レポート内で選択したオブジェクト間の左右の間隔を調整します。

  • [上下の間隔] レポート内で選択したオブジェクト間の上下の間隔を調整します。

  • [フォームの中央に配置] 選択したオブジェクトを、レポート デザイナー ウィンドウに対して上下左右の中央に配置します。

  • [順序] 選択したオブジェクトを背景または前景に移動します。

[レポート] メニュー

レポート デザイン画面がアクティブになっている場合、 [レポート] メニューには次のオプションがあります。

  • [レポートのプロパティ][レポートのプロパティ] ダイアログ ボックスを開きます。 このダイアログ ボックスでは、一般的なレポートのプロパティ (作成者の名前やグリッドの間隔など) を割り当てたり、レポート レイアウトのプロパティ (列数やページ サイズなど) を指定したりできます。 また、カスタム コード、アセンブリやクラスへの参照、データ出力要素の名前、データ変換の名前、およびデータ スキーマの名前も含めることができます。

  • [表示] レポート デザイナーのタブ[デザイン] と [プレビュー] を切り替えます。

  • [ページ ヘッダー] レポートのページ ヘッダーを追加または削除します。 ページ ヘッダーを削除すると、ページ ヘッダー内のすべてのアイテムが削除されます。

  • [ページ フッター] レポートのページ フッターを追加または削除します。 ページ フッターを削除すると、ページ フッター内のすべてのアイテムが削除されます。

  • [グループ化ペイン] [グループ化] ペインの表示と非表示を切り替えます。

[View](表示) メニュー

[表示] メニューを使用すると、レポート デザイナーのウィンドウとツール バーが表示されます。

  • [エラー一覧] このオプションを使用すると、レポートをパブリッシュまたはプレビューしたときに検出されたエラーが表示されます。

  • [出力] このオプションを使用すると、レポートをパブリッシュまたは処理するときに検出されたエラーや、レポートで "#Error" というテキストが表示された場合の式のエラーの詳細が表示されます。

  • [プロパティ ウィンドウ] このオプションを使用すると、デザイン画面で現在選択されているレポート アイテムのプロパティ値が表示されます。 入れ子になったレポート アイテムのプロパティを表示するには、レポート アイテムを複数回クリックして、レポート アイテムとその入れ子になったメンバーの階層を切り替える必要があります。 [プロパティ] ペインの先頭に表示されているアイテムの名前を確認すると、どのレポート アイテムのプロパティが表示されているかがわかります。

  • [ツールボックス] このオプションを使用すると、ツールボックスが表示されます。

  • [その他のウィンドウ] このオプションを使用すると、次のペインが表示されます。

    • [ドキュメント アウトライン] このオプションを使用すると、レポート内のレポート アイテムとそのテキスト ボックスのコレクションの階層ビューが表示されます。
  • [ツール バー] このオプションを使用すると、 [レポートの罫線][レポートの書式] など、レポート デザイナーの機能をサポートするツール バーが表示されます。 詳細については、「 レポート デザイナーのツール バー」を参照してください。

  • [レポート データ] このオプションを使用すると、[レポート データ] ペインが表示されます。このペインでは、レポート パラメーター、データ ソース、データセット、および画像を追加できます。

[プロジェクト] メニュー

プロジェクト内の共有データ ソースおよびレポートを管理するには、 [プロジェクト] メニューを使用します。 プロジェクトのアイテムを追加または削除すると、ソリューション エクスプローラーにおけるプロジェクト アイテムの階層表示が自動的に更新されます。

  • [新しい項目の追加] 新しい共有データ ソースまたは新しいレポートをプロジェクトに追加します。

  • [既存項目の追加] 既存の共有データ ソースまたは既存のレポートをプロジェクトに追加します。

  • [レポートのインポート] Microsoft Access などの別のアプリケーションからレポートをインポートします。

  • [プロジェクトから除外] プロジェクトからアイテムを除外します。 このオプションを使用しても、ファイル システムからアイテムは削除されません。

  • [すべてのファイルを表示] プロジェクト内のすべてのファイルを表示します。

  • [プロジェクト ツールボックス アイテムを最新の情報に更新] 新しいカスタム レポート アイテムをプロジェクトにインストールするときにツールボックスのキャッシュを更新します。

  • [プロパティ] このプロジェクトの [プロパティ ページ] ダイアログ ボックスを開きます。 詳細については、「 [プロパティ ページ] ダイアログ ボックス」を参照してください。

レポート デザイナーのツール バー

レポート デザイナーには、レポートのデザイン時に使用する、次の特殊なツール バーがあります。

  • [レポート] ページ ヘッダーやページ フッターの追加、レポート プロパティの設定、ルーラーや [グループ化] ペインの表示の切り替え、またはズームを使用したレポートの表示変更を実行します。

  • [レポートの罫線] 選択したすべての線と、選択したすべてのレポート アイテムの罫線の色、スタイル、および幅を設定します。

  • [レポートの書式] 選択したレポート アイテムの書式を設定します。 テキスト ボックスの場合、ツール バーを使用して、フォントのプロパティとテキストの色、背景色、およびテキストの配置といった書式を変更できます。

  • [レイアウト] データ領域内のレポート アイテムの描画順序やセルの結合を設定します。

  • [標準] プロジェクトを開いたり保存したり、ウィンドウを表示したり、デバッグ構成を選択したりします。

これらのツール バーを表示するかどうかを制御するには、 [表示] メニューを使用します。 機能がレポートデザイナー機能に適用されない場合は、他の Visual Studio ツールバーが無効になることがあります。

ソース管理

SQL Server Data Tools をソースプラグインと統合できます。[オプション] ダイアログボックスの [プロジェクトおよびソリューション] ページを使用すると、プラグインを指定したり、プロパティを構成したりできます。

カスタム レポート テンプレート

新しいレポートのテンプレートとしてカスタムレポートを使用するには、SQL Server Data Tools がインストールされているコンピューターの reportproject フォルダーにそれらのレポートをコピーするだけです。 既定では、このフォルダーは次の場所にあります: <drive>:\Program Files\Microsoft Visual Studio 14.0\Common7\IDE\Private Assemblies\ProjectItems\ReportProject。 レポート プロジェクトに新しいアイテムを追加すると、カスタム レポートが [テンプレート] ペインに表示されます。

また、カスタム スタイルをレポート ウィザードに追加することもできます。

SQL Server データ ツールのコマンド ライン サポート

SQL Server Data Tools は Microsoft Visual Studio と基になる devenv.exe アプリケーションに基づいています。 これらのオプションを使用するには、次の 2 つの項目に対して有効な値を設定しておく必要があります。

  • OverwriteDataSources、TargetDataSourceFolder、TargetReportFolder、および TargetServerURL のプロジェクト プロパティ。

  • 少なくとも 1 セットの構成プロパティ (デバッグやリリースなど)。

詳細については、「 データ ソースとレポートのパブリッシュ」を参照してください。

レポート サーバー プロジェクトの場合は、コマンド ラインから次のオプションを指定できます。

  • /deploy 構成ファイルで指定されたプロジェクト プロパティを使用してレポートを配置します。 たとえば、次のコマンドでは、プロジェクト プロパティで指定されたリリースの構成の設定を使用して、ソリューション ファイル Reports.sln で指定されたレポートを配置します。

    devenv.exe "C:\Users\MyUser\Documents\Visual Studio 2015\Projects\Reports\Reports.sln" /deploy "Release"  
    
  • /build ソリューション ファイルをビルドしますが、配置しません。 たとえば、次のコマンドでは、プロジェクト プロパティで指定されたデバッグ構成の設定を使用して、ソリューション ファイル Reports.sln で指定されたレポートをビルドします。

    devenv.exe "C:\Users\MyUser\Documents\Visual Studio 2015\Projects\Reports\Reports.sln" /build "Debug"  
    
  • /out ソリューションをビルドして生成した出力を、指定したファイルにリダイレクトします。 たとえば、次のコマンドでは、前の例のビルドの出力を mybuildlog.txt というファイルにリダイレクトします。

    devenv.exe "C:\Users\MyUser\Documents\Visual Studio 2015\Projects\Reports\Reports.sln" /build "Debug" /out mybuildlog.txt  
    

Reporting Services のキーボード ショートカット キー

次の場合、キーボード ショートカットを使用します。

  • SQL Server Data Tools でのウィンドウおよびモードの制御:

    説明 キーの組み合わせ
    選択したプロジェクトをビルドする Ctrl + Shift + B
    [プロパティ] ウィンドウを表示する F4
    データ ウィンドウを表示する Ctrl + Alt + D
    デバッグを開始する F5
    開いているウィンドウから次のウィンドウに移動する F6
  • レポート デザイン画面でのアイテムの制御:

    説明 キーの組み合わせ
    あるレポート アイテムから次のレポート アイテムにフォーカスを移動する Tab
    選択したレポート アイテムを移動する 方向キー
    選択したレポート アイテムを微調整する Ctrl + 方向キー
    選択したレポート アイテムのサイズを増減する Ctrl</localizedText> + <localizedText>Shift</localizedText> + 方向キー
    テキスト ボックスで、表示されているテキストの先頭にカーソルを移動する Ctrl</localizedText> + <localizedText>Home
    テキスト ボックスで、表示されているテキストの末尾にカーソルを移動する Ctrl</localizedText> + <localizedText>End
    テキストボックスで、現在のカーソル位置から表示されているテキストの先頭までのテキストを選択する Shift + Home
    テキストボックスで、現在のカーソル位置から表示されているテキストの末尾までのテキストを選択する Shift + End
    テキスト ボックスで、現在のカーソル位置から表現の先頭までのテキストを選択する Ctrl + Shift + Home
    テキスト ボックスで、現在のカーソル位置から表現の末尾までのテキストを選択する Ctrl + Shift + End
    選択したレポート アイテムのコンテキスト メニューを開く Shift + F10 + 新しいキーボードのプロパティ キー

次のステップ

SQL Server Data Tools のダウンロードソリューション エクスプローラー
レポートの Reporting Services
レポート定義言語
SQL Server Data Tools の配置およびバージョン サポート

その他の質問 Reporting Services のフォーラムに質問してみてください