メニューとショートカット キーのカスタマイズCustomize Menus and Shortcut Keys

適用対象:Applies to: はいSQL ServerSQL Server (サポートされているすべてのバージョン) yesSQL ServerSQL Server (all supported versions) はいAzure SQL データベースAzure SQL DatabaseYesAzure SQL データベースAzure SQL Database はいAzure SQL Managed InstanceAzure SQL Managed InstanceYesAzure SQL Managed InstanceAzure SQL Managed Instance はいAzure Synapse AnalyticsAzure Synapse AnalyticsyesAzure Synapse AnalyticsAzure Synapse Analytics はいParallel Data WarehouseParallel Data WarehouseyesParallel Data WarehouseParallel Data Warehouse適用対象:Applies to: はいSQL ServerSQL Server (サポートされているすべてのバージョン) yesSQL ServerSQL Server (all supported versions) はいAzure SQL データベースAzure SQL DatabaseYesAzure SQL データベースAzure SQL Database はいAzure SQL Managed InstanceAzure SQL Managed InstanceYesAzure SQL Managed InstanceAzure SQL Managed Instance はいAzure Synapse AnalyticsAzure Synapse AnalyticsyesAzure Synapse AnalyticsAzure Synapse Analytics はいParallel Data WarehouseParallel Data WarehouseyesParallel Data WarehouseParallel Data Warehouse

キーボード アクセス キーを使用すると、Alt キーを押しながら <single letter> を押すことでメニュー コマンドやボタンを選択できます。A keyboard accelerator allows you to select a menu command or button by pressing ALT+<single letter>. たとえば、 [編集] メニューを開くには、ALT + E キーを押します。For example, to open the Edit menu, press ALT+E. ツール バーのボタン、メニュー、メニュー コマンドの並べ替えや変更を行うには、 [ユーザー設定] ダイアログ ボックスを使用します。You can rearrange and modify toolbar buttons, menus, and menu commands by using the Customize dialog box. マウスを使用して設定を変更する方法と、キーボードだけを使用して設定を変更する方法を以下に示します。Instructions are provided for changing the settings using the mouse and using only the keyboard.

Ctrl キーを使用したストアド プロシージャのキーボード ショートカット キーは、 [ツール] メニューから開く [オプション] / [キーボード] ダイアログ ボックスを使用します。Keyboard accelerators for stored procedures using the Ctrl key can be created from the Keyboard page of the Tools/Options dialog box.

注意

このページの上部の [すべて折りたたみ] をクリックすると、見出しだけが表示されます。Click Collapse All at the top of this page to show only the headings.

マウスを使用してキーボード アクセス キー設定用ダイアログ ボックスを開く方法Opening the Keyboard Accelerator Dialog Box Using the Mouse

キーボード アクセス キーの割り当てや変更を行うためのダイアログ ボックスにアクセスするには (マウスを使用)To access the dialog box for assigning or changing a keyboard accelerator (using the mouse)

  1. [ツール] メニューの [ユーザー設定] をクリックします。On the Tools menu, click Customize.

  2. 変更するツール バーが表示されていることを確認します。Make sure the toolbar you want to change is visible.

    1. [ユーザー設定] ダイアログ ボックスの [ツール バー] タブをクリックします。In the Customize dialog box, click the Toolbars tab.

    2. 表示するツール バーのチェック ボックスをオンにします。Select the check box for the toolbar you want to display.

  3. [ユーザー設定] ダイアログ ボックスの [コマンド] タブをクリックします。In the Customize dialog box, click the Commands tab.

マウスを使用してツール バー ボタンのアクセス キーを変更する方法Changing a Toolbar Buttons Accelerator Key Using the Mouse

ツール バー ボタンのキーボード アクセス キーの割り当てや変更を行うには (マウスを使用)To assign or change a toolbar button's keyboard accelerator (using the mouse)

  1. ツール バーのボタンをクリックします。Click the button on the toolbar.

  2. [ユーザー設定] ダイアログ ボックスの [コマンド] タブで [選択したボタンの編集] をクリックします。In the Customize dialog box, on the Commands tab, click Modify Selection.

  3. ショートカット メニューの [名前] ボックスにツール バー ボタンの名前を入力し、キーボード アクセス キーとして使用する文字の前にアンパサンド (&) を付けます。In the Name box on the shortcut menu, type a name for the toolbar button with an ampersand (&) before the letter that you want as the keyboard accelerator.

  4. Enter キーを押します。Press ENTER.

  5. [ユーザー設定] ダイアログ ボックスの [閉じる] をクリックします。In the Customize dialog box, click Close.

マウスを使用してメニュー コマンドのアクセス キーを変更する方法Changing a Menu Commands Accelerator Key Using the Mouse

メニュー コマンドのキーボード アクセス キーの割り当てや変更を行うには (マウスを使用)To assign or change a menu command's keyboard accelerator (using the mouse)

  1. メニュー バーまたはツール バーのメニュー名をクリックします。Click the menu name on the menu bar or toolbar.

  2. メニュー コマンドをクリックします。Click the menu command.

  3. [ユーザー設定] ダイアログ ボックスの [選択したボタンの編集] をクリックします。In the Customize dialog box, click Modify Selection.

  4. ショートカット メニューの [名前] ボックスにメニュー コマンドの名前を入力し、キーボード アクセス キーとして使用する文字の前にアンパサンド (&) を付けます。In the Name box on the shortcut menu, type a name for the menu command with an ampersand (&) before the letter that you want as the keyboard accelerator.

  5. Enter キーを押します。Press ENTER.

  6. [ユーザー設定] ダイアログ ボックスの [閉じる] をクリックします。In the Customize dialog box, click Close.

キーボードを使用してキーボード アクセス キー設定用ダイアログ ボックスを開く方法Opening the Keyboard Accelerator Dialog Box Using the Keyboard

キーボード アクセス キーの割り当てや変更を行うためのダイアログ ボックスにアクセスするには (キーボードを使用)To access the dialog box for assigning or changing a keyboard accelerator (using the keyboard)

  1. Alt キーを押しながら T キーを押し、次に C と入力して、 [ユーザー設定] ダイアログ ボックスを表示します。Press ALT+T, then type C, to open the Customize dialog box.

  2. 変更するツール バーが表示されていることを確認します。Make sure the toolbar you want to change is visible.

    1. [ユーザー設定] ダイアログ ボックスで Alt キーを押しながら B キーを押して、 [ツール バー] タブを表示します。In the Customize dialog box, press ALT+B to show the Toolbars tab.

    2. 方向キーを使用して表示するツール バーを選択し、 Space キーを押してチェック ボックスをオンにします。Use the arrow keys to select the toolbar you want to display, then SPACE to select the check box.

  3. [ユーザー設定] ダイアログ ボックスで Alt キーを押しながら C キーを押して、 [コマンド] タブを表示します。In the Customize dialog box, press ALT+C to display the Commands tab.

キーボードを使用してツール バー ボタンのアクセス キーを変更する方法Changing a Toolbar Buttons Accelerator Key Using the Keyboard

ツール バー ボタンのキーボード アクセス キーの割り当てや変更を行うには (キーボードを使用)To assign or change a toolbar button's keyboard accelerator (using the keyboard)

  1. Alt + R キーを押して、 [コマンドの配置の変更] ダイアログ ボックスを表示します。Press ALT+R to display the Rearrange Commands dialog box.

  2. [コマンドの配置の変更] ダイアログ ボックスで、方向キーを使用して [ツール バー] を選択します。In the Rearrange Commands dialog box, use the arrow keys to select Toolbar.

  3. Tab キーを使用して [ツール バー] 一覧に移動し、方向キーを使用して、変更するボタンが入っているツール バーを選択し、 Enter キーを押します。Tab to the Toolbar list, and use the arrow keys to select the toolbar that contains the button you want to change, and then press ENTER.

  4. Tab キーを使用して [コントロール] 一覧に移動し、方向キーを使用して、変更するコマンドを選択します。Tab to the Controls list, and use the arrow keys to select the button you want to change.

  5. Alt + M キーを押して、 [選択したボタンの編集] を選択します。Press ALT+M, to select Modify Selection.

  6. Tab キーを使用してショートカット メニューの [名前] ボックスに移動し、ツール バー ボタンの名前を入力し、キーボード アクセス キーとして使用する文字の前にアンパサンド (&) を付けます。Tab to the Name box on the shortcut menu, type a name for the toolbar button with an ampersand (&) before the letter that you want as the keyboard accelerator.

  7. Enter キーを押します。Press ENTER.

  8. Tab キーを使用して [閉じる] ボタンに移動し、 Enter キーを押します。Tab to the Close button, and then press ENTER.

キーボードを使用してメニュー コマンドのアクセス キーを変更する方法Changing a Menu Commands Accelerator Key Using the Keyboard

メニュー コマンドのキーボード アクセス キーの割り当てや変更を行うには (キーボードを使用)To assign or change a menu command's keyboard accelerator (using the keyboard)

  1. Alt + R キーを押して、 [コマンドの配置の変更] ダイアログ ボックスを表示します。Press ALT+R to display the Rearrange Commands dialog box.

  2. Tab キーを使用して [メニュー バー] に移動し、 [メニュー バー] 一覧で方向キーを使用して対象のメニューを選択し、 Enter キーを押します。Tab to Menu Bar and then use the arrow keys to click the menu you want in the Menu Bar list, and then press ENTER.

  3. Tab キーを使用して [コントロール] 一覧に移動し、方向キーを使用して、変更するコマンドを選択します。Tab to the Controls list, and use the arrow keys to select the button you want to change.

  4. Alt + M キーを押して、 [選択したボタンの編集] を選択します。Press ALT+M, to select Modify Selection.

  5. Tab キーを使用してショートカット メニューの [名前] ボックスに移動し、メニュー コマンドの名前を入力し、キーボード アクセス キーとして使用する文字の前にアンパサンド (&) を付けます。Tab to the Name box on the shortcut menu, and type a name for the toolbar button with an ampersand (&) before the letter that you want as the keyboard accelerator.

  6. Enter キーを押します。Press ENTER.

  7. [ユーザー設定] ダイアログ ボックスの [閉じる] をクリックします。In the Customize dialog box, click Close.

ストアド プロシージャのキーボード ショートカット キーを作成する方法Creating a Keyboard Accelerator for a Stored Procedure

ストアド プロシージャのキーボード ショートカット キーを作成するにはTo create a keyboard accelerator for a stored procedure

  1. [ツール] メニューの [オプション] をクリックします。On the Tools menu, click Options.

  2. [キーボード] ページの [ショートカット] 一覧で、まだ使用していないキーの組み合わせを選択します。On the Keyboard page, select an unused keyboard combination in the Shortcut list.

  3. [ストアド プロシージャ] ボックスにストアド プロシージャの名前を入力し、 [OK] をクリックします。In the Stored Procedure box, type the stored procedure name, and then click OK.

メニューに新しい項目を追加する方法Adding a New Item to the Menu

メニューに新しい項目を追加するにはTo add a new item to the menu

  1. [ツール] メニューの [オプション] をクリックします。On the Tools menu, click Options.

  2. [ユーザー設定] ダイアログ ボックスの [コマンド] タブで [新しいメニュー] をクリックします。In the Customize dialog box, on the Commands tab, click New Menu.

  3. [コマンド] ボックスで [新しいメニュー] をメニュー バーにドラッグし、新しいメニューを表示する場所にドロップします。On the Commands box, drag New Menu to the menu bar and drop it where you want the new menu to appear.

  4. メニューで [新しいメニュー] を右クリックし、 [名前] ボックスに新しいメニューの名前を入力します。On the menu, right-click New Menu, and in the Name box, type a name for the new menu.

  5. [ユーザー設定] ダイアログ ボックスで、 [ファイル] などのカテゴリを選択し、 [ファイルを開く] などのコマンドを選択します。In the Customize dialog box, select category such as File, and select a command such as Open File. コマンドを新しいメニューにドラッグします。Drag the command to the new menu. 新しいメニューをポイントするとメニューが展開されます。As you point to the new menu, the menu will expand. 展開されたメニューにコマンドをドロップします。Drop the command onto the expanded menu.

  6. [ユーザー設定] ダイアログ ボックスの [閉じる] をクリックします。In the Customize dialog box, click Close.

注意

関連する内容が SQL Server Management StudioSQL Server Management Studio で表示されている場合にしか使用できないコマンドもあります。Some commands are available only when SQL Server Management StudioSQL Server Management Studio is displaying relevant content. メニューに使用できるコマンドが存在しない場合、メニュー項目は使用できません。If no commands on the menu are available, the menu item will not be available.

参照See Also

SQL Server Management Studio の機能Features in SQL Server Management Studio