Visual Studio Code を使用して Transact-SQL スクリプトを作成して実行するUse Visual Studio Code to create and run Transact-SQL scripts

適用対象:Applies to: はいSQL ServerSQL Server (サポートされているすべてのバージョン) yesSQL ServerSQL Server (all supported versions) - Linux適用対象:Applies to: はいSQL ServerSQL Server (サポートされているすべてのバージョン) yesSQL ServerSQL Server (all supported versions) - Linux

この記事では、Visual Studio Code の mssql 拡張機能を使用して SQL Server データベースを開発する方法について説明します。This article shows how to use the mssql extension for Visual Studio Code to develop SQL Server databases. Visual Studio Code はクロスプラットフォームであるため、Linux、macOS、および Windows で mssql 拡張機能を使用できます。Because Visual Studio Code is cross-platform, you can use mssql extension on Linux, macOS, and Windows.

Visual Studio Code をインストールして起動するInstall and start Visual Studio Code

Visual Studio Code は、拡張機能をサポートするクロスプラットフォームのグラフィカル コード エディターです。Visual Studio Code is a cross-platform, graphical code editor that supports extensions.

  1. お使いのコンピューターに Visual Studio Code をダウンロードしてインストールします。Download and install Visual Studio Code on your machine.

  2. Visual Studio Code を起動します。Start Visual Studio Code.

    注意

    xrdp リモート デスクトップ セッションを介して接続しているときに Visual Studio Code が起動しない場合は、「XRDP を使用して接続したときに Ubuntu で VS Code が動作しない」を参照してください。If Visual Studio Code does not start when you are connected through an xrdp remote desktop session, see VS Code not working on Ubuntu when connected using XRDP.

mssql 拡張機能をインストールするInstall the mssql extension

Visual Studio Code の mssql 拡張機能を使用すると、SQL Server に接続し、Transact-SQL (T-SQL) を使用してクエリを実行し、その結果を表示できます。The mssql extension for Visual Studio Code lets you connect to a SQL Server, query with Transact-SQL (T-SQL), and view the results.

  1. Visual Studio Code で、 [表示] > [コマンド パレット] を選択する、Ctrl+Shift+P を押す、または F1 を押して [コマンド パレット] を開きます。In Visual Studio Code, select View > Command Palette, or press Ctrl+Shift+P, or press F1 to open the Command Palette.

  2. コマンド パレット で、ドロップダウンから [拡張機能: 拡張機能のインストール] を選択します。In the Command Palette, select Extensions: Install Extensions from the dropdown.

  3. [拡張機能] ウィンドウで、「mssql」と入力します。In the Extensions pane, type mssql.

  4. [SQL Server (mssql)] 拡張機能を選択し、[インストール] を選択します。Select the SQL Server (mssql) extension, and then select Install.

    mssql 拡張機能をインストールする

  5. インストールが完了したら、[再読み込み] を選択して拡張機能を有効にします。After the installation completes, select Reload to enable the extension.

SQL ファイルを作成するか開くCreate or open a SQL file

mssql 拡張機能では、言語モードが SQL に設定されている場合に、コード エディターで mssql コマンドと T-SQL IntelliSense を有効にできます。The mssql extension enables mssql commands and T-SQL IntelliSense in the code editor when the language mode is set to SQL.

  1. [ファイル] > [新しいファイル] を選択するか、Ctrl+N を押します。Select File > New File or press Ctrl+N. Visual Studio Code では、既定で新しいプレーン テキスト ファイルが開きます。Visual Studio Code opens a new Plain Text file by default.

  2. 下部のステータス バーの [プレーン テキスト] を選択するか、Ctrl+K > M を押し、[言語] ドロップダウンから [SQL] を選択します。Select Plain Text on the lower status bar, or press Ctrl+K > M, and select SQL from the languages dropdown.

    SQL 言語モード

    注意

    この拡張機能を初めて使用する場合は、サポートされている SQL Server ツールが拡張機能によってインストールされます。If this is the first time you have used the extension, the extension installs supporting SQL Server tools.

ファイル拡張子が .sql である既存のファイルを開くと、言語モードが自動的に SQL に設定されます。If you open an existing file that has a .sql file extension, the language mode is automatically set to SQL.

SQL Server への接続Connect to SQL Server

次の手順に従って接続プロファイルを作成し、SQL Server に接続します。Follow these steps to create a connection profile and connect to a SQL Server.

  1. Ctrl+Shift+P を押すか、F1 を押して [コマンド パレット] を開きます。Press Ctrl+Shift+P or F1 to open the Command Palette.

  2. sql」と入力して mssql コマンドを表示するか、「sqlcon」と入力してドロップダウンから [MS SQL: Connect] を選択します。Type sql to display the mssql commands, or type sqlcon, and then select MS SQL: Connect from the dropdown.

    mssql コマンド

    注意

    mssql コマンドを実行する前に、SQL ファイル (作成した空の SQL ファイルなど) がコード エディターでフォーカスされている必要があります。A SQL file, such as the empty SQL file you created, must have focus in the code editor before you can execute the mssql commands.

  3. [MS SQL: Manage Connection Profiles] コマンドを選択します。Select the MS SQL: Manage Connection Profiles command.

  4. 次に、[作成] を選択して、お使いの SQL Server 用の新しい接続プロファイルを作成します。Then select Create to create a new connection profile for your SQL Server.

  5. 指示に従って、新しい接続プロファイルの接続プロパティを指定します。Follow the prompts to specify the properties for the new connection profile. それぞれの値を指定した後、Enter キーを押して続行します。After specifying each value, press Enter to continue.

    Connection プロパティConnection property 説明Description
    サーバー名または ADO 接続文字列Server name or ADO connection string SQL Server インスタンス名を指定します。Specify the SQL Server instance name. ローカル コンピューター上の SQL Server インスタンスに接続するには、localhost を使用します。Use localhost to connect to a SQL Server instance on your local machine. リモート SQL Server に接続するには、ターゲットの SQL Server の名前か、その IP アドレスを入力します。To connect to a remote SQL Server, enter the name of the target SQL Server, or its IP address. SQL Server コンテナーに接続するには、コンテナーのホスト コンピューターの IP アドレスを指定します。To connect to a SQL Server container, specify the IP address of the container's host machine. ポートを指定する必要がある場合は、コンマを使用して名前と区別します。If you need to specify a port, use a comma to separate it from the name. たとえば、ポート 1401 でリッスンしているサーバーの場合は、「<servername or IP>,1401」と入力します。For example, for a server listening on port 1401, enter <servername or IP>,1401.

    別の方法として、お使いのデータベースの ADO 接続文字列をここに入力できます。As an alternative, you can enter the ADO connection string for your database here.
    データベース名 (省略可能)Database name (optional) 使用するデータベース。The database that you want to use. 既定のデータベースに接続するには、ここにデータベース名を指定しないでください。To connect to the default database, don't specify a database name here.
    認証の種類Authentication Type [統合] または [SQL ログイン] を選択します。Choose either Integrated or SQL Login.
    ユーザー名User name [SQL ログイン] を選択した場合は、サーバー上のデータベースにアクセスできるユーザーの名前を入力します。If you selected SQL Login, enter the name of a user with access to a database on the server.
    パスワードPassword 指定したユーザーのパスワードを入力します。Enter the password for the specified user.
    パスワードを保存するSave Password Enter キーを押すことで [はい] を選択して、パスワードを保存します。Press Enter to select Yes and save the password. [いいえ] を選択すると、接続プロファイルを使用するたびにパスワードの入力を求められます。Select No to be prompted for the password each time the connection profile is used.
    プロファイル名 (省略可能)Profile Name (optional) 接続プロファイルの名前を入力します (localhost プロファイル など)。Type a name for the connection profile, such as localhost profile.

    すべての値を入力して Enter キーを押すと、Visual Studio Code によって接続プロファイルが作成され、SQL Server に接続します。After you enter all values and select Enter, Visual Studio Code creates the connection profile and connects to the SQL Server.

    ヒント

    接続に失敗した場合は、Visual Studio Code の [出力] パネルに表示されるエラー メッセージから問題を診断してください。If the connection fails, try to diagnose the problem from the error message in the Output panel in Visual Studio Code. [出力] パネルを開くには、[表示] > [出力] を選択します。To open the Output panel, select View > Output. 接続のトラブルシューティングに関する推奨事項も確認してください。Also review the connection troubleshooting recommendations.

  6. 下部のステータス バーで、接続を確認します。Verify your connection in the lower status bar.

    [接続状態]

前の手順の代わりに、ユーザー設定ファイル (settings.json) 内に接続プロファイルを作成して編集することもできます。As an alternative to the previous steps, you can also create and edit connection profiles in the User Settings file (settings.json). この設定ファイルを開くには、 [ファイル] > [ユーザー設定] > [設定] を選択します。To open the settings file, select File > Preferences > Settings. 詳細については、接続プロファイルの管理に関する記事を参照してください。For more information, see Manage connection profiles.

SQL データベースを作成するCreate a SQL database

  1. 先ほど開始した新しい SQL ファイル内で、「sql」と入力して、編集可能なコード スニペットの一覧を表示します。In the new SQL file that you started earlier, type sql to display a list of editable code snippets.

    SQL スニペット

  2. [sqlCreateDatabase] を選択します。Select sqlCreateDatabase.

  3. スニペットに「TutorialDB」と入力して、'DatabaseName' を置き換えます。In the snippet, type TutorialDB to replace 'DatabaseName':

    -- Create a new database called 'TutorialDB'
    -- Connect to the 'master' database to run this snippet
    USE master
    GO
    IF NOT EXISTS (
       SELECT name
       FROM sys.databases
       WHERE name = N'TutorialDB'
    )
    CREATE DATABASE [TutorialDB]
    GO
    
  4. Ctrl+Shift+E を押して Transact-SQL コマンドを実行します。Press Ctrl+Shift+E to execute the Transact-SQL commands. クエリ ウィンドウで結果を確認します。View the results in the query window.

    データベースのメッセージを作成する

    ヒント

    mssql コマンドのショートカットキーをカスタマイズできます。You can customize the shortcut keys for the mssql commands. ショートカットのカスタマイズ」を参照してください。See Customize shortcuts.

テーブルを作成するCreate a table

  1. コード エディター ウィンドウの内容を削除します。Delete the contents of the code editor window.

  2. Ctrl+Shift+P を押すか、F1 を押して [コマンド パレット] を開きます。Press Ctrl+Shift+P or F1 to open the Command Palette.

  3. sql」と入力して mssql コマンドを表示するか、「sqluse」と入力して [MS SQL: Use Database] コマンドを選択します。Type sql to display the mssql commands, or type sqluse, and then select the MS SQL: Use Database command.

  4. 新しい TutorialDB データベースを選択します。Select the new TutorialDB database.

    データベースを使用する

  5. コード エディターで、「sql」と入力してスニペットを表示し、[sqlCreateTable] を選択した後、Enter キーを押します。In the code editor, type sql to display the snippets, select sqlCreateTable, and then press Enter.

  6. スニペットに、テーブル名として「Employees」と入力します。In the snippet, type Employees for the table name.

  7. Tab キーを押して次のフィールドに移動し、スキーマ名として「dbo」と入力します。Press Tab to get to the next field, and then type dbo for the schema name.

  8. 列の定義を次の列に置き換えます。Replace the column definitions with the following columns:

    EmployeesId INT NOT NULL PRIMARY KEY,
    Name [NVARCHAR](50)  NOT NULL,
    Location [NVARCHAR](50)  NOT NULL
    
  9. Ctrl+Shift+E を押してテーブルを作成します。Press Ctrl+Shift+E to create the table.

挿入とクエリInsert and query

  1. 次のステートメントを追加して、Employees テーブルに 4 つの行を挿入します。Add the following statements to insert four rows into the Employees table.

    -- Insert rows into table 'Employees'
    INSERT INTO Employees
       ([EmployeesId],[Name],[Location])
    VALUES
       ( 1, N'Jared', N'Australia'),
       ( 2, N'Nikita', N'India'),
       ( 3, N'Tom', N'Germany'),
       ( 4, N'Jake', N'United States')
    GO
    -- Query the total count of employees
    SELECT COUNT(*) as EmployeeCount FROM dbo.Employees;
    -- Query all employee information
    SELECT e.EmployeesId, e.Name, e.Location
    FROM dbo.Employees as e
    GO
    

    入力している間に、T-SQL IntelliSense によってステートメントが完了します。While you type, T-SQL IntelliSense helps you to complete the statements:

    T-SQL IntelliSense

    ヒント

    mssql 拡張機能には、INSERT ステートメントと SELECT ステートメントを作成するために役立つコマンドもあります。The mssql extension also has commands to help create INSERT and SELECT statements. これらは、前の例では使用されていません。These were not used in the previous example.

  2. Ctrl+Shift+E を押してコマンドを実行します。Press Ctrl+Shift+E to execute the commands. 2 つの結果セットが [結果] ウィンドウに表示されます。The two result sets display in the Results window.

    結果

結果を表示して保存するView and save the result

  1. [表示] > [エディターのレイアウト] > [Flip Layout](レイアウトの入れ替え) を選択して、垂直または水平分割レイアウトに切り替えます。Select View > Editor Layout > Flip Layout to switch to a vertical or horizontal split layout.

  2. [結果] パネル見出しと [メッセージ] パネル見出しを選択して、これらのパネルを折りたたむか展開します。Select the Results and Messages panel headers to collapse and expand the panels.

    見出しを切り替える

    ヒント

    mssql 拡張機能の既定の動作をカスタマイズできます。You can customize the default behavior of the mssql extension. 拡張オプションのカスタマイズ」を参照してください。See Customize extension options.

  3. これらの結果にズームインするには、2 番目の結果グリッドの [最大化] グリッド アイコンを選択します。Select the maximize grid icon on the second result grid to zoom in to those results.

    グリッドを最大化する

    注意

    [最大化] アイコンは、T-SQL スクリプトで 2 つ以上の結果グリッドが生成される場合に表示されます。The maximize icon displays when your T-SQL script produces two or more result grids.

  4. グリッドを右クリックして、グリッドのコンテキスト メニューを開きます。Open the grid context menu by right-clicking on the grid.

    ショートカット メニュー

  5. [すべて選択] を選択します。Select Select All.

  6. グリッドのコンテキスト メニューをもう一度開き、[JSON として保存] を選択して、結果を .json ファイルに保存します。Open the grid context menu again and select Save as JSON to save the result to a .json file.

  7. JSON ファイルのファイル名を指定します。Specify a file name for the JSON file.

  8. JSON ファイルが 保存されたことを確認し、Visual Studio Code で開きます。Verify that the JSON file saves and opens in Visual Studio Code.

    JSON として保存する

SQL スクリプトを保存しておき、後で管理や大規模な開発プロジェクトのために実行する必要がある場合は、.sql 拡張子を付けてスクリプトを保存します。If you need to save and run SQL scripts later, for administration or a larger development project, save the scripts with a .sql extension.

次の手順Next steps

T-SQL を初めてお使いの場合は、「チュートリアル: Transact-SQL ステートメントの作成」と「Transact-SQL リファレンス (データベース エンジン)」 を参照してください。If you're new to T-SQL, see Tutorial: Write Transact-SQL statements and the Transact-SQL Reference (Database Engine).

mssql 拡張機能の使用または開発の貢献に関する詳細については、mssql 拡張機能プロジェクト Wiki を参照してください。For more information on using or contributing to the mssql extension, see the mssql extension project wiki.

Visual Studio Code の使用方法の詳細については、Visual Studio Code のドキュメントを参照してください。For more information on using Visual Studio Code, see the Visual Studio Code documentation.