Windows で Microsoft 監視エージェントを起動できない
この記事は、Windows がローカル コンピューターで Microsoft Monitoring Agent (Windows 用 Log Analytics エージェント) を起動しないシナリオのトラブルシューティングに役立ちます。 この問題が発生すると、"サービス固有のエラーで終了した Microsoft 監視エージェント サービスのアクセスが拒否されました" というエラー メッセージが表示されます。
前提条件
- プロセス モニター ツール
現象
サービス スナップイン (services.msc) を開いて Microsoft Monitoring Agent サービスを開始しようとすると、ダイアログ ボックスが表示され、次のエラー メッセージが表示されます。
Windows では、ローカル コンピューターで Microsoft 監視エージェントを起動できませんでした。 詳細については、「システム イベント ログ」を参照してください。 Microsoft 以外のサービスの場合は、サービス ベンダーに問い合わせて、サービス固有のエラー コード 5 を参照してください。
イベント ビューアー スナップイン (eventvwr.msc) では、対応するシステム イベント ログに "アクセスが拒否されました" というエラー エントリが表示されます。
Log Name: System
Source: Service Control Manager
Date: 8/19/2021 3:03:27 PM
Event ID: 7024
Task Category: None
Level: Error
Keywords: Classic
User: N/A
Computer: ContosoServer2k8R2
Description:
The Microsoft Monitoring Agent service terminated with service-specific error Access is denied.
原因
レジストリは、Microsoft Monitoring Agent から SecureStorageManager パラメーターへの読み取り/書き込みアクセスを拒否しています。 このシナリオを確認するには、"アクセスが拒否されました" というエラー メッセージが表示されたら、次の手順に従います。
プロセス モニターを開きます。
次の値を持つエントリを探します。
Column 値 プロセス名 HealthService.exe 操作 RegOpenKey Path HKLM\SYSTEM\CurrentControlSet\Services\HealthService\Parameters\SecureStorageManager 結果 アクセスが拒否されました 詳細 必要なアクセス: 読み取り/書き込み [スタート] を選択し、「regedit」と入力し、[レジストリ エディター] を選択します。
[レジストリ] エディターで、[表示] メニューを選択します。 [アドレス バー] の横にチェックマークがない場合は、そのメニュー項目を選択します。
アドレス バー (メニューの下とナビゲーション ウィンドウの上) で、既存のテキストを削除し、「 HKLM\SYSTEM\CurrentControlSet\Services\HealthService\Parameters\SecureStorageManager」と入力し、Enter キーを押します。
メニューの [アクセス許可の編集>] を選択します。
[ SecureStorageManager のアクセス許可 ] ダイアログ ボックスで、[ グループ名またはユーザー名 ] ボックスに SYSTEM と Administrators (<ComputerName>) のエントリがあることを確認します。 これらの各エントリについて、[GroupOrUserName> の<アクセス許可] ボックスの [フル コントロール] 行を調べて、[許可] 列が選択されているかどうかを確認します。
システム ユーザーまたは管理者グループに対してフル コントロールは明示的に許可されていませんか? その場合、誰かが既定のアクセス許可を変更しました。 この変更により、Microsoft Monitoring Agent には SecureStorageManager パラメーターにアクセスするためのアクセス許可がなくなりました。
次の条件に該当する場合は、既定のアクセス許可を変更できます。
サーバーが強化されます。
ユーザー、アプリケーション、またはスクリプトは、レジストリ内の読み取り/書き込みレベル未満に既定のアクセス許可を変更します。
ソリューション
システム ユーザーと管理者の SecureStorageManager パラメーターに完全な制御を復元します。 これを行うには、次の手順を実行します。
警告
レジストリ エディタや他の方法を使用してレジストリを変更する際、適切に変更しないと重大な問題を引き起こす可能性があります。 場合によっては、オペレーティング システムの再インストールが必要になります。 マイクロソフトは、このような問題の解決に関して、一切責任を負わないものとします。 レジストリの変更はユーザー自身の責任において行ってください。
(推奨) レジストリをバックアップします。
レジストリ エディターに戻るか、もう一度開きます。
アドレス バーで、 SecureStorageManager パラメーター (HKLM\SYSTEM\CurrentControlSet\Services\HealthService\Parameters\SecureStorageManager) のレジストリ パスを再入力し、Enter キーを押します。
[アクセス許可の編集] を>選択し、SYSTEM ユーザーと Administrators (ComputerName>) グループのフル コントロール (<許可) の既定のアクセス許可を再適用します。
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