Microsoft Dynamics 365 でメールボックスをテストして有効にすると、電子メール メッセージ エラーの送信中に不明なエラーが発生しました

この記事では、Microsoft Dynamics 365でメールボックスをテストして有効にしようとしたときに発生するエラーの解決策について説明します。

適用対象:Microsoft Dynamics 365
元の KB 番号: 4092733

現象

Microsoft Dynamics 365でメールボックスをテストして有効にしようとすると、次のエラーが表示されます。

"メールボックスがDynamics 365に接続されました" というメール メッセージの送信中に不明なエラーが発生しました。 メールボックス メールボックス <名> が同期されませんでした。 関連付けられている電子メール サーバー プロファイル <のプロファイル名> の所有者に通知されました。

[詳細] セクションを選択すると、次のテキストなどの詳細が表示される場合もあります。

"エラー: System.Net.Mail.SmtpException: 構文エラー、コマンドが認識されません。 サーバーの応答は次のとおりです。
at System.Net.Mail.SmtpConnection.ConnectAndHandshakeAsyncResult.End(IAsyncResult result)
at System.Net.Mail.SmtpTransport.EndGetConnection(IAsyncResult result)
at System.Net.Mail.SmtpClient.ConnectCallback(IAsyncResult result)"

原因

このエラーは、電子メール サーバー プロファイルの [詳細設定] セクション内の [送信ポート] の値が正しくない場合に発生する可能性があります。

解決方法

この問題を解決するには、次の手順を実行します。

  1. [設定] に移動し、[構成] をEmailし、[サーバー プロファイルのEmail] を選択します。

  2. このエラーを満たすメールボックスで使用されるEmail サーバー プロファイルを開きます。

    注:

    エラー メッセージ内でEmail サーバー プロファイルの名前を選択することもできます。 ハイパーリンクとして表示され、正しいEmailサーバー プロファイル レコードが開きます。

  3. [詳細設定] を選択します。

  4. [送信ポート] の値を修正し、[保存] を選択します

    注:

    SMTP サービスに接続するときに使用する正しいポートについては、メール プロバイダーのドキュメントを参照してください。 Gmail の場合、ポートは 587 です。

  5. [ メールボックス ] を選択し、エラーを受け取ったメールボックスを選択します。

  6. [ テスト & メールボックスを有効にする] ボタンを選択 します。

  7. テストが完了したら、メールボックス レコードを開き、結果が [成功] として表示されない場合は、[ アラート ] セクションを表示します。