Windows 11の再起動後に USB スキャナーからドキュメントをスキャンできない

この記事では、再起動されたWindows 11デバイスに接続する USB スキャナーからドキュメントをスキャンできない場合の問題について説明します。

現象

USB ケーブルを介してWindows 11 デバイスに接続するスキャナーがあるシナリオを検討してください。 スキャナーをオフにしてプラグを外し、Windows 11再起動した後、スキャナーを再接続してオンにしました。

このシナリオでは、スキャナーからドキュメントをスキャンしようとすると、次のエラーが原因でスキャンできません。

このデバイスを使用するには、WIA ドライバーが必要です。 インストール CD または製造元の Web サイトからインストールし、もう一度お試しください。

デバイスでこの問題が発生しているかどうかを確認するには、C:\Windows\debug\WIA\wiatrace.log パスの Windows Image Acquisition (WIA) サービス ログ ファイル (wiatrace.log) を参照してください。

この問題が発生した場合は、次の例のようなエラー メッセージが WIA サービス ログに表示されます。

[wiaservc.dll]エラー: USDWrapper::LoadDriver, (YourScannerName) のドライバーを読み込もうとするエラーが発生しました。エラー (0x80070057)

[wiaservc.dll]エラー: DeviceListManager::P rocessDeviceArrival、デバイスのドライバー (YourScannerName) の読み込みに失敗しました (hr = 0x80070057)

原因

この問題は、USB スキャナーを切断したときに、Windows 11の WIA サービスが再起動後にデバイス識別子情報を更新しない場合に発生する可能性があります。 これは、WIA サービスの既知の問題です。

回避策

この問題を解決するには、次の手順に従って WIA サービスを再起動します。

  1. Windows ターミナル、PowerShell、またはコマンド プロンプトを管理者として開きます。

  2. コマンドを sc.exe stop StiSvc 入力し、 Enter キーを選択して WIA サービスを停止します。

    WIA サービス コマンドの停止。

  3. コマンドを sc.exe start StiSvc 入力し、 Enter キーを選択して WIA サービスを開始します。 サービスの再起動が完了すると、WIA ドライバーは USB スキャナーからドキュメントを取得できるようになります。

    WIA サービス コマンドを開始します。

  4. ドキュメントをスキャンできるかどうかを確認します。