XCode プロジェクトのインポートImport an XCode Project

Microsoft Visual C++ for Cross-Platform Mobile Development には、XCode プロジェクトを Visual Studio に移動して、クロスプラットフォーム ライブラリを作成し、他のプロジェクトとコードを共有するためのサポートが含まれています。Microsoft Visual C++ for Cross-Platform Mobile Development includes support for moving your XCode projects into Visual Studio, where you can create cross-platform libraries and share code with other projects. [XCode からインポート] ウィザードを使うと、プロジェクトをインポートするプロセスと、C++ コードを分割して XCode ターゲットに取り込み、スタティック ライブラリまたは共有コード プロジェクトとして利用するプロセスが簡略化されます。The Import from XCode wizard simplifies the process of importing projects and splitting out the C++ code in your XCode targets for use as a static library or shared code project. iOS 固有のコードを Visual Studio で管理しながらも、XCode を使ってストーリーボードとビルドを行うことができます。You can manage your iOS-specific code in Visual Studio and still use XCode to do storyboards and builds. Visual Studio と XCode の間でコードを双方向に簡単に移動する方法については、「Move Changes Between XCode and Visual Studio (XCode と Visual Studio 間の変更の移動)」を参照してください。For information on how to easily move code back and forth between Visual Studio and XCode, see Move Changes Between XCode and Visual Studio.

[XCode からインポート] ウィザードの使用方法Using the Import From XCode wizard

このトピックでは、XCode プロジェクトを Visual Studio に移動して、コードの共有とクロスプラットフォーム ソリューションを活用する方法について説明します。This topic shows you how to move an XCode project into Visual Studio to take advantage of code sharing and cross-platform solutions. 前提条件として、プロジェクトをインポート、エクスポート、ビルドできるように Mac を Visual Studio にペアリングする必要があります。As a prerequisite, you must pair your Mac to Visual Studio to be able to import, export, and build your project. ペアリングを設定する手順については、「iOS を使用してビルドするためのツールのインストールおよび構成」を参照してください。For instructions on how to set up pairing, see Install And Configure Tools to Build using iOS. また、[XCode からインポート] ウィザードで使うために、XCode プロジェクトをネットワーク経由で共有するか、Visual Studio コンピューターに移動する必要があります。You must also share your XCode project over the network or move it to your Visual Studio computer to use the Import from XCode wizard.

XCode からのインポートImport from XCode

  1. [ファイル] メニューで、[新規作成][インポート][XCode からインポートする] の順に選択します。On the File menu, choose New, Import, Import from XCode. これにより、[XCode からインポート] ウィザードが開始されてダイアログが表示されます。This starts the Import from XCode wizard dialog.

    インポートする XCode ターゲット プロジェクトを選択Choose the XCode target project to import

  2. [プロジェクトを選択] ウィンドウで、[参照] ボタンを選択して XCode の .pbxproj ファイルを選びます。In the Choose a project pane, choose the Browse button to select an XCode .pbxproj file. [XCode プロジェクト ファイルの選択] ダイアログでプロジェクト ファイルに移動し、[開く] を選択します。Navigate to the project file in the Select XCode project file dialog, and then choose Open.

    [XCode プロジェクト ファイルの選択] ダイアログでプロジェクト ファイルを選択Select a project file in the Select Xcode project file dialog

    [XCode からインポート] ウィザードで、[次へ] を選択します。In the Import from XCode wizard, choose Next.

  3. [宛先ターゲット] ウィンドウで、Visual Studio プロジェクトにインポートする XCode プロジェクトからターゲットを選択します。In the Destination targets pane, choose the targets from the XCode project to import into Visual Studio projects. XCode ターゲットは、Visual Studio のプロジェクトに似ています。ほとんどのターゲットは、バイナリを生成するコードとリソースのコレクションです。XCode targets are similar to Visual Studio projects; most are a collection of code and resources that produce a binary. [XCode からインポート] ウィザードで宛先ターゲットとしてインポートできるのは、スタティック ライブラリではなく、バイナリを生成するターゲットだけです。The Import from XCode wizard only allows import of targets that produce a binary, but not a static library, as destination targets. XCode スタティック ライブラリのターゲットは、次のステップで操作します。XCode static library targets are the subject of the next step.

    [XCode からインポート] ウィザードの [宛先ターゲット] ウィンドウImport from XCode wizard Destination Targets pane

    [インポートするターゲット] で選択されている各ターゲットについて、ウィザードは、別個のスタティック ライブラリ プロジェクトに分割できる C++ コード ファイルを自動的に検出し、[C++ プロジェクト項目] セクションに置きます。For each target selected in Targets to import, the wizard automatically detects C++ code files that can be split into a separate static library project, and puts them in the C++ project items section. その他のコードおよびリソースは、[XCode プロジェクト項目] セクションに残ります。Other code and resources are left in the XCode project items section. これらの項目は、ウィザードによるインポート処理が完了すると、Visual Studio 内の別個のスタティック ライブラリおよびアプリケーション プロジェクトになります。These become separate static library and application projects in Visual Studio when the wizard completes the import process. 既定では、単体テストおよびフレームワークのターゲットは、ウィザードによって別個のプロジェクトには分割されません。By default, unit test and framework targets are not split into separate projects by the wizard.

    各プロジェクトに含めるファイルを変更するには、上矢印と下矢印のボタンを使います。To change which files are in each project, use the up and down buttons. 各プロジェクト内のファイルを適切に設定できたら、[次へ] を選択して、先へ進みます。When you are satisfied with the files in each project, choose Next to continue.

  4. [ライブラリ ターゲット] ウィンドウで、XCode プロジェクトから Visual Studio プロジェクトにインポートするスタティック ライブラリ ターゲットを選択します。In the Library targets pane, choose which static library targets from the XCode project to import into Visual Studio projects. このウィンドウでは、共有コード プロジェクトに配置するファイルと、スタティック ライブラリ プロジェクトに配置するファイルを選択することができます。In this pane, you can choose which files are placed in a Shared Code project, and which are placed in a static library project. [インポートするターゲット] リストに含まれる各ターゲットについて、[共有コード プロジェクト項目][スタティック ライブラリ プロジェクト項目] に配置するファイルを、上矢印と下矢印のボタンを使って制御できます。In each of targets in the Targets to import list, you can control which files are placed in the Shared Code project items and the Static Library project items by using the up and down buttons.

    [XCode からインポート] の [ライブラリ ターゲット] ウィンドウImport from XCode Library Targets pane

    共有コード プロジェクトは、Visual Studio のプロジェクトとの間でソース コード ファイルのセットを共有する 1 つの方法です。A Shared Code project is a way of sharing a set of source code files between projects in Visual Studio. コードは、それ専用のプロジェクトとしてではなく、コードが含まれているプロジェクトの一部としてビルドされます。The code is built as part of the project that includes it, not as a project of its own. 共有コードを含むプロジェクトはさまざまなアーキテクチャと構成を対象にしている場合があるため、これは、さまざまな種類のプラットフォーム向けにビルドするコードが含まれた 1 つのプロジェクトを提供するための最適な方法です。Because the projects that include the shared code may have different architectures and configurations, this is the best way to provide a single project that contains code that may be built for many kinds of platforms.

    各プロジェクト内のファイルを適切に設定できたら、[次へ] を選択して、先へ進みます。When you are satisfied with the files in each project, choose Next to continue.

  5. [グローバル プロパティ] ウィンドウは、Visual Studio 内のすべての iOS プロジェクトに対してフレームワークの検索パスとインクルード ヘッダーの検索パスを設定するために使用できます。The Global Properties pane can be used to set a framework search path and an include header search path for all iOS projects in Visual Studio. Visual Studio では、ソース コードの参照と IntelliSense のためにこれらのパスを使います。Visual Studio uses these paths for source code browsing and for IntelliSense. これらのグローバル パスは、ヘッダーとフレームワークの共通のセットを使う iOS プロジェクトを作成するときに役立ちます。These global paths are useful when you create iOS projects that use a common set of headers and frameworks.

    [XCode からインポート] の [グローバル プロパティ] ウィンドウImport from XCode Global Properties pane

    これらのグローバルのパスは、Visual Studio の [オプション] ダイアログで設定することもできます。These global paths can also be set in Visual Studio in the Options dialog. それには、[ツール] メニューで、[オプション] を選択します。To find them, on the Tools menu, select Options. [オプション] ダイアログで、[クロス プラットフォーム][C++][iOS][グローバル プロパティ] の順に展開します。In the Options dialog, expand Cross Platform, C++, iOS, Global Properties.

    [次へ] を選択して続行します。Choose Next to continue.

  6. [フレームワーク] ウィンドウでは、プロジェクトに対して参照と IntelliSense のために Visual Studio で使用されるパスを構成します。The Frameworks pane is used to configure the paths used by Visual Studio for browsing and IntelliSense for your project. これらのパスは、XCode プロジェクトによって参照される各フレームワークに対して、Visual Studio からアクセスできる必要があります。The paths must be accessible to Visual Studio for each framework referenced by your XCode project. ウィザードは、XCode プロジェクトのフレームワーク参照を確認し、Visual Studio からフレームワークを検索できるかどうかを表示します。The wizard checks the framework references in the XCode projects and displays whether Visual Studio can find the framework. 既にグローバル プロパティに設定してあるすべてのパスは、Visual Studio から検出できる必要があります。Any path you have already set up in the Global Properties should be discovered by Visual Studio. 例外は、フレームワーク リストに表示されます。The exceptions are listed in the Frameworks list. リストで X が付いているフレームワークごとに、Visual Studio がフレームワークを検索できるように、PC からアクセス可能なパスを指定してください。For each framework listed with an X, provide a PC accessible path for Visual Studio to find the framework. 参照ボタン [...] を使うと、[フォルダーの選択] ダイアログを使ってパスを検索できます。You can use the browse button [...] to use a Select Folder dialog to find the path. フレームワークのパスは、ローカルのコピー、ネットワークでアクセスできる Mac 上の共有のいずれかを指定できます。The framework path can be either to a local copy, or to a network-accessible share on your Mac.

    [XCode からインポート] の [フレームワーク] ウィンドウImport from XCode Frameworks pane

    [次へ] を選択して続行します。Choose Next to continue.

  7. [プロジェクト設定] ウィンドウでは、ウィザードで作成した各プロジェクトのフレームワークとインクルード ヘッダー ファイルの検索パス設定を変更できます。The Project Settings pane allows you to change the framework and include header search path settings for each project the wizard creates. このウィンドウを使うと、グローバル設定とは異なるプロジェクト固有のパスを設定できます。Use this pane to set project-specific paths that differ from the global settings.

    特定のプロジェクトのパスを設定するには、[宛先のプロジェクト] ドロップダウンでプロジェクト ファイルを選択した後、[フレームワークの検索パス] および [インクルードヘッダーの検索パス] コントロールに値を設定します。To set a path for a specific project, In the Destination project drop-down, select the project file, then set the values in the Framework Search Path and Include Header Search Path controls. 各コントロールの横にある参照ボタン [...] を使うと、[フォルダーの選択] ダイアログを使ってパスを検索できます。You can use the browse button [...] next to each control to use a Select Folder dialog to find the path.

    [XCode からインポート] の [プロジェクト] ウィンドウImport from XCode Projects pane

    この PC とペアリングされているリモート Mac がない場合は、[リモート コンピューターを構成] リンクが表示されます。If no remote Mac has been paired with this PC in Visual Studio, the Configure a Remote Machine link is shown. ペアリングを設定する手順については、「iOS を使用してビルドするためのツールのインストールおよび構成」を参照してください。For instructions on how to set up pairing, see Install And Configure Tools to Build using iOS.

    ウィザードの設定を使用して XCode プロジェクトをインポートするには、[インポート] を選択します。To import the XCode project by using the wizard settings, choose Import.

    [XCode からインポート] ウィザードによって、選択した XCode プロジェクト ターゲットに対応するプロジェクトが Visual Studio で作成されます。The Import from XCode wizard creates projects in Visual Studio that correspond to the selected XCode project targets. 他の C++ プロジェクトと共有できるコードは、別個の共有コード プロジェクトとスタティック ライブラリ プロジェクトに分割されます。The code that can be shared with other C++ projects is split into separate Shared Code and static library projects. 残りのコードは、iOS ライブラリ プロジェクトとアプリケーション プロジェクトに配置され、Visual Studio からリモートでビルドできます。The remaining code is placed in iOS library and application projects that can be built remotely by Visual Studio. Visual Studio と XCode の間でコードを移動する方法の詳細については、「XCode と Visual Studio 間の変更の同期」をご覧ください。For more information about moving code between Visual Studio and XCode, see Sync Changes Between XCode and Visual Studio.