Visual Studio ソリューションに含まれていないアプリのデバッグ (C++、 C#、Visual Basic、 F#)Debug an app that isn't part of a Visual Studio solution (C++, C#, Visual Basic, F#)

アプリをデバッグすることがあります (.exeファイル)、Visual Studio ソリューションの一部ではないです。You may want to debug an app (.exe file) that isn't part of a Visual Studio solution. 誰かが、Visual Studio の外部でアプリを作成した可能性があります。 または別の場所からアプリを取得します。You or someone else may have created the app outside of Visual Studio, or you got the app from somewhere else.

Visual Studio に存在しないアプリをデバッグする通常の方法が、Visual Studio の外部からアプリを起動しを使用して接続し、プロセスにアタッチVisual Studio デバッガーでします。The usual way to debug an app that doesn't exist in Visual Studio is to start the app outside of Visual Studio, and then attach to it using Attach to Process in the Visual Studio debugger. 詳細については、次を参照してください。実行中のプロセスにアタッチします。For more information, see Attach to running processes.

アプリにアタッチするには、数秒かかる手動の手順が必要です。Attaching to an app requires manual steps that take a few seconds. この遅延のためのアタッチ、起動時の問題をデバッグすることはできませんまたはアプリ ユーザーを待ちませんを入力し、すぐに終了します。Because of this delay, attaching won't help debug a startup issue, or an app that doesn't wait for user input and finishes quickly.

このような場合は、アプリでは、Visual Studio の EXE プロジェクトを作成または既存のインポートC#、Visual Basic、またはC++ソリューション。In these situations, you can create a Visual Studio EXE project for the app, or import it into an existing C#, Visual Basic, or C++ solution. EXE プロジェクトをサポートしていないプログラミング言語もあります。Not all programming languages support EXE projects.

Important

Visual Studio に組み込まれていないアプリのデバッグ機能は、アプリにアタッチするか、Visual Studio ソリューションに追加するかどうか、制限されます。Debugging features for an app that wasn't built in Visual Studio are limited, whether you attach to the app or add it to a Visual Studio solution.

ソース コードがある場合は、最良のアプローチは、Visual Studio プロジェクトにコードをインポートするのには。If you have the source code, the best approach is to import the code into a Visual Studio project. 次に、アプリのデバッグ ビルドを実行します。Then, run a debug build of the app.

かどうか、ソース コードがないし、アプリが見つからないデバッグ情報互換の形式で使用可能なデバッグ機能はごくわずかです。If you don't have the source code, and the app doesn't have debug information in a compatible format, available debugging features are very few.

既存のアプリの新しい EXE プロジェクトを作成するにはTo create a new EXE project for an existing app

  1. Visual Studio で、次のように選択します。ファイル > オープン > プロジェクトします。In Visual Studio, select File > Open > Project.

  2. プロジェクトを開くダイアログ ボックスで、すべてのプロジェクト ファイル選択されていない場合、ドロップダウンの横に、ファイル名します。In the Open Project dialog box, select All Project Files, if not already selected, in the dropdown next to File name.

  3. 移動し、 .exeファイル、それを選択し、オープンします。Navigate to the .exe file, select it, and select Open.

    新しい一時的な Visual Studio ソリューションにファイルが表示されます。The file appears in a new, temporary Visual Studio solution.

  4. このような実行コマンドを選択して、アプリのデバッグを開始デバッグの開始から、デバッグメニュー。Start debugging the app by selecting an execution command, like Start Debugging, from the Debug menu.

既存の Visual Studio ソリューションにアプリをインポートするにはTo import an app into an existing Visual Studio solution

  1. C++、 C#、Visual Studio で開いている Visual Basic ソリューションを選択またはファイル > 追加 > 既存のプロジェクトします。With a C++, C#, or Visual Basic solution open in Visual Studio, select File > Add > Existing Project.

  2. プロジェクトを開くダイアログ ボックスで、すべてのプロジェクト ファイル選択されていない場合、ドロップダウンの横に、ファイル名します。In the Open Project dialog box, select All Project Files, if not already selected, in the dropdown next to File name.

  3. 移動し、 .exeファイル、それを選択し、オープンします。Navigate to the .exe file, select it, and select Open.

    新しいプロジェクトを現在のソリューションとして、ファイルが表示されます。The file appears as a new project under the current solution.

  4. 新しいファイルが選択状態などの実行コマンドを選択して、アプリのデバッグを開始デバッグの開始から、デバッグメニュー。With the new file selected, start debugging the app by selecting an execution command, like Start Debugging, from the Debug menu.

関連項目See also