方法: Visual Studio で DLL プロジェクトからデバッグ (C#、 C++、Visual Basic、 F#)How to: Debug from a DLL project in Visual Studio (C#, C++, Visual Basic, F#)

DLL プロジェクトをデバッグする方法の 1 つでは、DLL プロジェクトのプロパティで呼び出し元のアプリを指定します。One way to debug a DLL project is to specify the calling app in the DLL project properties. 自体、DLL プロジェクトからデバッグを開始することができます。Then you can start debugging from the DLL project itself. このメソッドを使用するには、アプリは、構成するものと同じ場所に同じ DLL を呼び出す必要があります。For this method to work, the app must call the same DLL in the same location as the one you configure. 場合は、アプリを検索してさまざまなバージョンの DLL を読み込みます、そのバージョンには、ブレークポイントが含まれません。If the app finds and loads a different version of the DLL, that version won't contain your breakpoints. その他の Dll のデバッグの方法では、次を参照してください。 DLL のデバッグ プロジェクトします。For other methods of debugging DLLs, see Debugging DLL projects.

マネージ DLL を呼び出すネイティブ アプリ、管理対象アプリが、ネイティブ DLL を呼び出す、または、DLL と呼び出し元のアプリの両方をデバッグできます。If your managed app calls a native DLL, or your native app calls a managed DLL, you can debug both the DLL and the calling app. 詳細については、「方法 :混合モードでデバッグするFor more information, see How to: Debug in mixed mode.

ネイティブおよびマネージ DLL プロジェクトでは、呼び出し元のアプリを指定するためのさまざまな設定があります。Native and managed DLL projects have different settings to specify calling apps.

呼び出し元のアプリをネイティブ DLL プロジェクトの指定します。Specify a calling app in a native DLL project

  1. C++ DLL プロジェクトを選択ソリューション エクスプ ローラーします。Select the C++ DLL project in Solution Explorer. 選択、プロパティアイコン、キーを押してAlt+」と入力、または右クリックし、選択プロパティします。Select the Properties icon, press Alt+Enter, or right-click and choose Properties.

  2. <プロジェクト > プロパティ ページ ダイアログ ボックスに、必ず、構成にウィンドウの上部にあるフィールドが設定されているデバッグIn the <Project> Property Pages dialog box, make sure the Configuration field at the top of the window is set to Debug.

  3. 選択構成プロパティ > デバッグします。Select Configuration Properties > Debugging.

  4. 起動するデバッガー一覧で、いずれかを選択ローカル Windows デバッガーまたはリモート Windows デバッガーします。In the Debugger to launch list, choose either Local Windows Debugger or Remote Windows Debugger.

  5. コマンドまたはリモート コマンドボックスに、呼び出し元のアプリのファイル名と完全修飾パスなどの追加、 .exeファイル。In the Command or Remote Command box, add the fully qualified path and filename of the calling app, such as an .exe file.

    [プロパティ] ウィンドウをデバッグDebug Properties window

  6. [コマンド引数] ボックスに、任意の必要なプログラム引数を追加します。Add any necessary program arguments to the Command Arguments box.

  7. [OK] を選択します。Select OK.

マネージ DLL プロジェクトで呼び出し元のアプリを指定します。Specify a calling app in a managed DLL project

  1. C# または Visual Basic DLL プロジェクトを選択ソリューション エクスプ ローラーします。Select the C# or Visual Basic DLL project in Solution Explorer. 選択、プロパティアイコン、キーを押してAlt+」と入力、または右クリックし、選択プロパティします。Select the Properties icon, press Alt+Enter, or right-click and choose Properties.

  2. ウィンドウの上部にある [構成] フィールドが [デバッグ] に設定されていることを確認します。Make sure that the Configuration field at the top of the window is set to Debug.

  3. 開始アクション:Under Start action:

    • .NET Framework dll の場合、次のように選択します。外部プログラムの開始、呼び出し元のアプリの名前と完全修飾パスを追加します。For .NET Framework DLLs, select Start external program, and add the fully qualified path and name of the calling app.

    • または、選択URL でブラウザーを開始しローカル ASP.NET アプリの URL を入力します。Or, select Start browser with URL and fill in the URL of a local ASP.NET app.

    • .NET Core の Dll をデバッグプロパティ ページが異なる。For .NET Core DLLs, the Debug Properties page is different. 選択実行可能ファイルから、起動ドロップダウンで、し、呼び出し元のアプリでの名前と完全修飾パスを追加、実行可能ファイルフィールド。Select Executable from the Launch dropdown, and then add the fully qualified path and name of the calling app in the Executable field.

  4. 必要なコマンドライン引数を追加、コマンドライン引数またはアプリケーション引数フィールド。Add any necessary command-line arguments in the Command line arguments or Application arguments field.

    C# のデバッグ プロパティ ウィンドウC# Debug Properties window

  5. 使用ファイル > 選択した項目の保存またはCtrl+S変更を保存します。Use File > Save Selected Items or Ctrl+S to save changes.

DLL プロジェクトからデバッグします。Debug from the DLL project

  1. DLL プロジェクトにブレークポイントを設定します。Set breakpoints in the DLL project.

  2. DLL プロジェクトを右クリックし スタートアップ プロジェクトとして設定します。Right-click the DLL project and choose Set as Startup Project.

  3. 確認、ソリューション構成にフィールドが設定されているデバッグMake sure the Solutions Configuration field is set to Debug. キーを押してF5、緑 をクリックして開始矢印または選択デバッグ > デバッグの開始Press F5, click the green Start arrow, or select Debug > Start Debugging.

デバッグしても、ブレークポイントがヒットしない場合、DLL を出力することを確認 (既定で、 <プロジェクト > \Debugフォルダー) は、呼び出し元のアプリを呼び出している場所です。If debugging does not hit your breakpoints, make sure that your DLL output (by default, the <project>\Debug folder) is the location that the calling app is calling.

関連項目See also