Remote DebuggingRemote Debugging

別のコンピューターに配置されている Visual Studio アプリケーションをデバッグすることができます。You can debug a Visual Studio application that has been deployed on a different computer. このデバッグを行うには、Visual Studio リモート デバッガーを使用します。To do so, you use the Visual Studio remote debugger.

リモート デバッグの詳細な手順については、次のトピックを参照してください。For in-depth instructions on remote debugging, see these topics.

シナリオScenario LinkLink
Azure App ServiceAzure App Service スナップショット デバッガーまたはAzure での ASP.NET のリモート デバッグSnapshot Debugger or Remote debug ASP.NET on Azure
Azure 仮想マシンAzure VM Azure での ASP.NET のリモート デバッグRemote debug ASP.NET on Azure
Azure Service FabricAzure Service Fabric Azure Service Fabric アプリケーションのデバッグDebug an Azure Service Fabric application
ASP.NETASP.NET ASP.NET Core のリモート デバッグまたは ASP.NET のリモート デバッグRemote debug ASP.NET Core or Remote Debug ASP.NET
C# または Visual BasicC# or Visual Basic C# プロジェクトまたは Visual Basic プロジェクトのリモート デバッグRemote debug a C# or Visual Basic project
C++C++ C++ Project プロジェクトのリモート デバッグRemote debug a C++ project
ユニバーサル Windows アプリ (UWP)Universal Windows Apps (UWP) リモート コンピューターでの UWP アプリの実行またはインストールされているアプリ パッケージのデバッグRun UWP apps on a remote machine or Debug an installed app package

リモート デバッガーをダウンロードしてインストールするだけで、シナリオに関する追加の手順が不要な場合は、この記事の手順に従ってください。If you just want to download and install the remote debugger and don't need any additional instructions for your scenario, follow the steps in this article.

リモート ツールのダウンロードおよびインストールDownload and Install the remote tools

Visual Studio マシンではなく、デバッグするリモート デバイスまたはサーバーで、次の表のリンクから適切なバージョンのリモート ツールをダウンロードしてインストールします。On the remote device or server that you want to debug on, rather than the Visual Studio machine, download and install the correct version of the remote tools from the links in the following table.

  • お使いのバージョンの Visual Studio 用の最新のリモート ツールをダウンロードします。Download the most recent remote tools for your version of Visual Studio. 最新バージョンのリモート ツールは、以前のバージョンの Visual Studio と互換性がありますが、以前のバージョンのリモート ツールは、以降のバージョンの Visual Studio と互換性がありませんThe latest remote tools version is compatible with earlier Visual Studio versions, but earlier remote tools versions aren't compatible with later Visual Studio versions. (たとえば、Visual Studio 2017 を使用している場合、Visual Studio 2017 用のリモート ツールの最新の更新プログラムをダウンロードします。(For example, if you are using Visual Studio 2017, download the latest update of the remote tools for Visual Studio 2017. このシナリオでは、Visual Studio 2019 用のリモート ツールをダウンロードしないでください)。In this scenario, do not download the remote tools for Visual Studio 2019.)
  • インストール先のマシンと同じアーキテクチャを持つリモート ツールをダウンロードします。Download the remote tools with the same architecture as the machine you're installing them on. たとえば、64 ビットのオペレーティング システムを実行しているリモート コンピューターで 32 ビット アプリをデバッグする場合は、64 ビットのリモート ツールをインストールします。For example, if you want to debug a 32-bit app on a remote computer running a 64-bit operating system, install the 64-bit remote tools.
バージョンVersion LinkLink メモNotes
Visual Studio 2019Visual Studio 2019 リモート ツールRemote tools すべてのバージョンの Visual Studio 2019 と互換性があります。Compatible with all Visual Studio 2019 versions. デバイスのオペレーティング システム (x86、x64、または ARM64) に一致するバージョンをダウンロードします。Download the version matching your device operating system (x86, x64, or ARM64). Windows Server の場合、リモート ツールのダウンロードについては、ファイルのダウンロードのブロック解除に関するページを参照してください。On Windows Server, see Unblock the file download for help downloading the remote tools.
Visual Studio 2017Visual Studio 2017 リモート ツールRemote tools すべてのバージョンの Visual Studio 2017 と互換性があります。Compatible with all Visual Studio 2017 versions. デバイスのオペレーティング システム (x86、x64、または ARM64) に一致するバージョンをダウンロードします。Download the version matching your device operating system (x86, x64, or ARM64). Windows Server の場合、リモート ツールのダウンロードについては、ファイルのダウンロードのブロック解除に関するページを参照してください。On Windows Server, see Unblock the file download for help downloading the remote tools.
Visual Studio 2015Visual Studio 2015 リモート ツールRemote tools Visual Studio 2015 用のリモート ツールは My.VisualStudio.com で入手できます。Remote tools for Visual Studio 2015 are available from My.VisualStudio.com. メッセージが表示されたら、無料の Visual Studio Dev Essentials プログラムに参加するか、または Visual Studio サブスクリプション ID でサインインします。If prompted, join the free Visual Studio Dev Essentials program, or sign in with your Visual Studio subscription ID. Windows Server の場合、リモート ツールのダウンロードについては、ファイルのダウンロードのブロック解除に関するページを参照してください。On Windows Server, see Unblock the file download for help downloading the remote tools.
Visual Studio 2013Visual Studio 2013 リモート ツールRemote tools Visual Studio 2013 ドキュメントのダウンロード ページDownload page in Visual Studio 2013 documentation
Visual Studio 2012Visual Studio 2012 リモート ツールRemote tools Visual Studio 2012 ドキュメントのダウンロード ページDownload page in Visual Studio 2012 documentation
バージョンVersion LinkLink メモNotes
Visual Studio 2017Visual Studio 2017 リモート ツールRemote tools すべてのバージョンの Visual Studio 2017 と互換性があります。Compatible with all Visual Studio 2017 versions. デバイスのオペレーティング システム (x86、x64、または ARM64) に一致するバージョンをダウンロードします。Download the version matching your device operating system (x86, x64, or ARM64). Windows Server の場合、リモート ツールのダウンロードについては、ファイルのダウンロードのブロック解除に関するページを参照してください。On Windows Server, see Unblock the file download for help downloading the remote tools. 最新バージョンのリモート ツールについては、Visual Studio 2019 ドキュメントを開きます。For the most recent version of the remote tools, open the Visual Studio 2019 doc.
Visual Studio 2015Visual Studio 2015 リモート ツールRemote tools Visual Studio 2015 用のリモート ツールは My.VisualStudio.com で入手できます。Remote tools for Visual Studio 2015 are available from My.VisualStudio.com. メッセージが表示されたら、無料の Visual Studio Dev Essentials プログラムに参加するか、または Visual Studio サブスクリプション ID でサインインします。If prompted, join the free Visual Studio Dev Essentials program, or sign in with your Visual Studio subscription ID. Windows Server の場合、リモート ツールのダウンロードについては、ファイルのダウンロードのブロック解除に関するページを参照してください。On Windows Server, see Unblock the file download for help downloading the remote tools.
Visual Studio 2013Visual Studio 2013 リモート ツールRemote tools Visual Studio 2013 ドキュメントのダウンロード ページDownload page in Visual Studio 2013 documentation
Visual Studio 2012Visual Studio 2012 リモート ツールRemote tools Visual Studio 2012 ドキュメントのダウンロード ページDownload page in Visual Studio 2012 documentation

リモート デバッガーを実行するには、リモート ツールをインストールするのではなく、msvsmon.exe をリモート コンピューターにコピーします。You can run the remote debugger by copying msvsmon.exe to the remote computer, rather than installing the remote tools. ただし、リモート デバッガー構成ウィザード (rdbgwiz.exe) は、リモート ツールをインストールした場合にのみ使用できます。However, the Remote Debugger Configuration Wizard (rdbgwiz.exe) is available only when you install the remote tools. リモート デバッガーをサービスとして実行する場合は、構成にウィザードの使用が必要になることがあります。You may need to use the wizard for configuration if you want to run the remote debugger as a service. 詳細については、「(オプション) リモート デバッガーをサービスとして構成する」を参照してください。For more information, see (Optional) Configure the remote debugger as a service.

注意

  • ARM デバイスで Windows 10 アプリをデバッグするには、最新バージョンのリモート ツールで使用できる ARM64 を使用します。To debug Windows 10 apps on ARM devices, use ARM64, which is available with the latest version of the remote tools.
  • Windows RT デバイスで Windows 10 アプリをデバッグするには、ARM を使用します。これは、Visual Studio 2015 リモート ツールのダウンロードでのみ使用できます。To debug Windows 10 apps on Windows RT devices, use ARM, which is available only in the Visual Studio 2015 remote tools download.

要件Requirements

Supported Operating SystemsSupported Operating Systems

リモート コンピューターで次のいずれかのオペレーティング システムが実行されている必要があります。The remote computer must be running one of the following operating systems:

  • Windows 10 (Phone 以外)Windows 10 (not phone)

  • Windows 8 または 8.1 (Phone 以外)Windows 8 or 8.1 (not phone)

  • Windows 7 Service Pack 1Windows 7 Service Pack 1

  • Windows Server 2016Windows Server 2016

  • Windows Server 2012 または Windows Server 2012 R2Windows Server 2012 or Windows Server 2012 R2

  • Windows Server 2008 Service Pack 2、Windows Server 2008 R2 Service Pack 1Windows Server 2008 Service Pack 2, Windows Server 2008 R2 Service Pack 1

注意

Windows Phone をデバッグするには、USB 接続が必要です (リモート ツールは必要ありません)。Windows Phone requires a USB connection to debug (it does not require the remote tools).

サポートされているハードウェア構成Supported Hardware Configurations

  • 1.6 GHz 以上の高速プロセッサ1.6 GHz or faster processor

  • 1 GB の RAM (仮想マシン上で実行されている場合は 1.5 GB)1 GB of RAM (1.5 GB if running on a virtual machine)

  • 1 GB のハード ディスク空き容量1 GB of available hard disk space

  • 5400 RPM のハード ドライブ5400-RPM hard drive

  • 1024 x 768 以上のディスプレイ解像度の DirectX 9 対応ビデオ カードDirectX 9-capable video card running at 1024 x 768 or higher display resolution

ネットワーク構成Network configuration

リモート コンピューターと Visual Studio コンピューターは、ネットワーク、ワークグループ、またはホームグループを介して接続されているか、あるいはイーサネット ケーブルによって直接接続されている必要があります。The remote computer and the Visual Studio computer must be connected over a network, workgroup, or homegroup, or else connected directly through an Ethernet cable. プロキシ経由で接続された 2 台のコンピューター間のデバッグはサポートされていません。Debugging between two computers connected through a proxy is not supported. 待機時間の長い接続や低帯域幅の接続 (ダイヤルアップ インターネットなど)、または国をまたぐインターネット経由のデバッグは推奨されません。これらは、障害が発生するか、または過度に低速になる可能性があります。Debugging over a high latency or low bandwidth connection, such as dialup Internet, or over the Internet across countries is not recommended and may fail or be unacceptably slow.

(オプション) ファイル共有からリモート デバッガーを実行するには(Optional) To run the remote debugger from a file share

リモート デバッガー (msvsmon.exe) は、Visual Studio Community、Professional、または Enterprise が既にインストールされているコンピューターにあります。You can find the remote debugger (msvsmon.exe) on a computer with Visual Studio Community, Professional, or Enterprise already installed. 場合によっては、リモート デバッグをセットアップする最も簡単な方法は、ファイル共有からリモート デバッガー (msvsmon.exe) を実行することです。For some scenarios, the easiest way to set up remote debugging is to run the remote debugger (msvsmon.exe) from a file share. 使用に関する制限事項については、リモート デバッガーの [ヘルプ] ページ (リモート デバッガーの [ヘルプ] > [使用法] ) を参照してください。For usage limitations, see the remote debugger's Help page (Help > Usage in the remote debugger).

  1. お使いの Visual Studio のバージョンと一致するディレクトリで、の msvsmon.exe を見つけます。Find msvsmon.exe in the directory matching your version of Visual Studio:

    Program Files (x86)\Microsoft Visual Studio\2019\Enterprise\Common7\IDE\Remote Debugger\x86\msvsmon.exeProgram Files (x86)\Microsoft Visual Studio\2019\Enterprise\Common7\IDE\Remote Debugger\x86\msvsmon.exe

    Program Files (x86)\Microsoft Visual Studio\2019\Enterprise\Common7\IDE\Remote Debugger\x64\msvsmon.exeProgram Files (x86)\Microsoft Visual Studio\2019\Enterprise\Common7\IDE\Remote Debugger\x64\msvsmon.exe

    Program Files (x86)\Microsoft Visual Studio\2017\Enterprise\Common7\IDE\Remote Debugger\x86\msvsmon.exeProgram Files (x86)\Microsoft Visual Studio\2017\Enterprise\Common7\IDE\Remote Debugger\x86\msvsmon.exe

    Program Files (x86)\Microsoft Visual Studio\2017\Enterprise\Common7\IDE\Remote Debugger\x64\msvsmon.exeProgram Files (x86)\Microsoft Visual Studio\2017\Enterprise\Common7\IDE\Remote Debugger\x64\msvsmon.exe

  2. Visual Studio コンピューターでリモート デバッガー フォルダーを共有します。Share the Remote Debugger folder on the Visual Studio computer.

  3. リモート コンピューターで、共有フォルダーから msvsmon.exe を実行します。On the remote computer, run msvsmon.exe from the shared folder. セットアップの手順に従います。Follow the setup instructions.

ヒント

コマンド ライン インストールおよびコマンド ライン参照については、Visual Studio がインストールされているコンピューターのコマンド ラインで「msvsmon.exe /?」と入力して、msvsmon.exe のヘルプ ページを参照してください (または、リモート デバッガーで [ヘルプ] > [使用法] に移動)。For command line installation and command line reference, see the Help page for msvsmon.exe by typing msvsmon.exe /? in the command line on the computer with Visual Studio installed (or go to Help > Usage in the remote debugger).

リモート デバッガーのセットアップSet up the remote debugger

  1. リモート コンピューター上の [スタート] メニューで、 [リモート デバッガー] を見つけて起動します。On the remote computer, find and start the Remote Debugger from the Start menu.

    リモート コンピューターに対する管理アクセス許可がない場合は、 [リモート デバッガー] アプリを右クリックし、 [管理者として実行] を選択します。If you don't have administrative permissions on the remote computer, right-click the Remote Debugger app and select Run as administrator. それ以外の場合は、通常どおり開始します。Otherwise, just start it normally.

    管理者として実行されているプロセス、または別のユーザー アカウント (IIS など) で実行されているプロセスにアタッチする場合は、 [リモート デバッガー] アプリを右クリックし、 [管理者として実行] を選択します。If you are planning to attach to a process which is running as an administrator, or is running under a different user account (such as IIS), right-click the Remote Debugger app and select Run as administrator. 詳細については、「管理者としてリモート デバッガーを実行する」を参照してください。For more information, see Run the remote debugger as an administrator.

  2. リモート デバッガーを初めて (またはその構成を完了する前に) 開始すると、 [リモート デバッグの構成] ダイアログ ボックスが表示されます。The first time you start the remote debugger (or before you have configured it), the Remote Debugging Configuration dialog box appears.

    リモート デバッガーの構成Remote Debugger configuration

  3. Windows Web Services API がインストールされていない場合 (これは、Windows Server 2008 R2 でのみ発生します) は、 [インストール] ボタンを選択します。If the Windows Web Services API is not installed, which happens only on Windows Server 2008 R2, select the Install button.

  4. リモート ツールを使用するネットワークの種類を少なくとも 1 つ選択します。Select at least one network type you want to use the remote tools on. コンピューターがドメインを介して接続されている場合は、最初の項目を選択する必要があります。If the computers are connected through a domain, you must choose the first item. コンピューターがワークグループまたはホーム グループを介して接続されている場合は、必要に応じて、2 番目または 3 番目の項目を選択します。If the computers are connected through a workgroup or homegroup, choose the second or third item as appropriate.

  5. [リモート デバッグの構成] を選択してファイアウォールを構成し、リモート デバッガーを起動します。Select Configure remote debugging to configure the firewall and start the remote debugger.

  6. 構成が完了すると、 [リモート デバッガー] ウィンドウが表示されます。When configuration is complete, the Remote Debugger window appears.

    [リモート デバッガー] ウィンドウRemote Debugger window

    リモート デバッガーは接続を待機しています。The remote debugger is now waiting for a connection. 表示されているサーバー名とポート番号を使用して、Visual Studio でリモート接続構成を設定します。Use the server name and port number shown to set the remote connection configuration in Visual Studio.

リモート デバッガーを停止するには、 [ファイル] > [終了] を選択します。To stop the remote debugger, select File > Exit. リモート デバッガーを再起動するには、 [スタート] メニューを使用するか、またはコマンド ラインから次のコマンドを実行します。You can restart it from the Start menu, or from the command line:

<Remote debugger installation directory>\msvsmon.exe

リモート デバッガーの構成Configure the remote debugger

リモート デバッガーを初めて起動した後、リモート デバッガーの構成の一部を変更できます。You can change some aspects of the configuration of the remote debugger after you have started it for the first time.

  • 他のユーザーがリモート デバッガーに接続するためにアクセス許可を追加する必要がある場合は、 [ツール] > [アクセス許可] を選択します。If you need to add permissions for other users to connect to the remote debugger, choose Tools > Permissions. アクセス許可を付与または拒否するには、管理者特権が必要です。You must have administrator privileges to grant or deny permissions.

    重要

    リモート デバッガーは、Visual Studio コンピューターに対して使用しているユーザー アカウントとは別のユーザー アカウントで実行できますが、その場合、リモート デバッガーのアクセス許可に別のユーザー アカウントを追加する必要があります。You can run the remote debugger under a user account that differs from the user account you are using on the Visual Studio computer, but you must add the different user account to the remote debugger's permissions.

    または、コマンド ラインで /allow <username> パラメーターを使用してリモート デバッガーを開始できます: msvsmon /allow <username@computer>Alternatively, you can start the remote debugger from the command line with the /allow <username> parameter: msvsmon /allow <username@computer>.

  • 認証モードまたはポート番号を変更したり、リモート ツールのタイムアウト値を指定したりする必要がある場合は、 [ツール] > [オプション] を選択します。If you need to change the Authentication mode or the port number, or specify a timeout value for the remote tools: choose Tools > Options.

    既定で使用されるポート番号の一覧については、「リモート デバッガーのポートの割り当て」を参照してください。For a listing of the port numbers used by default, see Remote Debugger Port Assignments.

    警告

    リモート ツールを認証なしモードで実行することも選択できますが、このモードの使用は避けることを強く推奨します。You can choose to run the remote tools in No Authentication mode, but this mode is strongly discouraged. このモードで実行した場合、ネットワーク セキュリティはまったく提供されません。There is no network security when you run in this mode. [認証なし] モードは、ネットワークに悪意のあるコードや悪意のあるトラフィックのリスクがないことが確実である場合にのみ選択してください。Choose the No Authentication mode only if you are sure that the network is not at risk from malicious or hostile traffic.

(オプション) サービスとしてリモート デバッガーを構成する(Optional) Configure the remote debugger as a service

ASP.NET および他のサーバー環境でのデバッグでは、リモート デバッガーを管理者として実行するか、常に実行する場合は、リモート デバッガーをサービスとして実行する必要があります。For debugging in ASP.NET and other server environments, you must either run the remote debugger as an Administrator or, if you want it always running, run the remote debugger as a service.

リモート デバッガーをサービスとして構成する場合は、次の手順のようにします。If you want to configure the remote debugger as a service, follow these steps.

  1. リモート デバッガー構成ウィザード (rdbgwiz.exe) を見つけますFind the Remote Debugger Configuration Wizard (rdbgwiz.exe). (このアプリケーションは、リモート デバッガーとは別のアプリケーションです)。このアプリケーションは、リモート ツールをインストールした場合にのみ入手でき、(This is a separate application from the Remote Debugger.) It is available only when you install the remote tools. Visual Studio と共にはインストールされません。It is not installed with Visual Studio.

  2. 構成ウィザードの実行を開始します。Start running the configuration wizard. 最初のページが表示されたら、 [次へ] をクリックします。When the first page comes up, click Next.

  3. [Visual Studio 2015 リモート デバッガー サービスを実行する] チェック ボックスをオンにします。Check the Run the Visual Studio 2015 Remote Debugger as a service checkbox.

  4. ユーザー アカウントの名前とパスワードを追加します。Add the name of the user account and password.

    このアカウントに、 [サービスとしてログオン] のユーザー権限を追加することが必要になる場合があります。 [ローカル セキュリティ ポリシー] (secpol.msc) を [スタート] ページまたはウィンドウで見つけます (または、コマンド プロンプトで「secpol」と入力します)。You may need to add the Log on as a service user right to this account (Find Local Security Policy (secpol.msc) in the Start page or window (or type secpol at a command prompt). ウィンドウが表示されたら、 [ユーザー権利の割り当て] をダブルクリックし、右ペインで [サービスとしてログオン] を見つけます。When the window appears, double-click User Rights Assignment, then find Log on as a service in the right pane. これをダブルクリックします。Double-click it. ユーザー アカウントを [プロパティ] ウィンドウに追加して [OK] をクリックします)。Add the user account to the Properties window and click OK). [次へ] をクリックします。Click Next.

  5. リモート ツールが通信するネットワークの種類を選択します。Select the type of network that you want the remote tools to communicate with. 少なくとも 1 つのネットワークの種類を選択する必要があります。At least one network type must be selected. コンピューターがドメインを介して接続されている場合は、最初の項目を選択する必要があります。If the computers are connected through a domain, you should choose the first item. コンピューターがワークグループまたはホーム グループを介して接続されている場合は、2 番目または 3 番目の項目を選択する必要があります。If the computers are connected through a workgroup or homegroup, you should choose the second or third items. [次へ] をクリックします。Click Next.

  6. サービスを開始できた場合は、「 Visual Studio リモート デバッガー構成ウィザードは正常に完了しました」と表示されます。If the service can be started, you will see You have successfully completed the Visual Studio Remote Debugger Configuration Wizard. サービスを開始できなかった場合は、「 Visual Studio リモート デバッガー構成ウィザードを完了できませんでした」と表示されます。If the service cannot be started, you will see Failed to complete the Visual Studio Remote Debugger Configuration Wizard. このページには、サービスを開始するために従う必要があるヒントもいくつか提供されます。The page also gives some tips to follow to get the service to start.

  7. [完了] をクリックします。Click Finish.

    この時点で、リモート デバッガーはサービスとして実行されています。At this point the remote debugger is running as a service. これを確認するには、 [コントロール パネル] > [サービス] に移動して [Visual Studio 2015 リモート デバッガー] を探します。You can verify this by going to Control Panel > Services and looking for Visual Studio 2015 Remote Debugger.

    リモート デバッガー サービスは、 [コントロール パネル] > [サービス] で停止してから開始することができます。You can stop and start the remote debugger service from Control Panel > Services.

リモート シンボルを使用したデバッグのセットアップSet up debugging with remote symbols

Visual Studio コンピューターで生成したシンボルを使用して、コードをデバッグすることができます。You should be able to debug your code with the symbols you generate on the Visual Studio computer. リモート デバッガーのパフォーマンスは、ローカル シンボルを使用すると大幅に向上します。The performance of the remote debugger is much better when you use local symbols. リモート シンボルを使用する必要がある場合、リモート コンピューター上のシンボルを検索するように、リモート デバッグ モニターに指示する必要があります。If you must use remote symbols, you need to tell the remote debugging monitor to look for symbols on the remote machine.

Visual Studio 2013 Update 2 以降では、msvsmon コマンド ライン スイッチの Msvsmon /FallbackLoadRemoteManagedPdbs を使用して、マネージド コードにリモート シンボルを使用できます。Starting in Visual Studio 2013 Update 2, you can use the following msvsmon command-line switch to use remote symbols for managed code: Msvsmon /FallbackLoadRemoteManagedPdbs

詳細については、リモート デバッグのヘルプ (リモート デバッガーのウィンドウで F1 キーを押すか、または [ヘルプ] > [使い方] の順にクリックします) を参照してください。For more information, please see the remote debugging help (press F1 in the remote debugger window, or click Help > Usage). 詳細については、「.NET Remote Symbol Loading Changes in Visual Studio 2012 and 2013 (Visual Studio 2012 および 2013 における .NET のリモート シンボルの読み込みの変更)」を参照してください。You can find more information at .NET Remote Symbol Loading Changes in Visual Studio 2012 and 2013

関連項目See also