Visual Studio Tools for Unity を使用するUse Visual Studio Tools for Unity

このセクションでは、Visual Studio Tools for Unity の統合と生産性の機能の使用法、および Unity 開発における Visual Studio デバッガーの使用法について取り上げます。In this section, you'll learn how to use Visual Studio Tools for Unity's integration and productivity features, and how to use the Visual Studio debugger for Unity development.

Visual Studio で Unity スクリプトを開くOpen Unity scripts in Visual Studio

Visual Studio が unity の外部エディターとして設定されたら、unity エディターからスクリプトをダブルクリックすると自動的に起動するか、visual studio に切り替えて、選択したスクリプトを開きます。Once Visual Studio is set as the external editor for Unity, double-clicking a script from the Unity editor will automatically launch or switch to Visual Studio and open the chosen script.

または、[ アセット > [C# プロジェクトを開く ] メニューの [Unity] を選択して、ソースエディターでスクリプトを開いた状態で Visual Studio を開くこともできます。Alternatively, you can open Visual Studio with no script open in the source editor by selecting the Assets > Open C# Project menu in Unity.

Visual Studio で C# プロジェクトを開く

Visual Studio for Mac で C# プロジェクトを開く

Unity のドキュメントへのアクセスUnity documentation access

Visual Studio から簡単に Unity スクリプトに関するドキュメントにアクセスできます。You can access the Unity scripting documentation quickly from Visual Studio. Visual Studio Tools for Unity は、ローカルの API ドキュメントを見つけられない場合、ドキュメントをオンラインで検索することを試みます。If Visual Studio Tools for Unity doesn't find the API documentation locally, it will try to find it online.

  • Visual Studio で、情報を必要とする Unity API を選択するか、その上にカーソルを置き、 Ctrl+Alt+M キー、 Ctrl+H キーの順に押します。In Visual Studio, highlight or place the cursor over the Unity API you want to learn about, then press Ctrl+Alt+M , Ctrl+H
  • キーバインドの代わりに、 Help > UNITY API リファレンス メニューを使用することもできます。You can also use the Help > Unity API Reference menu instead of the keybinding. Visual Studio の Unity API リファレンスメニューThe Unity API Reference menu in Visual Studio
  • Visual Studio for Mac で、学習する Unity API の上にカーソルを強調表示または配置し、 Cmd キーを押します。 + 'In Visual Studio for Mac, highlight or place the cursor over the Unity API you want to learn about, then press Cmd+'
  • キーバインドの代わりに、 Help > UNITY API リファレンス メニューを使用することもできます。You can also use the Help > Unity API Reference menu instead of the keybinding. Visual Studio for Mac の Unity API リファレンスメニューThe Unity API Reference menu in Visual Studio for Mac

Unity API メッセージ用の IntelliSenseIntellisense for Unity API Messages

IntelliSense コード補完により、MonoBehaviour スクリプト内に Unity メッセージを簡単に実装でき、Unity API の学習に役立ちます。Intellisense code-completion makes it easy to implement Unity API messages in MonoBehaviour scripts, and assists with learning the Unity API. Unity メッセージ用の IntelliSense を使うには:To use IntelliSense for Unity messages:

  1. MonoBehaviour から派生するクラスの本体内部の新しい行にカーソルを置きます。Place the cursor on a new line inside the body of a class that derives from MonoBehaviour.

  2. Unity メッセージの名前 (OnTriggerEnter など) の入力を始めます。Begin typing the name of a Unity message, such as OnTriggerEnter.

  3. ontri 」まで入力すると、IntelliSense による候補の一覧が表示されます。Once the letters " ontri " have been typed, a list of IntelliSense suggestions appears.

Visual Studio での IntelliSense の使用

  1. 一覧での選択は、次の 3 つの方法で変更できます。The selection on the list can be changed in three ways:

    • および 方向キーを使います。With the Up and Down arrow keys.

    • 目的の項目をマウスでクリックします。By clicking with the mouse on the desired item.

    • 目的の項目の名前の入力を続けます。By continuing to type the name of the desired item.

  2. IntelliSense で選んだ Unity メッセージと必要なパラメーターを挿入するには、次のようにします。IntelliSense can insert the selected Unity message, including any necessary parameters:

    • Tab キーを押します。By pressing Tab.

    • Enter キーを押します。By pressing Enter.

    • 選んだ項目をダブルクリックします。By double-clicking the selected item.

Visual Studio で IntelliSense から Unity メッセージを挿入する

Unity MonoBehavior のスクリプト作成ウィザードUnity MonoBehavior scripting wizard

MonoBehavior ウィザードを使用して、Unity API のすべてのメソッドの一覧を表示し、空の定義を簡単に実装できます。You can use the MonoBehavior wizard to view a list of all the Unity API methods and quickly implement an empty definition. この機能は、Unity API で使用できる新機能をまだ学習しているときに、特に [メソッド コメントの生成] オプションが有効になっている場合に役に立ちます。This feature, particularly with the Generate method comments option enabled, is helpful if you are still learning what's available in the Unity API.

MonoBehavior ウィザードを使用して空の MonoBehavior メソッド定義を作成するには:To create empty MonoBehavior method definitions with the MonoBehavior wizard:

  1. Visual Studio で、メソッドの挿入位置にカーソルを合わせてから、 Ctrl+Shift+M キーを押して MonoBehavior ウィザードを起動します。In Visual Studio, position the cursor where you want the methods to be inserted, then press Ctrl+Shift+M to launch the MonoBehavior wizard. Visual Studio for Mac で、 Cmd + Shift + M キーを押します。In Visual Studio for Mac, press Cmd+Shift+M.

  2. [スクリプト メソッドの作成] ウィンドウで、追加する各メソッドの名前の横にあるチェック ボックスをオンにします。In the Create script methods window, mark the checkbox next to the name of each method you want to add.

  3. [Framework のバージョン] ドロップダウンを使用して、目的のバージョンを選択します。Use the Framework version dropdown to select your desired version.

  4. 既定では、メソッドは、カーソルの位置に挿入されます。By default, the methods are inserted at the position of the cursor. または、 [挿入ポイント] ドロップダウンの値を目的の位置に変更することで、クラス内に既に実装されている任意のメソッドの後ろに挿入することを選択できます。Alternatively, you can choose to insert them after any method that's already implemented in your class by changing the value of the Insertion point dropdown to the location you want.

  5. 選択したメソッドについてウィザードがコメントを生成するように指定するには、 [メソッドのコメントを生成] チェック ボックスをオンにします。If you want the wizard to generate comments for the methods you selected, mark the Generate method comments checkbox. これらのコメントは、メソッドを呼び出すタイミングやメソッドの全般的な役割について説明するためのものです。These comments are meant to help you understand when the method is called and what its general responsibilities are.

  6. [OK] ボタンを選択すると、ウィザードが終了し、コードにメソッドが挿入されます。Choose the OK button to exit the wizard and insert the methods into your code.

Visual Studio の [モノの動作] ウィザードダイアログ。

Visual Studio for Mac の [モノの動作] ウィザードダイアログ。

Unity プロジェクト エクスプローラーUnity Project Explorer

Unity Project Explorer にはすべての Unity プロジェクト ファイルとディレクトリが、Unity エディターで表示されるのと同じ方法で表示されます。The Unity Project Explorer shows all of your Unity project files and directories in the same way that the Unity Editor does. これは、通常の Visual Studio ソリューション エクスプローラーを使用して Unity スクリプト間を移動するのとは異なります。そこではそれらが Visual Studio によって生成されるプロジェクトとソリューションに編成されます。This is different than navigating your Unity scripts with the normal Visual Studio Solution Explorer, which organizes them into projects and a solution generated by Visual Studio.

  • Visual Studio のメイン メニューで、 [表示] > [Unity プロジェクト エクスプローラー] を選択します。On the main Visual Studio menu, choose View > Unity Project Explorer. キーボードショートカット: Alt + Shift * + E  Unity の [プロジェクトエクスプローラー] ウィンドウを表示します。Keyboard shortcut: Alt+Shift+E View the Unity Project Explorer window.
  • Visual Studio for Mac では、Unity プロジェクトを開いたときに、Solution Pad は次のように自動的に動作します。In Visual Studio for Mac, the Solution Pad automatically behaves like this when a Unity project is opened.

Unity のデバッグUnity debugging

Visual Studio Tools for Unity では、Visual Studio の強力なデバッガーを使用して、Unity プロジェクトのエディター スクリプトとゲーム スクリプトの両方をデバッグできます。Visual Studio Tools for Unity lets you debug both editor and game scripts for your Unity project using Visual Studio's powerful debugger.

Unity エディターでのデバッグDebug in the Unity editor

[デバッグ開始]Start debugging

  1. [Unity にアタッチ] というラベルの付いた [再生] ボタンをクリックするか、キーボード ショートカット F5 を使用して、Visual Studio を Unity に接続します。Connect Visual Studio to Unity by clicking the Play button labeled Attach to Unity , or use the keyboard shortcut F5. Visual Studio で [再生] をクリックするClick Play in Visual Studio
  1. [再生] ボタンをクリックするか、 Command + Return キーまたは F5 キーを押して、Visual Studio を Unity に接続します。Connect Visual Studio to Unity by clicking the Play button, or type Command + Return , or F5. [Play in Visual Studio for Mac] をクリックします。Click Play in Visual Studio for Mac
  1. Unity に切り替えた後、 [Play](再生) ボタンをクリックしてエディターでゲームを実行します。Switch to Unity and click the Play button to run the game in the editor.

Windows で [Unity で再生] をクリックする

MacOS で [Unity で再生] をクリックする

  1. Visual Studio に接続しながら Unity エディターでゲームを実行しているときに、ブレークポイントに達すると、ゲームの実行は一時停止し、ゲームがブレークポイントにヒットしたコード行が Visual Studio に表示されます。When the game is running in the Unity editor while connected to Visual Studio, any breakpoints encountered will pause execution of the game and bring up the line of code where the game hit the breakpoint in Visual Studio.

デバッグの停止Stop debugging

Visual Studio の [停止] ボタンをクリックするか、キーボード ショートカット Shift + F5 を使用します。Click the Stop button in Visual Studio, or use the keyboard shortcut Shift + F5. Visual Studio で [停止] をクリックするClick Stop in Visual Studio

Visual Studio for Mac で [停止] ボタンをクリックするか、 Shift + Command + Return キーを押します。Click the Stop button in Visual Studio for Mac, or press Shift + Command + Return. [停止] をクリックし Visual Studio for MacClick Stop in Visual Studio for Mac

Visual Studio でのデバッグの詳細については、「First look at the Visual Studio Debugger」(Visual Studio デバッガーを初めて使用する) を参照してください。To learn more about debugging in Visual Studio, see First look at the Visual Studio Debugger.

Unity にアタッチして再生Attach to Unity and Play

さらに使いやすくするために、 [Unity にアタッチ] ボタンを [Unity にアタッチして再生] モードに変更できます。For added convenience, you can change the Attach to Unity button to Attach to Unity and Play mode.

  1. [Unity にアタッチ] ボタンの横の小さな 下向き矢印 をクリックします。Click the small down arrow next to the Attach to Unity button.
  2. ドロップダウン メニューから [Unity にアタッチして再生] を選択します。Select Attach to Unity and Play from the dropdown menu. Visual Studio でのアタッチと再生Attach and play in Visual Studio

[再生] ボタンのラベルが [Unity にアタッチして再生] になります。The play button becomes labeled Attach to Unity and Play. これで、このボタンをクリックするか、キーボード ショートカット F5 を使用すると、Visual Studio デバッガーにアタッチされるだけでなく、自動的に Unity エディターに切り替わり、エディターでゲームが実行されます。Clicking this button or using the keyboard shortcut F5 now automatically switches to the Unity editor and runs the game in the editor, in addition to attaching the Visual Studio debugger.

Visual Studio for Mac から直接 [Unity にアタッチして再生] 構成を選択すると、デバッグの開始と Unity エディターでの再生を 1 回の手順でを完了できます。Starting debugging and playing the Unity editor can be completed in a single step directly from Visual Studio for Mac by choosing the Attach to Unity and Play configuration.

[Unity にアタッチして再生] を選択し Visual Studio for Mac

注意

[ Unity にアタッチ] と [再生 ] 構成を使用してデバッグを開始した場合は、[ 停止 ] ボタンをクリックしても unity エディターが停止します。If you started debugging using the Attach to Unity and Play configuration, the Stop button will also stop the Unity Editor.

Unity プレーヤー ビルドのデバッグDebug Unity player builds

Visual Studio を使用して、Unity プレーヤーの開発ビルドをデバッグできます。You can debug development builds of Unity players with Visual Studio.

Unity プレーヤーでのスクリプトのデバッグを有効にするEnable script debugging in a Unity player

  1. Unity で、 [File](ファイル) > [Build Settings](ビルド設定) を選択して、ビルド設定を開きます。In Unity, open the Build Settings by selecting File > Build Settings.

  2. [Build Settings](ビルド設定) ウィンドウで、 [Development Build](開発ビルド)[Script Debugging](スクリプトのデバッグ) の各チェック ボックスをオンにします。In the Build Settings window, mark the Development Build and Script Debugging checkboxes.

    デバッグのための Unity のビルド設定を構成します。Configure the Unity build settings for debugging.

デバッガーをアタッチする Unity インスタンスを選択するSelect a Unity instance to attach the debugger to

  • Visual Studio のメイン メニューで、 [デバッグ] > [Attach Unity Debugger](Unity デバッガーにアタッチ) を選択します。In Visual Studio, on the main menu, choose Debug > Attach Unity Debugger.

    Unity のデバッガーをアタッチします。Attach the debugger of Unity.

    [Unity のインスタンスの選択] ダイアログには、接続できる各 Unity インスタンスに関する情報が表示されます。The Select Unity Instance dialog displays some information about each Unity instance that you can connect to.

    接続する Unity のインスタンスを選択します。Choose an instance of Unity to connect to.

    プロジェクトProject

    Unity のこのインスタンスで実行されている Unity プロジェクトの名前。The name of the Unity project that's running in this instance of Unity.

    コンピューター Unity のこのインスタンスが実行されているコンピューターまたはデバイスの名前。Machine The name of the computer or device that this instance of Unity is running on.

    Unity のこのインスタンスが Unity エディターの一部として実行されている場合は Type Editor です。Unity のこのインスタンスがスタンドアロン プレーヤーの場合は Player です。Type Editor if this instance of Unity is running as part of the Unity Editor; Player if this instance of Unity is a stand-alone player.

    ポート Unity のこのインスタンスが通信に使用している UDP ソケットのポート番号。Port The port number of the UDP socket that this instance of Unity is communicating over.

重要

Visual Studio Tools for Unity と Unity インスタンスは UDP ネットワークソケットを介して通信しているため、ファイアウォールで許可する規則が必要になる場合があります。Because Visual Studio Tools for Unity and the Unity instance are communicating over a UDP network socket, your firewall may need rule to allow it. 必要に応じてプロンプトが表示される場合は、VSTU と Unity が通信できるように、接続を承認する必要があります。If needed, you may see a prompt, you'll have to authorize the connection so that VSTU and Unity can communicate.

  • Visual Studio for Mac の上部のメニューで、[実行] をクリックして [ プロセスにアタッチ > ます。In Visual Studio for Mac, on the top menu, choose Run > Attach to Process.
  • [ プロセスにアタッチ ] ダイアログボックスの下部にあるデバッガーのドロップダウンメニューで [ Unity デバッガー ] オプションを選択します。In the Attach to Process dialog, select Unity Debugger option in the Debugger drop-down menu at the bottom.
  • 一覧から Unity インスタンスを選択し、[ アタッチ ] ボタンをクリックします。Select a Unity instance from the list and click the Attach button.

Unity プロジェクトの DLL のデバッグDebug a DLL in your Unity project

多くの Unity 開発者は、コード コンポーネントを外部 DLL として作成し、自分で開発した機能を他のプロジェクトと簡単に共有できるようにしています。Many Unity developers are writing code components as external DLLs so that the functionality they develop can be easily shared with other projects. Visual Studio Tools for Unity では、これらの DLL のコードを Unity プロジェクトの他のコードとシームレスにデバッグできます。Visual Studio Tools for Unity makes it easy to debug code in these DLLs seamlessly with other code in your Unity project.

注意

現時点で、Visual Studio Tools for Unity はマネージド DLL のみをサポートしています。At this time, Visual Studio Tools for Unity only supports managed DLLs. C++ で記述された DLL など、ネイティブ コード DLL のデバッグはサポートしていません。It does not support debugging of native code DLLs, such as those written in C++.

ここで説明するシナリオは、ソース コードを持っていることを前提としている点に注意してください。つまり、自分のファースト パーティ コードを開発しているか再利用している場合、またはサード パーティ製のライブラリのソース コードを持っている場合に、作成する Unity プロジェクトを DLL として配置することを計画しているというケースです。Note that the scenario described here assumes that you have the source code—that is, you are developing or re-using your own first-party code, or you have the source code to a third-party library, and plan to deploy it in your Unity project as a DLL. このシナリオは、ソース コードを持っていない DLL のデバッグには適用されません。This scenario does not describe debugging a DLL for which you do not have the source code.

Unity プロジェクトで使用されるマネージド DLL プロジェクトをデバッグするにはTo debug a managed DLL project used in your Unity project

  1. Visual Studio Tools for Unity によって生成された Visual Studio のソリューションに、既存の DLL プロジェクトを追加します。Add your existing DLL project to the Visual Studio solution generated by Visual Studio Tools for Unity. あまり一般的な方法ではありませんが、Unity プロジェクトのコード コンポーネントが含まれた新しいマネージド DLL プロジェクトを開始することもできます。その場合は、Visual Studio のソリューションに新しいマネージド DLL プロジェクトを代わりに追加します。Less commonly, you might be starting a new managed DLL project to contain code components in your Unity project; if that's the case, you can add a new managed DLL project to the Visual Studio solution instead.

    既存の DLL プロジェクトをソリューションに追加します。Add your existing DLL project to the solution.

    どちらの場合も Visual Studio Tools for Unity によってプロジェクト参照が保持されるため、プロジェクト ファイルとソリューション ファイルを再生成する必要がある場合でも、これらの手順は 1 回実行するだけ済みます。In either case, Visual Studio Tools for Unity maintains the project reference, even if it has to regenerate the project and solution files again, so you only need to perform these steps once.

  2. DLL プロジェクトで、適切な Unity フレームワーク プロファイルを参照します。Reference the correct Unity framework profile in the DLL project. Visual Studio では、DLL プロジェクトのプロパティで、 [対象のフレームワーク] プロパティを、使用している Unity フレームワークのバージョンに設定します。In Visual Studio, in the DLL project's properties, set the Target framework property to the Unity framework version you're using. これは、Unity フル、Micro、または Web 基底クラス ライブラリなど、プロジェクトが対象とする API 互換性と一致する Unity 基底クラス ライブラリです。This is the Unity Base Class Library that matches the API compatibility that your project targets, such as the Unity full, micro, or web base class libraries. この設定により、他のフレームワークまたは互換性レベルに存在するが、使用している Unity フレームワークのバージョンには存在しないフレームワーク メソッドを DLL が呼び出すことを防止できます。This prevents your DLL from calling framework methods that exist in other frameworks or compatibility levels, but which might not exist in the Unity framework version you're using.

注意

Unity のレガシ ランタイムを使用している場合にのみ、以下が必要です。The following is only required if you are using Unity's legacy runtime. 新しい Unity ランタイムを使用している場合は、このような専用の 3.5 プロファイルを使用する必要はありません。If you are using the new Unity runtime, you don't need to use those dedicated 3.5 profiles anymore. お使いの Unity バージョンと互換性のある .NET 4.x プロファイルを使用してください。Use a .NET 4.x profile compatible with your Unity version.

Unity フレームワークに、DLL のターゲット フレームワークを設定します。Set the DLL's target framework to Unity framework.

  1. DLL は、Unity プロジェクトのアセット フォルダーにコピーします。Copy the DLL to your Unity project's Asset folder. Unity では、アセットとは、Unity のアプリと一緒にパッケージ化され、実行時に読み込めるように配置されるファイルのことです。In Unity, assets are files that are packaged and deployed together with your Unity app so that they can be loaded at run-time. DLL は実行時にリンクされるので、DLL はアセットとして配置する必要があります。Since DLLs are linked at run time, DLLs must be deployed as assets. アセットとして配置するには、Unity エディターは DLL を Unity プロジェクトの Assets フォルダー内に置く必要があります。To be deployed as an asset, the Unity Editor requires the DLLs to be put inside the Assets folder in your Unity project. これを実行するには、次の 2 つの方法があります。There are two ways you can do this:

    • DLL プロジェクトのビルド設定を変更して、出力 DLL ファイルと PDB ファイルを出力フォルダーから Unity プロジェクトの Assets フォルダーにコピーするビルド後タスクを組み込みます。Modify the build settings of your DLL project to include a post-built task that copies the output DLL and PDB files from its output folder to the Assets folder of your Unity project.

    • DLL プロジェクトのビルド設定を変更して、出力フォルダーを自分の Unity プロジェクトの Assets フォルダーに設定します。Modify the build settings of your DLL project to set its output folder to be the Assets folder of your Unity project. DLL ファイルと PDB ファイルの両方が Assets フォルダーに置かれます。Both DLL and PDB files will be placed in the Assets folder.

    PDB ファイルには DLL のデバッグのシンボルや、DLL コードからソース コード フォームへのマップが格納されているため、デバッグには PDB ファイルが必要です。The PDB files are needed for debugging because they contain the DLL's debugging symbols, and map the DLL code to its source code form. レガシ ランタイムをターゲットにしている場合、Visual Studio Tools for Unity は、DLL と PDB からの情報を使用して DLL.MDB ファイルを作成します。このファイルは、レガシ Unity スクリプト エンジンが使用するデバッグ シンボル形式になっています。If you are targeting the legacy runtime, Visual Studio Tools for Unity will use information from the DLL and PDB to create a DLL.MDB file, which is the debug symbol format used by the legacy Unity scripting engine. 新しいランタイムをターゲットにしていて、Portable-PDB を使用している場合、新しい Unity ランタイムは Portable-PDB をネイティブで使用できるため、Visual Studio Tools for Unity ではシンボル変換が試行されません。If you are targeting the new runtime, and using Portable-PDB, Visual Studio Tools for Unity will not try to do any symbol conversion as the new Unity runtime is able to natively consume Portable-PDBs.

    PDB 生成の詳細については、ここを参照してください。More information about PDB generation can be found here. 新しいランタイムをターゲットにしている場合は、Portable-PDB を適切に生成するために、[Debugging Information](デバッグ情報) が [移植可能] に設定されていることを確認します。If you are targeting the new runtime, please make sure that "Debugging Information" is set to "Portable", in order to properly generate Portable-PDB. レガシ ランタイムをターゲットにしている場合は、[全体] を使用する必要があります。If you are targeting the legacy runtime, you need to use "Full".

  2. コードをデバッグします。Debug your code. これで、Unity プロジェクトのソース コードと DLL ソース コードを一緒にしてデバッグできるようになりました。ブレークポイントやコードのステップ実行など、いつも使用しているデバッグ機能をすべて使用できます。You can now debug your DLL source code together with your Unity project's source code, and use all the debugging features you are used to, such as breakpoints and stepping through code.

キーボード ショートカットKeyboard shortcuts

キーボード ショートカットを使用すると、Visual Studio Tools for Unity の機能に素早くアクセスできます。You can quickly access the Unity Tools for Visual Studio functionality by using their keyboard shortcuts. 使用できるショートカットの概要を次に示します。Here's a summary of the shortcuts that are available.

コマンドCommand ショートカットShortcut シュートカット コマンド名Shortcut command name
MonoBehavior ウィザードを開くOpen the MonoBehavior Wizard Ctrl+Shift+MCtrl+Shift+M EditorContextMenus.CodeWindow.ImplementMonoBehavioursEditorContextMenus.CodeWindow.ImplementMonoBehaviours
Unity プロジェクト エクスプローラーを開くOpen the Unity Project Explorer Alt+Shift+EAlt+Shift+E View.UnityProjectExplorerView.UnityProjectExplorer
Unity のドキュメントにアクセスするAccess Unity documentation Ctrl+Alt+M、Ctrl+HCtrl+Alt+M, Ctrl+H Help.UnityAPIReferenceHelp.UnityAPIReference
Unity のデバッガー (プレーヤーまたはエディター) にアタッチするAttach to Unity debugger (player or editor) 既定値なしno default Debug.AttachUnityDebuggerDebug.AttachUnityDebugger

既定値では不便な場合は、ショートカット キーの組み合わせを変更できます。You can change the shortcut key combinations if you don't like the default. 変更方法については、「Visual Studio でのキーボード ショートカットの識別とカスタマイズ」を参照してください。For information on how to change it, see Identify and customize keyboard shortcuts in Visual Studio.

コマンドCommand ショートカットShortcut シュートカット コマンド名Shortcut command name
MonoBehavior ウィザードを開くOpen the MonoBehavior Wizard Cmd +Shift +MCmd+Shift+M EditorContextMenus.CodeWindow.ImplementMonoBehavioursEditorContextMenus.CodeWindow.ImplementMonoBehaviours
Unity のドキュメントにアクセスするAccess Unity documentation Cmd + 'Cmd+' Help.UnityAPIReferenceHelp.UnityAPIReference

既定値では不便な場合は、ショートカット キーの組み合わせを変更できます。You can change the shortcut key combinations if you don't like the default. 変更方法については、「 IDE のカスタマイズ」を参照してください。For information on how to change it, see Customizing the IDE.