ソリューションとプロジェクトを作成するCreate solutions and projects

プロジェクトは Visual Studio の論理コンテナーであり、ソース コード ファイル、ビットマップ、アイコン、コンポーネント、サービス参照など、アプリのビルドに必要なアイテムが格納されます。Projects are logical containers in Visual Studio that hold the items needed to build your app, such as source code files, bitmaps, icons, and component and service references. 新しいプロジェクトを作成すると、そのプロジェクトを含むソリューションが Visual Studio によって作成されます。When you create a new project, Visual Studio creates a solution to contain the project. その後、必要に応じて他の新規または既存のプロジェクトをソリューションに追加できます。You can then add other new or existing projects to the solution if you want. ソリューションには、特定のプロジェクトに関連付けられていないファイルを含めることもできます。Solutions can also contain files that aren't connected to any specific project.

ソリューション/プロジェクト階層

ソリューション エクスプローラーという名称のツール ウィンドウでソリューションやプロジェクトを表示できます。You can view your solutions and projects in a tool window called Solution Explorer. 次のスクリーンショットは、ソリューション エクスプローラー (BikeSharing.Xamarin-UWP) のサンプル ソリューションです。BikeSharing.Clients.Core と BikeSharing.Clients.Windows という 2 つのプロジェクトが含まれています。The following screenshot shows an example solution in Solution Explorer (BikeSharing.Xamarin-UWP) that contains two projects: BikeSharing.Clients.Core and BikeSharing.Clients.Windows. 各プロジェクトに複数のファイル、フォルダー、参照が含まれています。Each project contains multiple files, folders, and references. 太字のプロジェクト名はスタートアップ プロジェクトです。つまり、アプリを実行すると起動するプロジェクトです。The project name in bold is the startup project; that is, the project that starts when you run the app. スタートアップ プロジェクトにするプロジェクトを指定できます。You can specify which project is the startup project.

ソリューション エクスプローラーとプロジェクト

プロジェクトは自分で作成できますが (必要なファイルをプロジェクトに追加する方法で)、Visual Studio ではさまざまプロジェクト テンプレートが用意されており、プロジェクトを簡単に作成できます。While you can construct a project yourself by adding the necessary files to it, Visual Studio offers a selection of project templates to give you a head start. テンプレートから新しいプロジェクトを作成する場合、そのプロジェクトの種類の基本要素が与えられます。そこからファイルの名前を変更したり、新しいコード、既存のコード、その他のリソースを必要に応じて追加したりできます。Creating a new project from a template gives you a project with the essentials for that project type, and you can rename the files or add new or existing code and other resources to it as needed.

ただし、Visual Studio でアプリを開発するにあたり、ソリューションとプロジェクトは必須ではありません。That being said, solutions and projects are not required to develop apps in Visual Studio. また、Git からコピーしたか、他の場所からダウンロードしたコードを開くことができます。You can also just open code that you have cloned from Git or downloaded elsewhere. 詳細については、「プロジェクトまたはソリューションを使用せずに Visual Studio でコードを開発する」を参照してください。For more information, see Develop code in Visual Studio without projects or solutions.

注意

このトピックの説明は、Visual Studio Community エディション に基づいています。The descriptions in this topic are based on the Visual Studio Community edition. 実際に画面に表示されるダイアログ ボックスとメニュー コマンドは、使用中の設定または Visual Studio のエディションによっては、この中の説明と異なる場合があります。The dialog boxes and menu commands you see might differ from those described here, depending on your settings or Visual Studio edition. 設定を、たとえば、[全般][Visual C++] に変更するには、[ツール][設定のインポートとエクスポート][すべての設定をリセット] の順に選択します。To change your settings, for example to General or Visual C++ settings, choose Tools, Import and Export Settings, and then choose Reset all settings.

プロジェクト テンプレートからプロジェクトを作成するにはTo create a project from a project template

  1. Visual Studio では、いくつかの方法で新しいプロジェクトを作成できます。There are multiple ways to create a new project in Visual Studio. [スタート] ページの [プロジェクト テンプレートの検索] ボックスにプロジェクト テンプレートの名前を入力するか、[新しいプロジェクトの作成] リンクを選択して [新しいプロジェクト] ダイアログ ボックスを開きます。On the Start Page, enter the name of a project template in the Search project templates box, or choose the Create new project link to open the New Project dialog box. メニュー バーで [ファイル][新規作成][プロジェクト] の順に選択するか、ツール バーの [新しいプロジェクト] ボタンを選択するという方法もあります。You can also choose File, New, Project... on the menu bar, or choose the New Project button on the toolbar.

    スタート ページ

    [新しいプロジェクト] ダイアログ ボックスの [テンプレート] カテゴリの下に、利用できるプロジェクト テンプレートが一覧表示されます。In the New Project dialog box, available project templates appear in a list under the Templates category. テンプレートは、Visual C#、JavaScript、Azure Data Lake など、プログラミング言語やプロジェクトの種類に基づいて整理されています。Templates are organized by programming language and project type, such as Visual C#, JavaScript, and Azure Data Lake.

    [新しいプロジェクト] ダイアログ ボックス

    注意

    利用できる言語またはプロジェクト テンプレートの一覧は、実行している Visual Studio のバージョンとインストールされているワークロードに基づいて表示されます。The list of available languages and project templates that appears depends on the version of Visual Studio you are running and the workloads that are installed. 追加ワークロードのインストール方法については、「ワークロードやコンポーネントを追加または削除することで Visual Studio 2017 を変更する」を参照してください。To learn about how to install additional workloads, see Modify Visual Studio 2017 by adding or removing workloads and components.

  2. 言語名の隣にある三角形を選択し、使用するプログラミング言語のテンプレート一覧を表示し、プロジェクトの種類を選択します。Show the list of templates for the programming language you want to use by choosing the triangle next to the language name, and then choose a project type.

    次は、Visual C# Web プロジェクトで利用できるプロジェクト テンプレートの例です。The following example shows the project templates available for Visual C# web projects.

    プロジェクト テンプレート

  3. [名前] ボックスに新しいプロジェクトの名前を入力します。Enter a name for the new project in the Name box. プロジェクトはシステムの既定の場所に保存するか、[参照] ボタンで別の場所を探すことができます。You can choose to save the project in the default location on your system, or choose the Browse button to find another location.

    必要であれば、ソリューション名を変更したり、[ソース管理に追加] を選択して新しいプロジェクトを Git リポジトリに追加したりできます。You can also optionally choose to change the solution name, or add the new project to a Git repository by choosing Add to Source Control.

  4. [OK] ボタンを選択すると、ソリューションとプロジェクトが作成されます。Choose the OK button to create the solution and project.

  5. ソリューションにプロジェクトを追加する場合、ソリューション エクスプローラーでソリューション ノードを選択し、次にメニュー バーで、[プロジェクト][新しい項目の追加] の順に選択します。If you want to add an additional project to the solution, choose the solution node in Solution Explorer, and then on the menu bar, choose Project, Add New Item.

既存のコード ファイルからプロジェクトを作成するCreate a project from existing code files

コード ソース ファイルのコレクションがある場合、それらをプロジェクトに簡単に追加できます。If you have a collection of code source files, you can easily add them to a project.

  1. メニューで、[ファイル][新規作成][既存のコードからプロジェクトを作成] の順に選択します。On the menu, choose File, New, Project From Existing Code.

  2. [既存のコードからプロジェクトを作成] ウィザードの [作成するプロジェクトの種類を入力してください] ドロップダウン リスト ボックスでプロジェクトの種類を選択し、[次へ] ボタンを選択します。In the Create Project from Existing Code Files wizard, choose the project type you want in the What type of project would you like to create? drop-down list box, and then choose the Next button.

  3. ウィザードで、ファイルの場所を参照し、[名前] ボックスに新しいプロジェクトの名前を入力します。In the wizard, browse to the location of the files and then enter a name for the new project in the Name box. 完了したら、[完了] ボタンを選択します。When you are done, choose the Finish button.

注意

このオプションは、比較的単純なファイルのコレクションに最適です。This option works best for a relatively simple collections of files. 現在のところ、Visual C++、Apache Cordova、Visual Basic、Visual C# がプロジェクトの種類としてサポートされています。Currently, only Visual C++, Apache Cordova, Visual Basic, and Visual C# project types are supported.

ソリューションにファイルを追加するAdd files to a solution

ソリューションの Readme ファイルや、特定のプロジェクトの配下ではなく、ソリューション レベルで論理的に属する他のファイルなど、あるファイルが複数のプロジェクトに適用されている場合、そのようなファイルはソリューション自体に追加できます。If you have a file that applies to multiple projects, such as a readme file for the solution, or other files that logically belong at the solution level rather than under a specific project, then you can add them to the solution itself. ソリューションに項目を追加するには、ソリューション エクスプローラーでソリューション ノードのコンテキスト (右クリック) メニューで、[追加][新しい項目] の順に選択するか、[追加][既存の項目] の順に選択します。To add an item to a solution, on the context (right-click) menu of the solution node in Solution Explorer, choose Add, New Item, or Add, Existing Item.

.NET Framework の特定のバージョンを対象とする .NET プロジェクトの作成Create a .NET project that targets a specific version of the .NET Framework

プロジェクトを作成するとき、そのプロジェクトで使用する .NET Framework のバージョンを指定できます。When you create a project, you can specify a specific version of the .NET Framework that you want the project to use. .NET Framework バージョンを指定するには、[新しいプロジェクト] ダイアログ ボックスの [.NET Framework] バージョン ドロップダウン メニューを選択します。To specify a .NET framework version, choose the .NET Framework version drop-down menu in the New Project dialog box.

.NET Framework バージョン セレクター

注意

.NET Core テンプレートからプロジェクトを作成する場合、ドロップダウンで選択した .NET Framework バージョンは無視されます。If you are creating a project from a .NET Core template, the .NET Framework version you select in the drop-down is ignored.

ヒント

プロジェクト テンプレートを選択する前に .NET Framework バージョンを設定すると、その .NET Framework バージョンとの間に互換性があるテンプレートのみが Visual Studio に表示されます。If you set the .NET Framework version before selecting a project template, then Visual Studio will only show templates that are compatible with that .NET Framework version.

4 以前のバージョンの .NET Framework にアクセスするには、.NET Framework 3.5 がシステムにインストールされている必要があります。You must have .NET Framework 3.5 installed on your system to access .NET Framework versions earlier than .NET Framework 4.

空のソリューションの作成Create empty solutions

プロジェクトのない空のソリューションも作成できます。You can also create empty solutions that have no projects. 独自のソリューションとプロジェクトを一から作成する場合、空のソリューションが適しています。This might be preferable in cases where you want to construct your solution and projects from scratch.

空のソリューションを作成するにはTo create an empty solution

  1. メニューで、[ファイル][新規作成][プロジェクト] の順にクリックします。On the menu, choose File, New, Project....

  2. 左側のウィンドウ ([テンプレート]) で、[その他のプロジェクトの種類] を選択し、展開された一覧で [Visual Studio ソリューション] を選択します。In the left (Templates) pane, choose Other Project Types, Visual Studio Solutions in the expanded list.

  3. 中央のペインで、[空のソリューション] を選択します。In the middle pane, choose Blank Solution.

  4. ソリューションの [名前][場所] を入力し、[OK] を選択します。Enter Name and Location values for your solution, then choose OK.

空のソリューションの作成後、[プロジェクト] メニューの [新しい項目の追加] または [既存項目の追加] を選んで、新規または既存のプロジェクトや項目を追加できます。After you create an empty solution, you can add new or existing projects or items to it by choosing Add New Item or Add Existing Item on the Project menu.

前述のように、プロジェクトやソリューションがなくてもコード ファイルを開くことができます。As mentioned earlier, you can also open code files without needing a project or solution. この方法でコードを開発する方法については、「プロジェクトまたはソリューションを使用せずに Visual Studio でコードを開発する」を参照してください。To learn about developing code in this way, see Develop code in Visual Studio without projects or solutions.

一時プロジェクト (C# および Visual Basic) を作成するCreate a temporary project (C# and Visual Basic)

ディスクの場所を指定せずに .NET ベースのプロジェクトを作成する場合、それは一時的なプロジェクトになります。If you create a .NET-based project without specifying a disk location, it is a temporary project. 一時的なプロジェクトでは、.NET プロジェクトで実験できます。Temporary projects enable you to experiment with .NET projects. 一時的なプロジェクトで作業しているときはいつでも、一時的なプロジェクトを保存したり、破棄したりできます。At any time while you are working with a temporary project, you can choose to save it or discard it.

一時的なプロジェクトを作成するには、まず [ツール][オプション][プロジェクトおよびソリューション][全般] の順に進み、[作成時に新しいプロジェクトを保存] チェックボックスのチェックをオフにします。To create a temporary project, first go to Tools, Options, Projects and Solutions, General, and uncheck the Save new projects when created checkbox. それから、通常どおり、[新しいプロジェクト] ダイアログ ボックスを開きます。Then open the New Project dialog box as usual.

ソリューション、プロジェクト、アイテムを削除するDelete a solution, project, or item

ソリューションとそのコンテンツを完全に削除できますが、Visual Studio IDE でそれを行うことはできません。You can delete solutions and their contents permanently, but not by using the Visual Studio IDE. Visual Studio 内でアイテムを削除した場合、現在のソリューションまたはプロジェクトから削除されるだけです。Deleting items within Visual Studio only removes them from the current solution or project. ソリューションやその他のコンポーネントをシステムから完全に削除するには、エクスプローラーを利用し、.sln または .suo のソリューション ファイルが含まれるフォルダーを削除します。To permanently delete a solution or other component from your system, use File Explorer to delete the folder that contains the .sln and .suo solution files. ただし、ソリューションを完全に削除する前に、再び必要になる場合に備え、プロジェクトやファイルをバックアップしておくことをお勧めします。However, before permanently deleting a solution, it's recommended that you back up any projects or files in case you need them again.

注意

.suo ファイルは隠しファイルであり、エクスプローラーの既定の設定では表示されません。The .suo file is a hidden file that is not displayed under the default File Explorer settings. 隠しファイルを表示するには、エクスプローラーの [表示] メニューで [非表示項目] チェックボックスをオンにします。To show hidden files, on the View menu in File Explorer, select the Hidden Items checkbox.

ソリューションを完全に削除するにはTo permanently delete a solution

  1. ソリューション エクスプローラーで、削除するソリューションのコンテキスト メニューから [エクスプローラーでフォルダーを開く] を選択します。In Solution Explorer, on the context menu of the solution you want to delete, choose Open folder in File Explorer.

  2. ファイル エクスプローラーで、1 つ上の階層に移動します。In File Explorer, navigate up one level.

  3. ソリューションが含まれるフォルダーを選択し、Del キーを押します。Choose the folder containing the solution and then choose the Delete key.

関連項目See also

ソリューションおよびプロジェクトSolutions and Projects
GitHub の Microsoft のオープン ソース リポジトリMicrosoft's open source repositories on GitHub
Visual Studio のサンプルVisual Studio Samples
開発者コード サンプルDeveloper code samples