Visual Studio のウィンドウ レイアウトをカスタマイズするCustomize window layouts in Visual Studio

Visual Studio では、さまざまな開発ワークフローに最も適したウィンドウのレイアウトを作成するために、ウィンドウの位置、サイズ、および動作をカスタマイズできます。In Visual Studio you can customize the position, size and behavior of windows to create window layouts that work best for various development workflows. レイアウトをカスタマイズすると、IDE はそれを記憶します。When you customize the layout, the IDE remembers it. たとえば、 ソリューション エクスプローラー のドッキング位置を変更した後で Visual Studio を閉じた場合、次回起動時には、別のコンピューターで作業していても、 ソリューション エクスプローラー が同じ位置にドッキングされます。For example, if you change the docking location of Solution Explorer and then close Visual Studio, the next time that you start, even if you are working on another computer, Solution Explorer will be docked in that same location. また、カスタム レイアウトに名前を付けて保存した後、1 つのコマンドでレイアウト間を切り替えることもできます。You can also give a custom layout a name and save it, and then switch between layouts with a single command. たとえば、編集用のレイアウトとデバッグ用のレイアウトを作成し、[ウィンドウ | ウィンドウ レイアウトを適用] メニュー コマンドを使用してそれらを切り替えることができます。For example you could create a layout for editing, and another for debugging, and switch between them by using the Window | Apply Window Layout menu command.

ウィンドウの種類Kinds of windows

ツール ウィンドウとドキュメント ウィンドウTool and document windows

IDE には ツール ウィンドウドキュメント ウィンドウの 2 種類の基本的なウィンドウがあります。The IDE has two basic window types, tool windows and document windows. ツール ウィンドウには、ソリューション エクスプ ローラー、サーバー エクスプ ローラー、出力ウィンドウ、エラー一覧、デザイナー、デバッガー ウィンドウなどがあります。Tool windows include Solution Explorer, Server Explorer, Output Window, Error List, the designers, the debugger windows, and so on. ドキュメント ウィンドウには、ソース コード ファイル、任意のテキスト ファイル、構成ファイルなどが含まれます。Document windows contain source code files, arbitrary text files, config files, and so on. ツール ウィンドウは、サイズを変更したり、タイトル バーでドラッグしたりできます。Tool windows can be resized and dragged by their title bar. ドキュメント ウィンドウはタブでドラッグできます。ウィンドウに関するその他のオプションを設定するには、タブまたはタイトルバーを右クリックします。Document windows can be dragged by their tab. Right-click on the tab or title bar to set other options on the window.

[ウィンドウ] メニューには、IDE でのウィンドウのドッキング、フローティング、および非表示のオプションが表示されます。The Window menu shows options for docking, floating and hiding windows in the IDE. ウィンドウのタブまたはタイトル バーを右クリックすると、その特定のウィンドウのその他のオプションが表示されます。Right click on a window tab or title bar to see additional options for that specific window. 特定のツール ウィンドウの複数のインスタンスを同時に表示できます。You can display more than one instance of certain tool windows at a time. たとえば、複数の Web ブラウザー ウィンドウを表示することができます。また、 [ウィンドウ] メニューの [新規ウィンドウ] を選択して、複数のツール ウィンドウの追加のインスタンスを作成できます。For example, you can display more than one web browser window, and you can create additional instances of some tool windows by choosing New Window on the Window menu.

[プレビュー] タブ (ドキュメント ウィンドウ)Preview tab (document windows)

[プレビュー] タブで、ファイルを開かずに、エディターで見ることができます。In the Preview tab, you can view files in the editor without opening them. ファイルのプレビューは、 ソリューション エクスプローラーでファイルを選択したり、デバッグ中にファイルにステップ インしたり、[定義へ移動] を使用したり、検索結果を参照する際に利用できます。You can preview files by choosing them in Solution Explorer, during debugging when you step into files, with Go to Definition, and when you browse through results of a search. プレビュー ファイルはドキュメント タブの右側にあるタブに表示されます。Preview files appear in a tab on the right side of the document tab well. ファイルを変更するか [開く]を選択すると、編集のためにファイルが開きます。The file opens for editing if you modify it or choose the Open.

タブ グループTab groups

タブ グループは、IDE で 2 つ以上のドキュメントを開いて作業しているときに、限られたワークスペースを管理する能力を拡張します。Tab Groups extend your ability to manage limited workspace while you are working with two or more open documents in the IDE. 複数のドキュメント ウィンドウおよびツール ウィンドウを縦または横のタブ グループに整理し、あるタブ グループから別のグループにドキュメントを入れ替えることができます。You can organize multiple document windows and tool windows into either vertical or horizontal Tab Groups and shuffle documents from one Tab Group to another.

分割ウィンドウSplit windows

1 つのドキュメント内で同時に 2 つの場所を表示または編集する必要があるときに、ウィンドウを分割できます。When you have to view or edit two locations at once in a document, you can split windows. 2 つの独立したスクロール セクションにドキュメントを分割するには、 [ウィンドウ] メニューの [分割] をクリックします。To divide your document into two independently scrolling sections, click Split on the Window menu. 1 つのビューを戻すには、 [ウィンドウ] メニューの [分割の解除] をクリックします。Click Remove Split on the Window menu to restore the single view.


ツール バーは、ドラッグするか [カスタマイズ] ダイアログ ボックスを使用して配置できます。Toolbars can be arranged by dragging, or by using the Customize dialog box. ツールバーの配置とカスタマイズする方法の詳細については、「方法: メニューおよびツール バーをカスタマイズする」を参照してください。For more information about how to position and customize toolbars, see How to: Customize Menus and Toolbars.

ウィンドウの整列と固定Arrange and dock Windows

ドキュメント ウィンドウとツール ウィンドウはどちらも ドッキングできるので、IDE のウィンドウ フレーム内にサイズを合わせて配置したり、または IDE とは独立したウィンドウとしてフローティングさせることもできます。Both document windows and tool windows can be docked, so that it has a position and size within the IDE window frame, or floating as a separate window independent of the IDE. ツール ウィンドウは IDE フレーム内のどこにでもドッキングできます。一部のツール ウィンドウは、エディター フレーム内のタブ付きウィンドウとしてドッキングできます。Tool windows can be docked anywhere inside the IDE frame; some tool windows can be docked as tabbed windows in the editor frame. ドキュメント ウィンドウはエディター フレーム内にドッキングでき、タブ順の現在の位置にピン留めすることができます。Document windows can be docked within the editor frame, and they can be pinned to their current position in the tab order. 複数のウィンドウを "ラフト操作" で IDE 上または IDE 外で一緒にフローティングするよう、ドッキングできます。You can dock multiple windows to float together in a "raft" over or outside of the IDE. また、ツール ウィンドウは非表示にしたり最小化することもできます。Tool windows can also be hidden or minimized.

次の方法でウィンドウを配置できます。You can arrange windows in the following ways:

  • タブ ウェルの左側にドキュメント ウィンドウを固定する。Pin document windows to the left of the tab well.

  • タブによりウィンドウを編集フレームにドッキングする。Tab-dock windows to the editing frame.

  • IDE の枠の端にツール ウィンドウをドッキングする。Dock tool windows to the edge of a frame in the IDE.

  • ドキュメントまたはツール ウィンドウを IDE 上または IDE の外部にフローティングする。Float document or tool windows over or outside the IDE.

  • ツール ウィンドウを IDE の端で非表示にする。Hide tool windows along the edge of the IDE.

  • ウィンドウを別々のモニターに表示する。Display windows on different monitors.

  • ウィンドウの場所を既定のレイアウト、または保存済みのカスタム レイアウトにリセットする。Reset window placement to the default layout or to a saved custom layout.

    ツール ウィンドウとドキュメント ウィンドウは、ドラッグ、 [ウィンドウ] メニューのコマンドの使用、および配置するウィンドウのタイトル バーの右クリックによって配置できます。Tool and document windows can be arranged by dragging, by using commands on the Window menu, and by right-clicking the title bar of the window to be arranged.


次の手順で参照している Visual Studio ユーザー インターフェイス要素の一部は、お使いのコンピューターでは名前や場所が異なる場合があります。Your computer might show different names or locations for some of the Visual Studio user interface elements in the following instructions. これらの要素は、使用している Visual Studio のエディションや独自の設定によって決まります。The Visual Studio edition that you have and the settings that you use determine these elements. 詳細については、「Visual Studio IDE のカスタマイズ」を参照してください。For more information, see Personalize the Visual Studio IDE.

ウィンドウのドッキングDock Windows

ツール ウィンドウのタイトル バーまたはドキュメント ウィンドウのタブをクリックしてドラッグすると、ガイド用のひし形が表示されます。When you click and drag the title bar of a tool window, or the tab of document window, a guide diamond appears. ドラッグ操作中にマウス カーソルが、ひし形の矢印のいずれかの上にくると、網かけされた部分が表示されます。これは、この時にマウスのボタンを離すと、ウィンドウがドッキングされるを示しています。During the drag operation, when the mouse cursor is over one of the arrows in the diamond, a shaded area will appear that shows you where the window will be docked if you release the mouse button now.

ドッキング可能ウィンドウをスナップせずに移動するには、Ctrl キーを押しながらウィンドウをドラッグします。To move a dockable window without snapping it into place, choose the Ctrl key while you drag the window.

ツール ウィンドウまたはドキュメント ウィンドウを直近のドッキング場所に戻すには、 Ctrl キーを押しながらウィンドウのタイトル バーまたはタブをダブルクリックします。To return a tool window or document window to its most recent docked location, press CTRL while you double-click the title bar or tab of the window.

次の図は、ドキュメント ウィンドウのガイド用のひし形を示しています。ドキュメント ウィンドウは、編集フレーム内にのみドッキングできます。The following illustration shows the guide diamond for document windows, which can only be docked within the editing frame:

ドキュメント ウィンドウのガイドのひし形Document Window Guide Diamond

ツール ウィンドウは、IDE の枠の 1 辺または編集フレーム内に固定できます。Tool windows can be fastened to one side of a frame in the IDE or within the editing frame. ツール ウィンドウを別の位置にドラッグすると、ウィンドウの再ドッキングが容易になるように、ガイド用のひし形が表示されます。A guide diamond appears when you drag a tool window to another location to help you to easily re-dock the window.

ツール ウィンドウのガイド用のひし形Guide diamond for tool windows

ツール ウィンドウのガイドのひし形Tool Window Guide Diamonds

次の図は、青の網掛け部分で示されている、新しい場所にドッキングされているソリューション エクスプ ローラーを示しています。The following illustration shows Solution Explorer being docked in a new location, which is shown by the blue shaded area:

ソリューション エクスプローラーを新しい位置にドッキングDocking Solution Explorer in a new position

ツール ウィンドウを閉じる/自動的に隠すClose and auto-hide tool windows

タイトル バーの右上にある [X] をクリックして、ツール ウィンドウを閉じることができます。ウィンドウを再び開くには、キーボード ショートカットかメニュー コマンドを使用します。You can close a tool window by clicking the X in the upper right of the title bar; to reopen the window, use its keyboard shortcut or menu command. ツール ウィンドウでは自動非表示という機能をサポートしています。これは、別のウィンドウを使用すると現在のウィンドウが非表示になるものです。Tool windows support a feature named Auto Hide, which causes a window to slide out of the way when you use a different window. ウィンドウが自動非表示になっている場合は、IDE の端にあるタブにウィンドウの名前が表示されます。When a window is auto-hidden, its name appears on a tab at the edge of the IDE. 非表示のウィンドウをもう一度使用する場合は、タブをポイントすると、そのウィンドウが元の状態で表示されます。To use the window again, point to the tab so that the window slides back into view.

自動的に隠すAuto hide


[自動的に隠す] の操作対象が、個々のツール ウィンドウなのか、ドッキングされているウィンドウ グループなのかを設定するには、 [オプション] ダイアログ ボックスの [[自動的に隠す] ボタンをアクティブなツール ウィンドウにのみ実行する] をオンまたはオフにします。To set whether Auto Hide operates on tool windows individually or as docked groups, select or clear Auto Hide button affects active tool windows only in the Options dialog box. 詳細については、「 General, Environment, Options Dialog Box」を参照してください。For more information, see General, Environment, Options Dialog Box.


[自動的に隠す] が選択されているツール ウィンドウにフォーカスを移すと、そのウィンドウが一時的に表示されることがあります。Tool windows that have Auto Hide enabled may temporarily slide into view when the window has focus. ウィンドウを再び非表示にするには、そのウィンドウの外部にあるアイテムをクリックします。To hide the window again, select an item outside of the current window. フォーカスが別のアイテムに移ると、ウィンドウはビューから外れて元の状態に戻ります。When the window loses focus, it slides back out of view.

2 台目のモニターを指定するSpecifying a second monitor

2 台目のモニターがあり、オペレーティング システムでサポートされる場合は、ウィンドウをいずれのモニターに表示するのかを選択できます。If you have a second monitor and your operating system supports it, you can choose which monitor displays a window. 他のモニターで "ラフト操作" し、複数のウィンドウをグループ化することもできます。You can even group multiple windows together in "rafts" on other monitors.


ソリューション エクスプローラー の複数のインスタンスを作成し、別のモニターに移動することもできます。You can create multiple instances of Solution Explorer and move them to another monitor. ウィンドウを右クリックし、 [新しいソリューション エクスプローラー ビュー]をクリックします。Right-click the window and choose New Solution Explorer View. Ctrl キーを押しながらダブルクリックすると、すべてのウィンドウを元のモニターに戻すことができます。You can return all windows back to the original monitor by double-clicking while choosing the Ctrl key.

ウィンドウ レイアウトのリセット、名前付け、および切り替えReset, name, and switch between window layouts

[ウィンドウ レイアウトのリセット] を使用して設定コレクションを IDE の元のウィンドウ レイアウトに戻すことができます。You can return the IDE to the original window layout for your settings collection by using the Reset Window Layout command. このコマンドを実行すると、次のアクションが発生します。When you run this command, the following actions occur:

  • すべてのウィンドウが既定の場所に移動されます。All windows are moved to their default positions.

  • 既定のウィンドウ レイアウトで閉じられているウィンドウは閉じられます。Windows that are closed in the default window layout are closed.

  • 既定のウィンドウ レイアウトで開かれているウィンドウは開かれます。Windows that are open in the default window layout are opened.

カスタム レイアウトの作成と保存Create and save custom layouts

Visual Studio を使用すると、最大 10 個のカスタム ウィンドウ レイアウトを保存し、すばやく切り替えることができます。Visual Studio enables you to save up to 10 custom window layouts and quickly switch between them. 次の手順では、ドッキングされた状態およびフローティング状態のツール ウィンドウを使用して複数のモニターを活用するためのカスタム レイアウトの作成、保存、呼び出し、管理方法を説明します。The following steps show how to create, save, invoke, and manage custom layouts that take advantage of multiple monitors with both docked and floating tool windows.

最初に、2 つのプロジェクトがあるテスト ソリューションを作成し、それぞれに最適な別個のレイアウトを設定します。First, create a test solution that has two projects, each with a different optimal layout.

UI プロジェクトの作成とレイアウトのカスタマイズCreate a UI project and customize the layout
  1. [新しいプロジェクト] ダイアログで、C# WPF デスクトップ アプリケーションを作成し、任意の名前を付けます。In the New Project dialog, create a C# WPF Desktop Application and call it whatever you like. これがユーザー インターフェイスを操作するプロジェクトであることを装うため、デザイナー ウィンドウのスペースを最大にして、その他のツール ウィンドウを邪魔にならない所に移動したいと思います。Pretend that this is the project where we'll be working on the user interface, so we want to maximize the space for the designer window and move other tool windows out of the way.

  2. 複数のモニターがある場合は、 ソリューション エクスプローラー ウィンドウと プロパティ ウィンドウを 2 台目のモニターに移動させます。If you have multiple monitors, pull the Solution Explorer window and the Properties window over to your second monitor. シングル モニター システムでは、デザイナー以外のウィンドウはすべて閉じてください。On a single monitor system, try closing all the windows except the designer.

  3. Ctrl + Alt + X キーを押してツールボックスを表示します。Press Ctrl + Alt + X to display the Toolbox. ウィンドウがドッキングされている場合は、いずれかのモニターの配置したい場所でウィンドウがフローティングするように、ウィンドウをドラッグします。If the window is docked, drag it so that it floats somewhere where you'd like to position it, on either monitor.

  4. F5 キーを押して Visual Studio をデバッグ モードにします。Press F5 to put Visual Studio into debugging mode. 自動変数、呼び出しスタック、出力の各デバッグ ウィンドウを任意の場所に移動します。Adjust the position of the Autos, Call Stack and Output debugging windows the way you want them. 作成するレイアウトは、編集モードとデバッグ モードの両方に適用されます。The layout you are about to create will apply to both editing mode and debugging mode.

  5. デバッグ モードと編集モードの両方でレイアウトが希望どおりになったら、[メイン メニュー] で [ウィンドウ]、[ウィンドウのレイアウトを保存] の順にクリックします。When your layouts in both debugging mode and editing mode are how you want them, from the main menu choose Window > Save Window Layout. このレイアウトを "デザイナー" と呼びます。Call this layout "Designer."

    新しいレイアウトには、Ctrl + Alt + 1 ~ 0 キーの予約リストから次のキーボードのショートカットが割り当てられることに注意してください。Note that your new layout is assigned the next Keyboard shortcut from the reserved list of Ctrl + Alt + 1...0.

データベース プロジェクトとレイアウトの作成Create a database project and layout
  1. 新しい SQL Server データベース プロジェクトをソリューションに追加します。Add a new SQL Server Database project to the solution.

  2. ソリューション エクスプローラーで新しいプロジェクトを右クリックし、 [オブジェクト エクスプローラーで表示]を選択します。Right-click on the new project in Solution Explorer and choose View in Object Explorer. SQL Server オブジェクト エクスプローラー ウィンドウが表示され、データベース内のテーブル、ビュー、その他のオブジェクトにアクセスできるようになります。This displays the SQL Server Object Explorer window, which enables you to access tables, views and other objects in your database. このウィンドウは、フローティングさせることも、ドッキングしたままにすることもできます。You can either float this window or leave it docked. もう一方のツール ウィンドウを、好きなように調整します。Adjust the other tool windows the way you want them. よりリアルにするために実際のデータベースを追加することもできますが、このチュートリアルでは必要ありません。For added realism, you can add an actual database, but it's not necessary for this walkthrough.

  3. レイアウトが希望どおりになったら、[メイン メニュー] から、[ウィンドウ]、[ウィンドウ レイアウトの保存] の順にクリックします。When your layout is how you want it, from the main menu choose Window > Save Window Layout. このレイアウトを "DB プロジェクト" と呼びます。Call this layout "DB Project." (このプロジェクトではデバッグ モードのレイアウトは扱いません。)(We won't bother with a debug mode layout for this project.)

レイアウトの切り替えSwitch between the layouts
  1. レイアウトを切り替えるには、キーボードのショートカットを使うか、[メイン メニュー] で [ウィンドウ]、[ウィンドウ レイアウトの適用] の順にクリックします。To switch between layouts, use the Keyboard shortcuts, or from the main menu choose Window > Apply Window Layout.

    ウィンドウ レイアウト メニューの適用Apply window layout menu

    UI のレイアウトを適用後、編集モードとデバッグ モードの両方でレイアウトがどのように保持されているかに注意してください。After applying the UI layout, note how the layout is preserved both in editing mode and in debug mode.

    仕事場ではマルチ モニターがセットアップされ、自宅にはシングル モニターのノート PC がある場合、それぞれのコンピューター向けに最適化されたレイアウトを作成できます。If you have a multi monitor setup at work and a single monitor laptop at home, you can create layouts that are optimized for each machine.

    マルチモニターのレイアウトをシングルモニターのシステムに適用すると、2 台目のモニターに配置したフローティング ウィンドウが Visual Studio ウィンドウの背後に隠れるようになります。Note: If you apply a multi-monitor layout on a single-monitor system, the floating windows that you placed on the second monitor will now be hidden behind the Visual Studio window. Alt キーを押しながら Tab キーを押すと、背後にあるウィンドウを前に出すことができます。後で Visual Studio を複数のモニターで開く場合、レイアウトを再度適用して、ウィンドウを指定された場所に復元してください。You can bring these windows to the front by pressing Alt + Tab. If you later open Visual Studio with multiple monitors, you can restore the windows to their specified positions by re-applying the layout.

レイアウトの管理とローミングManage and roam your layouts
  1. [ウィンドウ]、[ウィンドウ レイアウトの管理] の順に選択し、カスタム レイアウトの削除、名前変更、または順序変更を行えます。You can remove, rename or reorder your custom layout by choosing Window > Manage Window Layouts. レイアウトを移動すると、キー バインドがリスト内の新しい位置を反映するように自動調整されます。If you move a layout, the key binding is automatically adjusted to reflect the new position in the list. バインディングは変更できないため、同時に保存できるレイアウトは最大 10 個です。The bindings cannot be otherwise modified, and so you can store a maximum of 10 layouts at a time.

    ウィンドウ レイアウトの管理Manage window layouts

    どのキーボード ショートカットがどのレイアウトに割り当てられているかを確認するには、[ウィンドウ]、[ウィンドウ レイアウトの適用] を選択します。To remind yourself which keyboard shortcut is assigned to which layout, choose Window > Apply Window Layout.

    これらのレイアウトは、Visual Studio のエディション間だけでなく、別のコンピューターの Blend インスタンス間や、任意の Express エディションからその他の Express 組織に自動的にローミングされます。These layouts automatically roam between Visual Studio editions, and also between Blend instances on separate machines, and from any Express edition to any other Express organization. ただし、レイアウトは Visual Studio、Blend、Express の間ではローミングしません。However, layouts do not roam across Visual Studio, Blend and Express.

方法: IDE 内で移動するHow to: Move Around in the IDE