Visual Studio の既定のキーボード ショートカット

Visual Studio のさまざまなコマンドやウィンドウには、該当するキーボード ショートカットを選択することでアクセスできます。 このページでは、Visual Studio のインストール時に選択できる 全般 プロファイルの既定のコマンド ショートカットの一覧を示します。 選択したプロファイルにかかわらず、 [オプション] ダイアログ ボックスを開き、 [環境] ノードを展開して、 [キーボード] を選択することで、コマンドの ショートカットを確認することができます。 また、別のショートカット キーを任意のコマンドに割り当てることで、ショートカット キーをカスタマイズすることもできます。

一般的なキーボード ショートカットの一覧、およびその他の生産性向上情報については、以下をご覧ください。

Visual Studio でのアクセシビリティについて詳しくは、「アクセシビリティのヒントとテクニック」および「方法: キーボード主体で操作する」を参照してください。

印刷可能なショートカット チートシート

こちらをクリックして Visual Studio の印刷可能なキーボード ショートカット チートシートを入手してください。

印刷可能なキーボード ショートカットのチートシート。

このセクションのすべてのショートカットは、特に指定がない限り、グローバルに適用されます。 "全体" コンテキストは、ショートカットが Visual Studio のすべてのツール ウィンドウで適用されることを意味します。

注意

[オプション] ダイアログ ボックスを開き、[環境] ノードを展開して、[キーボード] を選択することで、任意のコマンドの ショートカットを調べることができます。

コマンド キーボード ショートカット コマンド ID
ソリューションのビルド Ctrl + Shift + B Build.BuildSolution
キャンセル Ctrl + Break Build.Cancel
Compile Ctrl + F7 Build.Compile
ソリューションでコード分析を実行 Alt + F11 Build.RunCodeAnalysisonSolution
コマンド キーボード ショートカット [特殊なコンテキスト] コマンド ID
関数でブレークする Ctrl + B Debug.BreakatFunction
すべて中断する Ctrl + Alt + Break Debug.BreakAll
すべてのブレークポイントを削除する Ctrl + Shift + F9 Debug.DeleteAllBreakpoints
例外 Ctrl + Alt + E Debug.Exceptions
クイック ウォッチ Ctrl + Alt + Q

または Shift + F9
Debug.QuickWatch
やり直し Ctrl + Shift + F5 Debug.Restart
[カーソル行の前まで実行] Ctrl + F10 Debug.RunToCursor
次のステートメントの設定 Ctrl + Shift + F10 Debug.SetNextStatement
開始 F5 Debug.Start
デバッグなしで開始 Ctrl + F5 Debug.StartWithoutDebugging
ステップ イン F11 Debug.StepInto
ステップ アウト Shift + F11 Debug.StepOut
ステップ オーバー F10 Debug.StepOver
デバッグの停止 Shift + F5 Debug.StopDebugging
ブレークポイントを設定/解除する F9 Debug.ToggleBreakpoint
コマンド キーボード ショートカット [特殊なコンテキスト] コマンド ID
改行 Enter [テキスト エディター、レポート デザイナー、Windows フォーム デザイナー]

または Shift + Enter [テキスト エディター]
Edit.BreakLine
定義に縮小 Ctrl + MCtrl + O [テキスト エディター] Edit.CollapseToDefinitions
選択範囲のコメント Ctrl + KCtrl + C [テキスト エディター] Edit.CommentSelection
ワードを完成する Alt + → [テキスト エディター、ワークフロー デザイナー]

または Ctrl + Space [テキスト エディター、ワークフロー デザイナー]

または Ctrl + KW [ワークフロー デザイナー]

または Ctrl + K、Ctrl + W [ワークフロー デザイナー]
Edit.CompleteWord
コピー Ctrl + C

または Ctrl + Insert
Edit.Copy
[切り取り] Ctrl + X

または Shift + Delete
Edit.Cut
削除 Delete [チーム エクスプローラー]

または Shift + Delete [シーケンス図、UML アクティビティ図、レイヤー図]

または Ctrl + Delete [クラス図]
Edit.Delete
Find Ctrl + F Edit.Find
[すべての参照の検索] Shift+F12 Edit.FindAllReferences
フォルダーを指定して検索する Ctrl + Shift + F Edit.FindinFiles
次を検索 F3 Edit.FindNext
次の選択項目を検索 Ctrl + F3 Edit.FindNextSelected
ドキュメントのフォーマット Ctrl + K、Ctrl + D [テキスト エディター] Edit.FormatDocument
選択範囲のフォーマット Ctrl + K、Ctrl + F [テキスト エディター] Edit.FormatSelection
移動 Ctrl + G Edit.GoTo
宣言に移動 Ctrl + F12 Edit.GoToDeclaration
定義へ移動 F12 Edit.GoToDefinition
検索コンボ ボックスに移動 Ctrl + D Edit.GoToFindCombo
次の場所へ移動 F8 Edit.GoToNextLocation
スニペットの挿入 Ctrl + KCtrl + X Edit.InsertSnippet
[挿入] タブ Tab [レポート デザイナー、Windows フォーム デザイナー、テキスト エディター] Edit.InsertTab
行の切り取り Ctrl + L [テキスト エディター] Edit.LineCut
1 行下まで列を拡張 Shift + Alt + ↓ [テキスト エディター] Edit.LineDownExtendColumn
上に 1 行挿入 Ctrl + Enter [テキスト エディター] Edit.LineOpenAbove
メンバーの一覧を表示する Ctrl + J [テキスト エディター、ワークフロー デザイナー]

または Ctrl + K、Ctrl + L [ワークフロー デザイナー]

または Ctrl + K、L [ワークフロー デザイナー]
Edit.ListMembers
移動 Ctrl + , Edit.NavigateTo
ファイルを開く Ctrl + Shift + G Edit.OpenFile
上書きモード Insert [テキスト エディター] Edit.OvertypeMode
パラメーター ヒント Ctrl + Shift + Space [テキスト エディター、ワークフロー デザイナー]

または Ctrl + K、Ctrl + P [ワークフロー デザイナー]

または Ctrl + K、P [ワークフロー デザイナー]
Edit.ParameterInfo
貼り付け Ctrl + V

または Shift + Insert
Edit.Paste
定義をここに表示 Alt + F12 [テキスト エディター] Edit.PeekDefinition
やり直し Ctrl + Y

または Shift + Alt + Backspace

または Ctrl + Shift + Z
Edit.Redo
Replace Ctrl + H Edit.Replace
すべて選択する Ctrl + A Edit.SelectAll
現在の単語を選択 Ctrl + W [テキスト エディター] Edit.SelectCurrentWord
選択範囲の取り消し Esc [テキスト エディター、レポート デザイナー、設定デザイナー、Windows フォーム デザイナー、マネージド リソース エディター] Edit.SelectionCancel
ブロックの挿入 Ctrl + K、Ctrl + S Edit.SurroundWith
タブを左へ Shift + Tab [テキスト エディター、レポート デザイナー、Windows フォーム エディター] Edit.TabLeft
すべてのアウトラインの切り替え Ctrl + M、Ctrl + L [テキスト エディター] Edit.ToggleAllOutlining
ブックマークの設定/解除 Ctrl + K、Ctrl + K [テキスト エディター] Edit.ToggleBookmark
完了モードの切り替え Ctrl + Alt + Space [テキスト エディター] Edit.ToggleCompletionMode
アウトラインの展開/縮小 Ctrl + M、Ctrl + M [テキスト エディター] Edit.ToggleOutliningExpansion
選択範囲のコメントを解除 Ctrl + K、Ctrl + U [テキスト エディター] Edit.UncommentSelection
元に戻す Ctrl + Z

または Alt + Backspace
Edit.Undo
単語の最後まで削除 Ctrl + Delete [テキスト エディター] Edit.WordDeleteToEnd
単語の最初まで削除 Ctrl + Backspace [テキスト エディター] Edit.WordDeleteToStart
コマンド キーボード ショートカット [特殊なコンテキスト] コマンド ID
終了 Alt + F4 File.Exit
新しいファイル Ctrl + N File.NewFile
新しいプロジェクト Ctrl + Shift + N File.NewProject
新しい Web サイト Shift + Alt + N File.NewWebSite
ファイルを開く Ctrl + O File.OpenFile
プロジェクトを開く Ctrl + Shift + O File.OpenProject
Web サイトを開く Shift + Alt + O File.OpenWebSite
[名前の変更] F2 [チーム エクスプローラー] File.Rename
すべて保存する Ctrl + Shift + S File.SaveAll
選択されたファイルを上書き保存 Ctrl + S File.SaveSelectedItems
ブラウザーで表示 Ctrl + Shift + W File.ViewinBrowser
コマンド キーボード ショートカット [特殊なコンテキスト] コマンド ID
既存の項目を追加する Shift + Alt + A Project.AddExistingItem
新しい項目を追加する Ctrl + Shift + A Project.AddNewItem
コマンド キーボード ショートカット [特殊なコンテキスト] コマンド ID
メソッドの抽出 Ctrl + R、Ctrl + M Refactor.ExtractMethod
コマンド キーボード ショートカット [特殊なコンテキスト] コマンド ID
プロセスにアタッチする Ctrl + Alt + P Tools.AttachtoProcess
コマンド キーボード ショートカット [特殊なコンテキスト] コマンド ID
クラス ビュー Ctrl + Shift + C View.ClassView
ラベルの編集 F2 View.EditLabel
エラー一覧 Ctrl + \、Ctrl + E

または Ctrl + \、E
View.ErrorList
後ろに移動する Ctrl + - View.NavigateBackward
次に進む Ctrl + Shift + - View.NavigateForward
オブジェクト ブラウザー Ctrl + Alt + J View.ObjectBrowser
出力 Ctrl + Alt + O View.Output
[プロパティ] ウィンドウ F4 View.PropertiesWindow
更新 F5 [チーム エクスプローラー] View.Refresh
サーバー エクスプローラー Ctrl + Alt + S View.ServerExplorer
スマート タグの表示 Ctrl + .

または Shift + Alt + F10 [HTML エディター デザイン ビュー]
View.ShowSmartTag
ソリューション エクスプローラー Ctrl + Alt + L View.SolutionExplorer
TFS Team Explorer Ctrl + \、Ctrl + M View.TfsTeamExplorer
ツールボックス Ctrl + Alt + X View.Toolbox
コードを表示 Enter [クラス図]

または F7 [設定デザイナー]
View.ViewCode
ビュー デザイナー Shift + F7 [HTML エディター ソース ビュー] View.ViewDesigner
コマンド キーボード ショートカット [特殊なコンテキスト] コマンド ID
ドキュメント ウィンドウをアクティブにする Esc Window.ActivateDocumentWindow
ドキュメント ウィンドウを閉じる Ctrl + F4 Window.CloseDocumentWindow
次のドキュメント ウィンドウ Ctrl + F6 Window.NextDocumentWindow
次のドキュメント ウィンドウ ナビゲーション Ctrl + Tab Window.NextDocumentWindowNav
次の分割ペイン F6 Window.NextSplitPane

グローバル ショートカット

以下のキーボード ショートカットは グローバル です。つまり、Visual Studio ウィンドウにフォーカスがある場合にそれらを使用できます。

解析

コマンド キーボード ショートカット コマンド ID
後ろに移動する Shift + Alt + 3 Analyze.NavigateBackward
次に進む Shift + Alt + 4 Analyze.NavigateForward

アーキテクチャ

コマンド キーボード ショートカット コマンド ID
新しいダイアグラム Ctrl + \、Ctrl + N Architecture.NewDiagram

ビルド

コマンド キーボード ショートカット コマンド ID
選択範囲のビルド Ctrl + B (Visual Studio 2019) Build.BuildSelection
ソリューションのビルド Ctrl + Shift + B Build.BuildSolution
キャンセル Ctrl + Break Build.Cancel
Compile Ctrl + F7 Build.Compile
ソリューションでコード分析を実行 Alt + F11 Build.RunCodeAnalysisonSolution

クラス ビュー コンテキスト メニュー

コマンド キーボード ショートカット コマンド ID
プロパティ Alt + Enter ClassViewContextMenus.ClassViewMultiselectProjectreferencesItems.Properties

デバッグ

コマンド キーボード ショートカット コマンド ID
コード変更を適用 Alt + F10 Debug.ApplyCodeChanges
プロセスにアタッチする Ctrl + Alt + P Debug.AttachtoProcess
Autos Ctrl + Alt + V、A Debug.Autos
すべて中断する Ctrl + Alt + Break Debug.BreakAll
ブレークポイント Ctrl + Alt + B Debug.Breakpoints
[呼び出し履歴] Ctrl + Alt + C Debug.CallStack
すべてのブレークポイントを削除する Ctrl + Shift + F9 Debug.DeleteAllBreakpoints
Launch Alt + F2 Debug.DiagnosticsHub.Launch
逆アセンブリ Ctrl + Alt + D Debug.Disassembly
DOM Explorer Ctrl + Alt + V、D Debug.DOMExplorer
ブレークポイントを有効にする Ctrl + F9 Debug.EnableBreakpoint
例外 Ctrl + Alt + E Debug.Exceptions
関数のブレークポイント Ctrl + K、B (Visual Studio 2019)
Ctrl + B (Visual Studio 2017)
Debug.FunctionBreakpoint
前の呼び出しまたは IntelliTrace イベントへ移動 Ctrl + Shift + F11 Debug.GoToPreviousCallorIntelliTraceEvent
診断の開始 Alt + F5 Debug.Graphics.StartDiagnostics
即時 Ctrl + Alt + I Debug.Immediate
IntelliTrace の呼び出し Ctrl + Alt + Y、T Debug.IntelliTraceCalls
IntelliTrace イベント Ctrl + Alt + Y、F Debug.IntelliTraceEvents
JavaScript コンソール Ctrl + Alt + V、C Debug.JavaScriptConsole
ローカル Ctrl + Alt + V、L Debug.Locals
プロセス コンボ Ctrl + 数字 5 Debug.LocationToolbar.ProcessCombo
スタック フレーム コンボ Ctrl + 数字 7 Debug.LocationToolbar.StackFrameCombo
スレッド コンボ Ctrl + 数字 6 Debug.LocationToolbar.ThreadCombo
現在のスレッドのフラグ付きの状態を切り替える Ctrl + 数字 8 Debug.LocationToolbar.ToggleCurrentThreadFlaggedState
フラグが設定されたスレッドを切り替える Ctrl + 数字 9 Debug.LocationToolbar.ToggleFlaggedThreads
メモリ 1 Ctrl + Alt + M、1 Debug.Memory1
メモリ 2 Ctrl + Alt + M、2 Debug.Memory2
メモリ 3 Ctrl + Alt + M、3 Debug.Memory3
メモリ 4 Ctrl + Alt + M、4 Debug.Memory4
モジュール Ctrl + Alt + U Debug.Modules
並列スタック Ctrl + Shift + D、S Debug.ParallelStacks
並列ウォッチ 1 Ctrl + Shift + D、1 Debug.ParallelWatch1
並列ウォッチ 2 Ctrl + Shift + D、2 Debug.ParallelWatch2
並列ウォッチ 3 Ctrl + Shift + D、3 Debug.ParallelWatch3
並列ウォッチ 4 Ctrl + Shift + D、4 Debug.ParallelWatch4
プロセス Ctrl + Alt + Z Debug.Processes
クイック ウォッチ Shift + F9 または Ctrl + Alt + Q Debug.QuickWatch
プロセスに再アタッチする Shift + Alt + P Debug.ReattachtoProcess
Windows アプリケーションの更新 Ctrl + Shift + R Debug.RefreshWindowsapp
レジスタ Ctrl + Alt + G Debug.Registers
やり直し Ctrl + Shift + F5 Debug.Restart
[カーソル行の前まで実行] Ctrl + F10 Debug.RunToCursor
次のステートメントの設定 Ctrl + Shift + F10 Debug.SetNextStatement
コード マップの呼び出し履歴を表示する Ctrl + Shift + ` Debug.ShowCallStackonCodeMap
次のステートメントを表示する Alt + Num * Debug.ShowNextStatement
開始 F5 Debug.Start
Windows Phone アプリケーション分析の開始 Alt + F1 Debug.StartWindowsPhoneApplicationAnalysis
デバッグなしで開始 Ctrl + F5 Debug.StartWithoutDebugging
ステップ イン F11 Debug.StepInto
現在のプロセスにステップ インする Ctrl + Alt + F11 Debug.StepIntoCurrentProcess
関数にステップ イン Shift + Alt + F11 Debug.StepIntoSpecific
ステップ アウト Shift + F11 Debug.StepOut
現在のプロセスにステップ アウトする Ctrl + Shift + Alt + F11 Debug.StepOutCurrentProcess
ステップ オーバー F10 (デバッグ時:ステップ オーバー操作を実行する) Debug.StepOver
ステップ オーバー F10 (デバッグ以外:デバッグを開始し、ユーザー コードの最初の行で停止する) Debug.StepOver
現在のプロセスにステップ オーバーする Ctrl + Alt + F10 Debug.StepOverCurrentProcess
デバッグの停止 Shift + F5 Debug.StopDebugging
パフォーマンス分析の停止 Shift + Alt + F2 Debug.StopPerformanceAnalysis
タスク Ctrl + Shift + D、K Debug.Tasks
Threads Ctrl + Alt + H Debug.Threads
ブレークポイントを設定/解除する F9 Debug.ToggleBreakpoint
逆アセンブリの切り替え Ctrl + F11 Debug.ToggleDisassembly
ウォッチ 1 Ctrl + Alt + W、1 Debug.Watch1
ウォッチ 2 Ctrl + Alt + W、2 Debug.Watch2
ウォッチ 3 Ctrl + Alt + W、3 Debug.Watch3
ウォッチ 4 Ctrl + Alt + W、4 Debug.Watch4

デバッガー コンテキスト メニュー

コマンド キーボード ショートカット コマンド ID
削除 Alt + F9、D DebuggerContextMenus.BreakpointsWindow.Delete
逆アセンブルを表示 Alt + F9、A DebuggerContextMenus.BreakpointsWindow.GoToDisassembly
ソース コードへ移動 Alt + F9、S DebuggerContextMenus.BreakpointsWindow.GoToSourceCode

診断ハブ

コマンド キーボード ショートカット コマンド ID
収集を停止する Ctrl + Alt + F2 DiagnosticsHub.StopCollection

編集

コマンド キーボード ショートカット コマンド ID
コピー Ctrl + C

or

Ctrl + Ins
Edit.Copy
[切り取り] Ctrl + X

or

Shift + Delete
Edit.Cut
クリップボード リングの切り替え Ctrl + Shift + V

or

Ctrl + Shift + Ins
Edit.CycleClipboardRing
削除 削除 Edit.Delete
複製 Ctrl + D Edit.Duplicate
Find Ctrl + F Edit.Find
[すべての参照の検索] Shift+F12 Edit.FindAllReferences
フォルダーを指定して検索する Ctrl + Shift + F Edit.FindinFiles
次を検索 F3 Edit.FindNext
次の選択項目を検索 Ctrl + F3 Edit.FindNextSelected
前を検索 Shift + F3 Edit.FindPrevious
前の選択項目を検索 Ctrl + Shift + F3 Edit.FindPreviousSelected
メソッドの生成 Ctrl + K、Ctrl + M Edit.GenerateMethod
移動 Ctrl + G Edit.GoTo
すべてに移動 Ctrl +、 または Ctrl + T Edit.GoToAll
宣言に移動 Ctrl + F12 Edit.GoToDeclaration
定義へ移動 F12 Edit.GoToDefinition
メンバーに移動する Ctrl + 1、Ctrl + M または Ctrl + 1、M または Alt +\ Edit.GoToMember
次の場所へ移動 F8 ([エラー一覧] または [出力] ウィンドウ内の次のエラー) Edit.GoToNextLocation
前の場所へ移動 Shift + F8 ([エラー一覧] または [出力] ウィンドウ内の前のエラー) Edit.GoToPrevLocation
スニペットの挿入 Ctrl + K、Ctrl + X Edit.InsertSnippet
コントロールを下に移動 Ctrl + ↓ Edit.MoveControlDown
コントロールをグリッドで下へ移動 ↓ キー Edit.MoveControlDownGrid
コントロールを左に移動 Ctrl + ← Edit.MoveControlLeft
コントロールをグリッドで左へ移動 ← キー Edit.MoveControlLeftGrid
コントロールを右に移動 Ctrl + → Edit.MoveControlRight
コントロールをグリッドで右へ移動 → キー Edit.MoveControlRightGrid
コントロールを上へ移動 Ctrl + ↑ Edit.MoveControlUp
コントロールをグリッドで上へ移動 ↑ キー Edit.MoveControlUpGrid
次のブックマークに移動する Ctrl + K、Ctrl + N Edit.NextBookmark
フォルダー内の次のブックマーク Ctrl + Shift + K、Ctrl + Shift + N Edit.NextBookmarkInFolder
ファイルを開く Ctrl + Shift + G (カーソルの下のファイル名が開きます) Edit.OpenFile
貼り付け Ctrl + V

or

Shift + Ins
Edit.Paste
前のブックマークに移動する Ctrl + K、Ctrl + P Edit.PreviousBookmark
フォルダー内の前のブックマーク Ctrl + Shift + K、Ctrl + Shift + P Edit.PreviousBookmarkInFolder
クイック シンボル検索 Shift + Alt + F12 Edit.QuickFindSymbol
やり直し Ctrl + Y

or

Ctrl + Shift + Z

or

Shift + Alt + Backspace
Edit.Redo
リモート参照の更新 Ctrl + Shift + J Edit.RefreshRemoteReferences
Replace Ctrl + H Edit.Replace
フォルダーを指定して置換 Ctrl + Shift + H Edit.ReplaceinFiles
すべて選択する Ctrl + A Edit.SelectAll
次のコントロールを選択 Tab Edit.SelectNextControl
前のコントロールを選択 Shift + Tab Edit.SelectPreviousControl
タイル グリッドの表示 Enter Edit.ShowTileGrid
コントロール サイズを下に移動 Ctrl + Shift + ↓ Edit.SizeControlDown
コントロール サイズをグリッドで下に移動 Shift + ↓ Edit.SizeControlDownGrid
コントロール サイズを左に移動 Ctrl + Shift + ← Edit.SizeControlLeft
コントロール サイズをグリッドで左に移動 Shift + ← Edit.SizeControlLeftGrid
コントロール サイズを右に移動 Ctrl + Shift + → Edit.SizeControlRight
コントロール サイズをグリッドで右に移動 Shift + → Edit.SizeControlRightGrid
コントロール サイズを上に移動 Ctrl + Shift + ↑ Edit.SizeControlUp
コントロール サイズをグリッドで上に移動 Shift + ↑ Edit.SizeControlUpGrid
検索を中止する Alt + F3、S Edit.StopSearch
ブロックの挿入 Ctrl + K、Ctrl + S Edit.SurroundWith
元に戻す Ctrl + Z

or

Alt + Backspace
Edit.Undo

エディター コンテキスト メニュー

コマンド キーボード ショートカット コマンド ID
ブレークポイント条件 Alt + F9、C EditorContextMenus.CodeWindow.Breakpoint.BreakpointConditions
ブレークポイント ラベルの編集 Alt + F9、L EditorContextMenus.CodeWindow.Breakpoint.BreakpointEditlabels
一時ブレークポイントの挿入 Shift + Alt + F9、T EditorContextMenus.CodeWindow.Breakpoint.InsertTemporaryBreakpoint
項目の表示 Ctrl + ` EditorContextMenus.CodeWindow.CodeMap.ShowItem
実行 Ctrl + Alt + F5 EditorContextMenus.CodeWindow.Execute
ビューに移動 Ctrl + M、Ctrl + G EditorContextMenus.CodeWindow.GoToView
ヘッダー/コード ファイルの切り替え Ctrl + K、Ctrl + O (文字 'O') EditorContextMenus.CodeWindow.ToggleHeaderCodeFile
呼び出し階層の表示 Ctrl + K、Ctrl + T

or

Ctrl + K、T
EditorContextMenus.CodeWindow.ViewCallHierarchy

ファイル

コマンド キーボード ショートカット コマンド ID
終了 Alt + F4 File.Exit
新しいファイル Ctrl + N File.NewFile
新しいプロジェクト Ctrl + Shift + N File.NewProject
新しい Web サイト Shift + Alt + N File.NewWebSite
ファイルを開く Ctrl + O (文字 'O') File.OpenFile
プロジェクトを開く Ctrl + Shift + O (文字 'O') File.OpenProject
Web サイトを開く Shift + Alt + O (文字 'O') File.OpenWebSite
印刷 Ctrl + P File.Print
すべて保存する Ctrl + Shift + S File.SaveAll
選択されたファイルを上書き保存 Ctrl + S File.SaveSelectedItems
ブラウザーで表示 Ctrl + Shift + W File.ViewinBrowser

ヘルプ

コマンド キーボード ショートカット コマンド ID
ヘルプ コンテンツの追加と削除 Ctrl + Alt + F1 Help.AddandRemoveHelpContent
F1 ヘルプ F1 Help.F1Help
ヘルプの表示 Ctrl + F1 Help.ViewHelp
ウィンドウ ヘルプ Shift + F1 Help.WindowHelp

ロード テスト

コマンド キーボード ショートカット コマンド ID
カウンター ペインに移動 Ctrl + R、Q LoadTest.JumpToCounterPane

その他のコンテキスト メニュー

コマンド キーボード ショートカット コマンド ID
新しいダイアグラムの追加 [挿入] OtherContextMenus.MicrosoftDataEntityDesignContext.AddNewDiagram

プロジェクト

コマンド キーボード ショートカット コマンド ID
既存の項目を追加する Shift + Alt + A Project.AddExistingItem
新しい項目を追加する Ctrl + Shift + A Project.AddNewItem
クラス ウィザード Ctrl + Shift + X Project.ClassWizard
オーバーライド Ctrl + Alt + Ins Project.Override
変更のプレビュー Alt +; を押してから Alt + C Project.Previewchanges
選択したファイルの発行 Alt +; を押してから Alt + P Project.Publishselectedfiles
選択したファイルをサーバーから置換 Alt +; を押してから Alt + R Project.Replaceselectedfilesfromserver

プロジェクトとソリューション コンテキスト メニュー

コマンド キーボード ショートカット コマンド ID
下へ移動 Alt + ↓ ProjectandSolutionContextMenus.Item.MoveDown
上へ移動 Alt + ↑ ProjectandSolutionContextMenus.Item.MoveUp

リファクター

コマンド キーボード ショートカット コマンド ID
フィールドのカプセル化 Ctrl + R、Ctrl + E Refactor.EncapsulateField
インターフェイスの抽出 Ctrl + R、Ctrl + I Refactor.ExtractInterface
メソッドの抽出 Ctrl + R、Ctrl + M Refactor.ExtractMethod
パラメーターの削除 Ctrl + R、Ctrl + V Refactor.RemoveParameters
[名前の変更] Ctrl + R、Ctrl + R Refactor.Rename
パラメーター順序の再変更 Ctrl + R、Ctrl + O (文字 'O') Refactor.ReorderParameters

ソリューション エクスプローラー

コマンド キーボード ショートカット コマンド ID
開いているファイル フィルター Ctrl + [O (文字 'O')

or

Ctrl + [Ctrl + O (文字 'O')
SolutionExplorer.OpenFilesFilter
保留中の変更フィルター Ctrl + [P

or

Ctrl + [Ctrl + P
SolutionExplorer.PendingChangesFilter
アクティブ ドキュメントとの同期 Ctrl + [S

or

Ctrl + [Ctrl + S
SolutionExplorer.SyncWithActiveDocument

チーム

コマンド キーボード ショートカット コマンド ID
Git ブランチへの移動 Ctrl + 0 (ゼロ)、Ctrl + N

or

Ctrl + 0、N
Team.Git.GoToGitBranches
Git 変更へ移動 Ctrl + 0 (ゼロ)、Ctrl + G

or

Ctrl + 0、G
Team.Git.GoToGitChanges
Git コミットへの移動 Ctrl + 0 (ゼロ)、Ctrl + O (文字 'O')

or

Ctrl + 0、O
Team.Git.GoToGitCommits
チーム エクスプローラーの検索 Ctrl + ' Team.TeamExplorerSearch

Team Foundation コンテキスト メニュー

コマンド キーボード ショートカット コマンド ID
ビルドに移動 Ctrl + 0 (ゼロ)、Ctrl + B

or

Ctrl + 0、B
TeamFoundationContextMenus.Commands.GoToBuilds
接続に移動 Ctrl + 0 (ゼロ)、Ctrl + C

or

Ctrl + 0、C
TeamFoundationContextMenus.Commands.GoToConnect
ドキュメントに移動 Ctrl + 0 (ゼロ)、Ctrl + D

or

Ctrl + 0、D
TeamFoundationContextMenus.Commands.GoToDocuments
ホームに戻る Ctrl + 0 (ゼロ)、Ctrl + H

or

Ctrl + 0、H
TeamFoundationContextMenus.Commands.GoToHome
担当作業に移動 Ctrl + 0 (ゼロ)、Ctrl + M

or

Ctrl + 0、M
TeamFoundationContextMenus.Commands.GoToMyWork
保留中の変更に移動 Ctrl + 0 (ゼロ)、Ctrl + P

or

Ctrl + 0、P
TeamFoundationContextMenus.Commands.GoToPendingChanges
レポートに移動 Ctrl + 0 (ゼロ)、Ctrl + R

or

Ctrl + 0、R
TeamFoundationContextMenus.Commands.GoToReports
設定に移動 Ctrl + 0 (ゼロ)、Ctrl + S

or

Ctrl + 0、S
TeamFoundationContextMenus.Commands.GoToSettings
Web アクセスに移動 Ctrl + 0 (ゼロ)、Ctrl + A

or

Ctrl + 0、A
TeamFoundationContextMenus.Commands.GoToWebAccess
作業項目へ移動 Ctrl + 0 (ゼロ)、Ctrl + W

or

Ctrl + 0、W
TeamFoundationContextMenus.Commands.GoToWorkItems

テスト

コマンド キーボード ショートカット コマンド ID
コード化された UI テスト ビルダーの使用 Ctrl + \、Ctrl + C Test.UseCodedUITestBuilder
既存の操作の記録の使用 Ctrl + \、Ctrl + A Test.UseExistingActionRecording

テスト エクスプローラー

コマンド キーボード ショートカット コマンド ID
すべてのテストをデバッグする Ctrl + R、Ctrl + A TestExplorer.DebugAllTests
コンテキスト内のすべてのテストをデバッグする Ctrl + R、Ctrl + T TestExplorer.DebugAllTestsInContext
直前の実行をデバッグ Ctrl + R、D TestExplorer.DebugLastRun
直前の実行の繰り返し Ctrl + R、L TestExplorer.RepeatLastRun
すべてのテストを実行する Ctrl + R、A TestExplorer.RunAllTests
コンテキスト内のすべてのテストを実行する Ctrl + R、T TestExplorer.RunAllTestsInContext
テスト エクスプローラーの表示 Ctrl + E、T TestExplorer.ShowTestExplorer
タブを開く Ctrl + E、L LiveUnitTesting.OpenTab
コード カバレッジの結果 Ctrl + E、C Test.CodeCoverageResults

ツール

コマンド キーボード ショートカット コマンド ID
プロセスにアタッチする Ctrl + Alt + P Tools.AttachtoProcess
コード スニペット マネージャー Ctrl + K、Ctrl + B Tools.CodeSnippetsManager
GC の強制 Ctrl + Shift + Alt + F12、Ctrl + Shift + Alt + F12 Tools.ForceGC

表示

コマンド キーボード ショートカット コマンド ID
すべてのウィンドウ Shift + Alt + M View.AllWindows
アーキテクチャ エクスプローラー Ctrl + \、Ctrl + R View.ArchitectureExplorer
移動 Alt + 左矢印 (テキスト エディターでの View.NavigateBackward の機能とは異なる) View.Backward
ブックマーク ウィンドウ Ctrl + K、Ctrl + W View.BookmarkWindow
次に移動 Ctrl + Shift + 数字 1 View.BrowseNext
前に移動 Ctrl + Shift + 数字 2 View.BrowsePrevious
呼び出し階層 Ctrl + Alt + K View.CallHierarchy
クラス ビュー Ctrl + Shift + C View.ClassView
クラス ビューの検索コンボに移動 Ctrl + K、Ctrl + V View.ClassViewGoToSearchCombo
コード定義ウィンドウ Ctrl + \、D

or

Ctrl + \、Ctrl + D
View.CodeDefinitionWindow
コマンド ウィンドウ Ctrl + Alt + A View.CommandWindow
データ ソース Shift + Alt + D View.DataSources
ドキュメント アウトライン Ctrl + Alt + T View.DocumentOutline
ラベルの編集 F2 View.EditLabel
エラー一覧 Ctrl + \、E

or

Ctrl + \、Ctrl + E
View.ErrorList
F# Interactive Ctrl + Alt + F View.F#Interactive
シンボルの検索結果 Ctrl + Alt + F12 View.FindSymbolResults
転送 Alt + 右矢印 (テキスト エディターでの View.NavigateForward の機能とは異なる) View.Forward
参照コンテキストを前面へ Ctrl + Shift + 7 View.ForwardBrowseContext
全画面表示 Shift + Alt + Enter View.FullScreen
後ろに移動する Ctrl + - View.NavigateBackward
次に進む Ctrl + Shift + - View.NavigateForward
次のエラー Ctrl + Shift + F12 View.NextError
通知 Ctrl + W、N

or

Ctrl + W、Ctrl + N
View.Notifications
オブジェクト ブラウザー Ctrl + Alt + J View.ObjectBrowser
オブジェクト ブラウザーの検索コンボに移動 Ctrl + K、Ctrl + R View.ObjectBrowserGoToSearchCombo
出力 Ctrl + Alt + O (文字 'O') View.Output
参照コンテキストの表示 Ctrl + Shift + 8 (C++ のみ) View.PopBrowseContext
[プロパティ] ウィンドウ F4 View.PropertiesWindow
プロパティ ページ Shift + F4 View.PropertyPages
リソース ビュー Ctrl + Shift + E View.ResourceView
サーバー エクスプローラー Ctrl + Alt + S View.ServerExplorer
スマート タグの表示 Shift + Alt + F10

or

Ctrl + .
View.ShowSmartTag
ソリューション エクスプローラー Ctrl + Alt + L View.SolutionExplorer
SQL Server オブジェクト エクスプローラー Ctrl + \、Ctrl + S View.SQLServerObjectExplorer
タスク一覧 Ctrl + \、T

or

Ctrl + \、Ctrl + T
View.TaskList
TFS Team Explorer Ctrl + \、Ctrl + M View.TfsTeamExplorer
ツールボックス Ctrl + Alt + X View.Toolbox
UML モデル エクスプローラー Ctrl + \、Ctrl + U View.UMLModelExplorer
コードを表示 F7 View.ViewCode
ビュー デザイナー Shift + F7 View.ViewDesigner
Web ブラウザー Ctrl + Alt + R View.WebBrowser
拡大します Ctrl + Shift + . View.ZoomIn
縮小します Ctrl + Shift + , View.ZoomOut
テスト エクスプローラーの表示 Ctrl + E、T TestExplorer.ShowTestExplorer

ウィンドウ

コマンド キーボード ショートカット コマンド ID
ドキュメント ウィンドウをアクティブにする Esc Window.ActivateDocumentWindow
タブを選択に追加 Ctrl + Shift + Alt + Space Window.AddTabtoSelection
ドキュメント ウィンドウを閉じる Ctrl + F4 Window.CloseDocumentWindow
ツール ウィンドウを閉じる Shift + Esc Window.CloseToolWindow
タブを開いたままにする Ctrl + Alt + Home Window.KeepTabOpen
ナビゲーション バーに移動 Ctrl + F2 Window.MovetoNavigationBar
次のドキュメント ウィンドウ Ctrl + F6 Window.NextDocumentWindow
次のドキュメント ウィンドウ ナビゲーション Ctrl + Tab Window.NextDocumentWindowNav
次のペイン Alt + F6 Window.NextPane
次の分割ペイン F6 Window.NextSplitPane
次のタブ Ctrl + Alt + PgDn

or

Ctrl + PgDn
Window.NextTab
次のタブを選択に追加 Ctrl + Shift + Alt + PgDn Window.NextTabandAddtoSelection
次のツール ウィンドウ ナビゲーション Alt + F7 Window.NextToolWindowNav
前のドキュメント ウィンドウ Ctrl + Shift + F6 Window.PreviousDocumentWindow
前のドキュメント ウィンドウ ナビゲーション Ctrl + Shift + Tab Window.PreviousDocumentWindowNav
前のペイン Shift + Alt + F6 Window.PreviousPane
前の分割ペイン Shift + F6 Window.PreviousSplitPane
前のタブ Ctrl + Alt + PgUp

or

Ctrl + PgUp
Window.PreviousTab
前のタブを選択に追加 Ctrl + Shift + Alt + PgUp Window.PreviousTabandAddtoSelection
前のツール ウィンドウ ナビゲーション Shift + Alt + F7 Window.PreviousToolWindowNav
クイック起動 Ctrl + Q Window.QuickLaunch
クイック起動の前のカテゴリ Ctrl + Shift + Q Window.QuickLaunchPreviousCategory
ドック メニューの表示 Alt + - Window.ShowDockMenu
Ex MDI ファイル一覧の表示 Ctrl + Alt + ↓ Window.ShowEzMDIFileList
ソリューション エクスプローラーの検索 Ctrl + ; Window.SolutionExplorerSearch
ウィンドウ検索 Alt + ` Window.WindowSearch

Azure

コマンド キーボード ショートカット コマンド ID
モバイル サービス スクリプトの操作を再試行 Ctrl + Num *、Ctrl + R WindowsAzure.RetryMobileServiceScriptOperation
モバイル サービス スクリプトのエラーの詳細を表示 Ctrl + Num *、Ctrl + D WindowsAzure.ShowMobileServiceScriptErrorDetails

コンテキスト固有のショートカット

ADO.NET Entity Data Model デザイナー

このコンテキストに固有のショートカットは次のとおりです。

コマンド キーボード ショートカット コマンド ID
[下へ] Alt + ↓ OtherContextMenus.MicrosoftDataEntityDesignContext.MoveProperties.Down
下へ 5 Alt + PgDn OtherContextMenus.MicrosoftDataEntityDesignContext.MoveProperties.Down5
一番下へ Alt + End OtherContextMenus.MicrosoftDataEntityDesignContext.MoveProperties.ToBottom
一番上へ Alt + Home OtherContextMenus.MicrosoftDataEntityDesignContext.MoveProperties.ToTop
上へ Alt + ↑ OtherContextMenus.MicrosoftDataEntityDesignContext.MoveProperties.Up
上へ 5 Alt + PgUp OtherContextMenus.MicrosoftDataEntityDesignContext.MoveProperties.Up5
[名前の変更] Ctrl + R、R OtherContextMenus.MicrosoftDataEntityDesignContext.Refactor.Rename
ダイアグラムから削除 Shift + Del OtherContextMenus.MicrosoftDataEntityDesignContext.RemovefromDiagram
Entity Data Model ブラウザー Ctrl + 数字 1 View.EntityDataModelBrowser
Entity Data Model マッピングの詳細 Ctrl + 数字 2 View.EntityDataModelMappingDetails

クラス ダイアグラム

このコンテキストに固有のショートカットは次のとおりです。

コマンド キーボード ショートカット コマンド ID
[折りたたみ] Num - ClassDiagram.Collapse
Expand Num + ClassDiagram.Expand
削除 Ctrl + Del Edit.Delete
基本型の一覧を展開する/折りたたむ Shift + Alt + B Edit.ExpandCollapseBaseTypeList
ロリポップへ移動 Shift + Alt + L Edit.NavigateToLollipop
ダイアグラムから削除 削除 Edit.RemovefromDiagram
コードを表示 Enter View.ViewCode

コード化された UI テスト エディター

このコンテキストに固有のショートカットは次のとおりです。

コマンド キーボード ショートカット コマンド ID
参照をクリップボードにコピー Ctrl + C OtherContextMenus.UITestEditorContextMenu.CopyReferencetoClipboard
前に遅延を挿入 Ctrl + Alt + D OtherContextMenus.UITestEditorContextMenu.InsertDelayBefore
すべてを検索 Shift + Alt + L OtherContextMenus.UITestEditorContextMenu.LocateAll
UI コントロールの検索 Ctrl + Shift + L OtherContextMenus.UITestEditorContextMenu.LocatetheUIControl
コードの移動 Ctrl + Alt + C OtherContextMenus.UITestEditorContextMenu.Movecode
新しいメソッドに分割 Ctrl + Shift + T OtherContextMenus.UITestEditorContextMenu.Splitintoanewmethod

データセット エディター

このコンテキストに固有のショートカットは次のとおりです。

コマンド キーボード ショートカット コマンド ID
列の挿入 [挿入] OtherContextMenus.ColumnContext.InsertColumn
Ctrl + L OtherContextMenus.DbTableContext.Add.Column

相違ビューアー

このコンテキストに固有のショートカットは次のとおりです。

コマンド キーボード ショートカット コマンド ID
トリム スペースを無視 Ctrl + \、Ctrl + Spacebar Diff.IgnoreTrimWhitespace
インライン ビュー Ctrl + \、Ctrl + 1 Diff.InlineView
左側のみのビュー Ctrl + \、Ctrl + 3 Diff.LeftOnlyView
次の相違点 F8 Diff.NextDifference
前の相違点 Shift + F8 Diff.PreviousDifference
右側のみのビュー Ctrl + \、Ctrl + 4 Diff.RightOnlyView
左右に並べて表示 Ctrl + \、Ctrl + 2 Diff.SideBySideView
左右の切り替え Ctrl + \、Ctrl + Tab Diff.SwitchBetweenLeftAndRight
同期ビューの切り替え Ctrl + \、Ctrl + ↓ Diff.SynchronizeViewToggle
コメントの追加 Ctrl + Shift + K EditorContextMenus.CodeWindow.AddComment
ローカル ファイルの編集 Ctrl + Shift + P EditorContextMenus.CodeWindow.EditLocalFile

DOM Explorer

このコンテキストに固有のショートカットは次のとおりです。

コマンド キーボード ショートカット コマンド ID
更新 F5 DOMExplorer.Refresh
要素の選択 Ctrl + B DOMExplorer.SelectElement
レイアウトの表示 Ctrl + Shift + I DOMExplorer.ShowLayout

F# Interactive

このコンテキストに固有のショートカットは次のとおりです。

コマンド キーボード ショートカット コマンド ID
対話形式の評価を取り消し Ctrl + Break OtherContextMenus.FSIConsoleContext.CancelInteractiveEvaluation

グラフ ドキュメント エディター

このコンテキストに固有のショートカットは次のとおりです。

コマンド キーボード ショートカット コマンド ID
ノードの追加 [挿入] ArchitectureContextMenus.DirectedGraphContextMenu.Advanced.Add.AddNode
両方の依存関係 B ArchitectureContextMenus.DirectedGraphContextMenu.Advanced.Select.BothDependencies
受信の依存関係 I ArchitectureContextMenus.DirectedGraphContextMenu.Advanced.Select.IncomingDependencies
送信の依存関係 O ArchitectureContextMenus.DirectedGraphContextMenu.Advanced.Select.OutgoingDependencies
新しいコメント Ctrl + Shift + K

or

Ctrl + E、C
ArchitectureContextMenus.DirectedGraphContextMenu.NewComment
削除 削除 ArchitectureContextMenus.DirectedGraphContextMenu.Remove
[名前の変更] F2 ArchitectureContextMenus.DirectedGraphContextMenu.Rename

グラフィックス診断

このコンテキストに固有のショートカットは次のとおりです。

コマンド キーボード ショートカット コマンド ID
フレームのキャプチャ なし Debug.Graphics.CaptureFrame
ピクセル選択を下に移動 Shift + Alt + ↓ Graphics.MovePixelSelectionDown
ピクセル選択を左に移動 Shift + Alt + ← Graphics.MovePixelSelectionLeft
ピクセル選択を右に移動 Shift + Alt + → Graphics.MovePixelSelectionRight
ピクセル選択を上に移動 Shift + Alt + ↑ Graphics.MovePixelSelectionUp
実際のサイズに大きさを変更 Shift + Alt + 0 (ゼロ) Graphics.ZoomToActualSize
ウィンドウのサイズに合わせて大きさを変更 Shift + Alt + 9 Graphics.ZoomToFitInWindow
拡大します Shift + Alt + = Graphics.ZoomIn
縮小します Shift + Alt + - Graphics.ZoomOut

HTML エディター

このコンテキストに固有のショートカットは次のとおりです。

コマンド キーボード ショートカット コマンド ID
コントローラーに移動 Ctrl + M、Ctrl + G OtherContextMenus.HTMLContext.GoToController

HTML エディター デザイン ビュー

このコンテキストに固有のショートカットは次のとおりです。

コマンド キーボード ショートカット コマンド ID
コントロールを下に移動 Ctrl + ↓ Edit.MoveControlDown
コントロールを上へ移動 Ctrl + ↑ Edit.MoveControlUp
太字 Ctrl + B Format.Bold
ハイパーリンクに変換 Ctrl + L Format.ConverttoHyperlink
ブックマークの挿入 Ctrl + Shift + L Format.InsertBookmark
[斜体] Ctrl + I Format.Italic
Underline Ctrl + U Format.Underline
コンテンツ ページの追加 Ctrl + M、Ctrl + C Project.AddContentPage
列を左に Ctrl + Alt + ← Table.ColumntotheLeft
列を右に Ctrl + Alt + → Table.ColumntotheRight
上の行 Ctrl + Alt + ↑ Table.RowAbove
下の行 Ctrl + Alt + ↓ Table.RowBelow
Net 非ビジュアル コントロール Ctrl + Shift + N View.ASP.NETNonvisualControls
マスターの編集 Ctrl + M、Ctrl + M View.EditMaster
次のビュー Ctrl + PgDn View.NextView
スマート タグの表示 Shift + Alt + F10 View.ShowSmartTag
マークアップの表示 Shift + F7 View.ViewMarkup
前のタブ Ctrl + PgUp Window.PreviousTab

HTML エディター ソース ビュー

このコンテキストに固有のショートカットは次のとおりです。

コマンド キーボード ショートカット コマンド ID
コントローラーに移動 Ctrl + M、Ctrl + G OtherContextMenus.HTMLContext.GoToController
次のビュー Ctrl + PgDn View.NextView
ビューの同期 Ctrl + Shift + Y View.SynchronizeViews
ビュー デザイナー Shift + F7 View.ViewDesigner
前のタブ Ctrl + PgUp Window.PreviousTab

レイヤー図

このコンテキストに固有のショートカットは次のとおりです。

コマンド キーボード ショートカット コマンド ID
削除 Shift + Delete Edit.Delete

マネージド リソース エディター

このコンテキストに固有のショートカットは次のとおりです。

コマンド キーボード ショートカット コマンド ID
セルの編集 F2 Edit.EditCell
削除 削除 Edit.Remove
今すぐ削除する Ctrl + Delete Edit.RemoveRow
選択範囲の取り消し Escape Edit.SelectionCancel
オーディオ Ctrl + 数字 4 Resources.Audio
ファイル Ctrl + 数字 5 Resources.Files
アイコン Ctrl + 数字 3 Resources.Icons
画像 Ctrl + 数字 2 Resources.Images
その他 Ctrl + 数字 6 Resources.Other
文字列 Ctrl + 数字 1 Resources.Strings

マージ エディター ウィンドウ

このコンテキストに固有のショートカットは次のとおりです。

コマンド キーボード ショートカット コマンド ID
左ウィンドウにフォーカスを設定 Alt + 1 TeamFoundationContextMenus.MergeContextMenu.SetFocusonLeftWindow
結果ウィンドウにフォーカスを設定 Alt + 2 TeamFoundationContextMenus.MergeContextMenu.SetFocusonResultWindow
右ウィンドウにフォーカスを設定 Alt + 3 TeamFoundationContextMenus.MergeContextMenu.SetFocusonRightWindow

Microsoft SQL Server Data Tools、スキーマの比較

このコンテキストに固有のショートカットは次のとおりです。

コマンド キーボード ショートカット コマンド ID
SSDT スキーマ比較 Shift + Alt + C SQL.SSDTSchemaCompareCompare
SSDT スキーマ比較のスクリプト生成 Shift + Alt + G SQL.SSDTSchemaCompareGenerateScript
SSDT スキーマ比較の次の変更 Shift + Alt + . SQL.SSDTSchemaCompareNextChange
SSDT スキーマ比較の前の変更 Shift + Alt + , SQL.SSDTSchemaComparePreviousChange
SSDT スキーマ比較の停止 Alt + Break SQL.SSDTSchemaCompareStop
SSDT スキーマ比較の更新の書き込み Shift + Alt + U SQL.SSDTSchemaCompareWriteUpdates

Microsoft SQL Server Data Tools、テーブル デザイナー

このコンテキストに固有のショートカットは次のとおりです。

コマンド キーボード ショートカット コマンド ID
CommitAllEdits Shift + Alt + U
ワイルドカードの展開 Ctrl + R、E

or

Ctrl + R、Ctrl + E
SQL.ExpandWildcards
完全修飾名 Ctrl + R、Q

or

Ctrl + R、Ctrl + Q
SQL.FullyqualifyNames
スキーマへ移動 Ctrl + R、M

or

Ctrl + R、Ctrl + M
SQL.MovetoSchema
[名前の変更] F2

or

Ctrl + R、R

or

Ctrl + R、Ctrl + R
SQL 名前の変更
ViewFileInScriptPanel Shift + Alt + PgDn

Microsoft SQL Server Data Tools、T-SQL エディター

このコンテキストに固有のショートカットは次のとおりです。

コマンド キーボード ショートカット コマンド ID
CommitAllEdits Shift + Alt + U
デバッガーで実行 Alt + F5 SQL.ExecuteWithDebugger
ワイルドカードの展開 Ctrl + R、E

or

Ctrl + R、Ctrl + E
SQL.ExpandWildcards
完全修飾名 Ctrl + R、Q

or

Ctrl + R、Ctrl + Q
SQL.FullyqualifyNames
スキーマへ移動 Ctrl + R、M

or

Ctrl + R、Ctrl + M
SQL.MovetoSchema
[名前の変更] F2

or

Ctrl + R、R

or

Ctrl + R、Ctrl + R
SQL 名前の変更
T-SQL エディターのクエリのキャンセル Alt + Break SQL.TSqlEditorCancelQuery
T-SQL エディターのクエリの実行 Ctrl + Shift + E SQL.TSqlEditorExecuteQuery
T-SQL エディターの結果をファイルとして出力 Ctrl + D、F SQL.TSqlEditorResultsAsFile
T-SQL エディターの結果をグリッドに表示 Ctrl + D、G SQL.TSqlEditorResultsAsGrid
T-SQL エディターの結果をテキストに表示 Ctrl + D、T SQL.TSqlEditorResultsAsText
T-SQL エディターの推定プランの表示 Ctrl + D、E SQL.TSqlEditorShowEstimatedPlan
T-SQL エディターの実行プランの切り替え Ctrl + D、A SQL.TSqlEditorToggleExecutionPlan
T-SQL エディターの結果ペインの切り替え Ctrl + D、R SQL.TSqlEditorToggleResultsPane
T-SQL エディターのクエリの複製 Ctrl + Alt + N SQL.TSqlEditorCloneQuery
T-SQL エディター データベース コンボ Shift + Alt + PgDn SQL.TSqlEditorDatabaseCombo

Microsoft SQL Server Data Tools、T-SQL PDW エディター

このコンテキストに固有のショートカットは次のとおりです。

コマンド キーボード ショートカット コマンド ID
T-SQL エディターのクエリのキャンセル Alt + Break SQL.TSqlEditorCancelQuery
T-SQL エディターのクエリの実行 Ctrl + Shift + E SQL.TSqlEditorExecuteQuery
T-SQL エディターの結果をファイルとして出力 Ctrl + D、F SQL.TSqlEditorResultsAsFile
T-SQL エディターの結果をグリッドに表示 Ctrl + D、G SQL.TSqlEditorResultsAsGrid
T-SQL エディターの結果をテキストに表示 Ctrl + D、T SQL.TSqlEditorResultsAsText
T-SQL エディターの推定プランの表示 Ctrl + D、E SQL.TSqlEditorShowEstimatedPlan
T-SQL エディターの実行プランの切り替え Ctrl + D、A SQL.TSqlEditorToggleExecutionPlan
T-SQL エディターの結果ペインの切り替え Ctrl + D、R SQL.TSqlEditorToggleResultsPane
T-SQL エディターのクエリの複製 Ctrl + Alt + N SQL.TSqlEditorCloneQuery
T-SQL エディターのクエリの複製 Shift + Alt + PgDn SQL.TSqlEditorCloneQuery

Page Inspector

このコンテキストに固有のショートカットは次のとおりです。

コマンド キーボード ショートカット コマンド ID
最小 F12 PageInspector.Minimize

クエリ デザイナー

このコンテキストに固有のショートカットは次のとおりです。

コマンド キーボード ショートカット コマンド ID
データの取得の中止 Ctrl + T QueryDesigner.CancelRetrievingData
条件 Ctrl + 数字 2 QueryDesigner.Criteria
ダイアグラム Ctrl + 数字 1 QueryDesigner.Diagram
[SQL の実行] Ctrl + R QueryDesigner.ExecuteSQL
行にジャンプ Ctrl + G QueryDesigner.GoToRow
結合モード Ctrl + Shift + J QueryDesigner.JoinMode
結果 Ctrl + 数字 4 QueryDesigner.Results
Sql Ctrl + 数字 3 QueryDesigner.SQL

クエリ結果

このコンテキストに固有のショートカットは次のとおりです。

コマンド キーボード ショートカット コマンド ID
クエリ結果の新しい行 Alt + End SQL.QueryResultsNewRow
クエリ結果の更新 Shift + Alt + R SQL.QueryResultsRefresh
クエリ結果の停止 Alt + Break SQL.QueryResultsStop

レポート デザイナー

このコンテキストに固有のショートカットは次のとおりです。

コマンド キーボード ショートカット コマンド ID
改行 Enter Edit.BreakLine
左に 1 文字移動 ← キー Edit.CharLeft
1 文字左まで拡張 Shift + ← Edit.CharLeftExtend
右に 1 文字移動 → キー Edit.CharRight
1 文字右まで拡張 Shift + → Edit.CharRightExtend
[挿入] タブ Tab Edit.InsertTab
1 行下へ移動 ↓ キー Edit.LineDown
1 行下まで拡張 Shift + ↓ Edit.LineDownExtend
1 行上へ移動 ↑ キー Edit.LineUp
1 行上まで拡張 Shift + ↑ Edit.LineUpExtend
コントロールを下に移動 Ctrl + ↓ Edit.MoveControlDown
コントロールを左に移動 Ctrl + ← Edit.MoveControlLeft
コントロールを右に移動 Ctrl + → Edit.MoveControlRight
コントロールを上へ移動 Ctrl + ↑ Edit.MoveControlUp
選択範囲の取り消し Esc Edit.SelectionCancel
コントロール サイズを下に移動 Ctrl + Shift + ↓ Edit.SizeControlDown
コントロール サイズを左に移動 Ctrl + Shift + ← Edit.SizeControlLeft
コントロール サイズを右に移動 Ctrl + Shift + → Edit.SizeControlRight
コントロール サイズを上に移動 Ctrl + Shift + ↑ Edit.SizeControlUp
タブを左へ Shift + Tab Edit.TabLeft
ソース Ctrl + Alt + D View.ReportData

シーケンス図

このコンテキストに固有のショートカットは次のとおりです。

コマンド キーボード ショートカット コマンド ID
コードに移動 F12 ArchitectureDesigner.Sequence.NavigateToCode
削除 Shift + Del Edit.Delete

設定デザイナー

このコンテキストに固有のショートカットは次のとおりです。

コマンド キーボード ショートカット コマンド ID
セルの編集 F2 Edit.EditCell
今すぐ削除する Ctrl + Delete Edit.RemoveRow
選択範囲の取り消し Esc Edit.SelectionCancel
コードを表示 F7 View.ViewCode

ソリューション エクスプローラー

このコンテキストに固有のショートカットは次のとおりです。

コマンド キーボード ショートカット コマンド ID
Page Inspector で表示 Ctrl + K、Ctrl + G ClassViewContextMenus.ClassViewProject.View.ViewinPageInspector

チーム エクスプローラー

このコンテキストに固有のショートカットは次のとおりです。

コマンド ショートカット キー コマンド ID
削除 削除 Edit.Delete
[名前の変更] F2 File.Rename
チーム エクスプローラー ナビゲーションに移動 Alt + Home TeamFoundationContextMenus.Commands.GoToTeamExplorerNavigation
チーム エクスプローラー 次のセクション コンテンツに移動 Alt + ↓ TeamFoundationContextMenus.Commands.GoToTeamExplorerNextSectionContent
チーム エクスプローラー ページ コンテンツに移動 Alt + 0 (ゼロ) TeamFoundationContextMenus.Commands.GoToTeamExplorerPageContent
チーム エクスプローラー 前のセクション コンテンツに移動 Alt + ↑ TeamFoundationContextMenus.Commands.GoToTeamExplorerPreviousSectionContent
チーム エクスプローラー セクション 1 コンテンツに移動 Alt + 1 TeamFoundationContextMenus.Commands.GoToTeamExplorerSection1Content
チーム エクスプローラー セクション 2 コンテンツに移動 Alt + 2 TeamFoundationContextMenus.Commands.GoToTeamExplorerSection2Content
チーム エクスプローラー セクション 3 コンテンツに移動 Alt + 3 TeamFoundationContextMenus.Commands.GoToTeamExplorerSection3Content
チーム エクスプローラー セクション 4 コンテンツに移動 Alt + 4 TeamFoundationContextMenus.Commands.GoToTeamExplorerSection4Content
チーム エクスプローラー セクション 5 コンテンツに移動 Alt + 5 TeamFoundationContextMenus.Commands.GoToTeamExplorerSection5Content
チーム エクスプローラー セクション 6 コンテンツに移動 Alt + 6 TeamFoundationContextMenus.Commands.GoToTeamExplorerSection6Content
チーム エクスプローラー セクション 7 コンテンツに移動 Alt + 7 TeamFoundationContextMenus.Commands.GoToTeamExplorerSection7Content
チーム エクスプローラー セクション 8 コンテンツに移動 Alt + 8 TeamFoundationContextMenus.Commands.GoToTeamExplorerSection8Content
チーム エクスプローラー セクション 9 コンテンツに移動 Alt + 9 TeamFoundationContextMenus.Commands.GoToTeamExplorerSection9Content
チーム エクスプローラー 前に戻る Alt + ← TeamFoundationContextMenus.Commands.TeamExplorerNavigateBackward
チーム エクスプローラー 次に進む Alt + → TeamFoundationContextMenus.Commands.TeamExplorerNavigateForward
TFS コンテキストの担当作業ページのコピー作業項目の作成 Shift + Alt + C TeamFoundationContextMenus.MyWorkPageInProgress.TfsContextMyWorkPageCreateCopyWI
TFS コンテキストの担当作業ページのリンクされた新しい作業項目 Shift + Alt + L TeamFoundationContextMenus.MyWorkPageInProgress.TfsContextMyWorkPageNewLinkedWI
更新 F5 View.Refresh

テスト エクスプローラー

このコンテキストに固有のショートカットは次のとおりです。

コマンド キーボード ショートカット コマンド ID
テストを開く F12 TestExplorer.OpenTest

[テキスト エディター]

このコンテキストに固有のショートカットは次のとおりです。

コマンド キーボード ショートカット コマンド ID
改行 Enter

or

Shift + Enter
Edit.BreakLine
左に 1 文字移動 ← キー Edit.CharLeft
1 文字左まで拡張 Shift + ← Edit.CharLeftExtend
1 文字左に列を拡張 Shift + Alt + ← Edit.CharLeftExtendColumn
右に 1 文字移動 → キー Edit.CharRight
1 文字右まで拡張 Shift + → Edit.CharRightExtend
1 文字右に列を拡張 Shift + Alt + → Edit.CharRightExtendColumn
ブックマークをクリアする Ctrl + K、Ctrl + L Edit.ClearBookmarks
すべてのアウトラインを折りたたむ Ctrl + M、Ctrl + A Edit.CollapseAllOutlining
現在の領域を折りたたむ Ctrl + M、Ctrl + S Edit.CollapseCurrentRegion
タグを折りたたむ Ctrl + M、Ctrl + T Edit.CollapseTag
定義に縮小 Ctrl + M、Ctrl + O (文字 'O') Edit.CollapseToDefinitions
選択範囲の縮小 Shift + Alt + - Edit.ContractSelection
選択範囲のコメント Ctrl + K、Ctrl + C Edit.CommentSelection
ワードを完成する Ctrl + Space

or

Alt + →
Edit.CompleteWord
パラメーター ヒントをコピーする Ctrl + Shift + Alt + C Edit.CopyParameterTip
フィルター レベルを下げる Alt + , Edit.DecreaseFilterLevel
後退削除 バックスペース

or

Shift + Bkspce
Edit.DeleteBackwards
左右スペースの削除 Ctrl + K、Ctrl + \ Edit.DeleteHorizontalWhiteSpace
ドキュメントの終了 Ctrl + End Edit.DocumentEnd
ドキュメントの終了位置まで拡張 Ctrl + Shift + End Edit.DocumentEndExtend
ドキュメントの開始 Ctrl + Home Edit.DocumentStart
ドキュメントの開始位置まで拡張 Ctrl + Shift + Home Edit.DocumentStartExtend
すべてのアウトラインの展開 Ctrl + M、Ctrl + X Edit.ExpandAllOutlining
現在の領域の展開 Ctrl + M、Ctrl + E Edit.ExpandCurrentRegion
選択の拡大 Shift + Alt + = Edit.ExpandSelection
選択範囲を包含ブロックまで広げる Shift + Alt + ] Edit.ExpandSelectiontoContainingBlock
ドキュメントのフォーマット Ctrl + K、Ctrl + D Edit.FormatDocument
選択範囲のフォーマット Ctrl + K、Ctrl + F Edit.FormatSelection
すべてに移動 Ctrl + T

or

Ctrl + ,
Edit.GotoAll
かっこに移動 Ctrl + ] Edit.GotoBrace
対応するかっこに移動 Ctrl + Shift + ] Edit.GotoBraceExtend
最近に移動 Ctrl+T、R Edit.GotoRecent
ファイル内の次の問題に移動 Alt + PgDn Edit.GotoNextIssueinFile
ファイル内の前の問題に移動 Alt + PgUp Edit.GotoPreviousIssueinFile
選択内容を隠す Ctrl + M、Ctrl + H Edit.HideSelection
フィルター レベルを上げる Alt + . Edit.IncreaseFilterLevel
インクリメンタル検索 Ctrl + I Edit.IncrementalSearch
一致するすべての項目にキャレットを挿入 Shift + Alt +; Edit.InsertCaretsatAllMatching
次の一致にキャレットを挿入 Shift + Alt + . Edit.InsertNextMatchingCaret
[挿入] タブ Tab Edit.InsertTab
行の切り取り Ctrl + L Edit.LineCut
行の削除 Ctrl + Shift + L Edit.LineDelete
1 行下へ移動 ↓ キー Edit.LineDown
1 行下まで拡張 Shift + ↓ Edit.LineDownExtend
1 行下まで列を拡張 Shift + Alt + ↓ Edit.LineDownExtendColumn
行末 End Edit.LineEnd
行末まで拡張 Shift + End Edit.LineEndExtend
行末まで列を拡張 Shift + Alt + End Edit.LineEndExtendColumn
上に 1 行挿入 Ctrl + Enter Edit.LineOpenAbove
下に 1 行挿入 Ctrl + Shift + Enter Edit.LineOpenBelow
行頭に移動 Home Edit.LineStart
行頭まで拡張 Shift + Home Edit.LineStartExtend
行頭まで列を拡張 Shift + Alt + Home Edit.LineStartExtendColumn
行の置換 Shift + Alt + T Edit.LineTranspose
1 行上へ移動 ↑ キー Edit.LineUp
1 行上まで拡張 Shift + ↑ Edit.LineUpExtend
1 行上まで列を拡張 Shift + Alt + ↑ Edit.LineUpExtendColumn
メンバーの一覧を表示する Ctrl + J Edit.ListMembers
小文字に変換 Ctrl + U Edit.MakeLowercase
大文字に変換 Ctrl + Shift + U Edit.MakeUppercase
選択した行を下へ移動 Alt + ↓ Edit.MoveSelectedLinesDown
選択した行を上へ移動 Alt + ↑ Edit.MoveSelectedLinesUp
次の強調表示された参照 Ctrl + Shift + ↓ Edit.NextHighlightedReference
上書きモード [挿入] Edit.OvertypeMode
1 画面分下へ移動 (PageDown) PgDn Edit.PageDown
1 ページ下まで拡張 Shift + PgDn Edit.PageDownExtend
1 画面分上へ移動 (PageUp) PgUp Edit.PageUp
1 ページ上まで拡張 Shift + PgUp Edit.PageUpExtend
パラメーター ヒント Ctrl + Shift + Spacebar Edit.ParameterInfo
パラメーター ヒントを貼り付ける Ctrl + Shift + Alt + P Edit.PasteParameterTip
前を見る Ctrl + Alt + - Edit.PeekBackward
定義をここに表示 Alt+F12 Edit.PeekDefinition
次を見る Ctrl + Alt + = Edit.PeekForward
前の強調表示された参照 Ctrl + Shift + ↑ Edit.PreviousHighlightedReference
クイック ヒント Ctrl + K、Ctrl + I Edit.QuickInfo
インクリメンタル検索を元に戻す Ctrl + Shift + I Edit.ReverseIncrementalSearch
1 行下にスクロール Ctrl + ↓ Edit.ScrollLineDown
1 行上にスクロール Ctrl + ↑ Edit.ScrollLineUp
現在の単語を選択 Ctrl + W Edit.SelectCurrentWord
選択範囲の取り消し Escape Edit.SelectionCancel
最後に戻った場所まで選択 Ctrl + = Edit.SelectToLastGoBack
コード レンズ メニューの表示 Ctrl + K、Ctrl + ` Edit.ShowCodeLensMenu
ナビゲーション メニューの表示 Alt + ` Edit.ShowNavigateMenu
カレントを表示 Ctrl + M、Ctrl + U Edit.StopHidingCurrent
アウトラインの中止 Ctrl + M、Ctrl + P Edit.StopOutlining
アンカー位置の交換 Ctrl + K、Ctrl + A Edit.SwapAnchor
タブを左へ Shift + Tab Edit.TabLeft
すべてのアウトラインの切り替え Ctrl + M、Ctrl + L Edit.ToggleAllOutlining
ブックマークの設定/解除 Ctrl + K、Ctrl + K Edit.ToggleBookmark
完了モードの切り替え Ctrl + Alt + Space Edit.ToggleCompletionMode
アウトラインの展開/縮小 Ctrl + M、Ctrl + M Edit.ToggleOutliningExpansion
タスク一覧ショートカットの切り替え Ctrl + K、Ctrl + H Edit.ToggleTaskListShortcut
[右端で折り返す] の設定/解除 Ctrl + E、Ctrl + W Edit.ToggleWordWrap
選択範囲のコメントを解除 Ctrl + K、Ctrl + U Edit.UncommentSelection
下を表示 Ctrl + PgDn Edit.ViewBottom
下端まで拡張 Ctrl + Shift + PgDn Edit.ViewBottomExtend
上を表示 Ctrl + PgUp Edit.ViewTop
上端まで拡張 Ctrl + Shift + PgUp Edit.ViewTopExtend
スペースの表示 Ctrl + R、Ctrl + W Edit.ViewWhiteSpace
単語の最後まで削除 Ctrl + Delete Edit.WordDeleteToEnd
単語の最初まで削除 Ctrl + Backspace Edit.WordDeleteToStart
次の単語へ移動 Ctrl + → Edit.WordNext
次の単語まで拡張 Ctrl + Shift + → Edit.WordNextExtend
次の単語まで列を拡張 Ctrl + Shift + Alt + → Edit.WordNextExtendColumn
前の単語へ移動 Ctrl + ← Edit.WordPrevious
前の単語まで拡張 Ctrl + Shift + ← Edit.WordPreviousExtend
前の単語まで列を拡張 Ctrl + Shift + Alt + ← Edit.WordPreviousExtendColumn
単語の置換 Ctrl + Shift + T Edit.WordTranspose
対話形式で実行 Alt + Enter EditorContextMenus.CodeWindow.ExecuteInInteractive
対話形式で行を実行 Alt + ' EditorContextMenus.CodeWindow.ExecuteLineInInteractive
Page Inspector で表示 Ctrl + K、Ctrl + G OtherContextMenus.HTMLContext.ViewinPageInspector
TFS 注釈の次の領域に移動 Alt + PgDn TeamFoundationContextMenus.Annotate.TfsAnnotateMoveNextRegion
TFS 注釈の前の領域に移動 Alt + PgUp TeamFoundationContextMenus.Annotate.TfsAnnotateMovePreviousRegion

UML アクティビティ図

このコンテキストに固有のショートカットは次のとおりです。

コマンド キーボード ショートカット コマンド ID
削除 Shift + Del Edit.Delete

UML クラス図

このコンテキストに固有のショートカットは次のとおりです。

コマンド キーボード ショートカット コマンド ID
モデルから削除 Shift + Del Edit.DeleteFromModel

UML コンポーネント図

このコンテキストに固有のショートカットは次のとおりです。

コマンド キーボード ショートカット コマンド ID
モデルから削除 Shift + Del Edit.DeleteFromModel

UML ユース ケース図

このコンテキストに固有のショートカットは次のとおりです。

コマンド キーボード ショートカット コマンド ID
モデルから削除 Shift + Del Edit.DeleteFromModel

VC アクセラレータ エディター

このコンテキストに固有のショートカットは次のとおりです。

コマンド キーボード ショートカット コマンド ID
新しいアクセラレータ [挿入] Edit.NewAccelerator
キー タイピング登録 Ctrl + W Edit.NextKeyTyped

VC ダイアログ エディター

このコンテキストに固有のショートカットは次のとおりです。

コマンド キーボード ショートカット コマンド ID
コントロールを下に移動 ↓ キー Edit.MoveControlDown
コントロールを左に移動 ← キー Edit.MoveControlLeft
コントロールを右に移動 → キー Edit.MoveControlRight
コントロールを上へ移動 ↑ キー Edit.MoveControlUp
1 列左へスクロール Ctrl + ← Edit.ScrollColumnLeft
1 列右へスクロール Ctrl + → Edit.ScrollColumnRight
1 行下にスクロール Ctrl + ↓ Edit.ScrollLineDown
1 行上にスクロール Ctrl + ↑ Edit.ScrollLineUp
コントロール サイズを下に移動 Shift + ↓ Edit.SizeControlDown
コントロール サイズを左に移動 Shift + ← Edit.SizeControlLeft
コントロール サイズを右に移動 Shift + → Edit.SizeControlRight
コントロール サイズを上に移動 Shift + ↑ Edit.SizeControlUp
下揃え Ctrl + Shift + ↓ Format.AlignBottoms
中央揃え Shift + F9 Format.AlignCenters
左揃え Ctrl + Shift + ← Format.AlignLefts
上下中央揃え F9 Format.AlignMiddles
右揃え Ctrl + Shift + → Format.AlignRights
上揃え Ctrl + Shift + ↑ Format.AlignTops
ボタンの下端 Ctrl + B Format.ButtonBottom
ボタンの右端 Ctrl + R Format.ButtonRight
左右中央揃え Ctrl + Shift + F9 Format.CenterHorizontal
上下中央揃え Ctrl + F9 Format.CenterVertical
ニーモニックの確認 Ctrl + M Format.CheckMnemonics
テキストにサイズを合わせる Shift + F7 Format.SizetoContent
左右均等配置 Alt + →

or

Alt + ←
Format.SpaceAcross
上下均等配置 Alt + ↑

or

Alt + ↓
Format.SpaceDown
タブ オーダー Ctrl + D Format.TabOrder
ダイアログのテスト Ctrl + T Format.TestDialog
ガイドの切り替え Ctrl + G Format.ToggleGuides

VC イメージ エディター

このコンテキストに固有のショートカットは次のとおりです。

コマンド キーボード ショートカット コマンド ID
エアブラシ ツール Ctrl + A Image.AirbrushTool
ブラシ ツール Ctrl + B Image.BrushTool
コピーして選択範囲をアウトライン Ctrl + Shift + U Image.CopyandOutlineSelection
背景色を不透明にする Ctrl + J Image.DrawOpaque
楕円ツール Alt + P Image.EllipseTool
消去ツール Ctrl + Shift + I Image.EraseTool
塗りつぶし楕円ツール Ctrl + Shift + Alt + P Image.FilledEllipseTool
塗りつぶし四角形ツール Ctrl + Shift + Alt + R Image.FilledRectangleTool
塗りつぶし角丸長方形ツール Ctrl + Shift + Alt + W Image.FilledRoundedRectangleTool
[塗りつぶし] ツール Ctrl + F Image.FillTool
左右反転 Ctrl + H Image.FlipHorizontal
上下反転 Shift + Alt + H Image.FlipVertical
より大きいブラシ Ctrl + = Image.LargerBrush
線ツール Ctrl + L Image.LineTool
拡大ツール Ctrl + M Image.MagnificationTool
拡大 Ctrl + Shift + M Image.Magnify
新しいイメージ タイプ [挿入] Image.NewImageType
次の色 Ctrl + ]

or

Ctrl + →
Image.NextColor
次の背景色 Ctrl + Shift + ]

or

Ctrl + Shift + →
Image.NextRightColor
縁付き楕円ツール Shift + Alt + P Image.OutlinedEllipseTool
縁付き四角形ツール Shift + Alt + R Image.OutlinedRectangleTool
縁付き角丸長方形ツール Shift + Alt + W Image.OutlinedRoundedRectangleTool
鉛筆ツール Ctrl + I Image.PencilTool
前の色 Ctrl + [

or

Ctrl + ←
Image.PreviousColor
前の背景色 Ctrl + Shift + [

or

Ctrl + Shift + ←
Image.PreviousRightColor
矩形選択ツール Shift + Alt + S Image.RectangleSelectionTool
四角形ツール Alt + R Image.RectangleTool
90 度回転 Ctrl + Shift + H Image.Rotate90Degrees
角丸四角形ツール Alt + W Image.RoundedRectangleTool
グリッドの表示 Ctrl + Alt + S Image.ShowGrid
タイル グリッドの表示 Ctrl + Shift + Alt + S Image.ShowTileGrid
小さいブラシ Ctrl + . Image.SmallBrush
より小さいブラシ Ctrl + - Image.SmallerBrush
テキスト ツール Ctrl + T Image.TextTool
選択アイテムをブラシとして使用 Ctrl + U Image.UseSelectionasBrush
拡大します Ctrl + Shift + .

or

Ctrl + ↑
Image.ZoomIn
縮小します Ctrl + Shift + ,

or

Ctrl + ↓
Image.ZoomOut

VC ストリング エディター

このコンテキストに固有のショートカットは次のとおりです。

コマンド キーボード ショートカット コマンド ID
New string [挿入] Edit.NewString

[デザイナーの表示]

このコンテキストに固有のショートカットは次のとおりです。

コマンド キーボード ショートカット コマンド ID
データの取得の中止 Ctrl + T QueryDesigner.CancelRetrievingData
条件 Ctrl + 数字 2 QueryDesigner.Criteria
ダイアグラム Ctrl + 数字 1 QueryDesigner.Diagram
[SQL の実行] Ctrl + R QueryDesigner.ExecuteSQL
行にジャンプ Ctrl + G QueryDesigner.GoToRow
結合モード Ctrl + Shift + J QueryDesigner.JoinMode
結果 Ctrl + 数字 4 QueryDesigner.Results
Sql Ctrl + 数字 3 QueryDesigner.SQL

Visual Studio

このコンテキストに固有のショートカットは次のとおりです。

コマンド キーボード ショートカット コマンド ID
メソッド ペインの非表示 Ctrl + 数字 1 OtherContextMenus.ORDesignerContext.HideMethodsPane

Windows フォーム デザイナー

このコンテキストに固有のショートカットは次のとおりです。

コマンド キーボード ショートカット コマンド ID
改行 Enter Edit.BreakLine
左に 1 文字移動 ← キー Edit.CharLeft
1 文字左まで拡張 Shift + ← Edit.CharLeftExtend
右に 1 文字移動 → キー Edit.CharRight
1 文字右まで拡張 Shift + → Edit.CharRightExtend
ドキュメントの終了 End Edit.DocumentEnd
ドキュメントの終了位置まで拡張 Shift + End Edit.DocumentEndExtend
ドキュメントの開始 Home Edit.DocumentStart
ドキュメントの開始位置まで拡張 Shift + Home Edit.DocumentStartExtend
[挿入] タブ Tab Edit.InsertTab
1 行下へ移動 ↓ キー Edit.LineDown
1 行下まで拡張 Shift + ↑ Edit.LineDownExtend
1 行上へ移動 ↑ キー Edit.LineUp
1 行上まで拡張 Shift + ↓ Edit.LineUpExtend
コントロールを下に移動 Ctrl + ↓ Edit.MoveControlDown
コントロールを左に移動 Ctrl + ← Edit.MoveControlLeft
コントロールを右に移動 Ctrl + → Edit.MoveControlRight
コントロールを上へ移動 Ctrl + ↑ Edit.MoveControlUp
選択範囲の取り消し Escape Edit.SelectionCancel
コントロール サイズを下に移動 Ctrl + Shift + ↓ Edit.SizeControlDown
コントロール サイズを左に移動 Ctrl + Shift + ← Edit.SizeControlLeft
コントロール サイズを右に移動 Ctrl + Shift + → Edit.SizeControlRight
コントロール サイズを上に移動 Ctrl + Shift + ↑ Edit.SizeControlUp
タブを左へ Shift + Tab Edit.TabLeft

作業項目エディター

このコンテキストに固有のショートカットは次のとおりです。

コマンド キーボード ショートカット コマンド ID
作業項目のコピーの作成 Shift + Alt + C Edit.CreateCopyofWorkItem
作業項目の更新 F5 Edit.RefreshWorkItem
リンクされた新しい作業項目 Shift + Alt + L Team.NewLinkedWorkItem

作業項目クエリ ビュー

このコンテキストに固有のショートカットは次のとおりです。

コマンド キーボード ショートカット コマンド ID
作業項目のコピーの作成 Shift + Alt + C Edit.CreateCopyofWorkItem
インデントする Shift + Alt + → Edit.Indent
インデントを解除する Shift + Alt + ← Edit.Outdent
リンクされた新しい作業項目 Shift + Alt + L Team.NewLinkedWorkItem
更新 F5 Team.Refresh
トグル Shift + Alt + V Window.Toggle

作業項目結果ビュー

このコンテキストに固有のショートカットは次のとおりです。

コマンド キーボード ショートカット コマンド ID
作業項目のコピーの作成 Shift + Alt + C Edit.CreateCopyofWorkItem
インデントする Shift + Alt + → Edit.Indent
インデントを解除する Shift + Alt + ← Edit.Outdent
次の作業項目に移動する Shift + Alt + N Team.GotoNextWorkItem
前の作業項目に移動する Shift + Alt + P Team.GotoPreviousWorkItem
リンクされた新しい作業項目 Shift + Alt + L Team.NewLinkedWorkItem
更新 F5 Team.Refresh
トグル Shift + Alt + V Window.Toggle

ワークフロー デザイナー

このコンテキストに固有のショートカットは次のとおりです。

コマンド キーボード ショートカット コマンド ID
ワードを完成する Ctrl + K、W

or

Ctrl + K、Ctrl + W

or

Ctrl + Space

or

Alt + →
Edit.CompleteWord
フィルター レベルを下げる Alt + , Edit.DecreaseFilterLevel
フィルター レベルを上げる Alt + . Edit.IncreaseFilterLevel
メンバーの一覧を表示する Ctrl + K、L

or

Ctrl + K、Ctrl + L

or

Ctrl + J
Edit.ListMembers
パラメーター ヒント Ctrl + K、P

or

Ctrl + K、Ctrl + P

or

Ctrl + Shift + Spacebar
Edit.ParameterInfo
クイック ヒント Ctrl + K、I

or

Ctrl + K、Ctrl + I
Edit.QuickInfo
[折りたたみ] Ctrl + E、Ctrl + C

or

Ctrl + E、C
WorkflowDesigner.Collapse
すべて折りたたむ または WorkflowDesigner.CollapseAll
ノードの接続 Ctrl + E、Ctrl + F

or

Ctrl + E、F
WorkflowDesigner.ConnectNodes
変数の作成 Ctrl + E、Ctrl + N

or

Ctrl + E、N
WorkflowDesigner.CreateVariable
すべて展開 Ctrl + E、Ctrl + X

or

Ctrl + E、X
WorkflowDesigner.ExpandAll
埋め込み先で展開 Ctrl + E、Ctrl + E

or

Ctrl + E、E
WorkflowDesigner.ExpandInPlace
親へ移動 Ctrl + E、Ctrl + P

or

Ctrl + E、P
WorkflowDesigner.GoToParent
フォーカスの移動 Ctrl + E、Ctrl + M

or

Ctrl + E、M
WorkflowDesigner.MoveFocus
デザイナー間の移動 Ctrl + Alt + F6 WorkflowDesigner.NavigateThroughDesigner
復元 Ctrl + E、Ctrl + R

or

Ctrl + E、R
WorkflowDesigner.Restore
引数デザイナーの表示/非表示 Ctrl + E、Ctrl + A

or

Ctrl + E、A
WorkflowDesigner.ShowHideArgumentDesigner
インポート デザイナーの表示/非表示 Ctrl + E、Ctrl + I

or

Ctrl + E、I
WorkflowDesigner.ShowHideImportsDesigner
概要マップの表示/非表示 CTRL + E、CTRL + O (文字 'O')

or

Ctrl + E、O
WorkflowDesigner.ShowHideOverviewMap
変数デザイナーの表示/非表示 Ctrl + E、Ctrl + V

or

Ctrl + E、V
WorkflowDesigner.ShowHideVariableDesigner
選択の切り替え Ctrl + E、Ctrl + S

or

Ctrl + E、S
WorkflowDesigner.ToggleSelection
拡大します Ctrl を押しながらテンキーの + WorkflowDesigner.ZoomIn
縮小します Ctrl を押しながらテンキーの - WorkflowDesigner.ZoomOut

XAML デザイナー

このコンテキストに固有のショートカットは次のとおりです。

コマンド キーボード ショートカット コマンド ID
全体を表示する Ctrl + 0 (ゼロ) Design.FitAll
ハンドルの表示 F9 Design.ShowHandles
拡大します Ctrl + Alt + = Design.ZoomIn
縮小します Ctrl + Alt + - Design.ZoomOut
デザイナー オプション Ctrl + Shift + ;
テキストの編集 F2 Format.EditText
すべて Ctrl + Shift + R Format.ResetLayout.All
プロジェクト コードの実行 Ctrl + F9
非表示 (Blend のみ) Ctrl + H Timeline.Hide (Blend のみ)
ロック (Blend のみ) Ctrl + L Timeline.Lock (Blend のみ)
表示 (Blend のみ) Ctrl + Shift + H Timeline.Show (Blend のみ)
ロック解除 (Blend のみ) Ctrl + Shift + L Timeline.Unlock (Blend のみ)
Edge の左移動 (左) Ctrl + Shift + , View.EdgeLeftMoveLeft
Edge の左移動 (右) Ctrl + Shift + . View.EdgeLeftMoveRight
Edge の右移動 (左) Ctrl + Shift + Alt + , View.EdgeRightMoveLeft
Edge の右移動 (右) Ctrl + Shift + Alt + . View.EdgeRightMoveRight
プロパティ マーカー メニューの表示 Ctrl + Space View.ShowPropertyMarkerMenu

XML (テキスト) エディター

このコンテキストに固有のショートカットは次のとおりです。

コマンド キーボード ショートカット コマンド ID
XSLT デバッグを開始 Alt + F5 XML.StartXSLTDebugging
デバッグなしで XSLT を開始する Ctrl + Alt + F5 XML.StartXSLTWithoutDebugging

XML スキーマ デザイナー

このコンテキストに固有のショートカットは次のとおりです。

コマンド キーボード ショートカット コマンド ID
下から上 Alt + ↑ GraphView.BottomtoTop
左から右 Alt + → GraphView.LefttoRight
右から左 Alt + ← GraphView.RighttoLeft
上から下 Alt + ↓ GraphView.ToptoBottom
ワークスペースからの削除 削除 OtherContextMenus.GraphView.RemovefromWorkspace
コンテンツ モデル ビューの表示 Ctrl + 数字 2 XsdDesigner.ShowContentModelView
グラフ ビューの表示 Ctrl + 数字 3 XsdDesigner.ShowGraphView
スタート ビューの表示 Ctrl + 数字 1 XsdDesigner.ShowStartView