プロジェクトまたはソリューションを使用せずに Visual Studio でコードを開発するDevelop code in Visual Studio without projects or solutions

Visual Studio 2017 で、ほぼすべての種類のディレクトリ ベースのプロジェクトから、ソリューションまたはプロジェクト ファイルを使用せずに Visual Studio にコードを開くことができます。In Visual Studio 2017, you can open code from nearly any type of directory-based project into Visual Studio without the need for a solution or project file. これは、たとえば、GitHub でリポジトリを複製して、直接 Visual Studio に開き、ソリューションまたはプロジェクトを作成することなく開発を開始できることを意味します。This means you can, for example, clone a repo on GitHub, open it directly into Visual Studio, and begin developing, without having to create a solution or project. 必要な場合は、カスタム ビルド タスクを指定し、単純な JSON ファイルからパラメーターを起動できます。If needed, you can specify custom build tasks and launch parameters through simple JSON files.

Visual Studio でコード ファイルを開いた後、ソリューション エクスプローラーによって、フォルダー内のすべてのファイルが表示されます。After you open your code files in Visual Studio, Solution Explorer displays all the files in the folder. 任意のファイルをクリックして、編集を開始できます。You can click on any file to begin editing it. バックグラウンドでは、Visual Studio は、ファイルのインデックス作成を開始して、IntelliSense、ナビゲーション、およびリファクタリング機能を有効にします。In the background, Visual Studio starts indexing the files to enable IntelliSense, navigation, and refactoring features. ファイルを編集、作成、移動、または削除すると、Visual Studio は自動的に変更を追跡し、IntelliSense インデックスを継続的に更新します。As you edit, create, move, or delete files, Visual Studio tracks the changes automatically and continuously updates its IntelliSense index. コードは、構文が色付けされて表示され、多くの場合、基本的な IntelliSense ステートメント入力候補を含みます。Code will appear with syntax colorization and, in many cases, include basic IntelliSense statement completion.

コードを開くOpen any code

次のいずれかの方法で、Visual Studio にコードを開くことができます。You can open code into Visual Studio in any of the following ways:

  • Visual Studio メニュー バーで、[ファイル] > [開く] > [フォルダー] を選択して、コードの場所を参照します。On the Visual Studio menu bar, choose File > Open > Folder, and then browse to the code location.
  • コードを含むフォルダーのコンテキスト (右クリック) メニューで、[Visual Studio で開く] コマンドを選択します。On the context (right-click) menu of a folder containing code, choose the Open in Visual Studio command.
  • Visual Studio スタート ページ[フォルダーを開く] を選択します。Choose the Open Folder link on the Visual Studio Start Page.
  • キーボードのユーザーの場合は、Visual Studio で Ctrl+shift +Alt+O キーを押します。If you are a keyboard user, press Ctrl+Shift+Alt+O in Visual Studio.
  • 複製された GitHub リポジトリからコードを開きます。Open code from a cloned GitHub repo.

複製された GitHub リポジトリからコードを開くにはTo open code from a cloned GitHub repo

次の例は、GitHub リポジトリを複製し、Visual Studio でそのコードを開く方法を示しています。The following example shows how to clone a GitHub repo and then open its code in Visual Studio. この手順を実行するには、GitHub アカウントがあり、システム上に Git for Windows がインストールされている必要があります。To follow this procedure, you must have a GitHub account and Git for Windows installed on your system. 詳しくは、「Signing up for a new GitHub account (GitHub アカウントに登録する)」および「Git for Windows」をご覧ください。See Signing up for a new GitHub account and Git for Windows for more information.

  1. GitHub の複製するリポジトリに移動します。Go to the repo you want to clone on GitHub.

  2. [複製またはダウンロード] ボタンをクリックし、ドロップダウン メニューで [クリップボードにコピー] ボタンを選択して、GitHub リポジトリのセキュリティをコピーします。Choose the Clone or Download button and then choose the Copy to Clipboard button in the dropdown menu to copy the secure URL for the GitHub repo.

    GitHub の複製ボタン

  3. Visual Studio で、[チーム エクスプローラー] タブを選択し、チーム エクスプローラーを開きます。In Visual Studio, choose the Team Explorer tab to open Team Explorer. タブが表示されない場合は、[ビュー] > [チーム エクスプローラー] からタブを開きます。If you don't see the tab, open it from View > Team Explorer.

  4. チーム エクスプローラーの [ローカル Git リポジトリ] セクションで [複製] コマンドを選択し、GitHub ページの URL をテキスト ボックスに貼り付けます。In Team Explorer, under the Local Git Repositories section, choose the Clone command and then paste the URL of the GitHub page into the text box.

    プロジェクトの複製

  5. [複製] ボタンを選択して、プロジェクトのファイルをローカル Git リポジトリに複製します。Choose the Clone button to clone the project's files to a local Git repository. リポジトリのサイズによっては、この処理に数分かかることがあります。Depending on the size of the repo, this process could take several minutes.

  6. リポジトリがシステムに複製されたら、チーム エクスプローラーで、新しく複製されたリポジトリのコンテキスト (右クリック) メニューで [開く] コマンドを選択します。After the repo has been cloned to your system, in Team Explorer, choose the Open command on the context (right-click) menu of the newly cloned repo.

    複製されたリポジトリ

  7. [フォルダー ビューの表示] コマンドを選択して、ソリューション エクスプローラーでファイルを表示します。Choose the Show Folder View command to view the files in Solution Explorer.

    フォルダー ビューの表示

    複製されたリポジトリでフォルダーとファイルを参照したり、Visual Studio コード エディターでコードを表示/検索したり、構文の色付けなどの機能でコードを補完したりできるようになりました。You can now browse folders and files in the cloned repo, and view and search the code in the Visual Studio code editor, complete with syntax colorization and other features.

ビデオのムービー カメラ アイコン Visual Studio の GitHub リポジトリからコードを複製し、開く方法については、ビデオをご覧くださいWatch a video on how to clone and open code from a GitHub repo in Visual Studio.

コードを実行してデバッグするRun and debug your code

Visual Studio でプロジェクトまたはソリューションを使用せずにコードをデバッグすることができます。You can debug your code in Visual Studio without a project or solution! 一部の言語では、コード ベースで有効な "スタートアップ ファイル" (スクリプト、実行可能ファイル、プロジェクトなど) の指定が必要になる場合があります。To debug some languages, you may need to specify a valid startup file in the codebase, such as a script, executable, or project. ツールバーの [開始] ボタンの横にあるドロップダウン リスト ボックスに、Visual Studio によって検出されたすべてのスタートアップ アイテムと、明示的に指定した項目が一覧表示されます。The drop-down list box next to the Start button on the toolbar lists all of the startup items that Visual Studio detects, as well as items you specifically designate. コードのデバッグ時に、このコードが Visual Studio によって最初に実行されます。Visual Studio runs this code first when you debug your code.

Visual Studio で実行するコードの構成は、そのコードの種類やビルド ツールに応じて異なります。Configuring your code to run in Visual Studio differs depending on what kind of code it is, and what the build tools are.

MSBuild を使用するコードベースCodebases that use MSBuild

MSBuild ベース コードベースでは、[開始] ボタンのドロップダウン リストに表示される複数のビルド構成を保持できます。MSBuild-based codebases can have multiple build configurations that appear in the Start button's drop-down list. スタートップ アイテムとして使用したいファイルを選び、[開始] ボタンを選択してデバッグを開始します。Select the file that you want to use as the startup item, and then choose the Start button to begin debugging.

注意

C# および Visual Basic コードベースの場合、.NET デスクトップ開発のワークロードがインストールされている必要があります。For C# and Visual Basic codebases, you must have the .NET desktop development workload installed. C++ コードベースの場合、C++ によるデスクトップ開発のワークロードがインストールされている必要があります。For C++ codebases, you must have the Desktop development with C++ workload installed.

カスタム ビルド ツールを使用するコードベースCodebases that use custom build tools

お使いのコードベースでカスタム ビルド ツールを使用している場合、.json ファイルに定義されているビルド タスクを使用したコードの作成方法を Visual Studio に指示する必要があります。If your codebase uses custom build tools, then you must tell Visual Studio how to build your code using build tasks that are defined in a .json file. 詳細については、ビルドのカスタマイズとタスクのデバッグに関するページをご覧ください。For more information, see Customize build and debug tasks.

Python または JavaScript コードを含むコードベースCodebases that contain Python or JavaScript code

コードベースに Python または JavaScript コードが含まれている場合、.json ファイルを構成する必要はありませんが、対応するワークロードをインストールする必要が生じます。If your codebase contains Python or JavaScript code, you don't have to configure any .json files, but you do have to install the corresponding workload. また、次のようにスタートアップ スクリプトを構成する必要があります。You must also configure the startup script:

  1. [ツール] > [ツールと機能を取得...] を選択するか、または Visual Studio を複製して Visual Studio インストーラーを実行することで、Node.js 開発または Python 開発のワークロードをインストールします。Install the Node.js development or Python development workload by choosing Tools > Get Tools and Features..., or by closing Visual Studio and running the Visual Studio Installer.

    Node.js および Python 開発のワークロード

  2. ソリューション エクスプローラーで、JavaScript または Python ファイルを右クリックしたコンテキスト メニューで、[スタートアップ アイテムとして設定] コマンドを選択します。In Solution Explorer, on the right-click or context menu of a JavaScript or Python file, choose the Set as Startup Item command.

  3. [開始] ボタンを選択して、デバッグを開始します。Choose the Start button to begin debugging.

C++ コードを含むコードベースCodebases that contain C++ code

Visual Studio のソリューションやプロジェクトを使用せずに C++ コードを開く場合の手順については、C++ でフォルダーのプロジェクトを開く方法に関するページをご覧ください。For information about opening C++ code without solutions or projects in Visual Studio, see Open Folder projects for C++.

Visual Studio プロジェクトを含むコードベースCodebases that contain a Visual Studio project

コードのフォルダーに Visual Studio プロジェクトが含まれている場合、スタートアップ アイテムとしてプロジェクトを指定できます。If your code folder contains a Visual Studio project, you can designate the project as the startup item.

スタートアップ アイテムとしてプロジェクトを設定する

プロジェクトがスターアップ アイテムであることを反映して、[開始] ボタンのテキストが変更されます。The Start button's text changes to reflect that the project is the startup item.

[開始] ボタンにあるプロジェクト

関連項目See also