エンコーディングと改行Encodings and Line Breaks

Visual Studio では、次の文字が改行として解釈されます。The following characters are interpreted as line breaks in Visual Studio:

  • CR LF: キャリッジ リターン文字とライン フィード文字 (Unicode 文字では 000D + 000A)CR LF: Carriage return + line feed, Unicode characters 000D + 000A

  • LF: ライン フィード文字 (Unicode 文字では 000A)LF: Line feed, Unicode character 000A

  • NEL: 次行記号 (Unicode 文字では 0085)NEL: Next line, Unicode character 0085

  • LS: 行区切り記号 (Unicode 文字では 2028)LS: Line separator, Unicode character 2028

  • PS: 段落区切り記号 (Unicode 文字では 2029)PS: Paragraph separator, Unicode character 2029

他のアプリケーションからコピーされたテキストでは、元のエンコーディングと改行文字が保持されます。Text that is copied from other applications keeps the original encoding and line break characters. たとえば、メモ帳からテキストをコピーし、Visual Studio でテキスト ファイルに貼り付けた場合、貼り付けたテキストの設定は、メモ帳で使用していた設定と同じになります。For example, when you copy text from Notepad and paste it into a text file in Visual Studio, the text has the same settings that it had in Notepad.

改行文字が異なるファイルを開くと、一致しない改行文字を正規化するかどうか、また、どの種類の改行を使用するかを確認するダイアログ ボックスが表示される場合があります。When you open a file that has different line break characters, you may see a dialog box that asks whether the inconsistent line break characters should be normalized, and which type of line breaks to choose.

[ファイル] メニューの [保存オプションの詳細設定] ダイアログ ボックスを使用して、必要な改行の種類を決定できます。You can use the File, Advanced Save Options dialog box to determine the type of line break characters you want. また、同じ設定でファイルのエンコーディングを変更することもできます。You can also change the encoding of a file with the same settings.

[保存オプションの詳細設定] ダイアログ ボックス

注意

[ファイル] メニューに [保存オプションの詳細設定] が表示されない場合は、追加することができます。If you don't see Advanced Save Options on the File menu, you can add it. [ツール][カスタマイズ] の順に選択し、[コマンド] タブを選択します。メニュー バーのドロップダウン リストで、[ファイル] を選択し、[コマンドの追加...] ボタンを選択します。Choose Tools, Customize..., and then choose the Commands tab. In the Menu bar drop-down list, choose File, then choose the Add Command... button. [コマンドの追加] ダイアログ ボックスの [カテゴリ] の下で、[ファイル] を選択してから、[コマンド] 一覧で [保存オプションの詳細設定] を選択します。[OK] を選択し、[下へ移動] ボタンを選び、コマンドをメニュー内の任意の場所に移動します。In the Add Command dialog box, under Categories, choose File, and then in the Commands list, choose Advanced Save Options.... Choose OK and then choose the Move Down button to move the command to any place in the menu. [閉じる] を選び、[カスタマイズ] ダイアログ ボックスを閉じます。Choose Close to close the Customize dialog box. 詳細については、「メニューまたはツール バーのカスタマイズ」を参照してください。For more information, see Customize menus and toolbars.

または、[ファイル][<ファイル名> に名前を付けて保存] を選択して[保存オプションの詳細設定] ダイアログ ボックスにアクセスできます。[名前を付けてファイルを保存] ダイアログ ボックスで、[保存] ボタンの横にあるドロップダウンの三角形を選択し、[エンコード付きで保存] を選択します。Alternatively, you can access the Advanced Save Options dialog box by choosing File, Save <file> As.... In the Save File As dialog box, choose the drop-down triangle next to the Save button and choose Save with encoding....

関連項目See also

コード エディターでのコードの作成Writing code in the editor