テキストの検索と置換Find and replace text

[検索と置換] または [フォルダーを指定して検索]/[フォルダーを指定して置換] を使用して、Visual Studio エディターでテストを検索したり、置換したりすることができます。You can find and replace text in the Visual Studio editor by using Find and Replace or Find/Replace in Files.

ヒント

変数やメソッドなど、コード記号の名前を変更している場合、検索と置換よりもリファクター を使用する方が適しています。If you're renaming code symbols such as variables and methods, it's better to refactor them than to use find-and-replace. 検索と置換でやみくもにすべてのインスタンスを置換しても、リファクタリングはインテリジェントで、範囲を理解します。Refactoring is intelligent and understands scope, whereas find-and-replace blindly replaces all instances.

検索と置換機能は、エディター、その他の特定のテキストベースのウィンドウ ([検索結果] ウィンドウなど)、デザイナー ウィンドウ (XAML デザイナー、Windows フォーム デザイナーなど)、およびツール ウィンドウで利用できます。Find-and-replace functionality is available in the editor, in certain other text-based windows such as the Find Results windows, in designer windows such as the XAML designer and Windows Forms designer, and in tool windows.

検索のスコープは、現在のドキュメント、現在のソリューション、またはカスタム フォルダー セットに設定できます。You can scope searches to the current document, the current solution, or a custom set of folders. 複数ファイル検索用に、一連のファイル名拡張子を指定することもできます。You can also specify a set of file name extensions for multi-file searches. .NET 正規表現を使用して、検索構文をカスタマイズします。Customize search syntax by using .NET regular expressions.

ヒント

[検索/コマンド] ボックスは、ツール バー コントロールとして使用できますが、既定では表示されません。The Find/Command box is available as a toolbar control, but isn't visible by default. [検索/コマンド] ボックスを表示するには、[標準] ツール バーの [ボタンの追加または削除] を選択し、[検索] を選択します。To display the Find/Command box, select Add or Remove Buttons on the Standard toolbar, and then select Find.

[検索と置換] コントロールFind and Replace control

[検索と置換] コントロールは、コード エディター ウィンドウの右上隅に表示されます。The Find and Replace control appears in the upper right corner of the code editor window. [検索と置換] コントロールにより、現在のドキュメントに出現する指定された検索文字列がすべて直ちに強調表示されます。The Find and Replace control immediately highlights every occurrence of the given search string in the current document. 検索コントロールの [次を検索] または [前を検索] をクリックすると、1 つの出現箇所から別の出現箇所に移動できます。You can navigate from one occurrence to another by choosing the Find Next button or the Find Previous button on the search control.

[検索と置換] コントロール

[検索] ボックスの横にあるボタンをクリックして、置換オプションにアクセスすることもできます。You can access replacement options by choosing the button next to the Find text box. 置換を 1 か所ずつ実行するには、[置換] ボックスの横にある [次を置換] をクリックします。To make one replacement at a time, choose the Replace Next button next to the Replace text box. すべての一致項目を置換するには、[すべて置換] をクリックします。To replace all matches, choose the Replace All button.

一致項目の強調表示色を変更するには、[ツール] メニューで [オプション][環境][フォントおよび色] の順にクリックします。To change the highlight color for matches, choose the Tools menu, select Options, and then choose Environment, and select Fonts and Colors. [設定の表示] の一覧で [テキスト エディター] をクリックし、[表示項目] の一覧で [蛍光ペンの検索] (拡張機能) をクリックします。In the Show settings for list, select Text Editor, and then in the Display items list, select Find Highlight (Extension).

ツール ウィンドウでの検索Search tool windows

[検索] コントロールは、[出力] ウィンドウや [検索結果] ウィンドウなどのコード ウィンドウまたはテキスト ウィンドウでも使用できます。これには、[編集] > [検索と置換] を選択するか、Ctrl + F キーを押します。You can use the Find control in code or text windows, such as Output windows and Find Results windows, by selecting Edit > Find and Replace or pressing Ctrl+F.

一部のツール ウィンドウで使用できるバージョンの [検索] コントロールもあります。A version of the Find control is also available in some tool windows. たとえば、検索ボックスにテキストを入力することにより、[ツールボックス] ウィンドウに表示されるコントロールの一覧をフィルター処理できます。For example, you can filter the list of controls in the Toolbox window by entering text in the search box. コンテンツを検索できる他のツール ウィンドウとしては、ソリューション エクスプローラー[プロパティ] ウィンドウ、チーム エクスプローラーなどがあります。Other tool windows that allow you to search their contents include Solution Explorer, the Properties window, and Team Explorer.

[フォルダーを指定して検索] と [フォルダーを指定して置換]Find in Files and Replace in Files

[フォルダーを指定して検索]/[フォルダーを指定して置換][検索と置換] コントロールと同様に動作します。ただし、検索のスコープを定義できる点が異なります。Find/Replace in Files works like the Find and Replace control, except that you can define a scope for your search. エディター内で開いているファイルを検索するだけでなく、開いているすべてのドキュメント、ソリューション全体、現在のプロジェクト、および選択したフォルダー セットも対象にして検索できます。Not only can you search the current open file in the editor, but also all open documents, the entire solution, the current project, and selected folder sets. また、ファイル名拡張子によって検索することもできます。You can also search by file name extension. [フォルダーを指定して検索]/[フォルダーを指定して置換] ダイアログ ボックスにアクセスするには、[編集] メニューの [検索と置換] を選択するか、Ctrl + Shift + F キーを押します。To access the Find/Replace in Files dialog box, select Find and Replace on the Edit menu or press Ctrl+Shift+F.

[ファイルから検索] ダイアログ ボックス

検索結果Find Results

[すべて検索] を選択すると、[検索結果] ウィンドウが開き、検索に対する一致項目が一覧表示されます。When you choose Find All, a Find Results window opens and lists the matches for your search. 一覧内でいずれかの検索結果を選択すると、関連付けられたファイルが表示され、一致項目が強調表示されます。Selecting a result in the list displays the associated file and highlights the match. まだファイルが編集用に開いていなければ、タブ ウェルの右側にあるプレビュー タブで開かれます。If the file is not already open for editing, it is opened in a preview tab in the right side of the tab well. [検索結果] ボックスの一覧内の検索にも [検索] コントロールを使用できます。You can use the Find control to search through the Find Results list.

カスタムの検索フォルダー セットの作成Create custom search folder sets

[検索対象] ボックスの横にある [検索フォルダーの選択] ボタン ([...]) をクリックすると、検索スコープを定義できます。You can define a search scope by choosing the Choose Search Folders button (it looks like ...) next to the Look in box. [検索フォルダーの選択] ダイアログ ボックスでは、検索対象としてフォルダーのセットを指定し、その指定内容を後で再利用できるように保存することができます。In the Choose Search Folders dialog box, you can specify a set of folders to search, and you can save the specification so that you can reuse it later.

ヒント

リモート マシンのドライブをローカル コンピューターにマップした場合、リモート マシン上で検索するフォルダーを指定できます。If you've mapped a remote machine's drive to your local machine, you can specify folders to search on the remote machine.

カスタムのコンポーネント セットの作成Create custom component sets

[検索対象] ボックスの横にある [カスタム コンポーネント セットの編集] をクリックすると、コンポーネント セットを検索スコープとして定義できます。You can define component sets as your search scope by choosing the Edit Custom Component Set button next to the Look in box. インストールされている .NET または COM コンポーネント、ソリューションに含まれている Visual Studio プロジェクト、または任意のアセンブリやタイプ ライブラリ (.dll.tlb.olb.exe.ocx) を指定できます。You can specify installed .NET or COM components, Visual Studio projects that are included in your solution, or any assembly or type library (.dll, .tlb, .olb, .exe, or .ocx). 参照を検索するには、[参照内で検索] チェック ボックスをオンにします。To search references, select the Look in references box.

関連項目See also