Visual Studio 内の C++ の概要Get Started with C++ in Visual Studio

このクイックスタートを完了すると、Visual Studio を使用して C++ のアプリケーションを開発する際に使用できるさまざまなツールおよびダイアログ ボックスの使用方法を習得できます。Complete this quickstart to become familiar with many of the tools and dialog boxes that you can use when you develop applications in C++ with Visual Studio. "Hello, World" スタイルのコンソール アプリケーションを作成しながら、統合開発環境 (IDE) での作業方法について学習します。Create a "Hello, World"-style console application while you learn more about working in the integrated development environment (IDE).

必須コンポーネントPrerequisites

このクイックスタートを完了するために C++ について理解しておく必要はありませんが、いくつかの一般的なプログラミングの概念とデバッグの概念については理解しておく必要があります。You don't need to be familiar with C++ to complete this quickstart, but you should be familiar with some general programming and debugging concepts. Visual Studio のドキュメントでは、C++ でのプログラミング方法を説明しません。The Visual Studio documentation doesn't teach you how to program in C++. C++ の学習リソースとしては、ISO C++ Web サイトの「Get Started」 (概要) をお勧めします。A good guide to C++ learning resources is the Get Started page on the ISO C++ website.

作業を進めるには、Visual Studio 2017 バージョン 15.3 以降のコピーと、C++ によるデスクトップ開発ワークロードがインストールされている必要があります。To follow along, you need a copy of Visual Studio 2017 version 15.3 or later, with the Desktop development with C++ workload installed. インストールのためのファースト ガイドについては、「Install C++ support in Visual Studio」 (Visual Studio での C++ のインストール サポート) を参照してください。For a fast guide to installation, see Install C++ support in Visual Studio.

コンソール アプリを作成するCreate a console app

Visual Studio がまだ実行されていない場合は、起動します。If it's not running yet, start Visual Studio.

Visual C++ の設定が適用された IDEIDE with Visual C++ settings applied

Visual Studio を開くと、IDE の 3 つの基本的なパーツを確認できます。ツール ウィンドウ、メニューとツール バー、およびメイン ウィンドウ領域です。After you open Visual Studio, you can see the three basic parts of the IDE: tool windows, menus and toolbars, and the main window space. ツール ウィンドウは、アプリ ウィンドウの左側と右側にドッキングされます。Tool windows are docked on the left and right sides of the app window. 上部には、クイック起動ボックス、メニュー バー、および標準ツールバーがあります。The Quick Launch box, the menu bar, and the standard toolbar are found at the top. ウィンドウの中央には、[スタート ページ]が表示されます。The center of the window contains the Start Page. ソリューションまたはプロジェクトを開くと、この領域にはエディターとデザイナーが表示されます。When you open a solution or project, editors and designers appear in this space. アプリを開発する場合は、ほとんどの時間をこの中央の領域での作業に費やします。When you develop an app, most of your time is spent in this central area.

Visual Studio では、"プロジェクト" を使用してアプリのコードを整理し、"ソリューション" を使用してプロジェクトを整理します。Visual Studio uses projects to organize the code for an app, and solutions to organize your projects. プロジェクトには、アプリをビルドする場合に使用するすべてのオプション、構成、および規則が含まれています。A project contains all the options, configurations, and rules used to build your apps. また、プロジェクトでは、プロジェクトのすべてのファイルと、外部のファイルとの間のリレーションシップも管理します。It also manages the relationship between all the project's files and any external files. アプリを作成するには、まず、新しいプロジェクトとソリューションを作成します。To create your app, first, you create a new project and solution.

コンソール アプリ プロジェクトを作成するにはTo create a console app project

  1. メニューバーで [ファイル]、[新規作成]、[プロジェクト] の順に選択して、[新しいプロジェクト] ダイアログ ボックスを開きます。On the menu bar, choose File > New > Project to open the New Project dialog box.

    メニュー バーで [ファイル]、[新規作成]、[プロジェクト] の順に選択On the menu bar, choose File > New > Project

  2. [新しいプロジェクト] ダイアログで、[インストール]、[Visual C++] の順に選択する操作をまだ行っていない場合は、実行します。In the New Project dialog, select Installed > Visual C++ if it isn't selected already. 中央のウィンドウで [Windows コンソール アプリケーション] テンプレートを選択します。In the center pane, select the Windows Console Application template. [名前] 編集ボックスに、「HelloApp」と入力します。In the Name edit box, enter HelloApp.

    [新しいプロジェクト] ダイアログを使用してアプリ プロジェクトを作成するUse the New Project dialog to create your app project

    ダイアログ ボックスに含まれる選択肢は、インストールされている Visual Studio ワークロードおよびコンポーネントによって異なる場合があります。Your dialog box may have different choices, depending on the Visual Studio workloads and components you've installed. Visual C++ プロジェクト テンプレートが見つからない場合は、Visual Studio インストーラーをもう一度実行し、C++ によるデスクトップ開発ワークロードをインストールする必要があります。If you don't see Visual C++ project templates, you need to run the Visual Studio installer again and install the Desktop development with C++ workload. この作業は、[新しいプロジェクト] ダイアログから直接行うことができます。You can do this directly from the New Project dialog. インストーラーを起動するには、ダイアログで [Visual Studio インストーラーを開く] リンクを選択します。To launch the installer, choose the Open Visual Studio Installer link on the dialog.

  3. [OK] ボタンを選択して、アプリのプロジェクトとソリューションを作成します。Choose the OK button to create your app project and solution.

    Windows コンソール アプリの基本的なファイルを含む HelloApp プロジェクトとソリューションが作成され、ソリューション エクスプローラーに自動的に読み込まれます。The HelloApp project and solution, with the basic files for a Windows console app, are created and automatically loaded into Solution Explorer. コード エディターで HelloApp.cpp ファイルが開かれます。The HelloApp.cpp file is opened in the code editor. 次の項目がソリューション エクスプローラーに表示されます。These items appear in Solution Explorer:

    ソリューション エクスプローラーに表示されたソリューションのファイルFiles for the solution in Solution Explorer

アプリケーションにコードを追加するAdd code to the app

次に、コンソール ウィンドウに "Hello" という語を表示するコードを追加します。Next, add code to display the word "Hello" in the console window.

エディターでコードを編集するにはTo edit code in the editor

  1. HelloApp.cpp ファイルの return 0; という行の前に空白行を挿入し、次のコードを入力します。In the HelloApp.cpp file, enter a blank line before the line return 0; and then enter this code:

    cout << "Hello\n";
    

    coutの下に赤い波線が表示されます。A red squiggly line appears under cout. これにポインターを合わせると、エラー メッセージが表示されます。If you hover the pointer over it, an error message appears.

    cout のエラー テキストError text for cout

    エラー メッセージは、 [エラー一覧] ウィンドウにも表示されます。The error message also appears in the Error List window. このウィンドウを表示するには、メニュー バーで [表示]、[エラー一覧] の順に選択します。You can display this window by choosing View > Error List on the menu bar.

    [エラー一覧] ウィンドウのエラーError in Error List window

    コードには std::cout の宣言が欠落しています。これは <iostream> ヘッダー ファイルにあります。Your code is missing a declaration for std::cout, which is found in the <iostream> header file.

  2. iostream ヘッダーを組み込むには、このコードを #include "stdafx.h" の後に入力します。To include the iostream header, enter this code after #include "stdafx.h":

    #include <iostream>
    using namespace std;
    

    コードを入力したとき、ボックスが表示されたのに気づいたはずです。You probably noticed that a box appeared as you entered code. このボックスには、入力した文字のオートコンプリート候補が含まれています。This box contains auto-completion suggestions for the characters that you enter. これは、C++ の IntelliSense の一部で、コーディングの一連のヒントを提供します。それには、クラスやインターフェイスのメンバーやパラメーター情報が含まれます。It's part of C++ IntelliSense, which provides coding prompts, including class or interface members and parameter information. 定義済みのコード ブロックであるコード スニペットを使用することもできます。You can also use code snippets, which are pre-defined blocks of code. 詳細については、 Using IntelliSense および Code Snippetsを参照してください。For more information, see Using IntelliSense and Code Snippets.

    エディターでのコードの修正The fixed code in the editor

    エラーを修正すると、 cout の下の赤い波線が消えます。The red squiggly line under cout disappears when you fix the error.

  3. ファイルに変更内容を保存するには、Ctrl + S キーを押します。To save the changes to the file, press Ctrl+S.

アプリをビルドするBuild the app

コードをビルドするのは簡単です。It's easy to build your code. メニュー バーで、[ビルド]、[ソリューションのビルド] の順にクリックします。On the menu bar, choose Build > Build Solution. Visual Studio は HelloApp ソリューションをビルドし、[出力] ウィンドウに進行状況をレポートします。Visual Studio builds the HelloApp solution, and reports progress in the Output window.

HelloApp ソリューションのビルドBuild the HelloApp solution

アプリのデバッグとテストDebug and test the app

HelloApp をデバッグして、コンソール ウィンドウに "Hello" という語が表示されるかどうかを確認できます。You can debug HelloApp to see whether the word "Hello" appears in the console window.

アプリをデバッグするにはTo debug the app

  1. デバッガーを起動するには、メニュー バーで [デバッグ]、[デバッグ開始] の順に選択します。To start the debugger, choose Debug > Start Debugging on the menu bar.

    [デバッグ] メニューの [デバッグの開始] コマンドStart Debugging command on the Debug menu

    デバッガーが起動し、コードが実行されます。The debugger starts and runs the code. コンソール ウィンドウ (コマンド プロンプトのように見える別のウィンドウ) が数秒間表示されますが、デバッガーが実行を停止するとすぐに閉じます。The console window (a separate window that looks like a command prompt) appears for a few seconds but closes quickly when the debugger stops running. テキストを表示するには、ブレークポイントを設定してプログラムの実行を停止する必要があります。To see the text, you need to set a breakpoint to stop program execution.

ブレークポイントを追加するにはTo add a breakpoint

  1. エディターで、return 0; の行にカーソルを置きます。In the editor, put the cursor on the line return 0;. メニュー バーで、[デバッグ]、[ブレークポイントの設定/解除] の順に選択します。On the menu bar, choose Debug > Toggle Breakpoint. 左側の余白内をクリックしてブレークポイントを設定することもできます。You can also click in the left margin to set a breakpoint.

    [デバッグ] メニューの [ブレークポイントの設定/解除] コマンドToggle Breakpoint command on the Debug menu

    コード行の横の、エディター ウィンドウの左端の余白部分に、赤い円が表示されます。A red circle appears next to the line of code in the far left margin of the editor window.

    ウィンドウの余白部分に表示されたブレークポイントBreakpoint indicated in window margin

  2. デバッグを開始するには、F5 キーを押します。To start debugging, press F5.

    デバッガーが起動し、コンソール ウィンドウが表示されて Helloという語が示されます。The debugger starts, and a console window appears showing the word Hello.

    コンソール ウィンドウの Hello テキストHello text in the console window

  3. デバッグを停止するには、Shift + F5 キーを押します。To stop debugging, press Shift+F5.

コンソール プロジェクトのデバッグの詳細については、コンソール プロジェクトに関するページを参照してください。For more information about console project debugging, see Console Projects.

アプリのリリース バージョンのビルドBuild a release version of the app

すべてが機能することを確認したら、アプリケーションのリリース ビルドを準備できます。Now that you've verified that everything works, you can prepare a release build of the application. リリース ビルドでは、デバッグ情報を省略し、コンパイラの最適化オプションを使用してコードをより簡潔かつ迅速に作成します。Release builds leave out the debugging information, and use compiler optimization options to create smaller, faster code.

ソリューション ファイルをクリーンアップし、リリース バージョンをビルドするにはTo clean the solution files and build a release version

  1. メニュー バーで、[ビルド]、[ソリューションのクリーン] の順に選択して、前のビルドで作成された中間ファイルと出力ファイルを削除します。On the menu bar, choose Build > Clean Solution to delete intermediate files and output files that were created during previous builds.

    [ビルド] メニューの [ソリューションのクリーン] コマンドThe Clean Solution command on the Build menu

  2. HelloApp のソリューション構成を [デバッグ] から [リリース] に変更するには、ツールバーの [ソリューション構成] コントロールでドロップダウンを選択し、[リリース] を選択します。To change the solution configuration for HelloApp from Debug to Release, in the toolbar, select the dropdown on the Solution Configurations control and then choose Release.

    アプリケーションのリリース バージョンのビルドBuild a release version of the application

  3. ソリューションをビルドします。Build the solution. メニュー バーで、[ビルド]、[ソリューションのビルド] の順にクリックします。On the menu bar, choose Build > Build Solution.

このビルドが完了すると、コマンド プロンプト ウィンドウでコピーおよび実行できるアプリの作成は完了です。When this build completes, you've created an app that you can copy and run in any command prompt window. 大したことではありませんが、これはより複雑な処理へ通じる入口となります。It may not do much, but it's the gateway to greater things.

このクイック スタートは完了しました。Congratulations on completing this quickstart! その他の例については、「Visual Studio Samples」を参照してください。If you want to explore more examples, see Visual Studio Samples.

関連項目See also

C++ デスクトップ開発のための Visual Studio IDE の使用Using the Visual Studio IDE for C++ Desktop Development
チュートリアル: C# または Visual Basic による簡単なアプリケーションの作成Walkthrough: Create a Simple Application with C# or Visual Basic
Visual Studio の生産性に関するヒントProductivity Tips for Visual Studio
Visual Studio のサンプルVisual Studio Samples
Get Started Developing with Visual StudioGet Started Developing with Visual Studio