方法 : プロジェクト テンプレートと項目テンプレートを配置して整理するHow to: Locate and Organize Project and Item Templates

テンプレート ファイルは、テンプレートが [新しいプロジェクト] ダイアログ ボックスや [新しい項目の追加] ダイアログ ボックスに表示されるように、Visual Studio が認識する場所に配置する必要があります。Template files must be placed in a location that Visual Studio recognizes so that the templates will appear in the New Project and Add New Item dialog boxes. テンプレートにはカスタム サブカテゴリを作成できます。作成したサブカテゴリも、ユーザー インターフェイスに表示されます。You can create custom subcategories for templates so that the subcategories will also appear in the user interface.

テンプレートの配置Locating Templates

既定では、Visual Studio はプロジェクト テンプレートと項目テンプレートを 2 つの場所で検索します。By default, Visual Studio searches two locations for project and item templates. .vstemplate ファイルを含む圧縮ファイルがこれらの場所に存在する場合、テンプレートは [新しいプロジェクト] ダイアログ ボックスまたは [新しい項目の追加] ダイアログ ボックスに表示されます。If a compressed file that includes a .vstemplate file exists in these locations, a template will appear in the New Project or Add New Item dialog boxes.

インストールされたテンプレートInstalled Templates

既定では、製品と共にインストールされたテンプレートは次の場所に配置されます。By default, templates installed together with the product are located in:

  • \VisualStudioInstallationDirectory\Common7\IDE\ItemTemplates\言語\ロケール\\VisualStudioInstallationDirectory\Common7\IDE\ItemTemplates\Language\Locale\

  • \VisualStudioInstallationDirectory\Common7\IDE\ProjectTemplates\言語\ロケール\\VisualStudioInstallationDirectory\Common7\IDE\ProjectTemplates\Language\Locale\

    たとえば、次のディレクトリには英語用の Visual StudioVisual Studio プロジェクト テンプレートが含まれています。For example, the following directory contains the Visual StudioVisual Studio project templates for English:

    C:\VisualStudioInstallationDirectory\Common7\IDE\ItemTemplates\VisualBasic\1033\C:\VisualStudioInstallationDirectory\Common7\IDE\ItemTemplates\VisualBasic\1033\

カスタム テンプレートCustom Templates

既定では、カスタム テンプレートは次の場所に配置されます。By default, custom templates are located in:

  • \My Documents\Visual Studio バージョン\Templates\ProjectTemplates\言語\\My Documents\Visual Studio Version\Templates\ProjectTemplates\Language\

  • \My Documents\Visual Studio バージョン\Templates\ItemTemplates\言語\\My Documents\Visual Studio Version\Templates\ItemTemplates\Language\

    たとえば、次のディレクトリにはカスタム Visual C#Visual C# プロジェクト テンプレートが含まれています。For example, the following directory contains custom Visual C#Visual C# project templates:

    C:\Documents and Settings<ユーザー名>\My Documents\Visual Studio バージョン\Templates\ProjectTemplates\Visual C#\C:\Documents and Settings\UserName\My Documents\Visual Studio Version\Templates\ProjectTemplates\Visual C#\

    カスタム テンプレートには、ローカライズされたテンプレート用のサブディレクトリは含まれていません。Custom templates do not include a subdirectory for localized templates. カスタム テンプレートの既定ディレクトリは、[オプション] ダイアログ ボックスの [環境] > [プロジェクトおよびソリューション] で変更できます。You can change the default directory for custom templates in the Options dialog box, under Environment\Projects and Solutions.

テンプレートの整理Organizing Templates

[新しいプロジェクト] ダイアログ ボックスおよび [新しい項目の追加] ダイアログ ボックスには、インストールされたテンプレートやカスタム テンプレートの場所のディレクトリ構造がカテゴリとして反映されます。The categories in the New Project and Add New Item dialog boxes reflect the directory structures that exist in the installed and custom template locations. これらのディレクトリ構造を変更することにより、自分にとってわかりやすいようにテンプレートを整理できます。You can modify these directory structures to organize your templates in a way that makes sense to you.

注意

プログラミング言語のレベルでは、新しいカテゴリを作成できません。You cannot create a new category at the programming language level. 新しいカテゴリは、各言語内でのみ作成できます。New categories can only be created within each language.

特定言語について、インストールされたテンプレートとカスタム テンプレートのディレクトリ構造が異なる場合 (あるフォルダーについて、片方では下位にディレクトリがあり、もう片方ではディレクトリがない場合)、[新しいプロジェクト] ダイアログ ボックスでは、すべてのカテゴリをマージしたカテゴリのセットが表示されます。If the directory structures for installed and custom templates for a particular language do not have the same structure (that is, there are directories under one folder that do not exist under the other) the set of categories that appear in the New Project dialog will be the merger of all categories.

インストールされたテンプレートの整理Organizing Installed Templates

インストールされたテンプレートを整理するには、プログラミング言語のフォルダー内にサブディレクトリを作成します。You can organize installed templates by creating subdirectories in the programming language folder. これらのサブディレクトリは、各言語の [新しいプロジェクト] ダイアログ ボックスおよび [新しい項目の追加] ダイアログ ボックスで、仮想フォルダーとして表示されます。These subdirectories appear in the New Project and Add New Item dialog boxes as virtual folders within each language.

インストールされたプロジェクト テンプレートの新しいカテゴリを作成するにはTo create new installed project template categories
  1. インストールされたテンプレートのディレクトリの言語フォルダーに、フォルダーを作成します。Create a folder in the language folder of the installed template directory. たとえば、Visual StudioVisual Studio プロジェクト テンプレートに対して Office カテゴリを作成するには、次のディレクトリを作成する必要があります。For example, to create an Office category for Visual StudioVisual Studio project templates you would create the following directory:

    \Visual Studio のインストール ディレクトリ\Common7\IDE\ProjectTemplates\VisualBasic\1033\Office\\VisualStudioInstallationDirectory\Common7\IDE\ProjectTemplates\VisualBasic\1033\Office\

  2. このカテゴリのすべてのテンプレートを新しいフォルダーに配置します。Place all the templates for this category in the new folder.

  3. Visual StudioVisual Studio のすべてのインスタンスを閉じます。Close all instances of Visual StudioVisual Studio.

  4. [スタート] メニューの [ファイル名を指定して実行] をクリックし、「cmd」と入力し、[OK] をクリックします。On the Start menu, click Run, type cmd, and click OK.

  5. コマンド プロンプトで、devenv.exe を含むディレクトリに移動し、「devenv /installvstemplates」と入力します。At the command prompt, locate the directory that contains devenv.exe, and type devenv /installvstemplates.

  6. Visual StudioVisual Studio を実行します。Run Visual StudioVisual Studio.

  7. [ファイル] メニューの [新規作成]をポイントし、 [プロジェクト]をクリックします。On the File menu, click New, and then click Project.

  8. Office カテゴリが [新しいプロジェクト] ダイアログ ボックスの [プロジェクトの種類] ウィンドウの [Visual BasicVisual Basic] の下に表示されることを確認します。Verify that the Office category appears in the New Project dialog box, in the Project types pane, under Visual BasicVisual Basic.

    プロジェクト項目テンプレートのサブセットをカスタム フォルダーとしてグループ化することもできます。You can also group a subset of the project item templates into a custom folder.

インストールされた項目テンプレートの新しいカテゴリを作成するにはTo create new installed item template categories
  1. インストールされたテンプレートのディレクトリの言語フォルダーに、フォルダーを作成します。Create a folder in the language folder of the installed template directory. たとえば、Visual C#Visual C# 項目テンプレートに対して Web カテゴリを作成するには、次のディレクトリを作成する必要があります。For example, to create a Web category for Visual C#Visual C# item templates you would create the following directory:

    \Visual Studio のインストール ディレクトリ\Common7\IDE\ItemTemplates\CSharp\1033\Web\\VisualStudioInstallationDirectory\Common7\IDE\ItemTemplates\CSharp\1033\Web\

  2. このカテゴリのすべてのテンプレートを新しいフォルダーに配置します。Place all templates for this category in the new folder.

  3. Visual StudioVisual Studio のすべてのインスタンスを閉じます。Close all instances of Visual StudioVisual Studio.

  4. [スタート] メニューの [ファイル名を指定して実行] をクリックし、「cmd」と入力し、[OK] をクリックします。On the Start menu, click Run, type cmd, and click OK.

  5. コマンド プロンプトで、devenv.exe を含むディレクトリに移動し、「devenv /setup」と入力します。At the command prompt, locate the directory that contains devenv.exe, and type devenv /setup.

  6. Visual StudioVisual Studio を実行します。Run Visual StudioVisual Studio.

  7. プロジェクトを作成するか、既存のプロジェクトを開きます。Create a project or open an existing project.

  8. [プロジェクト] メニューの [新しい項目の追加]をクリックします。On the Project menu, click Add New Item.

  9. Web カテゴリが [新しい項目の追加] ダイアログ ボックスの [プロジェクトの種類] ウィンドウに表示されることを確認します。Verify that the Web category appears in the Add New Item dialog box, in the Project types pane.

カスタム テンプレートの整理Organizing Custom Templates

カスタム テンプレートを独自のカテゴリに整理するには、カスタム テンプレートの場所に新しいフォルダーを追加します。Custom templates can be organized into their own categories by adding new folders in the custom template location. [新しいプロジェクト] ダイアログ ボックスには、テンプレート カテゴリに加えた変更が反映されます。The New Project dialog box reflects any changes you make to your template categories.

カスタム プロジェクト テンプレートの新しいカテゴリを作成するにはTo create new custom project template categories
  1. カスタム プロジェクト テンプレートのディレクトリの言語フォルダーに、フォルダーを作成します。Create a folder in the language folder in the custom project template directory. たとえば、Visual C#Visual C# テンプレートに対して HelloWorld カテゴリを作成するには、次のディレクトリを作成する必要があります。For example, to create a HelloWorld category for Visual C#Visual C# templates, you would create the following directory:

    \My Documents\Visual Studio バージョン\Templates\ProjectTemplates\CSharp\HelloWorld\\My Documents\Visual Studio Version\Templates\ProjectTemplates\CSharp\HelloWorld\

  2. このカテゴリのすべてのテンプレートを新しいフォルダーに配置します。Place all the templates for this category in the new folder.

  3. [ファイル] メニューの [新規作成]をポイントし、 [プロジェクト]をクリックします。On the File menu, click New, and then click Project.

  4. HelloWorld カテゴリが [新しいプロジェクト] ダイアログ ボックスの [プロジェクトの種類] ウィンドウの [Visual C#Visual C#] の下に表示されることを確認します。Verify that the HelloWorld category appears in the New Project dialog box, in the Project types pane, under Visual C#Visual C#.

    カスタム項目テンプレートのサブセットをカスタム フォルダーとしてグループ化することもできます。You can also group a subset of the custom item templates into a custom folder.

カスタム項目テンプレートの新しいカテゴリを作成するにはTo create new custom item template categories
  1. カスタム項目テンプレートのディレクトリの言語フォルダーに、フォルダーを作成します。Create a folder in the language folder in the custom item template directory. たとえば、Visual C#Visual C# テンプレートに対して HelloWorld カテゴリを作成するには、次のディレクトリを作成する必要があります。For example, to create a HelloWorld category for Visual C#Visual C# templates you would create the following directory:

    \My Documents\Visual Studio バージョン\Templates\ItemTemplates\CSharp\HelloWorld\\My Documents\Visual Studio Version\Templates\ItemTemplates\CSharp\HelloWorld\

  2. このカテゴリのすべてのテンプレートを新しいフォルダーに配置します。Place all the templates for this category in the new folder.

  3. プロジェクトを作成するか、既存のプロジェクトを開きます。Create a project or open an existing project.

  4. [プロジェクト] メニューの [新しい項目の追加]をクリックします。On the Project menu, click Add New Item.

  5. HelloWorld カテゴリが [新しい項目の追加] ダイアログ ボックスの [プロジェクトの種類] ウィンドウに表示されることを確認します。Verify that the HelloWorld category appears in the Add New Item dialog box, in the Project types pane.

親カテゴリでのテンプレートの表示Displaying Templates in Parent Categories

.vstemplate ファイルの NumberOfParentCategoriesToRollUp 要素を使用して、サブカテゴリのテンプレートを親カテゴリに表示できます。You can enable templates in subcategories to be displayed in their parent categories by using the NumberOfParentCategoriesToRollUp element in the .vstemplate file. この手順は、プロジェクト テンプレートと項目テンプレートのどちらでも同じです。These steps are identical for both project templates and item templates.

親カテゴリにテンプレートを表示するにはTo display templates in parent categories
  1. テンプレートを含む .zip ファイルを探します。Locate the .zip file that contains the template.

  2. .zip ファイルを展開します。Extract the .zip file.

  3. Visual StudioVisual Studio で .vstemplate ファイルを開きます。Open the .vstemplate file in Visual StudioVisual Studio.

  4. TemplateData 要素に、NumberOfParentCategoriesToRollUp 要素を追加します。In the TemplateData element, add a NumberOfParentCategoriesToRollUp element. たとえば、次のコードを実行すると、テンプレートが親カテゴリに表示されますが、親カテゴリよりも上のレベルでは表示されません。For example, the following code makes the template visible in the parent category, but no higher.

    <TemplateData>  
        ...  
        <NumberOfParentCategoriesToRollUp>  
            1  
        </NumberOfParentCategoriesToRollUp>  
        ...  
    </TemplateData>  
    
  5. .vstemplate ファイルを保存して、閉じます。Save and close the .vstemplate file.

  6. テンプレートでファイルを選択して右クリックし、[送る] をクリックして [圧縮 (zip 形式) フォルダー] をクリックします。Select the files in your template, right-click the selection, click Send To, and then click Compressed (zipped) Folder. ファイルは .zip ファイルに圧縮されます。The files are compressed into a .zip file.

  7. 抽出したテンプレート ファイルと古いテンプレート .zip ファイルを削除します。Delete the extracted template files and the old template .zip file.

  8. 削除した .zip ファイルが含まれていたディレクトリに、新しい .zip ファイルを配置します。Put the new .zip file in the directory that had the deleted .zip file.

関連項目See Also

テンプレートのカスタマイズ Customizing Templates
Visual Studio テンプレート スキーマ参照 Visual Studio Template Schema Reference
NumberOfParentCategoriesToRollUp (Visual Studio テンプレート) NumberOfParentCategoriesToRollUp (Visual Studio Templates)
方法 : プロジェクト テンプレートを作成する How to: Create Project Templates
方法 : 項目テンプレートを作成するHow to: Create Item Templates