方法: Visual Studio IDE 内で移動するHow to: Move Around in the Visual Studio IDE

統合開発環境 (IDE) は、ユーザー設定やプロジェクトの要件に応じて、いくつかの異なる方法で、ウィンドウからウィンドウへ、またはファイルからファイルへ移動できるように設計されています。The integrated development environment (IDE) has been designed to allow you to move from window to window and file to file in several different ways, depending on your preference or project requirements. エディターで開いているファイルを順番に表示することも、IDE 内でアクティブなすべてのツール ウィンドウを順番に表示することもできます。You can choose to cycle through open files in the editor, or cycle through all active tool windows in the IDE. また、最後にアクセスした順序に関係なく、エディターで開いている任意のファイルに直接切り替えることもできます。You also can switch directly to any file open in the editor, regardless of the order in which it was last accessed. これらの機能は、IDE で作業するときの生産性を向上するのに役立ちます。These features can help increase your productivity when working in the IDE.

注意

使用している設定またはエディションによっては、ダイアログ ボックスで使用可能なオプションや、メニュー コマンドの名前や位置がこの記事に記載されている内容と異なる場合があります。The options available in dialog boxes, and the names and locations of menu commands you see, might differ from what is described in this article, depending on your active settings or edition. この記事は、[全般] 設定を念頭に置いて書かれています。This article was written with General settings in mind. 設定を、たとえば、[全般][Visual C++] に変更するには、[ツール][設定のインポートとエクスポート][すべての設定をリセット] の順に選択します。To change your settings, for example to General or Visual C++ settings, choose Tools, Import and Export Settings, and then choose Reset all settings.

ショートカット キーKeyboard Shortcuts

Visual Studio のほぼすべてのメニュー コマンドにはショートカット キーがあります。Almost every menu command in Visual Studio has a keyboard shortcut. 独自のカスタム ショートカットを作成することもできます。You can also create your own custom shortcuts. 詳細については、「Visual Studio でのキーボード ショートカットの識別とカスタマイズ」をご覧ください。For more information, see Identifying and Customizing Keyboard Shortcuts.

エディターで開いているファイル間を移動する方法はいくつかあります。You can use several methods to move through the files open in the editor. アクセス順に基づいてファイル間を移動する、IDE Navigator を使用して現在開いている任意のファイルをすばやく見つける、あるいはお気に入りのファイルをタブにピン留めして常に表示されているようにする、などです。You can move among files based on the order in which you access them, use the IDE Navigator to quickly find any file currently open, or pin favorite files to the tab well so that they are always visible.

[戻る] と [次に進む] を使うと、Microsoft Internet Explorer で [戻る] と [進む] で履歴を表示するのと同じように、開いているファイルをアクセスした順番に基づいて切り替えることができます。Navigate Backward and Navigate Forward cycle through the open files in the editor based on the order in which they were accessed, much like Back and Forward do for your viewing history in Microsoft Internet Explorer.

使用順に開いているファイル内を移動するにはTo move through open files in order of use

  • 最近使用した順序で開いているドキュメントをアクティブにするには、Ctrl+- キーを押します。To activate open documents in the order they were most recently touched, press Ctrl+-.

  • 逆の順序で開いているドキュメントをアクティブにするには、Ctrl+Shift+- キーを押します。To activate open documents in the reverse order, press Ctrl+Shift+-.

    注意

    [戻る][次に進む][表示] メニューにもあります。Navigate Backward and Navigate Forward also can be found on the View menu.

また、ファイルを最後にアクセスしたときに関係なく、IDE Navigator、エディターの [アクティブなファイル] リスト、または [Windows] ダイアログ ボックスを使って、エディターで開いている特定のファイルを切り替えることができます。You also can switch to a specific file open in the editor, regardless of when you last accessed the file, using the IDE Navigator, the Active Files list in the editor, or the Windows dialog box.

IDE Navigator は、Windows アプリケーションのスイッチャーのように動作します。The IDE Navigator works much like the Windows application switcher. メニューからは利用できず、ショートカット キーを使用してのみアクセスできます。It is not available from menus and can be accessed only using shortcut keys. 2 つのコマンドのいずれかを使って IDE Navigator にアクセスし (下記参照)、表示したい順番でファイルを切り替えることができます。You can use either of two commands to access the IDE Navigator (shown below) to cycle through files, depending on the order in which you want to cycle through.

Visual Studio IDE NavigatorVisual Studio IDE Navigator

Window.PreviousDocumentWindowNav では最後にアクセスしたファイルに移動することができ、Window.NextDocumentWindowNav では逆の順序で移動することができます。Window.PreviousDocumentWindowNav allows you to move to the file most recently accessed and Window.NextDocumentWindowNav allows you to move in the reverse order. [全般的な開発設定] では、Shift+Alt+F7Window.PreviousDocumentWindowNav に、Alt+F7Window.NextDocumentWindowNav に割り当てられています。General Development Settings assigns Shift+Alt+F7 to Window.PreviousDocumentWindowNav and Alt+F7 to Window.NextDocumentWindowNav.

注意

使っている設定の組み合わせの中に、このコマンドに割り当てられているショートカット キーの組み合わせがない場合は、[オプション] ダイアログ ボックスの [キーボード] ページを使って、独自のカスタム コマンドを割り当てることができます。If the settings combination you are using does not already have a shortcut key combination assigned to this command, you can assign your own custom command using the Keyboard page of the Options dialog box. 詳細については、「Visual Studio でのキーボード ショートカットの識別とカスタマイズ」をご覧ください。For more information, see Identifying and Customizing Keyboard Shortcuts.

エディターで特定のファイルに切り替えるにはTo switch to specific files in the editor

  • Ctrl+Tab キーを押して、IDE Navigator を表示します。Press Ctrl+Tab to display the IDE Navigator. 切り替える対象のファイルが選択されるまで、Ctrl キーを押さえたまま繰り返し Tab キーを押します。Hold down the CTRL key and press TAB repeatedly until you select the file you intend to switch to.

    ヒント

    [アクティブなファイル] リストの順番を逆に切り替えるには、Ctrl+Shift キーを押したまま Tab キーを押します。To reverse the order in which you go through the Active Files list, hold down the Ctrl+Shift keys and press Tab.

    - または- or -

  • エディターの右上隅で、[アクティブなファイル] ボタンを選び、切り替え先のファイルをリストから選びます。In the upper right corner of the editor, choose the Active Files button, and then select a file from the list to switch to.

    - または- or -

  • メニュー バーで、[ウィンドウ][ウィンドウ] の順に選びます。On the menu bar, choose Window, Windows.

  • 一覧で表示するファイルを選び、[開く] を選びます。In the list, select the file you want to view and then choose Activate.

IDE Navigator では、IDE で開いているツール ウィンドウを順番に表示することもできます。The IDE Navigator also lets you cycle through the tool windows you have open in the IDE. 2 つのコマンドのいずれかを使って IDE Navigator にアクセスし、表示したい順番でツール ウィンドウを切り替えることができます。You can use either of two commands to access the IDE Navigator to cycle through tool windows, depending on the order in which you want to cycle through. Window.PreviousToolWindowNav では最後にアクセスしたファイルに移動することができ、Window.NextToolWindowNav では逆の順序で移動することができます。Window.PreviousToolWindowNav allows you to move to the file most recently accessed and Window.NextToolWindowNav allows you to move in the reverse order. [全般的な開発設定] では、Shift+Alt+F7Window.PreviousDocumentWindowNav に、Alt+F7Window.NextDocumentWindowNav に割り当てられています。General Development Settings assigns Shift+Alt+F7 to Window.PreviousDocumentWindowNav and Alt+F7 to Window.NextDocumentWindowNav.

注意

使っている設定の組み合わせの中に、このコマンドに割り当てられているショートカット キーの組み合わせがない場合は、[オプション] ダイアログ ボックスの [キーボード] ページを使って、独自のカスタム コマンドを割り当てることができます。If the settings combination you are using does not already have a shortcut key combination assigned to this command, you can assign your own custom command using the Keyboard page of the Options dialog box. 詳細については、「Visual Studio でのキーボード ショートカットの識別とカスタマイズ」をご覧ください。For more information, see Identifying and Customizing Keyboard Shortcuts.

IDE で特定のツール ウィンドウに切り替えるにはTo switch to a specific tool window in the IDE

  • Alt+F7 キーを押して、IDE Navigator を表示します。Press Alt+F7 to display the IDE Navigator. 切り替える対象のウィンドウが選択されるまで、Alt キーを押したまま繰り返し F7 キーを押します。Hold down the Alt key and press F7 repeatedly until you select the window you intend to switch to.

    ヒント

    [アクティブなツール ウィンドウ] リストの順番を逆に切り替えるには、Shift キーと Alt キーを押したまま F7 キーを押します。To reverse the order in which you go through the Active Tool Windows list, hold down the SHIFT + ALT keys and press F7.

関連項目See also

ウィンドウ レイアウトをカスタマイズする Customizing window layouts
既定のキーボード ショートカットDefault Keyboard Shortcuts