Visual Studio 2017 で問題を報告する方法How to report a problem with Visual Studio 2017

Visual Studio に問題が発生した場合は、Microsoft にお知らせください。If you experience a problem with Visual Studio, we want to know about it. 診断および修正を行うには、問題を以下のようにして Developer Community に報告してください。Here's how to report the problem to Developer Community so that we can diagnose and fix it.

Visual Studio を使用して問題を報告するReport a problem by using Visual Studio

Visual Studio に関する問題を報告するには、Visual Studio または Visual Studio インストーラーからレポートを開始する必要があります。To report a problem for Visual Studio, you must initiate the report from Visual Studio or the Visual Studio Installer. Developer Community Web サイトから直接行うことはできません。You can't do it directly through the Developer Community website. Visual Studio を使用して報告する場合、レポートに自動的に診断情報を含めることができます。Reporting through Visual Studio allows for diagnostic information to be automatically included in the report.

Visual Studio Developer Community での問題の報告に関するポップアップ

  1. Visual Studio で、[ヘルプ] > [フィードバックの送信] > [問題の報告] の順に選びます。In Visual Studio, select Help > Send Feedback > Report a Problem.

    ヒント

    Visual Studio のインストールを完了できない場合、または Visual Studio 内のフィードバック ツールにアクセスできない場合は、Visual Studio インストーラーを使用して問題をレポートすることもできます。If you can't complete the Visual Studio installation or you can't access the feedback tool within Visual Studio, you can report a problem by using the Visual Studio Installer. そのためには、Visual Studio インストーラーの右上隅にあるフィードバック アイコンを選択します。To do so, choose the feedback icon in the upper-right corner of the Visual Studio Installer.

  2. サインインしていない場合は、次のスクリーンショットに示されているように、ツールの右側にある [サインイン] を選びます。If you are not signed in, select Sign In; it's on the right-hand side of the tool, as shown in the following screenshot. 画面に表示される手順に従ってサインインします。Follow the instructions on-screen to sign in.

    サインインして問題を報告する

    サインイン時に、発生している問題を報告することができます。When you sign in, you can report a problem that you're experiencing. 投稿されたその他の問題に投票したり、コメントしたりすることもできます。You can also vote or comment on any other problem that you see posted.

  3. サインインしたら、[フォロー項目] 画面で問題活動を確認することができます。Once signed in, you will be able to see your Problems and Activity in the Items I follow screen

    フォロー項目

  4. Visual Studio では、問題を検索したり、その問題が他のユーザーによって報告済みかどうかを確認するためのインターフェイスが提供されます。Visual Studio provides an interface to search for your problem and see if others have reported it. 報告済みの場合は、"上向きの矢印に投票" してお知らせください。If someone has reported it, "up-vote" it to let us know.

    注意

    検索する場合は、検索ボックスに目的のテキストを入力し、Enter キーを押すか、検索アイコンをクリックします。In order to search, please input the desired text into the search box and either click Enter or press the Search icon.

    類似問題を検索して投票する

  5. 発生した問題が見つからない場合は、画面の下部にある [新しい問題を報告する] を選択します。If you don’t find the problem you encountered, choose Report new problem at the bottom of the screen.

    注意

    [新しい問題を報告する] ボタンは、Developer Community の Visual Studio インターフェイスにのみ表示されます。The Report new problem button only appears in the Visual Studio interface for Developer Community. Developer Community Web サイトで直接問題を報告することはできません。You can't report a problem directly on the Developer Community website.

  6. 適切な Visual Studio チームに問題を転送できるように、報告には説明的なタイトルを付けてください。Create a descriptive title for the problem that helps us route it to the correct Visual Studio team.

  7. 可能であれば、問題を再現する手順など、さらに詳しい情報を記載します。Give us any additional details, and if possible, provide us with the steps to reproduce the problem.

    新しい問題を報告する

  8. [次へ] を選択して、[添付ファイル] タブに移動します。ここで、Microsoft に送信する現在の画面を取り込むことができます。Select Next to move to the Attachments tab. Here, you can capture your current screen to send it to Microsoft. 追加のスクリーンショットやその他のファイルを添付するには、[追加ファイルを添付] を選択します。To attach additional screenshots or other files, choose Attach Additional Files.

    Visual Studio の問題レポートにスクリーンショットを添付する

  9. スクリーンショットを添付しない場合や、再現手順を記録しない場合は、[次へ] を選択して [概要] タブに移動します。If you don't want to attach a screenshot or record a repro, select Next to move to the Summary tab.

  10. [送信] を選択して、イメージおよびトレースまたはダンプ ファイルと共に、レポートを送信します。Select Submit to send your report, along with any images and trace or dump files. ([送信] ボタンが灰色表示の場合、レポートのタイトルと説明が記載されていることを確認します)。(If the Submit button is grayed out, make sure that you've provided a title and description for the report.)

    収集されるデータについては、「Data we collect」(収集するデータ) を参照してください。For information about what data is collected, see Data we collect.

再現手順を記録するRecord a repro

トレースとヒープ ダンプのファイルは、問題を診断するうえで役立ちます。Trace and heap dump files are useful in helping us diagnose problems. [問題の報告] ツールで再現する手順を記録し Microsoft にデータを送信してくだされば、大変助かります。We appreciate it when you use the Report a Problem tool to record your repro steps and send the data to Microsoft. これを行う方法を次に示します。Here's how to do so:

  1. 問題のタイトルと説明を入力したら、[次へ] を選択して [添付ファイル] タブに移動します。After you enter a title and description for your problem, select Next to move to the Attachments tab.

  2. [記録] タブを選択します。Select the Record tab.

  3. 問題をそこで再現できる場合は、[操作の記録] で Visual Studio の現在のインスタンスを選択します。Under Record your actions, select the current instance of Visual Studio if you can reproduce the problem there. 再現できない (たとえば、Visual Studio がハングしている) 場合は、[<Create a new instance>](<新しいインスタンスの作成>) を選択して、Visual Studio の新しいインスタンスの操作を記録します。If you can't, for example if Visual Studio is hung, select <Create a new instance> to record the actions in a new instance of Visual Studio.

  4. [記録の開始] を選択します。Select Start Recording. ツールの実行を許可します。Give permission to run the tool.

    [記録の開始] を選択して、Visual Studio の問題レポートでトレースとヒープ ダンプ ファイルを提供する

  5. [ステップ記録ツール] ツールが表示されたら、問題を再現する手順を実行します。When the Steps Recorder tool appears, perform the steps that reproduce the problem.

  6. 終了したら、[記録の停止] ボタンを選択します。When you're done, choose the Stop Record button.

  7. 記録された情報が Visual Studio により収集され、パッケージ化されるまでしばらく待ちます。Wait a few minutes for Visual Studio to collect and package the information that you recorded.

    収集されるデータについては、「Data we collect」(収集するデータ) を参照してください。For information about what data is collected, see Data we collect.

さらに情報が必要な場合 ([さらに情報が必要です])When further information is needed (Need More Info)

Visual Studio 2017 バージョン 15.5 以降には、新しいワークフローがあり、ユーザーが問題レポートに関する追加情報を提供するのに役立ちます。Starting in Visual Studio 2017 Version 15.5, there's a new workflow to help users provide additional information about problem reports.

  1. Microsoft のエンジニアが Visual Studio Developer Community の問題を [さらに情報が必要です] の状態に設定した場合、その問題について、投稿、投票、フォロー、コメントしたすべてのユーザーに対して、Visual Studio の [問題の報告] ツールに通知が表示されます。When a Microsoft engineer sets the Visual Studio Developer Community problem to the Need More Info state, any user that posted, voted, followed, or commented on the problem gets a notification in the Report A Problem tool in Visual Studio.

    Visual Studio の [さらに情報が必要です] 通知

  2. [問題の表示] リンクをクリックし、注意が必要な問題のビューをフィルター処理して並べ替えます。Click on the View Problems link to filter and sort the view to the problems that need attention. これらの問題の横には、一般検索で区別するためのインジケーターもあります。These problems also have an indicator next to them, to differentiate them in general search.

  3. 問題をクリックして、問題の詳細ビューを表示します。Click on a problem to see the problem details view.

    [さらに情報が必要です] 通知

  4. [さらに情報が必要です] 要求を表示するには、問題の詳細ビューで [要求と応答を表示] リンクをクリックします。To view the Need More Info request, click the View their request and respond link in the problem details view. ダイアログ ボックスに要求が表示されます。A dialog box shows the request.

    [さらに情報が必要です] 通知

  5. コメントや添付ファイルを追加するか、手順を記録することで、さらに情報を提供することができます。You can provide more information by adding comments, attachments, or recording steps. このエクスペリエンスは、新しい問題を報告することや、問題への投票時に追加情報を提供することと似ています。This experience is similar to reporting a new problem or providing additional information when voting on a problem.

  6. 要求側の Microsoft エンジニアは、提供された追加情報に関する通知を受け取ります。The requesting Microsoft engineer receives a notification about the extra information provided. 調査に十分な情報がある場合は、問題の状態が変わります。If they have enough information to investigate, the problem state changes. それ以外の場合、エンジニアはさらに情報を求めます。Otherwise, the engineer asks for even further information.

    注意

    • 返信すると、通知は表示されなくなります。When you reply, the notification goes away. その代わりに、感謝を表すバナーが示され、追加情報を容易に提供できる方法が表示されます。In its place, you see a banner that thanks you and facilitates a way to provide even more information.
    • 問題の状態が変わると、その問題をフォローしているすべてのユーザーに対する通知は表示されなくなります。Once the issue changes state, the notification goes away for everyone that's following the issue.
    • 複数のユーザーが同じ [さらに情報が必要です] 要求で返信することができます。More than one person can reply on the same Need More Info request.
    • Web ブラウザーから直接アクセスした場合は、Developer Community[さらに情報が必要です] ワークフローはありませんが、そこでコメントや添付ファイルを提供することもできます。There isn't a Need More Info workflow on Developer Community when you access it directly through a web browser, but you can also provide comments and attachments there.

解決策を検索するかフィードバックを提供するSearch for solutions or provide feedback

Visual Studio を使って問題を報告することが望ましくない場合、またはできない場合は、Visual Studio Developer Community ページで既に問題が報告され、解決策が投稿されている可能性があります。If you don't want to or can't use Visual Studio to report a problem, there's a chance that the problem has already been reported and a solution posted on the Visual Studio Developer Community page.

レポートする問題はないが、製品に関するフィードバックや提案を提供したい場合、そのための場所も用意されています。If you don't have a problem to report but want to provide product feedback or a suggestion, there's a place for that, too. 詳細については、UserVoice ページを参照してください。For more information, see the UserVoice page.

関連項目See also