方法 : エンコーディングを使用してファイルを保存および開くHow to: Save and Open Files with Encoding

双方向言語をサポートするために、特定の文字エンコーディングを使用してファイルを保存できます。You can save files with specific character encoding to support bi-directional languages. また、Visual Studio でファイルが正しく開かれるように、ファイルを開くときにもエンコーディングを指定できます。You can also specify an encoding when opening a file, so that Visual Studio displays the file correctly.

エンコーディングを使用してファイルを保存するにはTo save a file with encoding

  1. [ファイル] メニューの [名前を付けてファイルを保存] を選び、[保存] の横のドロップダウン ボタンをクリックします。From the File menu, choose Save File As, and then click the drop-down button next to the Save button.

    [保存オプションの詳細設定] ダイアログ ボックスが表示されます。The Advanced Save Options dialog box is displayed.

  2. [エンコード] で、ファイルに使うエンコーディングを選択します。Under Encoding, select the encoding to use for the file.

  3. 必要に応じて、[行の終わり] で行末文字の書式を選びます。Optionally, under Line endings, select the format for end-of-line characters.

    このオプションは、異なるオペレーティング システムのユーザーとファイルを交換する場合に便利です。This option is useful if you intend to exchange the file with users of a different operating system.

    特定の方法でエンコードされていることがわかっているファイルを使用する場合は、ファイルを開くときに、そのエンコーディングを使用するように指定できます。If you want to work with a file that you know is encoded in a specific way, you can tell Visual Studio to use that encoding when opening the file. その方法は、ファイルがプロジェクトの一部であるかどうかによって異なります。The method you use depends on whether the file is part of your project.

プロジェクトの一部であるエンコードされたファイルを開くにはTo open an encoded file that is part of a project

  1. ソリューション エクスプローラーでファイルを右クリックし、[ファイルを開くアプリケーションの選択] を選びます。In Solution Explorer, right-click the file and choose Open With.

  2. [ファイルを開くアプリケーションの選択] ダイアログ ボックスで、ファイルを開くエディターを選びます。In the Open With dialog box, choose the editor to open the file with.

    フォーム エディターなど、多くの Visual Studio エディターは、エンコーディングを自動検出し、ファイルを適切に開きます。Many Visual Studio editors, such as the forms editor, will auto-detect the encoding and open the file appropriately. エンコーディングを選択できるエディターの場合は、[エンコード] ダイアログ ボックスが表示されます。If you choose an editor that allows you to choose an encoding, the Encoding dialog box is displayed.

  3. [エンコード] ダイアログ ボックスで、エディターで使うエンコーディングを選びます。In the Encoding dialog box, select the encoding that the editor should use.

プロジェクトの一部ではないエンコードされたファイルを開くにはTo open an encoded file that is not part of a project

  1. [ファイル] メニューの [開く] をポイントし、[ファイル] または [Web のファイル] を選んで、開くファイルを選びます。On the File menu, point to Open, choose File or File From Web, and then select the file to open.

  2. [開く] ボタンの横のドロップダウン ボタンをクリックし、[ファイルを開くアプリケーションの選択] を選びます。Click the drop-down button next to the Open button and choose Open With.

  3. 前の手順の 2. と 3. を実行します。Follow Steps 2 and 3 from the preceding procedure.

関連項目See Also

エンコード方式および Windows フォームのグローバリゼーション Encoding and Windows Forms Globalization
アプリケーションのグローバライズとローカライズGlobalizing and Localizing Applications