方法: 既存のテンプレートを更新するHow to: Update existing templates

テンプレートを作成し、複数のファイルを .zip ファイルに圧縮した後で、テンプレートを変更できます。After you create a template and compress the files into a .zip file, you may want to modify the template. それには、テンプレートのファイルを手動で変更するか、テンプレートに基づいてプロジェクトから新しいテンプレートをエクスポートします。You can do this by manually changing the files in the template, or by exporting a new template from a project that is based on the template.

テンプレートのエクスポート ウィザードの使用による既存のプロジェクト テンプレートの更新Using the Export Template Wizard to update an existing project template

Visual Studio のテンプレートのエクスポート ウィザードを使って、既存のテンプレートを更新することができます。Visual Studio provides an Export Template Wizard that can be used to update an existing template:

  1. [ファイル] > [新規] > [プロジェクト] の順に選んで、[新しいプロジェクト] ダイアログ ボックスを開きます。Open the New Project dialog box by choosing File > New > Project.

  2. 更新するテンプレートを選択し、プロジェクトの名前と場所を入力して、[OK] を選択します。Select the template that you want to update, enter a name and location for your project, and choose OK.

  3. Visual Studio でプロジェクトを変更します。Modify the project in Visual Studio.

  4. [プロジェクト] メニューの [テンプレートのエクスポート] を選択します。On the Project menu, choose Export Template.

    テンプレートのエクスポート ウィザードが開きます。The Export Template Wizard opens.

  5. ウィザードの指示に従って、テンプレートを .zip ファイルとしてエクスポートします。Follow the prompts in the wizard to export the template as a .zip file.

  6. (省略可能) テンプレートを [新しいプロジェクト] ダイアログ ボックスに追加するには、.zip ファイルを %USERPROFILE%\Documents\Visual Studio <バージョン>\Templates\ProjectTemplates ディレクトリに置きます。(Optional) To add the template to the New Project dialog box, place the .zip file in the following directory: %USERPROFILE%\Documents\Visual Studio <version>\Templates\ProjectTemplates. テンプレートのエクスポート ウィザード[テンプレートを自動的に Visual Studio にインポート] オプションを選ばなかった場合、このステップを実行する必要があります。You'll need to perform this step if you did not select the option Automatically import the template into Visual Studio in the Export Template Wizard.

  7. 古いテンプレートの .zip ファイルを削除します。Delete the old template .zip file.

既存のテンプレートを手動で更新するManually update an existing template

圧縮された .zip ファイル内のファイルを変更することで、テンプレートのエクスポート ウィザードを使わずに既存のテンプレートを更新できます。You can update an existing template without using the Export Template Wizard, by modifying the files in the compressed .zip file.

既存のテンプレートを手動で更新するにはTo manually update an existing template

  1. テンプレートを含む .zip ファイルを探します。Locate the .zip file that contains the template. ユーザー プロジェクト テンプレートは、%USERPROFILE%\Documents\Visual Studio <バージョン>\Templates\ProjectTemplates にあります。User project templates are located at %USERPROFILE%\Documents\Visual Studio <version>\Templates\ProjectTemplates.

  2. .zip ファイルを展開します。Extract the .zip file.

  3. 現在のテンプレート ファイルを変更または削除するか、テンプレートに新しいファイルを追加します。Modify or delete the current template files, or add new files to the template.

  4. .vstemplate XML ファイルを開いたり、変更したり、保存したりして、更新された動作または新しいファイルを処理します。Open, modify, and save the .vstemplate XML file to handle updated behavior or new files.

    .vstemplate スキーマの詳細については、「Visual Studio テンプレート スキーマ参照 (機能拡張)」を参照してください。For more information about the .vstemplate schema, see Visual Studio template schema reference (extensibility). ソース ファイルでパラメーター化できる内容の詳細については、「テンプレート パラメーター」を参照してください。For more information about what you can parameterize in the source files, see Template parameters.

  5. テンプレートでファイルを選び、右クリック メニューまたはコンテキスト メニューから、[送る] > [圧縮 (zip 形式) フォルダー] の順に選択します。Select the files in your template, and from the right-click or context menu, and choose Send to > Compressed (zipped) folder.

    選択したファイルは .zip ファイルに圧縮されます。The files that you selected are compressed into a .zip file.

  6. 新しい .zip ファイルを古い .zip ファイルと同じディレクトリに配置します。Put the new .zip file in the same directory as the old .zip file.

  7. 抽出したテンプレート ファイルと古いテンプレート .zip ファイルを削除します。Delete the extracted template files and the old template .zip file.

関連項目See also