方法: [定義をここに表示] を使用してコードを表示および編集する (Alt + F12)How to: View and edit code by using Peek Definition (Alt+F12)

[定義をここに表示] を使うと、記述中のコードから切り替えずにコードを表示および編集できます。You can use the Peek Definition command to view and edit code without switching away from the code that you're writing. [定義をここに表示][定義へ移動] では同じ情報が表示されますが、[定義をここに表示] ではコードがポップアップ ウィンドウに表示され、[定義へ移動] では別のコード ウィンドウに表示されます。Peek Definition and Go To Definition show the same information, but Peek Definition shows it in a pop-up window, and Go To Definition shows the code in a separate code window. [定義へ移動] を実行すると、コンテキスト (アクティブなコード ウィンドウ、現在の行、およびカーソルの位置) が定義コード ウィンドウに切り替わります。Go To Definition causes your context (that is, the active code window, current line, and cursor position) to switch to the definition code window. [定義をここに表示] を使用すると、元のコード ファイル内での位置を保ちながら、定義を表示および編集したり、定義ファイル内を移動したりできます。By using Peek Definition, you can view and edit the definition and move around inside the definition file while keeping your place in the original code file.

[定義をここに表示] は、C#、Visual Basic、および C++ のコードで使うことができます。You can use Peek Definition with C#, Visual Basic, and C++ code. Visual Basic では [定義をここに表示] に、定義メタデータのないシンボル (.NET Framework の組み込み型など) のオブジェクト ブラウザーへのリンクが表示されます。In Visual Basic, Peek Definition shows a link to the Object Browser for symbols that don't have definition metadata (for example, .NET Framework types that are built in).

[定義をここに表示] の操作Working with Peek Definition

[定義をここに表示] ウィンドウを開くにはTo open a Peek Definition window

  1. 探索する型またはメンバーのコンテキスト メニューから [定義をここに表示] を選択して、定義を表示できます。You can peek a definition by choosing Peek Definition from the context menu for a type or member that you want to explore. Visual Studio 2017 バージョン 15.4 以降では、オプションが有効な場合、マウスを使用して定義を表示することもできます。その場合、Ctrl キー (または別の修飾子) を押して、メンバー名をクリックします。In Visual Studio 2017 version 15.4 and later, if the option is enabled, you can also peek a definition using the mouse, by pressing Ctrl (or another modifier) and clicking the member name. または、キーボードの Alt + F12 キーを押します。Or, from the keyboard, press Alt+F12.

    次の図に、Print() という名前のメソッドの [定義をここに表示] ウィンドウを示します。This illustration shows the Peek Definition window for a method that's named Print():

    [表示のみ] ウィンドウ

    定義ウィンドウは、元のファイルの printer.Print("Hello World!") 行の下に表示されます。The definition window appears below the printer.Print("Hello World!") line in the original file. このウィンドウにより、元のファイル内のどのコードも隠れて見えなくなることはありません。The window doesn't hide any of the code in your original file. printer.Print("Hello World!") に続く行は定義ウィンドウの下に表示されます。The lines that follow printer.Print("Hello World!") appear under the definition window.

  2. [定義をここに表示] ウィンドウ内のさまざまな位置にカーソルを移動できます。You can move the cursor to different locations in the peek definition window. 元のコード ウィンドウ内を引き続き移動することもできます。You can also still move around in the original code window.

  3. 定義ウィンドウから文字列をコピーし、元のコード内で貼り付けることができます。You can copy a string from the definition window and paste it in the original code. 定義ウィンドウから元のコードに文字列をドラッグ アンド ドロップすることもできますが、定義ウィンドウからその文字列は削除されません。You can also drag and drop the string from the definition window to the original code without deleting it from the definition window.

  4. Esc キー、または定義ウィンドウ タブの [閉じる] ボタンを選択することで、定義ウィンドウを閉じることができます。You can close the definition window by choosing the Esc key or the Close button on the definition window tab.

[定義をここに表示] ウィンドウ内から [定義をここに表示] を開くOpen a Peek Definition window from within a Peek Definition window

既に [定義をここに表示] ウィンドウを開いている場合、そのウィンドウ内のコードで [定義をここに表示] を再度呼び出すことができます。If you already have a Peek Definition window open, you can call Peek Definition again on the code in that window. もう 1 つの定義ウィンドウが開きます。Another definition window opens. 定義ウィンドウ タブの横に一連の階層リンクの点が表示されます。これらの点を使用して定義ウィンドウ間を移動できます。A set of breadcrumb dots appears next to the definition window tab, which you can use to navigate between definition windows. 各点のツールヒントには、それぞれの点が表す定義ファイルの名前とパスが表示されます。The tooltip on each dot shows the file name and path of the definition file that the dot represents.

[表示のみ] ウィンドウ内の [表示のみ] ウィンドウ

複数の結果がある [定義をここに表示]Peek Definition with multiple results

複数の定義 (部分クラスなど) があるコードで [定義をここに表示] を使うと、結果の一覧がコード定義ビューの右側に表示されます。If you use Peek Definition on code that has more than one definition (for example, a partial class), a result list appears to the right of the code definition view. 一覧内の結果を選択してその定義を表示できます。You can choose any result in the list to display its definition.

複数の結果からの [表示のみ] ウィンドウ

[定義をここに表示] ウィンドウ内での編集Edit inside the Peek Definition window

[定義をここに表示] ウィンドウ内で編集を始めると、変更中のファイルがコード エディターの別のタブで自動的に開き、行った変更が反映されます。When you start to edit inside a Peek Definition window, the file that you're modifying automatically opens as a separate tab in the code editor and reflects the changes that you've made. [定義をここに表示] ウィンドウで続けて変更を加えたり、元に戻したり、保存したりすることができ、タブにはそれらの変更が反映され続けます。You can continue to make, undo, and save changes in the Peek Definition window, and the tab will continue to reflect those changes. 変更を保存せずに [定義をここに表示] ウィンドウを閉じた場合でも、タブ内で変更を加えたり、元に戻したり、保存したりすることができ、[定義をここに表示] ウィンドウで作業を中断した正確な位置から再開することができます。Even if you close the Peek Definition window without saving your changes, you can make, undo, and save more changes in the tab, picking up exactly where you left off in the Peek Definition window.

[表示のみ] ウィンドウ内での編集

[定義をここに表示] のオプションを変更するにはTo change options for Peek Definition

  1. [ツール] > [オプション] > [テキスト エディター] > [全般] の順に移動します。Go to Tools > Options > Text Editor > General.

  2. オプションの [定義をピーク ビューで開く] を選択します。Select the option Open definition in peek view.

  3. [OK] をクリックして、[オプション] ダイアログ ボックスを閉じます。Click OK to close the Options dialog box.

    マウス クリックの [定義をここに表示] オプションの設定

[定義をここに表示] のキーボード ショートカットKeyboard shortcuts for Peek Definition

[定義をここに表示] ウィンドウでは次のキーボード ショートカットを使うことができます。You can use these keyboard shortcuts with the Peek Definition window:

機能Functionality キーボード ショートカットKeyboard shortcut
定義ウィンドウを開くOpen the definition window Alt + F12Alt+F12
定義ウィンドウを閉じるClose the definition window EscEsc
定義ウィンドウを通常のドキュメント タブに昇格するPromote the definition window to a regular document tab Shift + Alt + HomeShift+Alt+Home
定義ウィンドウ間を移動するNavigate between definition windows Ctrl + Alt + -Ctrl + Alt + =Ctrl+Alt+- and Ctrl+Alt+=
複数の結果の間を移動するNavigate between multiple results F8Shift + F8F8 and Shift+F8
コード エディター ウィンドウと定義ウィンドウの間で切り替えるToggle between the code editor window and the definition window Shift + EscShift+Esc

注意

Visual Studio の他の場所でも、同じキーボード ショートカットを使って [定義をここに表示] ウィンドウでコードを編集できます。You can also use the same keyboard shortcuts to edit code in a Peek Definition window as you use elsewhere in Visual Studio.

関連項目See also