方法: [定義をここに表示] を使用してコードを表示および編集する (Alt + F12)

[定義をここに表示] を使うと、記述中のコードから切り替えずにコードを表示および編集できます。 [定義をここに表示][定義へ移動] では同じ情報が表示されますが、 [定義をここに表示] ではコードがポップアップ ウィンドウに表示され、 [定義へ移動] では別のコード ウィンドウに表示されます。 [定義へ移動] を実行すると、コンテキスト (アクティブなコード ウィンドウ、現在の行、およびカーソルの位置) が定義コード ウィンドウに切り替わります。 [定義をここに表示] を使用すると、元のコード ファイル内での位置を保ちながら、定義を表示および編集したり、定義ファイル内を移動したりできます。

[定義をここに表示] は、C#、Visual Basic、および C++ のコードで使うことができます。 Visual Basic では [定義をここに表示] に、定義メタデータのないシンボル (.NET の組み込み型など) の オブジェクト ブラウザー へのリンクが表示されます。

[定義をここに表示] を使用する

[定義をここに表示] ウィンドウを開く

  1. 探索する型またはメンバーの右クリック メニューから [定義をここに表示] を選択して、定義を表示できます。 オプションが有効な場合、マウスを使用して定義を表示することもできます。その場合、Ctrl キー (または別の修飾子) を押して、メンバー名をクリックします。 または、キーボードの Alt + F12 キーを押します。

    次の図に、Print() という名前のメソッドの [定義をここに表示] ウィンドウを示します。

    [表示のみ] ウィンドウ

    定義ウィンドウは、元のファイルの printer.Print("Hello World!") 行の下に表示されます。 このウィンドウにより、元のファイル内のどのコードも隠れて見えなくなることはありません。 printer.Print("Hello World!") に続く行は定義ウィンドウの下に表示されます。

  2. [定義をここに表示] ウィンドウ内のさまざまな位置にカーソルを移動できます。 元のコード ウィンドウ内を引き続き移動することもできます。

  3. 定義ウィンドウから文字列をコピーし、元のコード内で貼り付けることができます。 定義ウィンドウから元のコードに文字列をドラッグ アンド ドロップすることもできますが、定義ウィンドウからその文字列は削除されません。

  4. Esc キー、または定義ウィンドウ タブの [閉じる] ボタンを選択することで、定義ウィンドウを閉じることができます。

[定義をここに表示] ウィンドウ内から [定義をここに表示] を開く

既に [定義をここに表示] ウィンドウを開いている場合、そのウィンドウ内のコードで [定義をここに表示] を再度呼び出すことができます。 もう 1 つの定義ウィンドウが開きます。 定義ウィンドウ タブの横に一連の階層リンクの点が表示されます。これらの点を使用して定義ウィンドウ間を移動できます。 各点のツールヒントには、それぞれの点が表す定義ファイルの名前とパスが表示されます。

[表示のみ] ウィンドウ内の [表示のみ] ウィンドウ

複数の結果がある [定義をここに表示]

複数の定義 (部分クラスなど) があるコードで [定義をここに表示] を使うと、結果の一覧がコード定義ビューの右側に表示されます。 一覧内の結果を選択してその定義を表示できます。

複数の結果からの [表示のみ] ウィンドウ

[定義をここに表示] ウィンドウ内での編集

[定義をここに表示] ウィンドウ内で編集を始めると、変更中のファイルがコード エディターの別のタブで自動的に開き、行った変更が反映されます。 [定義をここに表示] ウィンドウで続けて変更を加えたり、元に戻したり、保存したりすることができ、タブにはそれらの変更が反映され続けます。 変更を保存せずに [定義をここに表示] ウィンドウを閉じた場合でも、タブ内で変更を加えたり、元に戻したり、保存したりすることができ、 [定義をここに表示] ウィンドウで作業を中断した正確な位置から再開することができます。

[表示のみ] ウィンドウ内での編集

[定義をここに表示] のオプションを変更するには

  1. [ツール] > [オプション] > [テキスト エディター] > [全般] の順に移動します。

  2. オプションの [定義をピーク ビューで開く] を選択します。

  3. [OK] をクリックして、 [オプション] ダイアログ ボックスを閉じます。

    マウス クリックの [定義をここに表示] オプションの設定

[定義をここに表示] のキーボード ショートカット

[定義をここに表示] ウィンドウでは次のキーボード ショートカットを使うことができます。

機能 キーボード ショートカット
定義ウィンドウを開く Alt+F12
定義ウィンドウを閉じる Esc
定義ウィンドウを通常のドキュメント タブに昇格する Ctrl+Alt+Home
定義ウィンドウ間を移動する Ctrl+Alt+ -Ctrl+Alt+ =
複数の結果の間を移動する F8Shift+F8
コード エディター ウィンドウと定義ウィンドウの間で切り替える Shift+Esc

注意

Visual Studio の他の場所でも、同じキーボード ショートカットを使って [定義をここに表示] ウィンドウでコードを編集できます。

関連項目