外部ツールの管理Manage external tools

Visual Studio から [ツール] メニューを使用して外部ツールを呼び出すことができます。You can call external tools from inside Visual Studio by using the Tools menu. [ツール] メニューではいくつかのツールを既定で使用できますが、このメニューは他の独自の実行可能ファイルを追加してカスタマイズできます。A few default tools are available from the Tools menu, and you can customize the menu by adding other executables of your own.

[Visual Studio ツール] メニューで使用できるツールTools available on the Visual Studio Tools menu

[ツール] メニューには、次のように組み込みコマンドがいくつか表示されます。The Tools menu contains several built-in commands, such as:

[ツール] メニューに新しいツールを追加するAdd new tools to the Tools menu

[ツール] メニューに表示する外部ツールを追加できます。You can add an external tool to appear on the Tools menu.

  1. [ツール][外部ツール...] の順に選択して、[外部ツール] ダイアログ ボックスを開きます。Open the External Tools dialog box by choosing Tools, External Tools....

  2. [追加] をクリックして情報を入力します。Click Add, and then fill in the information. たとえば、次のエントリを指定すると、Visual Studio で現在開いているファイルのディレクトリでエクスプローラーが開きます。For example, the following entry causes Windows Explorer to open at the directory of the file you currently have open in Visual Studio:

    • タイトル: Open File LocationTitle: Open File Location

    • コマンド: explorer.exeCommand: explorer.exe

    • [引数]: /root, "$(ItemDir)"Arguments: /root, "$(ItemDir)"

    [外部ツール] ダイアログ ボックス

外部ツールの定義時に使用できる引数の一覧を次に示します。The following is a full list of arguments that can be used when defining an external tool:

名前Name 引数Argument 説明Description
項目のパスItem Path $(ItemPath)$(ItemPath) 現在のファイルの完全なファイル名 (ドライブ + パス + ファイル名)。The complete file name of the current file (drive + path + file name).
項目のディレクトリItem Directory $(ItemDir)$(ItemDir) 現在のファイルのディレクトリ (ドライブ + パス)。The directory of the current file (drive + path).
項目のファイル名Item File Name $(ItemFilename)$(ItemFilename) 現在のファイルのファイル名 (ファイル名)。The file name of the current file (file name).
項目の拡張子Item Extension $(ItemExt)$(ItemExt) 現在のファイルのファイル名拡張子。The file name extension of the current file.
カレント行Current Line $(CurLine)$(CurLine) コード ウィンドウ内のカーソルの現在の行位置。The current line position of the cursor in the code window.
カレント列Current Column $(CurCol)$(CurCol) コード ウィンドウ内のカーソルの現在の列位置。The current column position of the cursor in the code window.
カレント テキストCurrent Text $(CurText)$(CurText) 選択されているテキスト。The selected text.
ターゲット パスTarget Path $(TargetPath)$(TargetPath) 作成するアイテムの完全なファイル名 (ドライブ + パス + ファイル名)。The complete file name of the item to be built (drive + path + file name).
ターゲット ディレクトリTarget Directory $(TargetDir)$(TargetDir) 作成するアイテムのディレクトリ。The directory of the item to be built.
ターゲット名Target Name $(TargetName)$(TargetName) 作成するアイテムのファイル名。The file name of the item to be built.
ターゲットの拡張子Target Extension $(TargetExt)$(TargetExt) 作成するアイテムのファイル名拡張子。The file name extension of the item to be built.
バイナリ ディレクトリBinary Directory $(BinDir)$(BinDir) 作成中のバイナリの最終的な場所 (ドライブ + パスとして定義されます)。The final location of the binary that is being built (defined as drive + path).
プロジェクト ディレクトリProject Directory $(ProjDir)$(ProjDir) 現在のプロジェクトのディレクトリ (ドライブ + パス)。The directory of the current project (drive + path).
プロジェクト ファイル名Project File Name $(ProjFileName)$(ProjFileName) 現在のプロジェクトのファイル名 (ドライブ + パス + ファイル名)。The file name of the current project (drive + path + file name).
ソリューション ディレクトリSolution Directory $(SolutionDir)$(SolutionDir) 現在のソリューションのディレクトリ (ドライブ + パス)。The directory of the current solution (drive + path).
ソリューション ファイル名Solution File Name $(SolutionFileName)$(SolutionFileName) 現在のソリューションのファイル名 (ドライブ + パス + ファイル名)。The file name of the current solution (drive + path + file name).

注意

IDE のステータス バーに、アクティブなコード エディターの挿入位置を示す、Current Line 変数および Current Column 変数が表示されます。The IDE status bar displays the Current Line and Current Column variables to indicate where the insertion point is located in the active Code Editor. Current Text 変数は、その場所で選択されているテキストまたはコードを返します。The Current Text variable returns the text or code selected at that location.

関連項目See also

C と C++ のビルド ツールC/C++ Build Tools