Visual Studio IDE のカスタマイズPersonalize the Visual Studio IDE

ユーザー独自の開発スタイルと要件に最適なサポートを行うために Visual Studio をさまざまな方法でカスタマイズすることができます。You can personalize Visual Studio in various ways to best support your own development style and requirements. 設定の多くは Visual Studio インスタンス間でローミングできます — 同期された設定に関するページを参照してください。Many of your settings roam with you across Visual Studio instances—see Synchronized settings. この記事では、さまざまなカスタマイズ方法と、詳細情報の参照先について簡単に説明します。This article briefly describes different personalizations and where you can find more information.

Note

このトピックは、Windows 上の Visual Studio に適用されます。This topic applies to Visual Studio on Windows. Visual Studio for Mac については、Visual Studio for Mac IDE のカスタマイズに関するページを参照してください。For Visual Studio for Mac, see Customize the Visual Studio for Mac IDE.

既定の設定Default settings

開発の種類に合わせて Visual Studio を最適化する既定の一連の設定を選択できます。You can choose a default collection of settings that optimizes Visual Studio for your type of development. 詳細については、環境設定に関するページを参照してください。For more information, see Environment settings.

一般的な環境オプションGeneral environment options

多くのカスタマイズ オプションが [環境オプション] ダイアログ ボックスで公開されています。Many personalization options are exposed through the Environment Options dialog box. このダイアログ ボックスにアクセスするには、次の 2 つの方法があります。There are two ways to access this dialog box:

  • メニュー バーで、[ツール] > [オプション] の順に選択します。[環境] ノードがまだ展開されていない場合は展開します。On the menu bar, choose Tools > Options, and if it's not already expanded, expand the Environment node.

  • Ctrl キーを押しながら Q キーを押し、検索ボックスに「環境」と入力します。結果から [環境]、[全般] の順に選択します。Press Ctrl+Q, type environment in the search box, and then choose Environment --> General from the results.

Tip

[オプション] ダイアログ ボックスが表示されたら、F1 キーを押して、そのページのさまざまな設定に関するヘルプを表示できます。When the Options dialog box appears, you can press F1 for help on the various settings on that page.

環境の配色テーマEnvironment color themes

明色、暗色、青の配色テーマを変更するには、検索ボックスに「環境」と入力した後、[環境]、[全般] の順に選択します。To change the color theme between light, dark and blue, type environment in the search box, and then choose Environment --> General. [オプション] ダイアログ ボックスで、[配色テーマ] オプションを変更します。In the Options dialog box, change the Color theme option.

エディターで配色オプションを変更するには、検索ボックスに「環境」と入力した後、[環境]、[フォントおよび色] の順に選択します。To change colorization options in the editor, type environment in the search box, and then choose Environment --> Fonts and Colors. 方法:フォントと色を変更する方法に関するページを参照してください。See How to: Change fonts and colors.

メイン メニューの大文字小文字の区別は、[タイトル文字] ("File") と [すべて大文字] ("FILE") の間で変更できます。You can change the main menu casing between Title Case ("File") and All Caps ("FILE"). 検索ボックスに「環境」と入力し、[環境]、[全般] の順に選択し、[タイトルの文字スタイルをメニュー バーに適用する] オプションを変更します。Type environment in the search box, select Environment --> General, and then change the Apply title case styling to menu bar option.

メニューおよびツール バーをカスタマイズするCustomize menus and toolbars

メニューやツールバーの項目を追加または削除するには、メニューおよびツール バーをカスタマイズする方法に関するページを参照してください。To add or remove menu or toolbar items, see How to: Customize menus and toolbars.

スタート ページStart page

自分とチームのカスタム スタート ページを作成するには、「スタート ページのカスタマイズ」を参照してください。To create a custom start page for you and your team, see Customize the Start page.

ウィンドウのレイアウトWindow layouts

複数のウィンドウ レイアウトを定義して保存し、それらを切り替えることができます。You can define and save multiple window layouts and switch between them. たとえば、コーディング用の 1 つのレイアウトとデバッグ用のレイアウトを定義できます。For example, you can define one layout for coding and one for debugging. ウィンドウの位置と動作を設定し、カスタム レイアウトを保存するには、「ウィンドウ レイアウトをカスタマイズする」を参照してください。To arrange window positions and behavior and save custom layouts, see Customize window layouts.

外部ツールExternal tools

[ツール] メニューをカスタマイズして、外部ツールを起動することができます。You can customize the Tools menu to launch external tools. 詳細については、「外部ツールの管理」を参照してください。For more information, see Manage external tools.

関連項目See also