ドキュメントDocuments, Environment, Options Dialog Box

[オプション] ダイアログ ボックスのこのページを使用し、統合開発環境 (IDE) の文書表示を制御し、ドキュメントやファイルに対する外部変更を管理します。Use this page of the Options dialog box to control the display of documents in the integrated development environment (IDE) and manage external changes to documents and files. このダイアログ ボックスにアクセスするには、[ツール] メニューの [オプション] をクリックし、[環境] ノードの [ドキュメント] を選択します。You can access this dialog box by clicking Options on the Tools menu and then selecting Documents in the Environment node. [ドキュメント] が一覧に表示されない場合は、[オプション] ダイアログ ボックスの [すべての設定を表示] を選択します。If Documents does not appear in the list, select Show all settings in the Options dialog box.

注意

使用している設定またはエディションによっては、ダイアログ ボックスで使用可能なオプションや、メニュー コマンドの名前や位置がヘルプに記載されている内容と異なる場合があります。The options available in dialog boxes, and the names and locations of menu commands you see, might differ from what is described in Help depending on your active settings or edition. 設定を変更するには、 [ツール] メニューの [設定のインポートとエクスポート] をクリックします。To change your settings, choose Import and Export Settings on the Tools menu. 詳細については、「Visual Studio IDE のカスタマイズ」を参照してください。For more information, see Personalize the Visual Studio IDE.

保存済みの現在のドキュメント ウィンドウを再利用Reuse current document window, if saved
選択すると、保存されている場合、現在のドキュメントを閉じ、同じウィンドウで新しいドキュメントを開きます。When selected, closes your current document if it has been saved, and opens a new document in the same window. 現在のドキュメントが保存されていない場合、開いている状態が維持され、新しいドキュメントを別個のウィンドウで開きます。If your current document has not been saved, it remains open and the new document is opened in a separate window. このオプションが選択されていない場合、新しいドキュメントを常に別個のウィンドウで開きます。When this option is cleared, new documents always open in separate windows.

切り取りと貼り付けの操作を複数のドキュメントで行うことがあまりなく、自分の作業領域で、開いているドキュメントやウィンドウの数を最小限に抑える場合、このオプションをお試しください。If you perform multi-document cut and paste operations infrequently and want to minimize the number of open documents and windows in your working space, try this option.

環境外でのファイルの変更を検出Detect when file is changed outside the environment
このオプションを選択すると、開いているファイルが IDE の外部のエディターで変更された場合、直後にメッセージで通知されます。When this option is selected, a message immediately notifies you of changes to an open file that have been made by an editor outside the IDE. このメッセージにより、ストレージからファイルを再読み込みできます。The message lets you reload the file from storage.

保存する場合、変更を自動的に読み込むAuto-load changes, if saved
[環境外でのファイルの変更を検出] を選択しているとき、IDE で開いているファイルが IDE の外部で変更されると、既定で、警告メッセージが生成されます。When you have Detect when file is changed outside the environment selected and an open file in the IDE changes outside the IDE, a warning message is generated by default. このオプションを有効にすると、警告は表示されず、ドキュメントが IDE に再読み込みされ、外部の変更が反映されます。If this option is enabled, no warning appears and the document is reloaded in the IDE to pick up the external changes.

読み取り専用ファイルの編集を有効にし、保存時に警告するAllow editing of read-only files; warn when attempt to save
このオプションを有効にすると、読み取り専用ファイルを開き、編集できます。When this option is enabled you can open and edit a read-only file. 完了時、変更の記録を保存する場合、[名前を付けて保存] コマンドを利用し、新しいファイル名でファイルを保存する必要があります。When you are finished, you must use the Save Ascommand to save the file by a new name if you want to save a record of your changes.

現在アクティブなドキュメントのディレクトリを使ってファイルを開くOpen file using directory of currently active document
このオプションを選択すると、[ファイルを開く] ダイアログ ボックスにアクティブなドキュメントのディレクトリが表示されます。When selected, this option specifies that the Open File dialog box displays the directory of the active document. このオプションを選択しない場合、[ファイルを開く] ダイアログ ボックスには、ファイルを開くために前回利用されたディレクトリが表示されます。When this option is cleared, the Open File dialog box displays the directory last used to open a file.

読み込み時に行の終わりの整合性を確認するCheck for consistent line endings on load
このオプションを選択すると、エディターはファイルの行の終わりをスキャンし、終わりの書式設定に不整合が検出された場合、メッセージ ボックスを表示します。Select this option to have the editor scan the line endings in a file and display a message box if inconsistencies are detected in how line endings are formatted.

全体的に元に戻す操作で編集したファイルが変更される場合、警告を表示Display warning when global undo will modify edited files
このオプションを選択すると、リファクタリング操作後に変更されたファイルで行われたリファクタリング変更を [全体的に元に戻す] コマンドでロールバックするときにメッセージ ボックスが表示されます。Select this option to display a message box when the Global Undo command will roll back refactoring changes made in files that also were changed after the refactoring operation. ファイルをリファクタリング前の状態に戻すと、リファクタリング後にファイルに行った変更が破棄されることがあります。Returning a file to its pre-refactoring state might discard subsequent changes made in the file.

その他のファイルをソリューション エクスプローラーに表示Show Miscellaneous files in Solution Explorer
このオプションを選択すると、[ソリューション エクスプローラー][その他のファイル] ノードが表示されます。Select this option to display the Miscellaneous Files node in Solution Explorer. その他のファイルとは、プロジェクトやソリューションに関連付けられていないファイルですが、利便性のためにソリューション エクスプローラーに表示できます。Miscellaneous files are files that are not associated with a project or solution but can appear in Solution Explorer for your convenience.

注意

このオプションを選択すると、アクティブな Web アプリケーションに含まれていない Web ドキュメントで、[ファイル] メニューの [ブラウザーで表示] コマンドが有効になります。Select this option to enable the View in Browser command on the File menu for Web documents not included in the active Web application.

その他のファイル プロジェクトに保存された < n > 項目< n > items saved in the Miscellaneous files project
ソリューション エクスプローラーその他のファイル フォルダーに保存するファイルの数を指定します。Specifies the number of files to persist in the MiscellaneousFiles folder of Solution Explorer. ファイルはエディターで開いていなくても一覧表示されます。These files are listed even if they are no longer open in an editor. 0 から 256 までの任意の整数を指定できます。You can specify any whole number from 0 to 256. 既定の数は 0 です。The default number is 0.

たとえば、このオプションを 5 に設定したとき、10 個のその他のファイルを開いている場合、10 個のファイルをすべて閉じたとき、最初の 5 個のファイルが その他のファイル フォルダーに引き続き表示されます。For example, if you set this option to 5 and have 10 miscellaneous files open, when you close all 10 files, the first 5 will still be shown in the Miscellaneous Files folder.

コードページでデータが保存できない場合、Unicode でドキュメントを保存Save documents as Unicode when data cannot be saved in codepage
このオプションを選択すると、選択したコードページと互換性のない情報を含むファイルが既定で Unicode として保存されます。Select this option to cause files containing information incompatible with the selected codepage to be saved as Unicode by default.

関連項目See Also

[環境] ([オプション] ダイアログ ボックス) Environment Options Dialog Box
その他のファイル Miscellaneous Files
テキストの検索と置換Finding and Replacing Text