[全般]([オプション] ダイアログ ボックス - [環境])General, Environment, Options Dialog Box

このページを使用して、統合開発環境 (IDE: Integrated Development Environment) のオプションのうち特に配色テーマ、ステータス バーの設定、およびファイル拡張子の関連付けを変更します。Use this page to change color themes, status bar settings, and file extension associations, among other options, for the integrated development environment (IDE). [オプション] ダイアログ ボックスを表示するには、[ツール] メニューを開いて、[オプション] をクリックし、[環境] フォルダーを開き、[全般] ページをクリックします。You can access the Options dialog box by opening the Tools menu, choosing Options, opening the Environment folder and then choosing the General page. このページが一覧に表示されない場合は、[オプション] ダイアログ ボックスの [すべての設定を表示] チェック ボックスをオンにします。If this page does not appear in the list, select the Show all settings check box in the Options dialog box.

注意

実際に画面に表示されるダイアログ ボックスとメニュー コマンドは、アクティブな設定またはエディションによっては、ヘルプの説明と異なる場合があります。The dialog boxes and menu commands you see might differ from those described in Help depending on your active settings or edition. 設定を変更するには、[ツール] メニューを開き、[設定のインポートとエクスポート] を選択します。To change your settings, open the Tools menu, and then choose Import and Export Settings. 詳細については、「Visual Studio IDE のカスタマイズ」を参照してください。For more information, see Personalize the Visual Studio IDE.

視覚的効果Visual Experience

[配色テーマ]Color theme

IDE の配色テーマで [青][淡色] または [濃色] を選択します。Choose the Blue, Light or Dark color theme for the IDE.

Visual Studio Marketplace から Visual Studio 配色テーマ エディターをダウンロードしインストールすることで、定義済みテーマを追加でインストールしたりカスタム テーマを作成したりすることもできます。You can install additional predefined themes, and create custom themes, by downloading and installing the Visual Studio Color Theme Editor from the Visual Studio Marketplace. このツールをインストールすると、追加の配色テーマが [配色テーマ] ボックスの一覧に表示されます。After you install this tool, additional color themes appear in the Color theme list box.

メニュー バーにタイトルの文字種を適用するApply title casing in menu bar

既定では、メニューはタイトルの文字種になります。Menus are in Title Casing by default. このオプションのチェック ボックスをオフにすると、メニューがすべて大文字に設定されます。Un-check this option to set them to ALL CAPS.

クライアントのパフォーマンスに基づいて視覚的効果を自動的に調整するAutomatically adjust visual experience based on client performance

Visual Studio で視覚的効果を自動的に調整するか、ユーザーが明示的に調整するかを指定します。Specifies whether Visual Studio sets the adjustment to the visual experience automatically or you set the adjustment explicitly. この調整によって、色の表示がグラデーションからフラットに変わったり、メニューまたはポップアップ ウィンドウでのアニメーションの使用が制限されたりすることがあります。This adjustment may change the display of colors from gradients to flat colors, or it may restrict the use of animations in menus or popup windows.

リッチ クライアント エクスペリエンスを有効にするEnable rich client experience

グラデーションやアニメーションなど、Visual Studio の視覚的効果のすべてを有効にします。Enables the full visual experience of Visual Studio, including gradients and animations. リモート デスクトップ接続や古いグラフィックス アダプターを使用している場合は、これらの機能のパフォーマンスが低下する可能性があるため、このオプションをオフにします。Clear this option when using Remote Desktop connections or older graphics adapters, because these features may have poor performance in those cases. このオプションをオンにできるのは、[クライアントのパフォーマンスに基づいて視覚的効果を自動的に調整する] をオフにした場合だけです。This option is available only when you clear the Automatically adjust visual experience based on client option.

可能ならハードウェアのグラフィックス アクセラレータを使用するUse hardware graphics acceleration if available

可能な場合は、ソフトウェア アクセラレータではなく、ハードウェアのグラフィックス アクセラレータを使用します。Uses hardware graphics acceleration if it is available, rather than software acceleration.

その他Other

項目をウィンドウ メニューに表示Items shown in Window menu
[ウィンドウ] メニューの [ウィンドウ] の一覧に表示されるウィンドウ数をカスタマイズします。Customizes the number of windows that appear in the Windows list of the Window menu. 1 ~ 24 の値を入力します。Type a number between 1 and 24. 既定値は 10 です。By default, the number is 10.

項目を最近使用した一覧に表示Items shown in recently used lists
[ファイル] メニューに表示される、最近使ったプロジェクトとファイルの数をカスタマイズします。Customizes the number of most recently used projects and files that appear on the File menu. 1 ~ 24 の値を入力します。Type a number between 1 and 24. 既定値は 10 です。By default, the number is 10. このオプションを使用すると、最近使用したプロジェクトやファイルを簡単に表示できます。This is an easy way to retrieve recently used projects and files.

ステータス バーの表示Show status bar
ステータス バーが表示されます。Displays the status bar. ステータス バーは IDE ウィンドウの一番下にあり、処理中の操作の進行状況が表示されます。The status bar is located at the bottom of the IDE window and displays information about the progress of ongoing operations.

[閉じる] ボタンを、アクティブなツール ウィンドウに対してのみ実行するClose button affects active tool window only
[閉じる] をクリックしたときに、ドッキング セット内のすべてのツール ウィンドウではなく、フォーカスのあるツール ウィンドウだけを閉じるように指定します。Specifies that when the Close button is clicked, only the tool window that has focus is closed and not all of the tool windows in the docked set. 既定では、このチェック ボックスはオンになっています。By default, this option is selected.

[自動的に隠す] ボタンを、アクティブなツール ウィンドウに対してのみ実行するAuto Hide button affects active tool window only
[自動的に隠す] をクリックしたときに、ドッキング セット内のすべてのツール ウィンドウではなく、フォーカスのあるツール ウィンドウだけを自動的に非表示にするように指定します。Specifies that when the Auto Hide button is clicked, only the tool window that has focus is hidden automatically and not all of the tool windows in the docked set. 既定では、このチェック ボックスはオフになっています。By default, this option is not selected.

関連項目See also

[環境] ([オプション] ダイアログ ボックス)Environment Options Dialog Box
ウィンドウ レイアウトをカスタマイズするCustomizing window layouts