方法: IDE アクセシビリティ オプションを設定するHow to: Set IDE Accessibility Options

ヒント

最近実施されたアクセシビリティの更新の詳細については、ブログ投稿の「Accessibility improvements in Visual Studio 2017 version 15.3 (Visual Studio 2017 バージョン 15.3 でのアクセシビリティの機能強化)」をご覧ください。To learn more about recent accessibility updates, see the Accessibility improvements in Visual Studio 2017 version 15.3 blog post.

Visual StudioVisual Studio には、視力の弱い方に見やすい表示にしたり、動作に制限があっても入力しやすくするための機能が装備してあります。 contains features that make it easier for people who have low vision to read and for people who have limited dexterity to write. たとえば、エディター内のテキストのサイズや色を変更する機能、ツール バーのテキストやボタンのサイズを変更する機能、入力する文字数を減らすためのメソッドやパラメーターのオート コンプリート機能などがあります。These features include changing the size and color of text in editors, changing the size of text and buttons on toolbars, and auto-completion for methods and parameters, to name a few.

また、Visual StudioVisual Studio では、Dvorak 配列のキーボードがサポートされています。この配列では、最も使用頻度の高い文字が最も入力しやすい位置にあります。In addition, Visual StudioVisual Studio supports Dvorak keyboard layouts, which make the most frequently typed characters more accessible. また、Visual StudioVisual Studio で設定されている既定のショートカット キーをカスタマイズすることもできます。You can also customize the default shortcut keys available with Visual StudioVisual Studio. 詳細については、「Visual Studio でのキーボード ショートカットの識別とカスタマイズ」をご覧ください。For more information, see Identifying and Customizing Keyboard Shortcuts.

注意

実際に画面に表示されるダイアログ ボックスとメニュー コマンドは、アクティブな設定またはエディションによっては、ヘルプの説明と異なる場合があります。The dialog boxes and menu commands you see might differ from those described in Help depending on your active settings or edition. 設定を変更するには、 [ツール] メニューの [設定のインポートとエクスポート] をクリックします。To change your settings, choose Import and Export Settings on the Tools menu. 詳細については、「Visual Studio IDE のカスタマイズ」を参照してください。For more information, see Personalize the Visual Studio IDE.

エディター、ダイアログ、およびツール ウィンドウEditors, Dialogs, and Tool Windows

既定では、Visual StudioVisual Studio のダイアログ ボックスおよびツール ウィンドウに対し、オペレーティング システムで使用されているフォント サイズと色が使用されます。By default, dialog boxes and tool windows in Visual StudioVisual Studio use the same font size and colors as the operating system. IDE、ダイアログ ボックス、ツール バー、ツール ウィンドウのフレームの色の設定は、配色 (明るいまたは暗い) に基づいています。The color settings for the frame of the IDE, dialog boxes, toolbars, and tool windows are based a color scheme: light or dark. [全般] ([オプション] ダイアログ ボックス - [環境]) で、現在の配色テーマを変更することができます。You can change the current color theme in the General, Environment, Options Dialog Box.

エディターのコード ビューでは、ポップアップ ウィンドウも表示できます。You can also display pop-up windows in the Code view of the editor. これらのウィンドウを表示し、関数またはステートメントを完成させるために利用できる現在のオブジェクトのメンバーおよびパラメーターを示すことができます。These windows can prompt you with available members on the current object and the parameters to complete a function or statement. キー入力が困難な場合は、ウィンドウの表示が役に立ちます。These windows can be helpful if you have difficulty typing. ただし、ウィンドウを表示するとコード エディターのフォーカスが妨げられるので、ユーザーによっては問題になる場合があります。However, they interfere with focus in the code editor, which can be problematic for some users. これらのウィンドウの表示を中止するには、[オプション] ダイアログ ボックスを開き、[テキスト エディター][すべての言語][全般] を順にクリックし、[自動メンバー表示] および [パラメーター ヒント] をオフにします。You can turn off these windows by opening the Options dialog box and clearing Auto list members and Parameter information in the Text Editor, All Languages, General page in the Options dialog box. 詳しくは、「方法: 一般エディター オプションを設定する」をご覧ください。For more information, see How to: Set General Editor Options.

統合開発環境 (IDE: Integrated Development Environment) のウィンドウを作業に最も適した位置に整列し直すことができます。You can rearrange the windows in the integrated development environment (IDE) to best suit the way you work. 各ツール ウィンドウを、ドッキング、フローティング、非表示、自動非表示にできます。You can dock, float, hide, or automatically hide each tool window.

ウィンドウ レイアウトを変更する方法について詳しくは、「ウィンドウ レイアウトをカスタマイズする」をご覧ください。For more information about how to change window layouts, see Customizing window layouts.

テキストのサイズの変更Changing the Size of Text

テキスト ベースのツール ウィンドウ、たとえば [コマンド] ウィンドウ、[イミディエイト] ウィンドウ、[出力] ウィンドウなどでは、[ツール] ダイアログ ボックスの [環境] オプションの [フォントおよび色] ウィンドウで設定を変更できます。You can change the settings for text-based tool windows, such as the Command window, Immediate window, and Output window, in the Fonts and Colors pane of the Environment options in the Tools dialog box. [設定の表示] ボックスの一覧で [すべてのテキスト ツール ウィンドウ] が選択されている場合、[前景色] および [背景色] ボックスの一覧に既定の設定として [既定値] が表示されます。When [All Text Tool Windows] is selected in the Show settings for drop-down list, the default setting is listed as Default in the Item foreground and Item background drop-down lists. エディターでのテキスト表示方法に関する設定も変更できます。You can also change the settings for how text is displayed in the editor.

テキスト ベースのツール ウィンドウおよびエディターでのテキスト サイズを変更するにはTo change the size of text in text-based tool windows and editors
  1. [ツール] メニューの [オプション]をクリックします。From the Tools menu, choose Options.

  2. [環境] フォルダーの [フォントおよび色] を選択します。Choose Fonts and Colors on the Environment folder.

  3. [設定の表示] メニューのオプションを選択します。Select an option on the Show settings for drop-down menu.

    エディター内のテキストのフォント サイズを変更するには、[テキスト エディター] を選択します。To change the font size for text in an editor, choose Text Editor.

    テキスト ベースのツール ウィンドウのテキストのフォント サイズを変更するには、[すべてのテキスト ツール ウィンドウ] を選択します。To change the font size for text in text-based tool windows, choose [All Text Tool Windows].

    エディター内のツールヒント テキストのフォント サイズを変更するには、[エディターのツール ヒント] を選択します。To change the font size for ToolTip text in an editor, choose Editor Tooltip.

    ステートメントのオート コンプリート用のポップアップで使用するテキストのフォント サイズを変更するには、[入力候補] を選択します。To change the font size for text in statement completion pop-ups, choose Statement Completion.

  4. [表示項目][テキスト形式] を選択します。From Display items, select Plain Text.

  5. [フォント] で新しいフォントの種類を選択します。In Font, select a new font type.

  6. [サイズ] で新しいフォントのサイズを選択します。In Size, select a new font size.

    注意

    テキスト ベースのツール ウィンドウおよびエディターのテキスト サイズをリセットするには [既定値を使用] を選択します。To reset the text size for text-based tool windows and editors, choose Use Defaults.

  7. [OK]をクリックします。Choose OK.

IDE で使用される色の変更Changing the Colors used in the IDE

また、エディター内のテキスト、マージン インジケーター、空白文字、およびコード要素の既定の色を変更することもできます。You can also choose to change the default colors for text, margin indicators, white space, and code elements in the editor.

注意

オペレーティング システム上の全アプリケーション ウィンドウでハイコントラスト色を使用する場合は、左 Alt +Shift + PrintScreen キーを押します。To use high contrast colors for all application windows on your operating system, press Left ALT+Left SHIFT+PRINT SCREEN. Visual StudioVisual Studio が起動されている場合は、Visual StudioVisual Studio を終了してから再起動すると、ハイコントラスト色の機能を完全に利用できます。If Visual StudioVisual Studio is open, close and reopen Visual StudioVisual Studio to fully implement high contrast colors.

エディター内の項目の色を変更するにはTo change the color of items in the editor
  1. [ツール] メニューの [オプション]をクリックします。From the Tools menu, choose Options.

  2. [環境] フォルダーの [フォントおよび色] を選択します。Choose Fonts and Colors from the Environment folder.

  3. [設定の表示][テキスト エディター] を選択します。In Show settings for, choose Text Editor.

  4. [表示項目] から、[テキスト形式][インジケーター マージン][スペースの表示][HTML の属性名][XML 属性] など変更対象の項目を選択します。From Display items, select an item whose display you need to change, such as Plain Text, Indicator Margin, Visible White Space, HTML Attribute Name, or XML Attribute.

  5. [前景色][背景色]、および [太字] の各オプションから表示設定を選択します。Select display settings from the following options: Item foreground, Item background, and Bold.

  6. [OK]をクリックします。Choose OK.

ツールバーToolbars

ツール バーの操作性を向上させるために、ツール バー ボタンにテキストを追加できます。To improve toolbar usability and accessibility, you can add text to toolbar buttons.

ツール バー ボタンにテキストを割り当てるにはTo assign text to toolbar buttons

  1. [ツール] メニューの [ユーザー設定] を選択します。From the Tools menu, choose Customize.

  2. [ユーザー設定] ダイアログ ボックスの [コマンド] タブを選択します。In the Customize dialog box, select the Commands tab.

  3. [ツール バー] を選択してから、テキストを表示するボタンが含まれているツール バーの名前を選択します。Select Toolbar and then choose the toolbar name that contains the button you intend to display text for.

  4. リスト ボックスから、変更対象のコマンドを選択します。In the list, select the command you intend to change.

  5. [選択したボタンの編集] を選択します。Choose Modify Selection.

  6. [イメージとテキストを表示] を選択します。Choose Image and Text.

ボタンの表示テキストを変更するにはTo modify the button's displayed text

  1. [選択したボタンの編集] を再度選択します。Re-select Modify Selection.

  2. [名前] の右側に、選択したボタンの新しいキャプションを入力します。Adjacent to In Name, insert provide a new caption for the selected button.

関連項目See Also

Visual Studio のユーザー補助機能 Accessibility Features of Visual Studio
ユーザー補助アプリケーションのデザイン リソースResources for Designing Accessible Applications