方法: キーボード主体で操作するHow to: Use the Keyboard Exclusively

ヒント

最近実施されたアクセシビリティの更新の詳細については、ブログ投稿の「Accessibility improvements in Visual Studio 2017 version 15.3 (Visual Studio 2017 バージョン 15.3 でのアクセシビリティの機能強化)」をご覧ください。To learn more about recent accessibility updates, see the Accessibility improvements in Visual Studio 2017 version 15.3 blog post.

Visual StudioVisual Studio で提供されているさまざまな既定のショートカット キーの組み合わせを使うと、統合開発環境 (IDE) 内で移動やコーディングを簡単に行うことができます。 provides many default shortcut key combinations to make it easy to navigate and code within the integrated development environment (IDE). Visual Studio で使われるすべてのショートカット キーの一覧については、「既定のキーボード ショートカット」をご覧ください。For a full listing of shortcut keys used in Visual Studio, see Default Keyboard Shortcuts. 他の Microsoft 製品で利用できるキーボード ショートカットについては、http://www.microsoft.com/enable/products/keyboard.aspx をご覧ください。For information on keyboard shortcuts available for other Microsoft products, see http://www.microsoft.com/enable/products/keyboard.aspx.

注意

実際に画面に表示されるダイアログ ボックスとメニュー コマンドは、アクティブな設定またはエディションによっては、ヘルプの説明と異なる場合があります。The dialog boxes and menu commands you see might differ from those described in Help depending on your active settings or edition. 設定を変更するには、 [ツール] メニューの [設定のインポートとエクスポート] をクリックします。To change your settings, choose Import and Export Settings on the Tools menu. 詳細については、「Visual Studio IDE のカスタマイズ」を参照してください。For more information, see Personalize the Visual Studio IDE.

ツールボックス コントロールToolbox Controls

キーボードを使って、ツールボックスのコントロールをフォームまたはデザイナーに追加できます。You can add a control on the Toolbox to a form or designer using the keyboard.

キーボードを使ってツールボックスからデザイナーにコントロールを追加するにはTo add controls from the Toolbox to a designer from the keyboard

  1. メニュー バーで [表示][ツールボックス] の順に選択します。On the menu bar, choose View, Toolbox.

  2. 現在の [ツールボックス] タブでセクション間を移動するには、Ctrl キーを押しながら上方向キーを押すか、Ctrl キーを押しながら下方向キーを押します。Use the Ctrl + Up Arrow or Ctrl + Down Arrow keys to move among the sections in the current Toolbox tab.

  3. コントロール間を移動するには、上方向キーまたは下方向キーを使用します。Use the Up Arrow or Down Arrow keys to move among the controls.

  4. コントロールを選択した後、Enter キーを押します。After the control is selected, use the Enter key.

    コントロールがフォームまたはデザイナーに追加されます。The control is added to the form or designer.

ダイアログ ボックス オプションDialog Box Options

キーボードを使って、ダイアログ ボックスのオプション間を移動し、オプションの設定を変更できます。You can move among the options in a dialog and change option settings using the keyboard.

キーボードを使ってダイアログ ボックスのオプションを設定するにはTo set dialog box options from the keyboard

  1. Tab キーまたは Shift + Tab キーを使って、ダイアログ ボックス内のコントロール間を上下に移動します。Use TAB or SHIFT + TAB to move up and down through the controls in the dialog box.

  2. オプションの設定を変更するには:To change option settings:

    • ラジオ ボタンの場合は、上方向キーと下方向キーを使って、選択を変更します。For radio buttons, use UP ARROW and DOWN ARROW to change the selection.

    • チェック ボックスの場合は、Space キーを使ってオンまたはオフにします。For check boxes, use SPACEBAR to select or unselect.

    • ドロップダウン リストの場合は、Alt + 下方向キーを使って項目を表示し、上方向キーと下方向キーを使って選択した項目を変更します。For drop-down lists, use ALT + DOWNARROW to display items and then use UPARROW and DOWNARROW to change the selected item.

    • ボタンの場合は、Enter キーを押して呼び出します。For buttons, press ENTER to invoke.

    • グリッドの場合は、方向キーを使って移動します。For grids, use the Arrow keys to navigate. グリッド内のドロップダウン リストの場合は、Shift + Alt + 下方向キーを使って項目を表示し、上方向キーと下方向キーを使って選択した項目を変更します。For drop-down lists in grids, use SHIFT + ALT + DOWNARROW to display items and then use UPARROW and DOWNARROW to change the selected item.

ウィンドウおよびファイルに関する移動Window and File Navigation

IDE では、キーボードを使って開いているツール ウィンドウやドキュメント ウィンドウ間を移動するための方法が複数用意されています。The IDE provides several ways for you to move among open tool and document windows using the keyboard. また、キーボードを使って、ツール ウィンドウを別の場所に移動してドッキングすることもできます。You can also move and dock tool windows in different locations using the keyboard.

キーボードを使って IDE 内のウィンドウ間およびファイル間を移動するにはTo navigate among windows and files in the IDE from the keyboard

  • エディターまたはデザイナー内でファイル間を移動するには、Ctrl + Tab キーを押して、[アクティブなファイル] が選択された IDE ナビゲーターを表示します。To move among files in an editor or designer, choose CTRL + TAB keys to display the IDE Navigator with Active Files selected. 強調表示されているファイルに移動するには、Enter キーを押します。Choose the Enter key to navigate to the highlighted file.

  • ドッキングされたツール ウィンドウ間を移動するには、Alt + F7 キーを押して、[アクティブなツール ウィンドウ] が選択された IDE ナビゲーターを表示します。To move among docked tool windows, choose Alt + F7 to display the IDE Navigator with Active Tool Windows selected. 強調表示されているファイルに移動するには、Enter キーを押します。Choose the Enter key to navigate to the highlighted window.

キーボードを使ってツール ウィンドウを移動してドッキングするにはTo move and dock tool windows from the keyboard

  1. 移動するツール ウィンドウに移動し、フォーカスを設定します。Navigate to the tool window you intend to move and give it focus.

  2. [ウィンドウ] メニューで [ドッキング可能] オプションを選択します。On the Window menu, select the Dockable option.

  3. Alt + Space キーを押して、[移動] を選択します。Press ALT + Space and then choose Move.

    ドッキング ガイドのひし形が表示されます。The docking guide diamond appears.

  4. 方向キーを押して、ウィンドウを新しい場所に移動します。Use the ARROW keys to move the window to a new location.

    方向キーを押すと、ウィンドウと共にマウス ポインターが移動します。The mouse pointer moves with the window as you use the ARROW keys.

  5. 新しい場所に到達したら、方向キーを押して、ガイドのひし形の適切な部分にマウス ポインターを移動します。When you have reached the new location, use the ARROW keys to move the mouse pointer over the correct portion of the guide diamond.

    新しいドッキング場所にツール ウィンドウの輪郭が表示されます。An outline of the tool window appears in the new docking location.

  6. Enter キーを押します。Press ENTER.

    ツール ウィンドウが、新しいドッキング場所の所定の位置にスナップされます。The tool window snaps into place at the new docking location.

関連項目See Also

キーボード ショートカットの識別とカスタマイズ Identifying and Customizing Keyboard Shortcuts
アクセシビリティのヒントとテクニック Accessibility Tips and Tricks
既定のキーボード ショートカットDefault Keyboard Shortcuts