[オプション] ダイアログ ボックス (Visual Studio)Options Dialog Box (Visual Studio)

[オプション] ダイアログ ボックスでは、必要に応じて統合開発環境 (IDE) を構成することができます。The Options dialog box enables you to configure the integrated development environment (IDE) to your needs. たとえば、プロジェクトの既定の保存場所の確立、ウィンドウの既定の外観や動作の変更、よく使用されるコマンドのショートカットの作成などを行うことができます。For example, you can establish a default save location for your projects, alter the default appearance and behavior of windows, and create shortcuts for commonly used commands. 開発言語やプラットフォームに固有のオプションもあります。There are also options specific to your development language and platform. [オプション] には [ツール] メニューからアクセスできます。You can access Options from the Tools menu.

注意

使用している設定またはエディションによっては、ダイアログ ボックスで使用可能なオプションや、メニュー コマンドの名前や位置がヘルプに記載されている内容と異なる場合があります。The options available in dialog boxes, and the names and locations of menu commands you see, might differ from what is described in Help depending on your active settings or edition. 設定を変更するには、 [ツール] メニューの [設定のインポートとエクスポート] をクリックします。To change your settings, choose Import and Export Settings on the Tools menu. 詳細については、「Visual Studio IDE のカスタマイズ」を参照してください。For more information, see Personalize the Visual Studio IDE.

[オプション] ダイアログ ボックスのレイアウトLayout of the Options dialog box

[オプション] ダイアログ ボックスは 2 つの部分 (左側のナビゲーション ウィンドウと右側の表示領域) に分かれています。The Options dialog box is divided into two parts: a navigation pane on the left and a display area on the right. ナビゲーション ウィンドウのツリー コントロールには、[環境]、[テキスト エディター]、[プロジェクトおよびソリューション]、および [ソース管理] などのフォルダー ノードが含まれています。The tree control in the navigation pane includes folder nodes, such as Environment, Text Editor, Projects and Solutions, and Source Control. 任意のフォルダー ノードを展開すると、その中に含まれるオプションのページがリストされます。Expand any folder node to list the pages of options that it contains. 特定のページのノードを選択すると、表示領域にそのオプションが表示されます。When you select the node for a particular page, its options appear in the display area.

IDE 機能のオプションは、この機能がメモリに読み込まれるまでは、ナビゲーション ウィンドウには表示されません。Options for an IDE feature do not appear in the navigation pane until the feature is loaded into memory. したがって、前のセッションを終了したときに表示されていたオプションが、新規セッションを開始した時点では表示されない場合があります。Therefore, the same options might not be displayed as you begin a new session that were displayed as you ended the last. プロジェクトを作成するか、特定のアプリケーションを使用するコマンドを実行すると、関連するオプションのノードが [オプション] ダイアログ ボックスに追加されます。When you create a project or run a command that uses a particular application, nodes for relevant options are added to the Options dialog box. 追加されたこれらのオプションは、IDE 機能がメモリにある限り有効です。These added options will then remain available as long as the IDE feature remains in memory.

注意

一部の設定コレクションでは、[オプション] ダイアログ ボックスのナビゲーション ウィンドウに表示されるページ数のスコープが設定されます。Some settings collections scope the number of pages that appear in the navigation pane of the Options dialog box. [すべての設定を表示] を選択すると、使用可能なすべてのページを表示できます。You can choose to view all possible pages by selecting Show all settings.

オプションの適用方法How options are applied

[オプション] ダイアログ ボックスで [OK] をクリックすると、すべてのページのすべての設定が保存されます。Clicking OK in the Options dialog box saves all settings on all pages. 任意のページで [キャンセル] をクリックすると、他の [オプション] ページで行ったものを含め、すべての変更要求がキャンセルされます。Clicking Cancel on any page cancels all change requests, including any just made on other Options pages. [フォントおよび色] ([オプション] ダイアログ ボックス - [環境]) での変更など、オプション設定に加えた一部の変更は、Visual Studio を閉じて再度開いたときに初めて有効になります。Some changes to option settings, such as those made on Fonts and Colors, Environment, Options Dialog Box, will only take effect after you close and reopen Visual Studio.

すべての設定を表示Show all settings

[すべての設定を表示] のオンまたはオフの操作は、[OK] をクリックしていなくても、[オプション] ダイアログ ボックスで行ったすべての変更に適用されます。Selecting or unselecting Show all settings applies all changes you have made in the Options dialog box, even though you have not yet clicked OK.

関連項目See Also

エディターのカスタマイズCustomizing the Editor