[オプション]、[テキスト エディター]、[すべての言語]Options, Text Editor, All Languages

このダイアログ ボックスでは、コード エディターの既定の動作を変更できます。This dialog box allows you to change the default behavior of the Code Editor. 設定は、HTML デザイナーのソース ビューなど、コード エディターに基づいて他のエディターにも適用されます。These settings also apply to other editors based upon the Code Editor, such as the HTML Designer's Source view. このダイアログ ボックスを開くには、[ツール] メニューから [オプション] を選択します。To open this dialog box, select Options from the Tools menu. [テキスト エディター] フォルダー内で [すべての言語] サブフォルダーを展開し、[全般] を選択します。Within the Text Editor folder, expand the All Languages subfolder and then choose General.

注意事項

このページから、すべての開発言語の既定のオプションが設定されます。This page sets default options for all development languages. このダイアログでオプションをリセットすると、すべての言語の全般オプションがここで選択されているものにリセットされます。Remember that resetting an option in this dialog will reset the General options in all languages to whatever choices are selected here. 1 つだけの言語のテキスト エディター オプションを変更にするには、その言語のサブフォルダーを展開し、そのオプション ページを選択します。To change Text Editor options for just one language, expand the subfolder for that language and select its option pages.

全般オプション ページでオプションを選択すると、一部のプログラミング言語で灰色のチェックマークが表示されることがあります。A grayed checkmark is displayed when an option has been selected on the General options pages for some programming languages, but not for others.

注意

実際に画面に表示されるダイアログ ボックスとメニュー コマンドは、アクティブな設定またはエディションによっては、ヘルプの説明と異なる場合があります。The dialog boxes and menu commands you see might differ from those described in Help depending on your active settings or edition. 設定を変更するには、 [ツール] メニューの [設定のインポートとエクスポート] をクリックします。To change your settings, choose Import and Export Settings on the Tools menu. 詳細については、「Visual Studio IDE のカスタマイズ」を参照してください。For more information, see Personalize the Visual Studio IDE.

[入力候補]Statement Completion

自動メンバー表示Auto list members

選択すると、エディターに文字を入力すると同時に、利用可能なメンバー、プロパティ、値、メソッドのポップアップ リストが IntelliSense により表示されます。When selected, pop-up lists of available members, properties, values, or methods are displayed by IntelliSense as you type in the editor. 任意の項目をポップアップ リストから選択し、コードに挿入します。Choose any item from the pop-up list to insert the item into your code. このオプションを選択すると、[メンバーの詳細を非表示] オプションが有効になります。Selecting this option enables the Hide advanced members option.

[メンバーの詳細を非表示]Hide advanced members

選択すると、ステートメント入力候補のポップアップ リストが短くなり、よく使用する項目だけが表示されます。When selected, shortens pop-up statement completion lists by displaying only those items most commonly used. その他の項目は、リストに表示されません。Other items are filtered from the list.

[パラメーター ヒント]Parameter information

選択すると、現在の宣言またはプロシージャの完全な構文と指定可能な全パラメーターがエディター内のカーソル位置の下に表示されます。When selected, the complete syntax for the current declaration or procedure is displayed under the insertion point in the editor, with all of its available parameters. 次に割り当て可能なパラメーターは、太字で表示されます。The next parameter you can assign is displayed in bold.

設定Settings

[仮想空白を使用]Enable virtual space

このオプションがオンで、[右端で折り返す] がオフの場合、コード エディターの行末を越える任意の場所をクリックしてコメントを入力できます。When this option is selected and Word wrap is cleared, you can click anywhere beyond the end of a line in the Code Editor and type. この機能を使用すると、コードの横の一貫した位置にコメントを配置できます。This feature can be used to position comments at a consistent point next to your code.

右端で折り返すWord wrap

選択すると、表示可能な編集領域を超える行部分 (水平方向) が自動的に次の行に表示されます。When selected, any portion of a line that extends horizontally beyond the viewable editor area is automatically displayed on the next line. このオプションをオンにすると、[右端の折り返しの記号を表示する] オプションが有効になります。Selecting this option enables the Show visual glyphs for word wrap option.

注意

[仮想空白] 機能は、[右端で折り返す] がオンになっているときはオフになります。The Virtual Space feature is turned off while Word Wrap is on.

[右端の折り返しの記号を表示する]Show visual glyphs for word wrap

選択すると、長い行を折り返したとき、その位置に折り返し矢印インジケーターが表示されます。When selected, a return-arrow indicator is displayed where a long line wraps onto a second line.

LineBreakSymbol スクリーンショットLineBreakSymbol screenshot

インジケーターを表示しない場合、このオプションをオフにします。Clear this option if you prefer not to display these indicators.

注意

このような注意を促すための矢印は、コードに追加されたり、印刷されたりすることはありません。These reminder arrows are not added to your code, and do not print. これらは参照専用です。They are for reference only.

[選択領域がない場合は、切り取りまたはコピー コマンドを空白行に適用する]Apply Cut or Copy commands to blank lines when there is no selection

このオプションは、空白行に挿入ポインターを置き、何も選択せずにコピーまたは切り取り操作を行った場合のエディターの動作を設定します。This option sets the behavior of the editor when you place the insertion point on a blank line, select nothing, and then Copy or Cut.

  • このオプションを選択した場合、空白行がコピーされるか切り取られます。When this option is selected, the blank line is copied or cut. その後に貼り付けを行うと、新しい空白行が挿入されます。If you then Paste, a new, blank line is inserted.

  • このオプションが選択されていないとき、[切り取り] コマンドを使用すると、空白行が削除されます。When this option is cleared, the Cut command removes blank lines. ただし、クリップボードのデータは保持されます。However, the data on the Clipboard is preserved. そのため、その後に貼り付けコマンドを実行すると、最後にクリップボードにコピーされた内容が貼り付けられます。Therefore, if you then use the Paste command, the content most recently copied onto the Clipboard is pasted. 前にコピーされた内容がない場合、貼り付けは行われません。If nothing has been copied previously, nothing is pasted.

この設定は、行が空白でない場合には、コピーや切り取りに何の影響も与えません。This setting has no effect on Copy or Cut when a line is not blank. 何も選択されていない場合は、行全体のコピーまたは切り取りが行われます。If nothing is selected, the entire line is copied or cut. その後に貼り付けを行うと、行全体のテキストとその行末文字の貼り付けが行われます。If you then Paste, the text of the entire line and its endline character are pasted.

ヒント

空白、タブ、および行末のインジケーターを表示し、インデントの設定された行と、空白行とを区別できるようにするには、[編集] メニューの [詳細] をクリックし、[スペースの表示] を選択します。To display indicators for spaces, tabs, and line ends, and thus distinguish indented lines from lines that are entirely blank, select Advanced from the Edit menu and choose View White Space.

表示Display

[行番号]Line numbers

選択すると、行番号が各コード行の隣に表示されます。When selected, a line number appears next to each line of code.

注意

行番号がコードに追加されたり、印刷されたりすることはありません。These line numbers are not added to your code, and do not print. これらは参照専用です。They are for reference only.

[シングル クリックでの URL ナビゲーションを有効にする]Enable single-click URL navigation

選択すると、エディターの URL にマウス カーソルを置いたときに、マウス カーソルが手の形に変わります。When selected, the mouse cursor changes to a pointing hand as it passes over a URL in the editor. URL をクリックすると、示されているページが Web ブラウザーに表示されます。You can click the URL to display the indicated page in your Web browser.

[ナビゲーション バー]Navigation bar

選択すると、コード エディターの上部にナビゲーション バーが表示されます。When selected, displays the Navigation bar at the top of the code editor. そのドロップダウンの [オブジェクト] 一覧と [メンバー] 一覧では、コードの特定のオブジェクトを選択したり、そのメンバーから選択したり、コード エディターで選択したメンバーの宣言に移動したりできます。Its dropdown Objects and Members lists allow you to choose a particular object in your code, select from its members, and navigates to the declaration of the selected member in the Code Editor.

参照See Also