[オプション]、[テキスト エディター]、[C#]、[詳細]Options, Text Editor, C#, Advanced

このダイアログ ボックスを使用して、Visual C# のエディターの書式設定、コードのリファクタリング、および XML ドキュメントのコメントの設定を変更します。Use this dialog box to modify the settings for editor formatting, code refactoring, and XML documentation comments for Visual C#. このダイアログ ボックスを表示するには、[ツール] メニューの [オプション] をクリックし、[テキスト エディター] フォルダー、[C#] を順に展開し、[詳細設定] をクリックします。To access this dialog box, click Options on the Tools menu, expand the Text Editor folder, expand C#, and then click Advanced.

注意

実際に画面に表示されるダイアログ ボックスとメニュー コマンドは、アクティブな設定またはエディションによっては、ヘルプの説明と異なる場合があります。The dialog boxes and menu commands you see might differ from those described in Help depending on your active settings or edition. 設定を変更するには、 [ツール] メニューの [設定のインポートとエクスポート] をクリックします。To change your settings, choose Import and Export Settings on the Tools menu. 詳細については、「Visual Studio IDE のカスタマイズ」を参照してください。For more information, see Personalize the Visual Studio IDE.

アウトラインOutlining

ファイルが開かれたときにアウトライン モードを実行するEnter outlining mode when files open
選択すると、コードの折りたたみ可能なブロックを作成するコード ファイルが自動的にアウトラインになります。When selected, automatically outlines the code file, which creates collapsible blocks of code. 初めてファイルが開かれると、#regions ブロックとアクティブでないコード ブロックが折りたたまれます。The first time a file is opened, #regions blocks and inactive code blocks collapse.

エディターのヘルプEditor Help

エディターでエラーに下線を引くUnderline errors in the editor
コードのビルド エラーを識別します。Identifies build errors in code. このオプションを選択すると、色付きの波線が表示されます。色にはそれぞれ特定の意味があります。When this option is selected, wavy underlines appear in colors that have specific meanings:

  • 赤は解析エラーです。Parse errors are red.

  • 青はビルド エラーです。Build errors are blue.

  • 緑はビルドの警告です。Build warnings are green.

  • 紫は無効なエディット コンティニュの編集内容です。Invalid Edit and Continue edits are purple.

下線付きのコード セグメントの上にマウス ポインターを置いて、ヒントでエラーに関する情報を確認してください。Move the pointer over the underlined code segment to see a ToolTip with information about the error.

有効なセマンティック エラーを表示するShow live semantic errors
明示的なコンパイルのない特定のコンパイル エラー (たとえば、不明な型を宣言して使用したり、不明なプロパティを参照したりする) を特定します。Identifies certain compile errors without explicit compilation, for example, declaring and using an unknown type or referencing an unknown property.

カーソルの下にあるシンボルへの参照をハイライトするHighlight references to symbol under cursor
シンボル内にカーソルを置いたり、シンボルをクリックしたりすると、コード ファイル内のそのシンボルのすべてのインスタンスが強調表示されます。When the cursor is positioned inside a symbol, or when you click a symbol, all the instances of that symbol in the code file are highlighted.

リファクタリングRefactoring

リファクタリングの結果を確認するVerify results of refactoring
ビルド エラーを含むコードをリファクタリングする場合、またはリファクタリングによってコード参照が元のバインドとは別のものにバインドされる場合に、[検証結果] ダイアログ ボックスが表示されます。Displays the Verification Results dialog box when you try to refactor code that contains build errors, or when refactoring would cause a code reference to bind to something different from its original binding.

メンバーにコンパイラが生成した参照が指定されているときに警告するWarn on members with compiler generated references
コンパイラによって生成された参照と同じ名前を持つメンバーをリファクタリングすると、警告ダイアログ ボックスが表示されます。Displays a warning dialog when you try to refactor a member that has the same name as a compiler generated reference.

XML ドキュメントのコメントXML Documentation Comments

/// が入力されたとき、XML ドキュメントのコメントを生成するGenerate XML documentation comments for ///
選択すると、/// コメント イントロダクションを入力した後に、<summary> start タグと end タグが XML ドキュメント コメントに自動的に挿入されます。When selected, inserts the <summary> start and end tags automatically for XML documentation comments after you type the /// comment introduction. XML ドキュメントの詳細については、「XML ドキュメント コメント」を参照してください。For more information about XML documentation, see XML Documentation Comments.

インターフェイスの実装Implement Interface

生成されたコードを #region で囲むSurround generated code with #region
[インターフェイスの実装] または [インターフェイスを明示的に実装] が使用されると、#region <interface name> メンバーがメソッドの前後に挿入されます。Inserts a #region <interface name> Member around the methods when Implement Interface or Implement Interface Explicitly is used.

using の整理Organize Usings

using を並べ替える際に、'System' ディレクティブを先頭に配置するPlace 'System' directives first when sorting usings
選択すると、System using ディレクティブが他の using ディレクティブより前に表示されます。When selected, System using directives appear before other using directives. 詳細については、Visual C# IntelliSense の「using の整理」を参照してください。For more information, see Organize usings in Visual C# IntelliSense.

関連項目See Also

XML ドキュメント コメント XML Documentation Comments
言語固有のエディター オプションの設定 Setting Language-Specific Editor Options
Visual C# の IntelliSenseVisual C# IntelliSense