[オプション]、[テキスト エディター]、[C#]、[IntelliSense]Options, Text Editor, C#, IntelliSense

Visual C# での IntelliSense の動作設定を変更するには、[IntelliSense] プロパティ ページを使用します。Use the IntelliSense property page to modify settings that affect the behavior of IntelliSense for Visual C#. [IntelliSense] プロパティ ページにアクセスするには、[ツール] メニューの [オプション] をクリックして、[テキスト エディター] フォルダーで [C#] をクリックし、[IntelliSense] をクリックします。You can access the IntelliSense property page by clicking Options on the Tools menu, then clicking C# in the Text Editor folder, and then clicking IntelliSense.

注意

実際に画面に表示されるダイアログ ボックスとメニュー コマンドは、アクティブな設定またはエディションによっては、ヘルプの説明と異なる場合があります。The dialog boxes and menu commands you see might differ from those described in Help depending on your active settings or edition. 設定を変更するには、 [ツール] メニューの [設定のインポートとエクスポート] をクリックします。To change your settings, choose Import and Export Settings on the Tools menu. 詳細については、「Visual Studio IDE のカスタマイズ」を参照してください。For more information, see Personalize the Visual Studio IDE.

[IntelliSense] プロパティ ページには、以下のプロパティがあります。The IntelliSense property page contains the following properties:

入力候補一覧Completion Lists

文字が入力された後に入力候補一覧を表示するShow completion list after a character is typed
このオプションを選択すると、入力を開始したときに IntelliSense によって入力候補一覧が自動的に表示されます。When this option is selected, IntelliSense automatically displays the completion list when you begin typing. このオプションを選択しない場合でも、IntelliSense の入力候補は [IntelliSense] メニューから、または CTRL キーを押しながら SPACE キーを押して使用できます。When this option is not selected, IntelliSense completion is still available from the IntelliSense menu or by pressing CTRL+SPACE.

入力候補一覧にキーワードを配置するPlace keywords in completion lists
このオプションを選択すると、IntelliSense によって C# キーワード (class など) が入力候補一覧に追加されます。When this option is selected, IntelliSense adds C# keywords, for example, class, to the completion list.

入力候補一覧にコード スニペットを配置するPlace code snippets in completion lists
このオプションを選択すると、IntelliSense によって C# コード スニペットのエイリアスが入力候補一覧に追加されます。When this option is selected, IntelliSense adds aliases for C# code snippets to the completion list. コード スニペットのエイリアスがキーワードと同じ場合 (class など)、キーワードは、ショートカットで置き換えられます。In the case where the code snippet alias is the same as a keyword, for example, class, the keyword is replaced by the shortcut. 詳細については、「Visual C# のコード スニペット」を参照してください。For more information, see Visual C# Code Snippets.

入力候補一覧からの選択Selection in Completion Lists

次の文字の入力によって確定するCommitted by typing the following characters:
入力すると、入力候補一覧内の選択した項目に対して IntelliSense のオート コンプリートを実行するすべての文字を指定します。Specifies all characters that execute IntelliSense automatic completion for the selected item in completion list, after they are typed.

スペース バーを押すことによって確定するCommitted by pressing the space bar
入力候補一覧内の選択した項目に対して IntelliSense のオート コンプリートを実行するために、スペース バーを押すアクションを含めることを指定します。Specifies to include the action of pressing the space bar to execute IntelliSense automatic completion for the selected item in completion list.

単語を完全に入力した後 Enter キーで新しい行を追加するAdd new line on enter at end of fully typed word
入力候補一覧内のエントリのすべての文字を入力して ENTER キーを押すと、新しい行が自動的に作成され、新しい行にカーソルが移動することを指定します。Specifies that if you type all the characters for an entry in the completion list and then press ENTER, a new line is created automatically and the cursor moves to the new line.

たとえば、else を入力し、ENTER キーを押すと、エディターには次のように表示されます。For example, if you type else and then press ENTER, the following appears in the editor:

else

| (カーソルの位置)| (cursor location)

ただし、el のみを入力して ENTER キーを押すと、エディターには次のように表示されます。However, if you type only el and then press ENTER, the following appears in the editor:

else| (カーソルの位置)else| (cursor location)

IntelliSense メンバーの選択IntelliSense Member Selection

最近使用されたメンバーをあらかじめ選択するPre-selects most recently used member
このオプションを選択すると、統合開発環境 (IDE) での現在のセッション中に、オブジェクト名の自動補完のために、ポップアップ メンバーの一覧ボックスで最近選択したメンバーが IntelliSense によってあらかじめ選択されます。When this option is selected, IntelliSense pre-selects the members that you have recently selected in the pop-up List Members box for automatic object name completion, during your current session in the integrated development environment (IDE). 最近使用したメンバーの履歴は、IDE の各セッションの間に消去されます。The history of most recently used members is cleared between each session in the IDE. 詳細については、「最近使用されたメンバーに対する IntelliSense」を参照してください。For more information, see IntelliSense for Most Recently Used Members.

関連項目See Also

[全般]、[環境]、[オプション] ダイアログ ボックス General, Environment, Options Dialog Box
XML ドキュメント コメント XML Documentation Comments
IntelliSense の使用Using IntelliSense