[オプション]、[テキスト エディター]、[ファイル拡張子]Options, Text Editor, File Extension

この [オプション] ダイアログでは、Visual Studio 統合開発環境 (IDE) で特定のファイル拡張子を持つすべてのファイルを処理する方法を指定できます。This Options dialog allows you to specify how all files with certain file extensions will be handled by the Visual Studio integrated development environment (IDE). 入力した拡張子ごとに、[使用したエディター] を選択できます。For each Extension that you enter, you can select an Editing Experience. これにより、特定の種類の文書を開く IDE のエディターまたはデザイナーを選択できます。This allows you to choose the IDE editor or designer in which documents of a certain type will open. オプションを表示するには、[ツール] メニューから [オプション] を選択し、[テキスト エディター] ノードを展開し、[ファイル拡張子] を選択します。To display these options, choose Options from the Tools menu, expand the Text Editor node, and select File Extension.

"エンコードあり" オプションを選択すると、その種類の文書を開くときにダイアログが表示され、その文書のエンコード スキームを選択できます。When you select an option "with Encoding," a dialog will be displayed whenever you open a document of that type that allows you to select an encoding scheme for that document. これは、さまざまなプラットフォームで、あるいはさまざまなターゲット言語で使用できるようにプロジェクト文書の各種バージョンを用意している場合に便利です。This can be helpful if you are preparing versions of your project documents for use on different platforms or in different target languages.

注意

実際に画面に表示されるダイアログ ボックスとメニュー コマンドは、アクティブな設定またはエディションによっては、ヘルプの説明と異なる場合があります。The dialog boxes and menu commands you see might differ from those described in Help depending on your active settings or edition. 設定を変更するには、 [ツール] メニューの [設定のインポートとエクスポート] をクリックします。To change your settings, choose Import and Export Settings on the Tools menu. 詳細については、「Visual Studio IDE のカスタマイズ」を参照してください。For more information, see Personalize the Visual Studio IDE.

UIElement の一覧UIElement List

拡張機能Extension
IDE の [使用したエディター] を定義するファイル拡張子を入力します。Type the file extension whose Editing Experience in the IDE you wish to define.

[エディター]Editor
このファイル拡張子を持つ文書を開く IDE のエディターまたはデザイナーを選択します。Select the IDE editor or designer in which documents with this file extension will open. "エンコードあり" オプションを選択すると、その種類の文書を開くときにダイアログが表示され、エンコード スキームを選択できます。When you select an option "with Encoding," a dialog will be displayed whenever you open such a document that allows you to select an encoding scheme.

[追加]Add
指定した [拡張子][使用したエディター] が含まれるエントリを拡張子一覧に追加します。Adds an entry that includes the specified Extension and Editing Experience to the Extension List.

削除Remove
拡張子一覧から選択したエントリを削除します。Deletes the selected entry from the Extension List.

[拡張子一覧]Extension List
[使用したエディター] が指定されているすべての拡張子を一覧表示します。Lists all extensions for which an Editing Experience has been specified.

[拡張子のないファイルの割り当て先]Map extensionless files to
拡張子のないファイルを IDE で処理する方法を指定する場合、このオプションを選択します。Select this option if you wish to specify how files without an extension will be handled by the IDE.

[拡張子のないファイルのオプション]Extensionless file options
[エディター] と同じ一覧を提供します。Provides the same list as Editor. ファイル拡張子のない文書を開く IDE のエディターまたはデザイナーを選択します。Select the IDE editor or designer in which documents without file extensions will open.

関連項目See Also

方法 : エディター モードを管理するHow to: Manage Editor Modes