[オプション]、[テキスト エディター]、[全般]Options, Text Editor, General

このダイアログ ボックスでは、Visual StudioVisual Studio コード/テキスト エディターのグローバル設定を変更できます。This dialog box lets you change global settings for the Visual StudioVisual Studio Code and Text Editor. このダイアログ ボックスを表示するには、[ツール] メニューの [オプション] をクリックし、[テキスト エディター] フォルダーを展開し、[全般] をクリックします。To display this dialog box, click Options on the Tools menu, expand the Text Editor folder, and then click General.

注意

実際に画面に表示されるダイアログ ボックスとメニュー コマンドは、アクティブな設定またはエディションによっては、ヘルプの説明と異なる場合があります。The dialog boxes and menu commands you see might differ from those described in Help depending on your active settings or edition. 設定を変更するには、 [ツール] メニューの [設定のインポートとエクスポート] をクリックします。To change your settings, choose Import and Export Settings on the Tools menu. 詳細については、「Visual Studio IDE のカスタマイズ」を参照してください。For more information, see Personalize the Visual Studio IDE.

設定Settings

[ドラッグ アンド ドロップ編集]Drag and drop text editing
選択すると、マウスでテキストを選択してドラッグし、現在の文書内や開いている他の文書内の別の場所に移動させることができます。When selected, enables you to move text by selecting it and dragging it with the mouse to another location within the current document or any other open document.

[区切り記号を自動強調表示する]Automatic delimiter highlighting
選択すると、パラメーターまたは項目/値の組を分ける区切り文字とそれに対応する括弧が強調表示されます。When selected, delimiter characters that separate parameters or item-value pairs, as well as matching braces, are highlighted.

[変更履歴を記録する]Track changes
コード エディターが選択されているとき、マージンに黄色の縦線が表示され、ファイルが前回保存されてから変更されたコードに印を付けます。When the code editor is selected, a vertical yellow line appears in the selection margin to mark code that has changed since the file was most recently saved. 変更を保存すると、縦線は緑色になります。When you save the changes, the vertical lines become green.

[シグネチャ (BOM) なしの UTF-8 エンコードを自動検出]Auto-detect UTF-8 encoding without signature
既定では、エディターはバイト オーダー マークまたは文字セット タグを探してエンコードを検出します。By default, the editor detects encoding by searching for byte order marks or charset tags. 現在の文書でいずれも見つからない場合、コード エディターはバイト順序をスキャンし、UTF-8 エンコードを自動検出します。If neither is found in the current document, the code editor attempts to auto-detect UTF-8 encoding by scanning byte sequences. エンコードの自動検出を無効にするには、このオプションをオフにします。To disable the auto-detection of encoding, clear this option.

表示Display

[マージン]Selection margin
選択すると、エディターのテキスト領域の左端に沿って縦の余白が表示されます。When selected, displays a vertical margin along the left edge of the editor's text area. この余白をクリックしてテキスト行全体を選択したり、クリックしてドラッグし、連続するテキスト行を選択したりできます。You can click this margin to select an entire line of text, or click and drag to select consecutive lines of text.

マージン オンSelection Margin on マージン オフSelection Margin off
HTMLpageSelectionMarginOn スクリーンショットHTMLpageSelectionMarginOn screenshot HTMLpageSelectionMarginOff スクリーンショットHTMLpageSelectionMarginOff screenshot

インジケーター マージンIndicator margin
選択すると、エディターのテキスト領域の左端の外に縦の余白が表示されます。When selected, displays a vertical margin outside the left edge of the editor's text area. この余白をクリックすると、アイコンとテキストに関連付けられているヒントが表示されます。When you click in this margin, an icon and ToolTip that are related to the text appear. たとえば、インジケーター マージンにブレークポイントやタスク一覧のショートカットが表示されます。For example, breakpoint or task list shortcuts appear in the indicator margin. インジケーター マージンの情報は印刷されません。Indicator Margin information does not print.

[垂直スクロール バー]Vertical scroll bar
選択すると、垂直スクロール バーが表示されます。このバーで上下にスクロールし、エディターの表示領域外の要素を表示できます。When selected, displays a vertical scrollbar which allows you to scroll up and down to view elements that fall outside the viewing area of the Editor. 縦のスクロール バーが利用できない場合、Page Up キー、Page Down キー、カーソル キーでスクロールできます。If vertical scrollbars are not available, you can use the Page Up, Page Down and cursor keys to scroll.

[水平スクロール バー]Horizontal scroll bar
選択すると、水平スクロール バーが表示されます。このバーで左右にスクロールし、エディターの表示領域外の要素を表示できます。When selected, displays a horizontal scrollbar which allows you to scroll from side-to-side to view elements that fall outside the viewing area of the Editor. 水平スクロール バーが表示されない場合は、カーソル キーでスクロールできます。If horizontal scrollbars are unavailable, you can use the cursor keys to scroll.

[現在の行を強調表示する]Highlight current line
選択すると、カーソルが置かれているコード行の周りに灰色のボックスが表示されます。When selected, displays a gray box around the line of code in which the cursor is located.

関連項目See Also

[オプション]、[テキスト エディター]、[すべての言語] Options, Text Editor, All Languages
[オプション]、[テキスト エディター]、[すべての言語]、[タブ] Options, Text Editor, All Languages, Tabs
[オプション]、[テキスト エディター]、[ファイル拡張子] Options, Text Editor, File Extension
キーボード ショートカットの識別とカスタマイズ Identifying and Customizing Keyboard Shortcuts
エディターのカスタマイズ Customizing the Editor
IntelliSense の使用Using IntelliSense