[プロジェクトおよびソリューション] の [オプション] ダイアログ ボックスProjects and Solutions, Options Dialog Box

プロジェクトおよびソリューションに関連する Visual StudioVisual Studio 動作を設定します。Sets Visual StudioVisual Studio behavior related to projects and solutions. これらのオプションにアクセスするには、[ツール]、[オプション] の順に選択し、[プロジェクトおよびソリューション] を展開し、[全般] をクリックします。To access these options, select Tools > Options expand Projects and Solutions, and click General.

プロジェクトおよびテンプレート フォルダーの既定のパスは、同じダイアログ ボックスの [場所] タブで設定します。The default paths for project and template folders are set through the Locations tab in the same dialog box.

注意

使用している設定またはエディションによっては、ダイアログ ボックスで使用可能なオプションや、メニュー コマンドの名前や位置がヘルプに記載されている内容と異なる場合があります。The options available in dialog boxes, and the names and locations of menu commands you see, might differ from what is described in Help depending on your active settings or edition. このヘルプ ページは、全般的な開発設定を考慮して記述されています。This Help page was written with the General Development settings in mind. 設定を表示または変更するには、[ツール] メニューの [設定のインポートとエクスポート] をクリックします。To view or change your settings, choose Import and Export Settings on the Tools menu. 詳細については、「Visual Studio IDE のカスタマイズ」を参照してください。For more information, see Personalize the Visual Studio IDE.

[全般] タブのオプションGeneral tab options

ビルドがエラーで終了した場合には常にエラー一覧を表示するAlways show Error List if build finishes with errors
プロジェクトのビルドが失敗した場合にのみ、ビルドの完了時に [エラー一覧] ウィンドウを開きます。Opens the Error List window on build completion, only if a project failed to build. ビルド処理中に発生したエラーが表示されます。Errors that occur during the build process are displayed. このオプションがオフの場合、エラーは引き続き発生しますが、ビルドの完了時にウィンドウは開きません。When this option is cleared, the errors still occur but the window does not open when the build is complete. 既定では、このオプションは有効になっています。This option is enabled by default.

ソリューション エクスプローラーでアクティブなアイテムを追跡するTrack Active Item in Solution Explorer
選択した場合、ソリューション エクスプローラーが自動的に開いて、アクティブな項目が選択されます。When selected, Solution Explorer automatically opens and the active item is selected. 選択される項目は、プロジェクトまたはソリューション内の別のファイルや、デザイナー内の異なるコンポーネントを処理の対象にすると変更されます。The selected item changes as you work with different files in a project or solution, or different components in a designer. このオプションがオフのとき、ソリューション エクスプローラーでの選択内容は自動的に変更されません。When this option is cleared, the selection in Solution Explorer does not change automatically. 既定では、このオプションは有効になっています。This option is enabled by default.

ビルド構成の詳細を表示Show advanced build configurations
選択した場合、ビルドの構成オプションが [プロジェクト プロパティ ページ] ダイアログ ボックスおよび [ソリューション プロパティ ページ] ダイアログ ボックスに表示されます。When selected, the build configuration options appear on the Project Property Pages dialog box and the Solution Property Pages dialog box. オフにすると、ビルドの構成オプションは、1 つの構成または 2 つの構成のデバッグとリリースを含む および プロジェクトのための、[プロジェクト プロパティ ページ] ダイアログ ボックスや [Visual BasicVisual Basicソリューション プロパティ ページVisual C#Visual C#] ダイアログ ボックスに表示されません。When cleared, the build configuration options do not appear on the Project Property Pages dialog box and the Solution Property Pages dialog box for Visual BasicVisual Basic and Visual C#Visual C# projects that contain one configuration or the two configurations debug and release. プロジェクトにユーザー定義の構成がある場合、ビルドの構成オプションが表示されます。If a project has a user-defined configuration, the build configuration options are shown.

オフの場合、[ビルド] メニューのコマンド ([ソリューションのビルド][ソリューションのリビルド][ソリューションのクリーン] など) はリリース構成で実行され、[デバッグ] メニューのコマンド ([デバッグ開始][デバッグなしで開始] など) はデバッグ構成で実行されます。When unselected, the commands on the Build menu, such as Build Solution, Rebuild Solution, and Clean Solution, are performed on the Release configuration and the commands on the Debug menu, such as Start Debugging and Start Without Debugging, are performed on the Debug configuration.

常にソリューションを表示Always show solution
選択した場合、ソリューションおよびソリューションで動作するすべてのコマンドが常に IDE に表示されます。When selected, the solution and all commands that act on solutions are always shown in the IDE. オフの場合、すべてのプロジェクトはスタンドアロン プロジェクトとして作成され、ソリューションに 1 つのプロジェクトだけが含まれている場合、ソリューション エクスプローラー内のソリューションや、IDE 内のソリューションで動作するコマンドは表示されません。When cleared, all projects are created as stand-alone projects and you do not see the solution in Solution Explorer or commands that act on solutions in the IDE if the solution contains only one project.

新しいプロジェクトを作成時に保存するSave new projects when created
選択すると、[新しいプロジェクト] ダイアログ ボックスにプロジェクトの場所を指定できます。When selected, you can specify a location for your project in the New Project dialog box. オフの場合、すべての新しいプロジェクトは一時プロジェクトとして作成されます。When cleared, all new projects are created as temporary projects. 一時プロジェクトで作業する場合、ディスクの場所を指定しなくても、プロジェクトを作成して試してみることができます。When you are working with temporary projects, you can create and experiment with a project without having to specify a disk location.

プロジェクトの場所が信頼されていないときにユーザーに警告Warn user when the project location is not trusted
完全に信頼されていない場所 (UNC パスの上や HTTP パスの上など) で、新しいプロジェクトの作成または既存のプロジェクトのオープンを試行すると、メッセージが表示されます。If you attempt to create a new project or open an existing project in a location that is not fully trusted (for example, on a UNC path or an HTTP path), a message is displayed. このオプションを使用して、完全に信頼されていない場所でプロジェクトの作成またはオープンを試行するたびにメッセージを表示するかどうかを指定します。Use this option to specify whether the message is displayed each time that you attempt to create or open a project in a location that is not fully trusted.

ビルド開始時に出力ウィンドウを表示Show Output window when build starts
ソリューション ビルドの開始時に、IDE の出力ウィンドウを自動的に表示します。Automatically displays the Output Window in the IDE at the outset of solution builds. 詳細については、「方法 : 出力ウィンドウを制御する」を参照してください。For more information, see How to: Control the Output Window.

ファイル名の変更時にシンボルの名前変更を求めるプロンプトを出すPrompt for symbolic renaming when renaming files
選択すると、Visual StudioVisual Studio がコード要素に対するプロジェクト内のすべての参照も名前変更するかどうかを確認する、メッセージ ボックスが表示されます。When selected, Visual StudioVisual Studio displays a message box asking whether or not it should also rename all references in the project to the code element.

[Prompt before moving files to a new location](新しい場所にファイルを移動する前にメッセージを表示する)Prompt before moving files to a new location
選択すると、Visual StudioVisual Studio は、ソリューション エクスプ ローラーでの操作によってファイルの場所が変更される前に確認メッセージ ボックスを表示します。When selected, Visual StudioVisual Studio displays a confirmation message box before the locations of files are changed by actions in Solution Explorer.

[場所] タブのオプションLocations tab options

プロジェクトの場所Projects location
Visual StudioVisual Studio が新しいプロジェクトとソリューション フォルダーを作成する既定の場所を指定します。Specifies the default location where Visual StudioVisual Studio creates new projects and solution folders. 複数のダイアログ ボックスも、このオプションで指定した場所をフォルダーの開始点として使用します。Several dialog boxes also use the location set in this option for folder starting points. たとえば、[プロジェクトを開く] ダイアログ ボックスは、この場所を [マイ プロジェクト] のショートカットのために使用します。For example, the Open Project dialog box uses this location for the My Projects shortcut.

ユーザー プロジェクト テンプレートの場所User project templates location
[新しいプロジェクト] ダイアログ ボックスで [マイ テンプレート] の一覧を作成するときに使用される既定の場所を指定します。Specifies the default location that the New Project dialog box uses to create the list of My Templates. 詳細については、「方法 : プロジェクト テンプレートと項目テンプレートを配置して整理する」を参照してください。For more information, see How to: Locate and Organize Templates.

ユーザー項目テンプレートの場所User item templates location
[新しい項目の追加] ダイアログ ボックスで [マイ テンプレート] の一覧を作成するときに使用される既定の場所を設定します。Specifies the default location that the Add New Item dialog box uses to create the list of My Templates. 詳細については、「方法 : プロジェクト テンプレートと項目テンプレートを配置して整理する」を参照してください。For more information, see How to: Locate and Organize Templates.

関連項目See Also