Visual Studio のソリューションおよびプロジェクト

この記事では、Visual Studio の "プロジェクト" と "ソリューション" について説明します。 また、ソリューション エクスプローラー ツール ウィンドウ、および新しいプロジェクトの作成方法についても簡単に説明します。

注意

このトピックは、Windows 上の Visual Studio に適用されます。 Visual Studio for Mac については、Visual Studio for Mac のプロジェクトおよびソリューションに関するページを参照してください。

プロジェクト

Visual Studio で、アプリまたは Web サイトを作成するときは、"プロジェクト" から始めます。 論理的には、実行可能ファイル、ライブラリ、または Web サイトにコンパイルされる、すべてのファイルがプロジェクトに含まれています。 これらのファイルには、ソース コード、アイコン、イメージ、データ ファイルなどを含めることができます。 また、プロジェクトには、プログラムが通信するさまざまなサービスまたはコンポーネントで必要になる可能性がある、コンパイラ設定とその他の構成ファイルも含まれています。

プロジェクト ファイル

Visual Studio では、MSBuild を使用してソリューション内の各プロジェクトをビルドします。各プロジェクトには MSBuild プロジェクト ファイルが含まれています。 ファイル拡張子は、C# プロジェクト (.csproj)、Visual Basic プロジェクト (.vbproj)、またはデータベース プロジェクト (.dbproj) などのプロジェクトの種類を反映しています。 プロジェクト ファイルは、MSBuild がプロジェクトをビルドするために必要なすべての情報と手順が含まれる XML ドキュメントです。これには、コンテンツ、プラットフォーム要件、バージョン管理情報、Web サーバーまたはデータベース サーバーの設定、実行するタスクなどがあります。

プロジェクト ファイルは、MSBuild XML スキーマに基づいています。 Visual Studio で新しい sdk スタイルのプロジェクト ファイルのコンテンツを確認するには、 [ソリューション エクスプローラー] 内でプロジェクト ノードを右クリックし、 [編集]<projectname> を選択します。 .NET フレームワークのコンテンツや、そのスタイルのその他のプロジェクトのコンテンツを確認するには、まずプロジェクトをアンロードします ( [ソリューション エクスプローラー] を右クリックして、 [プロジェクトのアンロード] を選択します)。 次に、プロジェクトを右クリックして、 [編集]<projectname> を選択します。

注意

Visual Studio でソリューションまたはプロジェクトを使用して、コードの編集、ビルド、デバッグを行う必要はありません。 単に Visual Studio でソース ファイルを含むフォルダーを開いて編集を開始できます。 詳細については、「プロジェクトまたはソリューションを使用せずに Visual Studio でコードを開発する」を参照してください。

新しいプロジェクトの作成

新しいプロジェクトを作成する最も簡単な方法は、目的のプロジェクトの種類に適したプロジェクト テンプレートを使用することです。 プロジェクト テンプレートには、事前に生成されたコード ファイル、構成ファイル、資産、設定の基本セットが含まれています。 [ファイル] > [新規] > [プロジェクト] を使用して、プロジェクト テンプレートを選択します。 詳細については、新しいプロジェクトの作成に関するページを参照してください。

また、新しいプロジェクトの作成元として使用できるカスタム プロジェクト テンプレートを作成することもできます。 詳細については、プロジェクト テンプレートと項目テンプレートの作成に関するページをご覧ください。

新しいプロジェクトを作成すると、Visual Studio によって、その既定の場所である %USERPROFILE%\source\repos に保存されます。 この場所を変更するには、 [ツール] > [オプション] > [プロジェクトおよびソリューション] > [場所] に移動します。 詳細については、「[オプション] ダイアログ ボックス:[プロジェクトおよびソリューション] > [場所]」を参照してください。

解決策

プロジェクトは ソリューション 内に含まれます。 ソリューションは、その名前にもかかわらず、"答え" ではありません。 1 つ以上の関連するプロジェクト、およびビルド情報、Visual Studio ウィンドウの設定、特定のプロジェクトに関連付けられていないその他のファイルに対するコンテナーに過ぎません。

ソリューション ファイル

Visual Studio では、ソリューションの設定を格納するために、2 種類のファイル ( .sln および .suo) を使用します。

拡張子 名前 説明
.sln Visual Studio ソリューション ソリューション内のプロジェクト、プロジェクト項目、およびソリューション項目を整理します。
.suo ソリューション ユーザー オプション ユーザー レベルの設定やブレークポイントなどのカスタマイズを格納します。

重要

ソリューションは独自の形式を持つテキスト ファイル (拡張子 .sln) で記述され、手動での編集は想定されていません。 これに対して、 .suo ファイルは隠しファイルであり、エクスプローラーの既定の設定では表示されません。 隠しファイルを表示するには、エクスプローラーの [表示] メニューで [非表示項目] チェックボックスをオンにします。

ソリューション フォルダー

"ソリューション フォルダー" は、ソリューション エクスプローラー にのみ存在する仮想フォルダーで、ソリューション内のプロジェクトをグループ化するために使用できます。 コンピューター上のソリューション ファイルを検索する場合は、 [ツール] > [オプション] > [プロジェクトおよびソリューション] > [場所] にアクセスします。 詳細については、「[オプション] ダイアログ ボックス:[プロジェクトおよびソリューション] > [場所]」を参照してください。

ヒント

ステップ バイ ステップの手順とサンプル コードを備えた、最初から作成したプロジェクトとソリューションの例については、「プロジェクトとソリューションについて理解する」を参照してください。

ソリューション エクスプローラー

新しいプロジェクトを作成した後は、 ソリューション エクスプローラー を使用して、プロジェクトとソリューション、およびそれらの関連項目を表示して管理できます。 次の図に、2 つのプロジェクトを含む C# ソリューションが表示された ソリューション エクスプローラー を示します。

2 つのプロジェクトを含むソリューション エクスプローラーのスクリーンショット。

ソリューション エクスプローラー の上部のツールバーには、ソリューション ビューからフォルダー ビューに切り替える、隠しファイルを表示する、すべてのノードを折りたたむためなどのボタンがあります。

Visual Studio での 2 つのプロジェクトを含むソリューション エクスプローラーのスクリーンショット。

ソリューション エクスプローラー の上部にあるツール バーには、ソリューション ビューからフォルダー ビューへの切り替え、保留中の変更のフィルター処理、すべてのファイルの表示、すべてのノードの表示、プロパティ ページの表示、コード エディターでのコードのプレビューなどを行うためのボタンがあります。

多くのメニュー コマンドは、ソリューション エクスプローラー で各種項目の右クリックのコンテキスト メニューから使用できます。 これらのコマンドには、プロジェクトのビルド、NuGet パッケージの管理、参照の追加、ファイル名の変更、テストの実行などが含まれます。 詳細については、「ソリューション エクスプローラーの使用方法」を参照してください。

ASP.NET Core プロジェクトでは、ソリューション エクスプローラー でファイルを入れ子にする方法をカスタマイズできます。 詳細については、ソリューション エクスプローラーでのファイルの入れ子のカスタマイズに関するページを参照してください。

ヒント

閉じたソリューション エクスプローラーをもう一度開くには、メニュー バーから [ビュー] > [ソリューション エクスプローラー] を選択するか、Ctrl+Alt+L を押します。 また閉じたサイド タブをそれらの既定の場所に復元するには、メニュー バーの [ウィンドウ] > [ウィンドウ レイアウトのリセット] を選択します。

注意

Visual Studio に表示されるアプリケーションのイメージおよびアイコンを参照するには、Visual Studio Image Library を参照してください。

関連項目